Error 11:Un recognised......

Asked by Balakrishna on 2009-07-18

In my xp home and Ubuntu 9.04 dual boot, I can not boot into Ubunu 9.04; Every time I select Ubuntu,it says Error 11-Unrecognised divice string-Press any key to continue....
Then again back to grub.
But I can boot into xp easily.
I burned super grub disk cd and through it, I can boot into Ubuntu.
Select booting from cd >Gnu Linux >Boot Gnu Linux >Boot Linux directly and it is done.
I do not know how to re-install or repair GRUB in terminal
Please tell me. I tried Live CD also but no use.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Balakrishna
Solved:
2009-07-21
Last query:
2009-07-21
Last reply:
2009-07-21
Tom (tom6) said : #1

Hi :)

Can i just check that this doesn't work? You put the ubuntu cd in the cd/dvd-drive and reboot the machine. When you get to a menu saying "Try Ubuntu without making changes to this machine" you select that and then don't get to a working desktop? Does this guide help?
https://help.ubuntu.com/community/BootFromCD

When you do manage to get into Ubuntu please can you go up to the top taskbar and click on

Applications - Accessories - Terminal

and into the terminal/command window/console type

sudo fdisk -l

then copy the output into here so we can see if something wrong with that. Good luck with this!
Regards from
Tom :)

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xe423b127

   Device Boot Start End Blocks Id System
/dev/sda1 * 1 5222 41945683+ 7 HPFS/NTFS
/dev/sda2 5223 19439 114198052+ f W95 Ext'd (LBA)
/dev/sda5 5223 10118 39327088+ 7 HPFS/NTFS
/dev/sda6 10445 10836 3148708+ 7 HPFS/NTFS
/dev/sda7 15667 19439 30306591 7 HPFS/NTFS
/dev/sda8 10837 15462 37158313+ 83 Linux
/dev/sda9 15463 15666 1638598+ 82 Linux swap / Solaris

Partition table entries are not in disk order

Tom (tom6) said : #3

Ok, the sda numbers are made in chronological order, when they were made rather than where they are on the drive. It looks as though they are laid out sda1, sda2 and sda2 contains sda5, a gap, sda6, sda8, sda9, sda7. The important thing is that sda8 is where most of Ubuntu is and that sda9 is there - sda9 is good for performance :) When you go up to the top taskbar and click on

System - Administration

can you see "Partition Editor" there? If it is there be careful of it - it can delete or create partitions quite fast so just avoid clicking on the "Apply" button in there unless you are sure that you know what it's going to do otherwise you could lose a lot of data very fast. If you can't see it there that's fine we can add it later if needed.

Please get back to a terminal console and type in

cd /boot/grub

gedit menu.lst

and copy all the lines at the end that don't start with a # into here. We say that lines starting with a # are "commented out" because the machine doesn't read them, so it's a good way of being able to leave notes to each other without the machine trying to run them as commands. So if you could copy all the lines that aren't commented out into here (preferably just the ones at the end of the file) then we could see what it's trying to do when it's booting up :)

Good luck and regards again from
Tom :)

Hello Tom,
Terminal screen shot I al lready pasted is NOT from Live session user but as I said, after installing the SUPER GRUB DISK, entered 'enter' several times and was able to log into my desktop then I did as you told. I can not see the 'partion Manager'in adm.But it was visible in live cd. Here I am pasting the out put of your 2nd advice.
Before I also tried this link
http://ubuntuforums.org/showthread.php?t=783665 As amonty said , I typed in terminal
/boot/grub/menu.lst BUT MY DESKTOPSAYS THAT "PERMISSION DENIED' !
HERE IT IS PASTED

balakrishna@Balakrishna-Bharati:~$ /boot/grub/menu.lst
bash: /boot/grub/menu.lst: Permission denied
balakrishna@Balakrishna-Bharati:~$

Here as per your advice:
# menu.lst - See: grub(8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default saved

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 10

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line) and entries protected by the
# command 'lock'
# e.g. password topsecret
# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
#
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
## kopt_2_6_8=root=/dev/hdc1 ro
## kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=4dcfb85e-6b72-4551-a9a2-dd12cdec99f4 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=4dcfb85e-6b72-4551-a9a2-dd12cdec99f4

## should update-grub create alternative automagic boot options
## e.g. alternative=true
## alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
## lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
## lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
## altoptions=(single-user) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
## howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
## memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title Debian GNU/Linux, kernel 2.6.28-11-generic
root 4dcfb85e-6b72-4551-a9a2-dd12cdec99f4
kernel /boot/vmlinuz-2.6.28-11-generic root=UUID=4dcfb85e-6b72-4551-a9a2-dd12cdec99f4 ro quiet splash
initrd /boot/initrd.img-2.6.28-11-generic

title Debian GNU/Linux, kernel 2.6.28-11-generic (recovery mode)
root 4dcfb85e-6b72-4551-a9a2-dd12cdec99f4
kernel /boot/vmlinuz-2.6.28-11-generic root=UUID=4dcfb85e-6b72-4551-a9a2-dd12cdec99f4 ro single
initrd /boot/initrd.img-2.6.28-11-generic

title Debian GNU/Linux, kernel memtest86+
root 4dcfb85e-6b72-4551-a9a2-dd12cdec99f4
kernel /boot/memtest86+.bin

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Microsoft Windows XP Home Edition
rootnoverify (hd0,0)
savedefault
makeactive
chainloader +1

I did not understand where to paste the above output without#.
Please answer me.

Tom (tom6) said : #5

Lol, that's ok. It'll take me a little while to work this out but it's ok :)

Tom (tom6) said : #6

Right, so lets try this. First make a backup of menu.lst by typing

cd /boot/grub
ls
sudo cp menu.lst menu.lst-190709
ls

Note the "ls" is a lower-case "LS". The sudo command will ask for your normall user password, not your SuperUser/Root one. We need to use sudo because /boot/grub is a system folder so it's protected from normal user accidents. The "cp" command should create a CoPy of "menu.lst" and give it the name "menu.lst-190709" so that we can easily find the right one and copy it back if this goes wrong! The 2nd "ls" should confirm that the new file "menu.lst-190709" has been added to the LiSt of what's in the /boot/grub folder :)

Is that all working so far?

Tom (tom6) said : #7

Ok, assuming that has worked and given us a backup copy of "menu.lst" then please try

cd /boot/grub
sudo gedit menu.lst

now scroll down to the lines

root 4dcfb85e-6b72-4551-a9a2-dd12cdec99f4

change those to

root (hd0,7)

also change the parts of the lines from

root=UUID=4dcfb85e-6b72-4551-a9a2-dd12cdec99f4 ro quiet splash

so that they say

root=/dev/sda8

for example the line

kernel /boot/vmlinuz-2.6.28-11-generic root=UUID=4dcfb85e-6b72-4551-a9a2-dd12cdec99f4 ro quiet splash

should be

kernel /boot/vmlinuz-2.6.28-11-generic root=/dev/sda8

At least it should be that for now. So now just click on "Save" :) Hopefully that should allow you to boot into Ubuntu without needing the SuperGrub disk :)
Good luck and regards from
Tom :)

Sorry Tom,
 I think I messed up everything........I installed Start up manager through Sy Manager. Then I edited something there-use colour in bootloader and so on...... Now If I try to start Ubuntu even with SGD, only a black screen seen with a splash screen with a 'x' mark in it which does not gets closed !On the top,- All, Date, BBconnecction icon is seen. no other options at all ! Only shadowed line.
Please don't get angry...help me

Tom (tom6) said : #9

lol, stuff happens. It's the best way to learn!

Tom (tom6) said : #10

So do you have an Ubuntu Cd? or the cd of any other distro?

Yes Tom, I have Ubuntu 9.04 and also 8.10 intrepid. What do you suggest? I installed live 9.04 and tried to recover[reinstall grub in hd0,8 ]and it asks to reboot. But again it is the same!

Tom (tom6) said : #12

Ok, so you can boot up from the 9.04 cd into a working desktop? Assuming that's so then try opening a terminal console and type in

sudo fdisk -l

again and give us the output from there again lol

Tom (tom6) said : #13

Also in the terminal console try typing

cd /media
ls

Note that "ls" is lower-case "LS" and will hopefully show all the different partitions available. Making a quick guess i would try

cd disk
ls

note that this time there's no / mark fllowing from the "cd" command, this is becuase we don't want it to go back to the very root of th filesystem, especially since there's no /disk folder, but there is a /media/disk folder. lol, does that make sense or is it muddly? Sorry about that

Good luck and regards form
Tom :)

Tom (tom6) said : #14

Also in the terminal console try typing

cd /media
ls

Note that "ls" is lower-case "LS" and will hopefully show all the different partitions available. Making a quick guess i would try

cd disk
ls

note that this time there's no / mark following from the "cd" command, this is because we don't want it to go back to the very root of the file-system, especially since there's no /disk folder, but there is a /media/disk folder. lol, does that make sense or is it muddily? Sorry about that

Good luck and regards form
Tom :)

Here you are for .sudo fdisk -lubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xe423b127

   Device Boot Start End Blocks Id System
/dev/sda1 * 1 5222 41945683+ 7 HPFS/NTFS
/dev/sda2 5223 19439 114198052+ f W95 Ext'd (LBA)
/dev/sda5 5223 10118 39327088+ 7 HPFS/NTFS
/dev/sda6 10445 10836 3148708+ 7 HPFS/NTFS
/dev/sda7 15667 19439 30306591 7 HPFS/NTFS
/dev/sda8 10837 15462 37158313+ 83 Linux
/dev/sda9 15463 15666 1638598+ 82 Linux swap / Solaris

Partition table entries are not in disk order
ubuntu@ubuntu:~$

I think, through Live cd, the output does not tallies with actual desktop
ubuntu@ubuntu:~$
ubuntu@ubuntu:~$ cd /media
ubuntu@ubuntu:/media$ ls
ubuntu@ubuntu:/media$ cd disk
bash: cd: disk: No such file or directory
ubuntu@ubuntu:/media$ ls

Tom (tom6) said : #17

So "ls" isn't showing anything in the /media folder? Hmm, try

cd /mnt
ls

and then

cd /dev/sda8
ls

Tom (tom6) said : #18

Also have a quick look in the "Places" menu on the top taskbar. Are there quite a few "Media" in there or a folder "Removable Media"?

I'm really just trying to find the ubuntu that's on the hard-drive. We can see it's still there from the "sudo fdisk -l" command, so we should be able to access it somehow. At the moment i'm considering forcing it to mount thorugh gparted but that's like using a sledge-hammer to crack a walnut.

No-No media or anything like that. Removable media is also not seen.

Look at this:ubuntu@ubuntu:~$ cd /mnt
ubuntu@ubuntu:/mnt$ ls
ubuntu@ubuntu:/mnt$ cd /dev/sda8
bash: cd: /dev/sda8: Not a directory
ubuntu@ubuntu:/mnt$ ls

What now?

Tom (tom6) said : #21

Ok, on the top taskbar click on

System - Administration - Partition Editor

all of the partitions probably lack little keys beside them. Try right-click on sda8 and about halfway down should be the option "Mount". Once it's been mounted go back to the terminal and try this again

cd /media
ls

Hello,
 No way. While I right-clicked;
Del,Resize/move,copy,format to,manage flags,check,label and information these are shown.
I tried to' check' and was succeeded. It did the 'check and repair'.
What now?
'unmount' option was faded.
cd media/ls does not works.

Florian Diesch (diesch) said : #23

Lines like
  root 4dcfb85e-6b72-4551-a9a2-dd12cdec99f4
and
  root=UUID=4dcfb85e-6b72-4551-a9a2-dd12cdec99f4 ro quiet splash
are fine and should not need to be changed.

The problem seems to be the
  title Other operating systems:
  root
near the end of the file

Thanks to Tom and Florian Diesch.....I ended up in re-installing Ubuntu 9.04. I was fed-up with 'repair'.

Thanks.

Tom (tom6) said : #26

Lol, nicely done. I guess it's all working well now?
Working through this guide might help sort almost all your multimedia out in one go
https://help.ubuntu.com/community/Medibuntu
i tend to go with non-free components and haven't had to pay anyone for them yet. Hopefully one day soon i will be able o go completely OpenSource and really free myself

Good luck and regards from
Tom :)

Tom (tom6) said : #27

@ Florian
Lol, the Windows side was booting up fine. It was the Ubuntu side that was having troubles. I think you got it the wrong way around for once. ;)

Tom (tom6) said : #28

Hi :)

Have you been able to try the new Ubuntu 10.04 before it gets officially released?
http://www.ubuntulinux.org/testing/lucid/beta2
Trying it as a LiveCd or as an extra dual/multi-boot would be ideal. Developers and everyone are keen to try to iron out any problems before 10.04 gets officially released so you might find faster & more effective answers to your bug reports which would make 10.04 work better on your system for you

Thanks and regards from
Tom :)