sound & display brightness problem in dell studio 1555 with ubuntu 9.04

Asked by adashrath on 2009-06-18

I was using Ubuntu 8.10 on dell studio 1555. There was sound but while using headphone, sound was also coming from speaker. Also I was unable to change display brightness.
Now I had updated to Ubuntu 9.04. Ubuntu Studio is also installed.
No sound in kernel 2.6.28-13-generic, kernel 2.6.28-11-generic, kernel 2.6.28-3-rt.
But strange thing is that there is sound in kernel 2.6.27-14-generic. I had also updated alsa driver to 1.0.20. But still problem not solved.
I am able to change display brightness hardly for a minute after boot. Then unable to change it. Even on removal of power, there is no change in display brightness. So unable to work for more time if there is no power.

If I could get solution, it would be better for me.

Waiting for support...
Thanks.

Question information

Andrew Chadwick (achadwick) said : #4

Sound: as root, create /etc/modprobe.d/alsa-base-local.conf and add the lines

 #------------------8<---------------------
 # per http://www.namanb.com/2009/07/ubuntu-sound-problems-on-dell-studio.html
 # and http://bbs.archlinux.org/viewtopic.php?pid=592107
 options snd-hda-intel model=dell-m6
 #-------------------->8---------------------

and then reboot. After this, sound began working fine on my Studio 1555. Let me know if you need further info about how to achieve this.

Brightness: it's an ongoing problem; seems to be an underlying kernel ACPI bug, or possibly some quirk of the specific BIOS. Follow https://bugs.launchpad.net/bugs/392812 for more info.

Can you help with this problem?

Provide an answer of your own, or ask adashrath for more information if necessary.

To post a message you must log in.