Illuminated keyboard will not iluminate

Asked by Eycks on 2007-05-31

I purchased a logisys kb608bk illuminated keyboard. Using XP it lights up. The light switch is also the Scroll Lock key. Using fiesty fawn the scroll lock key keeps me from completing a boot until I turn it off. Once booted the scroll lock key does show up using xev but no light. I do not know how I did it but by pushing rndom keys using Ubuntu the keyboard did light up once. The keyboard has a functin key which causes the function led to light up but xev does not see it. I mention this because the lower part of the scroll lock key is the EL on/off.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2007-05-31
Last reply:
2010-08-18
Bryan Haskins (bryan-h) said : #1

It sounds sort of like it might be a software control for the switch more so than an up and under dealy hardware switch, as in you press that button, the OS catches it and throws back whatever it needs to know to flick on the lighting. This would mainly be the case if you had to install anything on Windows for it to work, though to a lesser degree if it were internal. We could just be intercepting that keystroke in some way the keyboard doesn't expect. It's in an environment it isn't used to. I'm not sure how I can help more directly than just give you that as something to think about.

Not sure if this is the same solution, but for me the Scroll Lock key wasn't working with various versions of Ubuntu that I tried. I needed this due to a KVM switch I had that used Scroll Lock to switch between computers. To get the Scroll Lock key to work, first, find an unused modifier by typing:

xmodmap -pm

My mod3 was free (so adjust the commands accordingly if you use a different modifier). Now type the following:

xmodmap -e 'add mod3 = Scroll_Lock'

After doing this, your scroll lock key will now work. You can now make this a permanent fix by adding the following line to /root/.Xmodmap (if the file isn't there, then create it):

add mod3 = Scroll_Lock

By putting this in root's Xmodmap, it will enable the scroll lock key every time X starts.

El Boricua (elboricua) said : #3

Mike thanks a million for the info, it worked!
However, I'm a newbie and need a little bit more info.

To make this a permanent fix, you said to add the following line "add mo3 = Scroll_Lock" to /root/.Xmodmap and that if the file is not there, to create it.
This file is a "text" file, is that correct?

Will this text file I will be creating have the following:

add mod3 = Scroll_Lock'

or will it have the following:

xmodmap: up to 3 keys per modifier, (keycodes in parentheses):

shift Shift_L (0x32), Shift_R (0x3e)
lock Caps_Lock (0x42)
control Control_L (0x25), Control_R (0x6d)
mod1 Alt_L (0x40), Alt_L (0x7d), Meta_L (0x9c)
mod2 Num_Lock (0x4d)
mod3 Scroll_Lock (0x4e)
mod4 Super_L (0x7f), Hyper_L (0x80)
mod5 Mode_switch (0x5d), ISO_Level3_Shift (0x7c)

Last question, do I save the text file on the root folder as: .Xmodmap

I just recently made the change from XP to Ubuntu and I really appreciate any help!

Stefan (sawspam) said : #4

FYI - This fix works for a Frisby USB keyboard connected through a USB KVM switch to Ubuntu 8.10 (Intrepid Ibex).

I have this same problem. I work with Mike`s instruction. I do everything same like Mike. My keyboard is now iluminated .I pushed Scroll lock key it works. Shortcuts like ALT+TAB now not work. I must scroll lock key off and then I can use ALT+TAB. Can anybody helps me with it?

Thanks
Sorry for my English

Paul Eycks (peycks) said : #6

This solves the problem. Hopefully my next problem will be solved in less than 3 years.

Paul Eycks (peycks) said : #7

https://answers.launchpad.net/ubuntu/+question/7456/+confirm?answer_id=5

Is where I was directed if my question was answered. When I click on this link I am told I do not have permission to be there. Could this be the first time a question was ever answered and no one has ever used this link?

Paul Eycks (peycks) said : #8

A final note. I added xmodmap -e 'add mod3 = Scroll_Lock' to /etc/gdm/PreSession/Default and now my keyboard illuminates without having to manually run the command from a terminal. A final irony, I got an illuminated keyboard to be able to type in a darkened room. The way the letters are printed on the keys when the ligths are out the keyboard looks beautiful but I can't read the characters on the keys :)

Tomislav (tzcrnko) said : #9

Thank you Mike Fraiser , you're genius ! I search for an answer on this question for a days and u solve it!

Thank you, Thank you!
My Speedlink illuminated keyboard sl-6453-ssv work in linux ubuntu now! Yes! Gloving in the dark :D

Can you help with this problem?

Provide an answer of your own, or ask Eycks for more information if necessary.

To post a message you must log in.