Notifications have no dismiss icon or pointer

Asked by Bill Farmer

I am developing an application using gtk+ which temporarily disables keyboard auto repeat because I can't find a way to detect auto repeated key presses. I am using the libnotify api to remind the user that things will be restored as they were when the app exits. However the notification appears always in the same place and has no dismiss icon or pointer. And it's black instead of yellow. I've tried three different ways of popping up a notification, my app, notify-send, and disconnecting the network cable. The results are the same.

Is this an intentional design change? If so, is it documented anywhere?

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Steven Danna
Last query:
Last reply:
Revision history for this message
Bill Farmer (williamjfarmer) said :

I'm attempting to attach a screendump

Revision history for this message
Bill Farmer (williamjfarmer) said :

I was expecting to be able to attach a screendump and fill in the Ubuntu version and problem area, so I will put it here instead.

Ubuntu 9.04 - the Jaunty Jackalope - released in April 2009.
Package notify-osd

Revision history for this message
Best Steven Danna (ssd7) said :

The behavior you described is intentional (unless I'm misunderstanding you) and is part of Ubuntu's new notification design. See:

Revision history for this message
Bill Farmer (williamjfarmer) said :