backend usr lib cups backend hp does not exist

Asked by Melvyn on 2009-06-14

Hi,

I'm having a problem with my HP Deskjet 950c since I installed 9.04. At first I couldn't get it to print in B&W only. It would work only in full colour, with all the waste that this implies. I then uninstalled cups, hplip and reinstalled it. Now my printer isn't even recognised! When I installed hplip I got the message that cups-image wasn't installed and that the hplip installation couldn't continue without this dependency. (But I have libcupsimage2).

Now I'm at a complete loss. Any guidance would be most appreciated.

Best,

Melvyn

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2009-06-26
Last reply:
2009-07-12
Melvyn (melvyn-gattinoni) said : #1
Melvyn (melvyn-gattinoni) said : #2

Anybody have a clue on the above?

R.M. Hildigerr V. (moonsdad) said : #3

I had a similar problem with my HP Photosmart C4440, and I received the same message: "usr/lib/cups/backend/hp does not exist!"
I went to System --> Administration --> Printing, right-clicked my printer's icon, and selected properties. Under "policies" I found that the Enabled State was unselected. I clicked the check-box next to Enabled and my printer began working again. I don't know how it became un-Enabled, it stopped in the middle of a print job.
Does this help, or was your problem more with Synaptic?

Melvyn (melvyn-gattinoni) said : #4
Launchpad Janitor (janitor) said : #5

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Ubuntu 12.04 x86_64 Cups 1.5.3-0ubuntu3, holip 3.12.2-1ubuntu3.1, hp: laserjet 1522.
Error appeared again.
Fix from R.M. Hildigerr V. (moonsdad) work.

Melvyn (melvyn-gattinoni) said : #7

Thanks. Problem resolved