Problems booting new 9.04 installation

Asked by swestfall

So, I downloaded the newest version of ubuntu 9.04, burned it successfully to a disk using Infra Recorder and the methods displayed in the documentation. I made sure that I had enough RAM and disk space for the install and I re-started my computer with the disk in the tray. It brought up the ubuntu menu and I checked the disk for errors as told.

The test returned no errors. Therefore, I decided it I was ready to install.

I started up the installation and went through the process. Everything seemed to go fine and I followed all instructions carefully. When the installation was finished, I was prompted to re-start my computer. I clicked re-start, the tray ejected my disk, I closed the tray and hit enter, just like I was told to do.

My computer shut-down and started to re-boot only to stop and give me an Error 21. I can't exactly remember the message, but it had something to do with the grub. I have lost all ability to boot my computer without the ubuntu disk!

PLEASE HELP! I have a restore disk for my Windows XP OS, but it says it will wipe my hard drive if I run it!

I do have about 90% of my files backed up on an external drive, but I would really prefer not to have to go through all of that nonsense. PLEASE tell me there is a quick fix for this and hurry I need my computer!

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
swestfall (getpaidtobesocial) said :


I shut-it back down and tried to run it without the disc. Here's everything I see including the error I get:

I see a quick flash of the eMachines logo on a white background, just like I always do at start-up. Then, instead of seeing the Windows logo next followed by a perfect boot of my computer, now all I get is:

GRUB Loading stage1.5

GRUB Loading, please wait...
Error 21

and a flashing cursor on the next line.

My computer will do absolutely nothing without having the disk in my drive at start-up!
All the files on my hard drive are still accessible from this trial version of ubuntu that I'm using to send these questions in, but that does me no good.

Please, someone, tell me how I can fix this without having to use my Windows XP restore CD and wipe my hard drive!

Revision history for this message
swestfall (getpaidtobesocial) said :

BTW, if there is a way that I can just uninstall ubuntu and go back to using Windows XP only,
 that is safe for my hard drive, please let me know!

Revision history for this message
swestfall (getpaidtobesocial) said :

Over 15 hrs and not a single peep for the "Global Support team"!

Looks like I'm gonna have to do this myself and do it the hard way.

For anyone else out there reading this that comes across this problem, if you don't get an answer from support, luckily you should still be able to run the "try it out without changing your computer" version to copy any files that you need onto an external source before using your restore CD to wipe your hard drive clean and re-install Windows XP.

This is really too bad. I really wanted to give ubuntu a try. It looks like people working on this project are doing it all for the right reasons. Too bad support is so slow getting to your problems after their product has basically rendered your computer useless.

Oh well, I guess you get what you pay for.

Revision history for this message
Benjamin Drung (bdrung) said :

GRUB does not find the correct partition, on which the boot files are located. The solution is to reinstall GRUB. Please have a look at the forum post [1]. Post #6 have a detailed description how to reinstall GRUB.

BTW, complaining about the bad support does not make anyone response faster. Waiting 16 hours for an answer is not very long compared to others. If you want instant support, you can go to the Ubuntu IRC channel.


Can you help with this problem?

Provide an answer of your own, or ask swestfall for more information if necessary.

To post a message you must log in.