Wifi issues Macbok Pro 4.1 Ubuntu 9.04

Asked by Tom Reid on 2009-06-04

Hi

I have managed to install 9.04 and dual boot Mac and Ubuntu, but I can't get the wireless to work, instructions for this machine are as follows:

"Wireless (Broadcom)

Should work after enabling the proprietary wireless driver in System -> Administration -> Hardware Drivers. You may need to restart the computer in order for the change to take effect. (this is the 'wl' driver provided by Broadcom.)
If this is already enabled but your wireless is not working disable it, restart, then enable it and restart again.
You can also unload these two modules: rmmod ssb wl, and then load only the 'wl' by running: modprobe wl. If this works in your case you may want to black list the ssb module.
The new kernel version 2.6.28-12 seems to disable wireless driver. It does't work neither to unload then reload module nor reinstalling it from System -> Administrator -> Hardware Driver (does not appear any broadcom driver available). At the moment, use old kernel version 2.6.28-11 and it should work after enabling proprietary driver from System -> Administrator -> Hardware Drivers (disable it first, then reboot, then enable it again, reboot)."

Being relatively new to the Linux world, I'm not finding the above easy to understand. I have the hardware driver installed and it seems to be working. I did remove it and re-boot and then activated it again, tried again, but still no wifi.

I am confused by the references above to "kernel version". I'm running 9.04, is this the new Kernel version?

The commands rmmod ssb wl

did'nt work the terminal said the commands were not possible.

Can anyone help? The machine is running beautifully, except for the wifi.

cheers
to

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2009-06-04
Last reply:
2009-06-04
Craig Huffstetler (xq) said : #1

This is excerpted from a document:

"System -> Administration -> Hardware Drivers. You may need to restart the computer in order for the change to take effect. (this is the 'wl' driver provided by Broadcom.)

If this is already enabled but your wireless is not working disable it, restart, then enable it and restart again.

You can also unload these two modules: rmmod ssb wl, and then load only the 'wl' by running: modprobe wl. If this works in your case you may want to black list the ssb module.

The new kernel version 2.6.28-12 seems to disable wireless driver. It doesn't [sic] work neither to unload then reload module nor reinstalling it from System -> Administrator -> Hardware Driver (does not appear any Broadcom [sic] driver available). At the moment, use old kernel version 2.6.28-11 and it should work after enabling proprietary driver from System -> Administrator -> Hardware Drivers (disable it first, then reboot, then enable it again, reboot)." (spelling errors corrected, grammar corrected...)

Source: https://help.ubuntu.com/community/MacBookPro4-1/Jaunty#Wireless%20(Broadcom)

To get the current kernel version go to Applications > Accessories > Terminal

And type in:

uname -a

At the command prompt.

Can you help with this problem?

Provide an answer of your own, or ask Tom Reid for more information if necessary.

To post a message you must log in.