How to install adaptec hostraid serveraid-7e

Asked by Davim


I have an adaptec hostraid serveraid-7e RAID controller, I've created one RAID1 volume but when I try to install Ubuntu server 7.04 it detects my hard drives as separated volumes.
Any ideas to solve this???

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Markus Thielmann
Last query:
Last reply:
Revision history for this message
Best Markus Thielmann (thielmann) said :

Thanks for your question.

The ServeRAID-7e controller is a so called "FakeRAID" controller. See for information on the chipset. These controllers need -in opposite to real hardware controllers- additional drivers. Ubuntus SoftwareRAID support pre-dates your chipset. So it's -at the moment- unable to support it out of the box.

Nevertheless, you'll find information on how to set up your RAID1 volume with installed Ubuntu at

Please don't hesitate to ask again, if there are any additional questions.

Revision history for this message
Davim (davim) said :

Thanks Markus Thielmann, that solved my question.

Revision history for this message
Davim (davim) said :

Is there any place where I can find a list of supported raid controllers in Ubuntu?


Revision history for this message
Alan Pope 🍺🐧🐱 πŸ¦„ (popey) said :

alan@mother:~$ apt-cache show dmraid
Package: dmraid
Priority: optional
Section: universe/admin
Installed-Size: 612
Maintainer: Ubuntu MOTU Developers <email address hidden>
Original-Maintainer: Utnubu Team <email address hidden>
Architecture: i386
Version: 1.0.0.rc13-2ubuntu3
Depends: libc6 (>= 2.5-0ubuntu1), libdevmapper1.02 (>= 2:1.02.02-2), libselinux1 (>= 1.32), libsepol1 (>= 1.14), lsb-base
Filename: pool/universe/d/dmraid/dmraid_1.0.0.rc13-2ubuntu3_i386.deb
Size: 185154
MD5sum: 2cfac59dbce633315ad5d785e4f970b0
SHA1: a7234ac22451b91b652f3eaece630c77d22d322b
SHA256: 1d2903aebd336b65665aaab65adf0c5d3957c88d1ff2dcd52405b98014b4a34e
Description: Device-Mapper Software RAID support tool
 dmraid discovers, activates, deactivates and displays properties
 of software RAID sets (eg, ATARAID) and contained DOS partitions.
 dmraid uses the Linux device-mapper to create devices with respective
 mappings for the ATARAID sets discovered.
 The following formats are supported:
  Highpoint HPT37X/HPT45X
  Intel Software RAID
  LSI Logic MegaRAID
  NVidia NForce RAID (nvraid)
  Promise FastTrack
  Silicon Image(tm) Medley(tm)
  VIA Software RAID
 Please read the documentation in /usr/share/doc/dmraid BEFORE attempting
 any use of this software. Improper use can cause data loss!
Bugs: mailto:<email address hidden>
Origin: Ubuntu

Note:- " Please read the documentation in /usr/share/doc/dmraid " - the README in that folder has a list of supported devices near the top.

Revision history for this message
Alan Pope 🍺🐧🐱 πŸ¦„ (popey) said :

Hmm, I only mentioned fakeraid support there. The easiest way to see if a device is supported is to google for the model number and linux/ubuntu.