Login Error "user's home/.dmrc file is being ignored."

Asked by Steve Clarke on 2007-05-28

Same problem as Yanski had, but after trying that solution I still have the same error. I also don't seem to have full access to the root anymore, and can't modify root config files. What do I try next?

Any help much appreciated!
Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Alan Pope ㋛
Solved:
2007-06-04
Last query:
2007-06-04
Last reply:
2007-06-03
Ralph Janke (txwikinger) said : #1

Thanks for the question.

I am not sure what problem Yanski had, but you seem to ask how to modify system config files. You need to claim administrator priviledge to do this. Here are some instructions for this https://help.ubuntu.com/community/RootSudo.

I hope this helps.

Steve Clarke (clarkesj) said : #2

$Home/.dmrc file is being ignored at log in to Ubuntu. Stopping me from editing /etc/sane.d/conf.dll and any other file not in my home folder, therefore can't get scanner working.

Ralph Janke (txwikinger) said : #3

Could you please open a commandline terminal and run the command

ls -l .dmrc

and paste the output here.

Thanks.

Steve Clarke (clarkesj) said : #4

-rw-r--r-- 1 steve steve 26 2006-09-13 06:34 .dmrc

Ralph Janke (txwikinger) said : #5

I don't think the .dmrc file has anything to do with your problem of accessing the configuration file you want. It just contains some localisation information for gnome.

I also think the file you try to access is /etc/sane.d/dll.conf

try to open it with the following:

ALT-F2 to run a command and enter:

sudo gedit /etc/sane.d/dll.conf

The password is the same you use for logging in.

Now you should be able to change the file.

I hope this helps

Steve Clarke (clarkesj) said : #6

OK, editing it that way worked. Thanks!

I still have a problem where after I log into Ubuntu, I get the message box:
"Users $Home/.dmrc file is being ignored. This prevents the default session and language from being saved. File should be owned by user and have 644 permissions.
Users $Home directory must be owned by user and not writable by others."

Yanski had the same issue, and was given advice that gave his .dmrc file 644 permissions. I tried the same advice, but it didn't make any difference for me.

What can I try next?

Thanks heaps for your help!
Steve.

Ralph Janke (txwikinger) said : #7

Try to set the permissions of your home folder to 700 then logout and login again.

It should be fine then, and according to some stuff I read, you can then afterwards change them again back, or whatever you want.

Steve Clarke (clarkesj) said : #8

I entered in terminal:
sudo chmod 700 .dmrc
logged out then in again, but no change. Is that the correct command?
What else can I try?

Thanks,
Steve.

Ralph Janke (txwikinger) said : #9

No, enter

chmod 644 .dmrc
chmod 700 ~

~ represents the home folder.

Steve Clarke (clarkesj) said : #10

Sorry, but I'm a confused newbie.
When I put in "chmod 644 .dmrc" what should happen? How do I set the permissions to 700 (700 what)? I just get "steve@AMD-Ubuntu:~$ " on a new line.
This, I assume means it has gone and reset something. Or should I get something else?

Any good books (in shops or online) on Ubuntu?
Thanks.

Ralph Janke (txwikinger) said : #11

The .dmrc file permissions should be 644 not 700. The permissions for your home folder should be 700.

Ralph Janke (txwikinger) said : #12

There is the Official Ubuntu book.

Steve Clarke (clarkesj) said : #13

How do I set the home folder to 700 permissions?
Is the official Ubuntu book online or does it have an ISBN?
Thanks.

Best Alan Pope ㋛ (popey) said : #14

sudo chmod 700 /home/steve

(assuming your user is "steve").

Print ISBN-10: 0-13-243594-2
Print ISBN-13: 978-0-13-243594-9

http://vig.prenhall.com/catalog/academic/product/0,1144,0132435942,00.html

It's published under a creative commons license so you may well find it online available for legal download.

Steve Clarke (clarkesj) said : #15

Thanks Alan Pope, that solved my question.

David S (cq081) said : #16

And mine, many thanks. :)

kdkirsch (kdkirsch) said : #17

sudo chmod 700 /home/[USER]

Solved my problem. Thanks so much for your help.

Thank very much for the fix. It solve mine too.

Thank very much for the fix. It solved mine too.

stuntman (snityam) said : #20

thanks a lot....this short solution helped me solve my problem

houstonbofh (leesharp) said : #21

I guess this bug is still out there. A new install of Gutsy on the 9/24 daily build, and after installing all of the "essentials" this appeared on reboot. Fixing permissions on the home directory was the fix.

So, I would not mark it "Solved" as the problem still occurs, and the fix is not trivial to find. However, I am not sure what broke it.

james davis (jazz452) said : #22

Cheers Ralph you were the first with the fix.

Blue-July (ritab-ch) said : #23

Guys,
chmod 644 .dmrc
chmod 700 ~

solved it for me. Thank you-Ralph...You made it so simple.

FED (mufeed-alaa) said : #24

Guys! i`m really confused.. I mean, i have the same problem, and I tried the same solutions!
but.. nothing worked out for me!
please, HELP!

peter (lovedaypeter) said : #25

HELP!!!, i have the same problem as FED: i tried the chmod 644 and the chmod 700, but the message still appears. im running ubuntu 8.04; initially the system kept crashing, so i ran the recovery kernel. now it doesnt crash, but this message keeps appearing.
besides being annoying, does anyone know if it affects the system?

thank you
help please

ps-write every command in an idiots guide version, im still new to ubuntu and linux

peter (lovedaypeter) said : #26

i just ran that ls -l command and got:
-rw -r --r-- 2 root lp 1825 2009-01-05 01:43 .dmrc

houstonbofh (leesharp) said : #27

peter wrote:
> Question #7296 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/7296
>
> peter posted a new comment:
> i just ran that ls -l command and got:
> -rw -r --r-- 2 root lp 1825 2009-01-05 01:43 .dmrc

It should look like this;

-rw------- 1 username username 28 2009-01-05 09:27 .dmrc

Try "sudo chwon user:group .dmrc" and see if it gets better.

peter (lovedaypeter) said : #28

houstonbofh:
i supposed you meant chown, and that chwon was a typ-o, coz it wasnt recognised.
i ran the command with the group option but it gave me an error, after reading the help file for chown, i just ran
sudo chown ubuntu .dmrc
that seems to have fixed it. thanks

do tell me if there command i used has any unwanted consequences please.

again thanks

peter (lovedaypeter) said : #29

just to clarify the last comment, ubuntu is my user name, so the command was
sudo chown user .dmrc

houstonbofh (leesharp) said : #30

peter wrote:
> Question #7296 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/7296
>
> peter posted a new comment:
> houstonbofh:
> i supposed you meant chown, and that chwon was a typ-o, coz it wasnt recognised.

I would love to tell you that it was an intentional mistake to make sure
people would actually read, and not just cut and paste... It sounds
better anyway. :) But it was just typing while hungry... And what you
did is fine. Glad it worked.

   Lee

Alex Fuchs (al-fox) said : #31

Using Ubuntu 8.10
Got the same error message at login after giving read & write permissions to my /home folder to a virtual machine i setup with VirtualBox.
Tried reseting permissions on /home folder and .dmrc file using the command line but could not get it right.
Using Gnome Commander showed: for /home, Owner: username ;
Group: username ; Access permissions: read,write,execute to Owner only set the Number view to 700.
For .dmrc, Owner: username ; Group: username ; Acces permissions: read,write to Owner and read to Group & Others set the Number view to 644.
Hope this helps.

Brayan Habid (brayanhabid) said : #32

Just to help a little. I'm using both jaunty and intrepid, jaunty showed this problem and here is my solution:

i did a chown brayan to /home/brayan/ and then to /home/brayan/.dmrc

then i did a chmod 644 to /home/brayan/.dmrc and a chmod 700 to /home/brayan

for some reason, jaunty doesnt accept that home folder may be read by other users. Any chmod different from 700 (like 755, 744 or other) will show the .dmrc ignored error again

Doug Haskin (dshaskin) said : #33

I received the same error messages on both my machines (desktop and laptop, running 9.04) this morning, after working with file sharing on both machines yesterday.

The problem appears to start up when you share your home folder. The share works, but 9.04 doesn't seem to like it, and gives the error message on subsequent start-ups.

While I understand that enabling full sharing on your home folder might not be the best security move, in my case I am only doing it while in my home office, as it's a lot quicker than setting sharing on individual folders as needed below my home folder. I cancel the sharing when using the laptop out in the wild.

For those who prefer to work with the Gnome interface and not at the command line, it might be helpful to know that I made the necessary changes to the file permissions (to eliminate the error message) using the Nautilus file browser. I've listed the steps needed to do that below.

I do understand that using the GUI interface is not as direct as using a command line, but it can be a more comforting way to deal with the problem for those who are new to the operating system, particularly MS users who don't remember or never had to deal with the old DOS command line.

Thanks to all above for pointing me in the right direction!
------------------------
GNOME GUI method for changing File Permissions:
Select "Places" then "Home Folder" from the menus on the upper left.
The window that is displayed shows the contents of your home or username folder. Because you need to modify the permissions of that containing folder, click once on the "Up" arrow on the menu at the top of that window.
You are now looking at the contents of your Home folder, in which there should be a folder with your username.
Right click on that folder and select "Properties" from the resulting menu.
On the Properties window, select "Permissions"
The owner on the first line should be you.
Folder access beneath that should be "create and delete files"
File access will not show anything, but drop it down and select "read and write"
Group should be set to you
Folder access beneath that should be "create and delete files"
File access will not show anything, but drop it down and select "read and write"
The folder access line under "Others" should say "Access files"
Again, File access will not show anything, but drop it down and select "read only"
Finally, assuming you want all the files in your home or user directory to share the same permissions, you can click on the "Apply permissions to enclosed files" button at the bottom of the page.
Click "Closed"
Restart or reboot and you should not receive the error message

Fabio Cardoso (pktp69) said : #34

Just to clarify the question.
This error occurs when you mess up with the permissions of your prime /home/user, changing it to 777.
The propper way being 700, any changes made to it may crash the recursive directories.
After changing the permisson of /home/user (or ~) to 700, change the permission of .dmrc to 644 and reboot. That´s it, you got it fixed.
I prefer not to do this as root for safety reasons.

[]s
pktp69