IBM lenovo T60 with 4GB of memory, Ubuntu Fiesty (7.04) 64bit only sees 3GB. Can it use all?

Asked by stathy on 2007-05-23

I am wondering if Fiesty is using the full 4GB of memory on my system even though it only claims to see 3GB?

If not how can I correct this so it can utilize the full 4GB?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
stathy
Solved:
2007-06-12
Last query:
2007-06-12
Last reply:
2007-06-12
stathy (stouloumis) said : #1

Find documentation that Linux actually reservers ~1GB of memory for the kernel and leaves 3GB available. So, in a sense it is using the full 4GB.

stathy (stouloumis) said : #2

Actually, this has been submitted to the kernel bug team.

Cesare Tirabassi (norsetto) said : #3

Do you have a bios option called "Memory Remap" or something similar?
If you enable that, you will see the full 4GB (check it again in BIOS) but it is possible that Ubuntu will not boot (due to modules using MMIO).

stathy (stouloumis) said : #4

No I did not see the Memory Remap option in the bios. Let me check to see if there is a bios upgrade.

Is this the only way to get it to currently work?

stathy (stouloumis) said : #5

Also, the bios shows the full 4GB. It is just that Fiesty does not seem to be able to see the full 4GB.

Cesare Tirabassi (norsetto) said : #6

OK, can you please add this info to the bug report? Thanks.

Best stathy (stouloumis) said : #7

Information added to the associated bug.

Khalid Al-Baloushi (baloushi) said : #8

Nothing is wrong with Feisty or your machine. This is a normal problem for all 32-bit operating systems (including XP and Vista).

To overcome this problem in Linux you may either use the 64 bit version or rebuild the kernel with support of 64GB RAM.

To rebuild the kernel:
http://www.howtoforge.com/kernel_compilation_ubuntu

You may also use the Feisty server kernel:
http://www.softwarevoices.com/archives/53-Only-seeing-3GB-of-RAM-on-Ubuntu-7.04-Feisty-when-4GB-are-installed-SOLUTION.html

Khalid Al-Baloushi (baloushi) said : #9

I'm sorry, I just noticed the title!

If you're using the 64bit version then this is probably a bug.

KK (kkfok1) said : #10

This is not really a bug but limitation that can be resovled by incorporate the HIGHMEM64G=y into the kernel and release it as part of the repo. I have tried to recompile the kernel with this option and 4GB ram was recognised but there are other drivers problem. So, to recompile is not really an option to me. Sincerely hope that the Ubuntu team will rectify this into the next release/patch.

Thanks

Ivin (ivin-fox) said : #11

I have the same problem on my R60. I upgraded via adept manager from 7.10 (where everything was ok - 4GB total physical memory) to actual 8.04 -> 2.95 Total physical memory ....
I going to install old version again, because i need this mem for my simulations ...

enos76 (enos76) said : #12

This is a limintation of all Lenovo T60 and T61 Thinkpads and cannot be overcome in any way.

The limitation is caused by the Intel chipset used on these machines. Other manufactorers (e.g. Dell) have been able to solve the issue by remapping the memory above 3Gb, while Lenovo just chose the easy way out and put a 3Gb limit. 4Gb can be installed (2+2), they will be recognized by the BIOS, but only 3Gb will be available to the operating system, not even if the latter is 64bit, not even with the latest (to date) BIOS updates.

References:
- My Own Experience With One Of These Crappy Machine (c)
- http://blog.venthur.de/2007/05/14/4gb-ram-on-a-t60/
- http://forums.lenovo.com/lnv/board/message?board.id=T_Series_Thinkpads&message.id=4054
(ignore comments from non-lenovo owners who talk just about 32 vs 64 bit OSs)

Fabián Rodríguez (magicfab) said : #13

Fabián Rodríguez suggests this article as an answer to your question:
FAQ #669: “I have 4GB or more of RAM but can't see it in Ubuntu. How can I enable support for all my RAM ?”.