Connecting to Apple Time Capsule

Asked by caffeinated

I recently installed 9.04. When I look at "places - network" my time capsule is listed by name. If I double click on it, a blank window opens, showing no files or folders.

The time capsule is also the air port I'm using to connect to the internet. It seems I'm connected to the time capsule, since I can use the internet and also because the device shows up by it's name in "network." But none of the folders on the time capsule show up. Under "properties" no relavant info shows up about the time capsule either.

I've tried to mount the drive in a terminal window, using the IP address and share name. The time capsule name is "Kate's Time Capsule" Would the apostrophe or spaces cause a problem? I've also tried to type the IP address directly into the Nautilus address bar.

I'm lost. Can anyone help?


Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
caffeinated (steve-ferencik) said :

I was able to get into the Time Capsule from my wife's Mac. I had to change some permissions. Sorry to waste everyone's time.

Revision history for this message
komputes (komputes) said :

I can confirm having the same problem with a Time Capsule. I do not know how to get it to display files or prompt for authentication. I only get a blank window with 0 items.

Revision history for this message
David Latapie (david-latapie) said :

Same thing for me: Ubuntu on a PC, a dead Mac, a Time Capsule with my data, the TC shows up on network but nothing else, blank folder once I click it. Help!

Revision history for this message
jonoisawitness (jonoisawitness) said :


I have the exact same problem. would you please be able to post what you did to get it working?
any help is appreciated as i am an ubuntu noob.