failed to find DC for domain member with update 2.2.3-3ubuntu0.10

Asked by rxexgx


not really sure if it's a sssd problem or a dependency (samba?), but since 2.2.3-3ubuntu0.10 we can't join any vm into the domain.

tested with focal:
Ubuntu 20.04.6 LTS

net ads join member -U <user> osName=Ubuntu osVer=`lsb_release -rs` -S <DC>.<DOMAIN>
Password for [<DOMAIN>\<USER>]:
Failed to join domain: failed to find DC for domain member - A domain controller for this domain was not found.

Working fine with 2.2.3-3ubuntu0.9

No change in: samba.conf / sssd.conf / krb5.conf

Anything I missed, or any tip where I can have a look at?


Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Revision history for this message
Best Manfred Hampl (m-hampl) said :

There is no difference in the sources between sssd version 2.2.3-3ubuntu0.9 and 2.2.3-3ubuntu0.10; it was repackages because of changes in the dependent samba package. I assume the cause lies in samba and not sssd.

Maybe what you see is Bug #2009858

Revision history for this message
rxexgx (rxexgx) said :

Thanks. Indeed, it's the issue. Just downgraded the packages and the domain join is working.

Revision history for this message
rxexgx (rxexgx) said :

Thanks Manfred Hampl, that solved my question.

Revision history for this message
sdfd (dfgfger) said :

TDMG is a full-service marketing agency that offers a wide variety of digital and traditional services. They have experts in all areas of marketing so that they can help businesses with any stage of marketing. Whether you need help creating a plan, executing it, or measuring the results, TD Marketing Group has you covered. Contact us today to see how they can help your business grow!