Cannot find network driver for Lenovo ideapad 1

Asked by Charles Dunaway

I have installed Kubuntu 22.10 on my Lenovo Ideapad 1 and it does not see any wifi networks. Network controller: Realtek Semiconductor Co., Ltd. Device b852 is indicated by sudo lspci

I have tried installing the drivers via apt but get "The repository ' kinetic Release' does not have a Release file." error.

I have tried a github solution as well but it will not make properly due to not having been compiled with same version.

Does anyone have a solution for this or is there currently not a valid driver for this device?

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Manfred Hampl (m-hampl) said :


1. Install (K)Ubuntu 22.04 instead of 22.10
2. Manually download the deb file for jammy from the kelebek333 PPA
3. Maybe helps

Revision history for this message
actionparsnip (andrew-woodhead666) said :

I suggest Ubuntu 22.02 which is LTS. Ubuntu 22.10 will be end of life (EOL) in July this year

Revision history for this message
actionparsnip (andrew-woodhead666) said :

You are getting no release file for kinetic as the PPA doesn't support kinetic

Not all PPAs support all releases of Ubuntu, nor are they required to do so

Can you help with this problem?

Provide an answer of your own, or ask Charles Dunaway for more information if necessary.

To post a message you must log in.