Disable touchpad while typing

Asked by Roger Stanley Jarvis

I have a Starlabs STARLITE laptop, running Ubuntu 20.04 focal (x86-64) and using Cinnamon 4.4.8.
My system settings allow Disable touchpad while typing, and I have this switched on.
However, it does not disable the touch pad: the slightest touch moves the cursor to a new insertion point, or highlights text which the next keystroke replaces, or clicks a button if the cursor gets near one.
There must be a solution?
While I have never been convinced that it ever worked satisfactorily it certainly seems to have got much more troublesome in recent months.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Roger Stanley Jarvis
Last query:
Last reply:
Revision history for this message
Lakakhan (lakakhan) said :

Disabling the touchpad while typing is a feature that is commonly found on laptops and other portable devices. The purpose of this feature is to prevent accidental cursor movement or clicks while you are typing, which can be frustrating and disruptive.

The steps to disable the touchpad while typing can vary depending on the device and operating system you are using. Here are some general steps you can try:

Check the touchpad settings: Look for a settings menu or control panel for the touchpad. You may be able to find a setting that allows you to disable the touchpad while typing.

Use keyboard shortcuts: Some devices have built-in keyboard shortcuts that allow you to quickly enable and disable the touchpad. Look for instructions in your device's manual or online documentation to find out what the shortcuts are.

Use third-party software: Some third-party software programs allow you to control the touchpad and disable it while typing. Look for software specifically designed for your device or operating system.

Look for a Function key: Some laptops have a function key that allows you to disable and enable the touchpad. Pressing the key combination (fn + F3, fn + F5, etc) will disable or enable the touchpad.

Check the BIOS settings: In some cases, the touchpad settings can be managed through the BIOS. Restart the computer and press the key to enter the BIOS settings. Look for the touchpad settings and disable the touchpad while typing.

Please note that the steps and the availability of the features may vary depending on the device and operating system you are using, so it's always a good idea to check the device's manual or the manufacturer's website for the most up-to-date instructions.

Please let me know if there's anything else I can help you with.

Revision history for this message
Lakakhan (lakakhan) said :
Revision history for this message
Roger Stanley Jarvis (rsj102) said :

Thank you. I wasn't able to trace references in the places you suggested, other than the System file itself, as I mentioned.

However, by trying each function key separately I eventually made F1 work. My first attempts only locked the cursor and would not then unlock it - my only option was then a complete shutdown with the on-off key. Eventually, though it began to do both jobs, and (so far) continues to turn the touchpad off and on.