epson workforce 645 printer will not work with ubuntu 22.04

Asked by Geoffrey Scully

Recent clean install of 22.04. LTS on a Dell Optiplex 7050.
Epson Workforce 645 printer is recognized, and found drivers were installed. When I turn on the printer - connected by USB, and I've tried a different cable - the computer beeps recognition, as it does when I turn off the printer.
When I try to print a document from LibreOffice Writer a popup on the computer says it's printing, then another promptly comes up saying the printing job has been completed. But nothing happened at the printer. I've tried rebooting the printer at that moment.
It seems that this "cups" software is satisfied the job is done but has not actually passed the command to the printer, from what I've been able to discern from trying to research this. I have no idea what to try next.
I've tried different drivers, and uninstalling and re-installing the printer.
The printer worked fine on my previous computer running an earlier Ubuntu version in 32 bit.
My knowledge of terminal is pretty much limited to copy and pasting command lines.
Thanks for any advice!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Geoffrey Scully
Solved:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1
Revision history for this message
Geoffrey Scully (jeff98) said :
#2

Thank you very much for your response!
When I uninstall the printer and then select "Add Printer" and select "Workforce 645", it searches for drivers and gives me two listings, the 2nd of which, when tried, brings me back to the first, which has the Accept or Decline options.
I tried to go through the troubleshooter, to no avail.
I don't know how to point it to a different driver that I've downloaded.
Also, do I need a "deb" in the driver filename? I'm assuming that's for debian and I recall Ubuntu is that type system.
I have an Intel 64 bit computer? 'Any chance you could point me to the right driver?
I appreciate your taking the time to help me!
jeff98

Revision history for this message
staedtler-przyborski (staedtler-przyborski) said :
#3
Revision history for this message
Geoffrey Scully (jeff98) said :
#4

Thanks taking the time to send the link, which I've been to.
When you "Accept" the following choices appear:

Dateiname Dateigröße
epson-inkjet-printer-escpr-1.7.21-1lsb3.2.i486.rpm 4.41 MB
epson-inkjet-printer-escpr_1.7.21-1lsb3.2_i386.deb 4.89 MB
epson-inkjet-printer-escpr-1.7.21-1lsb3.2.x86_64.rpm 4.41 MB
epson-inkjet-printer-escpr_1.7.21-1lsb3.2_amd64.deb 4.89 MB
epson-inkjet-printer-escpr-1.7.21-1lsb3.2.src.rpm 4.68 MB
epson-inkjet-printer-escpr-1.7.21-1lsb3.2.tar.gz 5.09 MB
Information
[Notice]
In order to install these drivers, you need to install LSB package (version 3.2 or later) beforehand.

Ubuntu: # apt install lsb
Fedora: # yum install lsb
openSUSE: # yast --install lsb

So...
Which one do I download?
And once I have downloaded it, how do I get the program - under Settings, Printer - to find the driver as a choice when I re-install the printer?
Thanks for reading this! I appreciate any help you can offer.
- jeff98

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#5

Grab the amd64 deb file

Revision history for this message
Geoffrey Scully (jeff98) said :
#6

How do I install it?
Thanks for your response!

Revision history for this message
Manfred Hampl (m-hampl) said :
#7

Execute the commands (in a terminal window):

sudo apt install lsb
sudo dpkg -i epson-inkjet-printer-escpr_1.7.21-1lsb3.2_amd64.deb

and report he results.

Revision history for this message
Geoffrey Scully (jeff98) said :
#8

Manfred - Thanks so much! But listen...

While I was waiting I "grabbed the amd64 deb file" and after it showed "downloaded" I clicked on it and a new popup gave me 2 options: to open it under "Software Install", or open it under "Archive Manager". Before, I had gone directly to my Downloads folder and unzipped a driver file.
Then, in reading the forums I stumbled upon this command and decided to try it:
sudo apt install printer-driver-escpr
...and it found and installed that amd64 deb driver without any further input from me!
I opened LibreOffice Writer and was amazed when it printed out a page of beautiful black and white. The wonders never cease!
I am very grateful for everyone's help !

Revision history for this message
Manfred Hampl (m-hampl) said :
#9

Perfectly done on your own - congratulations!