Setting Up Dual Monitors

Asked by Chewmanfoo on 2007-05-22

Hello,

I've used Ubuntu for a while, but have now installed it on a PC with dual monitors. In SUSE Linux Enterprise Desktop, configuring both monitors was relatively easy and could be done through a GUI. Does Ubuntu feature something similar? I'm not familiar with configuration files at all and would prefer not to have to edit them. One monitor is connected to an onboard Intel 915G and the second is connected to an add-on Radeon 7000 card. If I could enable dual-head mode on the Radeon, that would be fine, too. If anyone has any step-by-step instructions for setting this up, that would be great.

Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Chewmanfoo
Solved:
2007-05-25
Last query:
2007-05-25
Last reply:
2007-05-23
Massimo Forti (slackwarelife) said : #1

Thanks for your question. This is a example of xorg.conf file in which is configured two monitors:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
 FontPath "/usr/share/fonts/X11/misc"
 FontPath "/usr/share/fonts/X11/cyrillic"
 FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
 FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
 FontPath "/usr/share/fonts/X11/Type1"
 FontPath "/usr/share/fonts/X11/100dpi"
 FontPath "/usr/share/fonts/X11/75dpi"
 # path to defoma fonts
 FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
 Load "i2c"
 Load "bitmap"
 Load "ddc"
 Load "dri"
 Load "extmod"
 Load "freetype"
 Load "glx"
 Load "int10"
 Load "vbe"
EndSection

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc105"
 Option "XkbLayout" "us"
EndSection

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ImPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "stylus"
 Option "Device" "/dev/input/wacom"
 Option "Type" "stylus"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "eraser"
 Option "Device" "/dev/input/wacom"
 Option "Type" "eraser"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "cursor"
 Option "Device" "/dev/input/wacom"
 Option "Type" "cursor"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
    Identifier "ATI Technologies Inc RV280 [Radeon 9200 PRO] 0"
    VendorName "ATI"
    BoardName "ATI Radeon"
    Driver "radeon"
    BusID "PCI:1:0:0"
    Screen 0
EndSection

Section "Device"
    Identifier "ATI Technologies Inc RV280 [Radeon 9200 PRO] 1"
    BoardName "ATI Radeon"
    Driver "radeon"
    BusID "PCI:1:0:0"
    Screen 1
EndSection

Section "Monitor"
 Identifier "L194WT"
 Option "DPMS"
         HorizSync 56-70
         VertRefresh 28-83
EndSection

Section "Monitor"
 Identifier "CPD-G500"
 Option "DPMS"
        HorizSync 30-121
        VertRefresh 48-160
EndSection

Section "Screen"
 Identifier "Default Screen0"
 Device "ATI Technologies Inc RV280 [Radeon 9200 PRO] 0"
 Monitor "L194WT"
 DefaultDepth 24
 SubSection "Display"
  Depth 1
  Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 4
  Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 8
  Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 15
  Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 16
  Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 24
  Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
 EndSubSection
EndSection

Section "Screen"
Identifier "Default Screen1"
Device "ATI Technologies Inc RV280 [Radeon 9200 PRO] 1"
Monitor "CPD-G500"
DefaultDepth 24
      SubSection "Display"
            Depth 1
            Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
      EndSubSection
      SubSection "Display"
             Depth 4
             Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
     EndSubSection
     SubSection "Display"
            Depth 8
            Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
     EndSubSection
     SubSection "Display"
            Depth 15
            Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
            Depth 16
            Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
           Depth 24
           Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
EndSection

Section "ServerLayout"
  Identifier "Default Layout"
  Screen "Default Screen0"
  Screen "Default Screen1" LeftOf "Default Screen0"
  InputDevice "Generic Keyboard"
  InputDevice "Configured Mouse"
  InputDevice "stylus" "SendCoreEvents"
  InputDevice "cursor" "SendCoreEvents"
  InputDevice "eraser" "SendCoreEvents"
  Option "Xinerama" "on"
  Option "Clone" "on"
EndSection

Section "DRI"
 Mode 0666
EndSection

To do the right way you must do in a shell:

$: sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.buckup #this do a backup of you xorg.conf file

after do in a shell:

$: sudo gedit /etc/X11/xorg.conf

Copy my post file into it (delete all you see before), than you must change this part of file:

Section "Monitor"
 Identifier "L194WT"
 Option "DPMS"
         HorizSync 56-70
         VertRefresh 28-83
EndSection

Section "Monitor"
 Identifier "CPD-G500"
 Option "DPMS"
        HorizSync 30-121
        VertRefresh 48-160
EndSection

You must insert you data. If you have some doubt I'm here. Thanks

Chewmanfoo (chewmanfoo) said : #2

Hello Massimo,

Thanks for the quick reply! My xorg.conf is currently blank. Should there be something in it?

Chewmanfoo (chewmanfoo) said : #3

Hello Massimo,

Sorry, disregard my previous post. My xorg.conf does contain information. I'll give it a try and let you know how I make out.

Massimo Forti (slackwarelife) said : #4

Have you found any problems ??? I'm here Thanks

Chewmanfoo (chewmanfoo) said : #5

Good morning Massimo,

I added the appropriate lines for device, monitor and screen to my xorg.conf, but it's not working. I think it's because I don't have the correct driver name or PCI slot identifier. Where would I be able to find the name of the driver that my Radeon 7000 is using?

Massimo Forti (slackwarelife) said : #6

Ok, post your backup file. We start using it. Thanks

Chewmanfoo (chewmanfoo) said : #7

Hello Massimo,

Here's the contents of my original, untouched xorg.conf file:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
 FontPath "/usr/share/fonts/X11/misc"
 FontPath "/usr/share/fonts/X11/cyrillic"
 FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
 FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
 FontPath "/usr/share/fonts/X11/Type1"
 FontPath "/usr/share/fonts/X11/100dpi"
 FontPath "/usr/share/fonts/X11/75dpi"
 # path to defoma fonts
 FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
 Load "i2c"
 Load "bitmap"
 Load "ddc"
 Load "dri"
 Load "extmod"
 Load "freetype"
 Load "glx"
 Load "int10"
 Load "vbe"
EndSection

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc105"
 Option "XkbLayout" "us"
EndSection

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ImPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "stylus"
 Option "Device" "/dev/input/wacom"
 Option "Type" "stylus"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "eraser"
 Option "Device" "/dev/input/wacom"
 Option "Type" "eraser"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "cursor"
 Option "Device" "/dev/input/wacom"
 Option "Type" "cursor"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
 Identifier "Intel Corporation 82915G/GV/910GL Integrated Graphics Controller"
 Driver "i810"
 BusID "PCI:0:2:0"
EndSection

Section "Monitor"
 Identifier "DELL E173FP"
 Option "DPMS"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Device "Intel Corporation 82915G/GV/910GL Integrated Graphics Controller"
 Monitor "DELL E173FP"
 DefaultDepth 24
 SubSection "Display"
  Depth 1
  Modes "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 4
  Modes "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 8
  Modes "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 15
  Modes "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 16
  Modes "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 24
  Modes "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
 EndSubSection
EndSection

Section "ServerLayout"
 Identifier "Default Layout"
 Screen "Default Screen"
 InputDevice "Generic Keyboard"
 InputDevice "Configured Mouse"
 InputDevice "stylus" "SendCoreEvents"
 InputDevice "cursor" "SendCoreEvents"
 InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
 Mode 0666
EndSection

Best Chewmanfoo (chewmanfoo) said : #8

Unfortunately, I had to switch back to Windows on my computer at work where I was using the dual monitors. I just couldn't get Ubuntu to recognize both monitors, after hours of troubleshooting. We use several Windows-only applications internally as well, so it was for the better. I'll continue to use Ubuntu at home where I'm not as dependent on things working the way I'm used to all the time!

Jason Jia (jiaruo) said : #9

OH, looks like Ubuntu display setting is not that easy, I have two screens now, but only use as one. Thanks the answer from Chewmanfoo but I am new to linux, can you tell me how to get the "/etc/X11/xorg.conf (xorg X Window System server configuration file)" Thanks

Chewmanfoo (chewmanfoo) said : #10

Hi Jason,

You can fire up Terminal (located under Applications - Accessories if I remember correctly) and type:

cd /etc/X11

Then type:

sudo gedit xorg.conf