PWG Raster printing is broken

Asked by Peter

PWG raster printing output is corrupt. If you can share a link that goes directly to a form to enter a bug I can supply the details.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Revision history for this message
Manfred Hampl (m-hampl) said :

What kind of bug form are you looking for? You can (and should) put any text information into this question document.

Please provide more details (at least the Ubuntu release, make and model of the printer if applicable, the actions that you are executing, any error messages, etc. etc.)
The minimum required is providing the following three items:
- What you do
- What you expect to happen
- What's happening instead

Revision history for this message
Peter (ppoirier1) said :

Was looking for a form where you enter a bug title, repro conditions, OS version, etc. then it tells you the bug number after you submit. But I can do here as well.

OS: 22.04 LTS
Problem: Ubuntu generates corrupt PWG-Raster format print data
Environment: Print emulator that returns image/pwg-raster in document-format-supported
Repro: Print a simple website to said print emulator
Expected result: OS generates valid RWG-Raster and sends to the printer
Actual result: Printing a 4-page website sends several GB of garbage to the printer.
Regression: Yes. Worked in 21.10. May be related to the 2.3.3op2 -> 2.4.1 CUPS upgrade?

Note: Most printers that support image/pwg-raster also support image/urf, in which case Ubuntu sends urf, which works fine, so you may not actually see this issue in normal use.
Note 2: Even if the printer returns image/pwg-raster in document-format-preferred, Ubuntu still forces image/urf, another clash between expected and actual behavior. So the only way to repro this is to remove image/urf from document-format-supported.

Revision history for this message
Manfred Hampl (m-hampl) said :

The preferred way of reporting bugs in Ubuntu packages is using the "ubuntu-bug" command and providing the faulty package as parameter. From your description above I am not able to identify the package that might be causing the problem.
Does the error appear when printing from programs like openoffice, or are you using the command line (e.g. lpr) for sending the print job to the printer, or how do you initiate the printing?

Please see also

Revision history for this message
Peter (ppoirier1) said :

Yes, that was where I got stuck with ubuntu-bug. It's the base OS, not any app or package. Repros with Firefox, Libre Office, etc. The app doesn't matter.

Revision history for this message
Best Manfred Hampl (m-hampl) said :

Even the "base OS" consists of packages.

A potential candidate might be the package cups, containing a file named /usr/lib/cups/filter/rastertopwg

Revision history for this message
Peter (ppoirier1) said :

OK, I will try again. Vielen dank!

Revision history for this message
Peter (ppoirier1) said :

Following up, "ubuntu-bug cups" did run and after about 5 password prompts collected some data and possibly sent it to the dev team, but probably nothing relevant since this error didn't cause a crash.

Revision history for this message
Peter (ppoirier1) said :

Thanks Manfred Hampl, that solved my question.