Multimedia buttons on Cherry CyMotion Master Linux keyboard not working

Asked by Terry Coles

Since I upgraded to Kubuntu 22.04, the Multimedia buttons stopped working as they used to. My player of choice is Clementine, but they aren't working properly in any player.

If Clementine has focus then the Stop, Next Track and Previous Track buttons work, but I cannot make the Play/Pause button work. If Clementine does not have focus, such as when I'm using a different Plasma Activity, none of the multimedia buttons work.

Back in 2006 when I bought the keyboard I had some problems with mapping the Media keys and I even have a copy of an email that I sent to Cherry asking about this because the supplied software only supported 32 bit machines and I had a 64 bit Athlon at the time. The substance of my query was regarding the compilation of the supplied source code and whether it
would work. Unfortunately I can't find any response.

Whatever happened, I clearly fixed it at the time because it has worked ever since.... until Kubuntu 22.04.

Cherry do not appear to support this keyboard anymore because the downloads page only lists Windows drivers under the listing for the *Linux* keyboard, so no hope in that direction.

I can control the music using the 'Media Player' widget, but this requires two mouse clicks whereas the keyboard button falls easily to hand.

Can anyone shed any light on this?

Question information

Language:
Portuguese Edit question
Status:
Needs information
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:

This question was reopened

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

Does the system have a make and model?
Does the keyboard have a make and model?

Revision history for this message
Terry Coles (terryjcoles) said :
#2

This computer is a Dell Optiplex 790 with:

Operating System: Kubuntu 22.04
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.3
Kernel Version: 5.15.0-27-generic (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-2600 CPU @ 3.40GHz
Memory: 7.7 GiB of RAM
Graphics Processor: NVIDIA GeForce GT 720/PCIe/SSE2

The keyboard is a CyMotion Master Linux keyboard:

Part No: G86-21070GBAAAC /02
Serial No: G 000409 3S25

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#3

If you run

xev

In a terminal and press the media buttons. Do they create events OK?

Revision history for this message
Terry Coles (terryjcoles) said :
#4

Yes.

This is some of what I get from pressing the Play/Pause button:

KeyRelease event, serial 41, synthetic NO, window 0x7400001,
    root 0x293, subw 0x0, time 70401, (-656,-99), root:(215,346),
    state 0x10, keycode 172 (keysym 0x1008ff14, XF86AudioPlay), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#5

If you go into keyboard settings. Select to change the key for play and whatever controls you have and press the button when asked. It may help

Revision history for this message
Terry Coles (terryjcoles) said :
#6

I tried that. I also tried binding the keys from within Clementine, but no joy. Some of the keys work, eg, the Stop key, but only if I have focus. Similarly, some of the the standard keys don't work eg, F6 for Play/Pause, but the ones that work still only work if Clementine has focus.

I'm currently burning a copy of Ubuntu 22.04 to a USB stick to see if that makes any difference. If it does, I'll try a new Kubuntu 22.04 (instead of upgrading), If it doesn't I'll try Mint. I may get some clues from that.

Revision history for this message
Terry Coles (terryjcoles) said :
#7

Well. I just spent a happy hour or so trying different distros to see if the behaviour changed and it certainly did! This problem is a bit like a chameleon; it changes it's behaviour depending on what is happening. Here's a summary of what I see in Clementine and Rhythmbox:

1. In Kubuntu 22.04, I get no Play/Pause button support at all, the Stop button works and the Next and Previous Track buttons work OK. I now find that they work when the player doesn't have focus. Maybe that something to do with the fact that I've installed Rhythmbox since the last post.

2. In Ubuntu 22.04 (clean installation) the Play/Pause button works but the Next and Previous Track buttons jump several tracks at a time.

3. In Linux Mint 20.3, the Play/Pause button works with Next and Previous Track buttons only working some of the time !!!!

This possibly isn't a fair test because these two distros don't have Activities so the program always had focus.

I'm thinking that the problem is the lack of CyMotion Master Linux keyboard driver support, eg the driver that I installed originally or the kernel has had something dropped. Is that likely? If so, would a different multimedia keyboard, (say from Logitech) be likely to work?

Revision history for this message
Terry Coles (terryjcoles) said :
#8

I just received my nice shiny new Logitech G213 keyboard and the symptoms have changed yet again:

I still can't get the Play/Pause button to work, but Stop, Next Track and Previous Track all work fine. The Volume Up, Volume Down and Volume Mute all work as advertised, so this is definitely a step forward (plus the keys light up very prettily, which can't be bad with my ageing eyes). :-)

However, the button that I use the most still doesn't work; Play/Pause. So I'm still looking for an answer to this.

Revision history for this message
Terry Coles (terryjcoles) said (last edit ):
#9

This morning I booted up and the Play/Pause button is working !!!! I have no explanation for this; there were no updates applied after my post yesterday afternoon and I did reboot after I plugged the new keyboard in. The other multimedia buttons also work so now I'm happy. :-)

So I ended up buying a new keyboard which didn't solve this problem, but I don't particularly regret this. I'm sure the old one would have started to show it's age soon.

Revision history for this message
Terry Coles (terryjcoles) said :
#10

I'm sorry to resurrect this, but this morning when I booted up the Play/Pause key was not working again.

So what could be common to three distros (Kubuntu, Ubuntu and Mint) two different keyboards and also be ephemeral in the way described above?

Revision history for this message
Terry Coles (terryjcoles) said :
#11

I just tried Fedora 36 live and the multimedia keys work fine in RhythmBox. The problem is that with the ephemeral nature of the fault, I can't be sure that this is the problem, although I must say it is likely.

Revision history for this message
Terry Coles (terryjcoles) said :
#12

Another idea occurred.

My Dell XPS13 laptop comes with multimedia keys of its own, so I booted it up and tried playing some tracks in Clementine. Everything worked. However, this was with Kubuntu 21.10 installed.

I then upgraded to 22.04 and the multimedia keys continued to work as they should. I then plugged in the Cherry K/B and, guess what? The keys all worked.

This is odd because I upgraded the desktop too, so this problem presumably has to do with some other software that I have installed on my desktop but not on my laptop. There's a lot of that, so it may be a losing battle to track it down. Unless any other ideas are forthcoming, I think I'm going to have to do a clean installation of Kubuntu 22.04 and then add the software back, one package at a time until it either breaks or I get a fully functional system.

Revision history for this message
Terry Coles (lp-hadrian-way) said :
#13

I have just spotted something which shows that the keyboard was a red herring. When the Play / Pause button is pressed the music stops and the player goes to Pause mode. When the button is pressed again, the music may or may not be heard. The key phrase is 'be heard'. If I have just been listening to the audio from a video played in Chromium, the player restarts (I can see the progress indicator increasing), but there is no sound.

It seems to me that Chromium is grabbing the audio channel and not letting it go. I find that a bit confusing because I thought that the linux sound system could play music from multiple sources and certainly if I don't press the Play / Pause button while watching a video, I can hear both audio tracks.

Any thoughts on this?

BTW. This shows why the fault was such a chameleon; if I hadn't been watching video it worked and if I had it didn't. It's just that I hadn't realised this at the time.

Can you help with this problem?

Provide an answer of your own, or ask Terry Coles for more information if necessary.

To post a message you must log in.