Accessibility 'Hover Click' not working in Jammy 22.04

Asked by Rashad Chowdhury

The 'Hover Click' I am discussing can be started by

1. Opening 'Settings'
2. 'Accessibility' on the left bar
3. Scroll down to 'Click Assist'
4. Toggle 'Hover Click' on

Normally 'Hover Click' lets you place your mouse somewhere and a click will happen without having to press your physical mouse. On Jammy 22.04 I've been finding when I turn 'Hover Click' on, it will work for a few clicks, though unreliably, and then just stop working.

To get the few clicks working again, I can toggle 'Hover Click' off and then back on in the Settings > Accessibility > Click Assist > Hover Click but again, it will be unreliable and stop after a few clicks.

Can anyone help me troubleshoot? For example, how to uninstall and reinstall 'hover click' or any alternative suggestions to fix this issue.

I have some pain clicking my mouse repeatedly, so this will be very appreciated. This also makes, Jammy 22.04 a blocker for me since I was using 'Hover Click' on Impish 21.10 just fine, so I'm planning to revert back to Impish as a last resort. I imagine this will be a headache for anyone else relying on 'Hover Click'.

I didn't make a bug yet, so please direct me to do so. If something is wrong with the application and not just my upgrade to 22.04. Besides turning off/on 'Hover Click', I tried restarting my computer, but it didn't help.

I wonder if it has something to do with the updated Desktop as it seems 'Hover Click' starts hiccuping when I try to click anywhere besides the top bar. But I'm not sure.

Thank you for any help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Rashad Chowdhury
Solved:
Last query:
Last reply:
Revision history for this message
Rashad Chowdhury (son-goku) said :
#1

tl;dr I was running Wayland, but switching to Xorg allowed 'Hover Click' to start working.

Searching for alternatives to 'Hover click' I came accross 'mousetweaks' which is supposedly (* more on supposedly later) the 'Hover Click' daemon.
source: http://xahlee.info/linux/linux_mouse_hover_click.html

Running mousetweaks in my terminal, gave the following output:
$ mousetweaks
Not running under X11. Aborting.

I saw on various sites that a switch was being made in Jammy 22.04's default for Xorg or Wayland depending on the drivers you had.

Instead of checking my drivers to see my intended default, I decided to confirm if I'm on Wayland.

To see if I'm on Wayland, typing 'Alt+F2' then 'r' gives the output 'Restart is not available on Wayland'
source: https://www.reddit.com/r/Fedora/comments/6omauc/the_quickest_and_fun_way_to_check_if_you_are/

Then I decided to install Xorg in the terminal:
$ sudo apt-get install xorg openbox

I would have thought I had nothing to install, but it showed I had 5 packages to install. I confirmed 'y' to install. Though if I had to redo, I might consider without installing Xorg first as I would think I already had Xorg (** more on this later).

I uncommented
#WaylandEnable=false
by removing the # in /etc/gdm3/custom.conf

and restarted my Desktop in the terminal
$ sudo systemctl restart gdm3

source: https://linuxconfig.org/how-to-enable-disable-wayland-on-ubuntu-22-04-desktop

'Hover Click' is working as expected for me now :)

Some notes.

* I'm not sure if the current 'Hover Click' relies on the 'mousetweaks' deamon as I get the same result when running mousetweaks in the terminal while in Xorg
$ mousetweaks
Not running under X11. Aborting.

and I confirmed I am on Xorg using 'Alt+F2' then 'r'

** I would imagine I have Xorg on my machine after upgrading to Jammy 22.04 because why would /etc/gdm3/custom.conf let me uncomment Wayland=false if I had no fallback option. I mean the comment was a customizable flag, not something I had to type in. Regardless, I decided to install Xorg and then uncomment Wayland=false because I didn't want to deal with a situation where I'm looking at a black screen because my laptop didn't have a fallback to Wayland available.

Last two considerations,

1) What was I running when I was using Impish 21.10? I have no idea and I don't intend to install 21.10 and try out Wayland & Xorg and see if 'Hover Click' works on one but not the other.

2) Can I get 'Hover Click' working on Wayland? I honestly never even knew Wayland or Xorg was a thing so I have no idea what I'm missing out on and it intrigues me to see what Wayland offers that Xorg doesn't.

I hope this solution was detailed enough that anyone dealing with the same issue can resolve it :) Good luck!