Files found in the search results in Activities cannot be opened

Asked by Pablo Bossanova

Files found in the search results in Activities (Ubuntu 22.04) cannot be opened. Programs are not a problem, they can be opened directly.

Explanation: When a file like xyz.odt is clicked in the search results of activities, only the activities window closes, the file and the associated program do not open. The folder that is displayed to the left of it can be opened by clicking on it and a Nautilus search window appears with the results. Only the file cannot be opened directly

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Pablo Bossanova
Solved:
Last query:
Last reply:
Revision history for this message
Bernard Stafford (bernard010) said :
#1

An .odt file is usually associated with Libre Office.
Files are opened according to permissions.
You can hover over a file and Right click it and select Properties.
The first tab General tab Open the drop down box
to change which Program opens the file.
Their are tabs at the top Select the Permissions tab.
It will either be Read only , Read & Write or None.
These are the file access.

Revision history for this message
Pablo Bossanova (pablobossanova) said :
#2

Thank you for the answer. However, this is not my problem.
The affiliation to the programs - odt to LibreOffice, PDF to Evince etc - is set correctly. I can open all files in Nautilus or Nemo with double click without problems. However, if I open the activities and search for a specific file, it shows up, but I can't open it with a double click....

Revision history for this message
Bernard Stafford (bernard010) said :
#3

When the file shows up in the search try hovering over it and selecting which program to open it with.
Then it may open next time with a click.

Revision history for this message
Pablo Bossanova (pablobossanova) said :
#4

When I move the mouse over the file nothing happens. Also a click with the right mouse button shows no possibilities.

Revision history for this message
Bernard Stafford (bernard010) said :
#5

You can move the file in your Documents folder.
Open the File Manager that is on your desktop.
Click on Documents folder click on the .odt file.
It should open with the appropriate program.

Revision history for this message
Pablo Bossanova (pablobossanova) said :
#6

I think you misunderstand me. The file association is set correctly. There is no problem to open the files directly in Nautilus or Nemo! The problem is that when I open Activities with the Super button and search for a file, I can't open it directly (in the Activities Overview). The Activities Overview closes, but the file does not open.

Revision history for this message
Manfred Hampl (m-hampl) said :
#7

Which Ubuntu release are you running?
What is the output of the commands (to be executed in a terminal window):

uname -a
lsb_release -crid
echo $XDG_SESSION_TYPE

Revision history for this message
Pablo Bossanova (pablobossanova) said (last edit ):
#8

@Manfred Hampl

Thank you very much for the help. The output is as follows:

uname -a:
Linux 5.15.0-27-generic #28-Ubuntu SMP Thu Apr 14 04:55:28 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

lsb_release -crid:
Distributor ID: Ubuntu
Description: Ubuntu 22.04 LTS
Release: 22.04
Codename: jammy

echo $XDG_SESSION_TYPE:
wayland

It doesn't matter if xorg or wayland. The error exists in both sessions

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#9
Revision history for this message
Manfred Hampl (m-hampl) said :
#10

I do not see that problem on my system.

I suggest to check whether this is related only to openoffice files, or more.

Open a terminal window and issue the command

touch tes1.txt test2.txt test3.txt

then search for test*.txt in activities.
You should see these three files (or eventually more, depending on what you have on you system)

When you point to one of the files with the mouse, does the background around that file become darker?
When you doubleclick one file, what happens?

Revision history for this message
Pablo Bossanova (pablobossanova) said (last edit ):
#11

@ Manfred Hampl

Thank you for your patience. Yes, I can see the files, the search works fine. When I move the mouse over the search results, they also bbe highlighted. But when I double click them nothing happens. The activity overview / search results closes and that was it. This happens with all files. Programs and results for the Software Center can be opened without any problems. Is there a terminal command to open the activities overview, so that you can read what happens when you click on a search result? That might provide the answer. My Google search did not give me a working answer.

Revision history for this message
Manfred Hampl (m-hampl) said :
#12

If you create a new user and log in with that new user, do you also see the same problem?

Revision history for this message
Pablo Bossanova (pablobossanova) said :
#13

Yes, it's the same.

Revision history for this message
Pablo Bossanova (pablobossanova) said :
#14

As I just found out, files and folders on the desktop (gnome-shell-extension DING active) cannot be opened either. This is actually not important for me, I always work with an icon free desktop, but maybe this is related to the activities overview. Does anyone here have an idea how I can find out what is going wrong?

Revision history for this message
Pablo Bossanova (pablobossanova) said :
#15

I've got it!

Command journalctl -f gave the following issue:

"gnome-shell[169846]: DING: grep: /proc/sys/fs/binfmt_misc/WSLInterop: No such file or directory"

"DING: WSL Interopability is disabled. Please enable it before using WSL."

"DING: grep: /proc/sys/fs/binfmt_misc/WSLInterop: No such file or directory"

So I searched for WSL using the good old Synaptik package manager. Because I wondered what a pure Ubuntu needs with the Linux environment of Windows. And lo and behold, the package wlsu was installed. With the help of the installation journal of Sanaptic was the bugger quickly found. The package came with the installation of Wine - probably winetricks- onto the system. After uninstalling wlsu, double-clicking on the Gnome Activities Qverview and on the desktop worked without problems. Thanks anyway for the well-intentioned help!

And please excuse my bad English