totem does not support x-hls

Asked by Mokichi Hanano

In Videos(totem), I clicked Channels/Rai.tv/Most Popular/Cinema/* and tried to see an movie.
This message was displayed:
 "Unable to play the file
application/x-hls decoder is required, but is not installed."
How should I solve this problem, please.
(Cause using ubuntu 21.10 so required decoder might no be included by default?)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
Last query:
Last reply:
Revision history for this message
Best Manfred Hampl (m-hampl) said :
#1

Try installing the package ubuntu-restricted-extras and if that still does not help, also the package gstreamer1.0-plugins-bad

Revision history for this message
Mokichi Hanano (yamatsutsuji) said :
#2

Just install gstreamer1.0-plugins-bad, video was successfully played.
Thanks very much, m-hampl!

For whom in similar situation:
It may be useful trying "apt show gstreamer1.0-plugins-[base,good,bad,ugly] | grep application/your-preferred-codec"
If grep hit, try install that package. Will work well!

Revision history for this message
Mokichi Hanano (yamatsutsuji) said :
#3

Thanks Manfred Hampl, that solved my question.