Ubuntu Desktop background is obsured by black rectangle

Asked by FC de Kock

I tried to change to icon size as describe in "https://fostips.com/desktop-icon-size-spacing-ubuntu-20-04/". In the process the desktop became obscured by the black rectangle. Only narrow strips of the background at the bottom and right sides of the screen are visible behind the black rectangle. I tried to reset the background using "Settings", "Gnome-tweaks" and "dconf Editor" to no avail. Any advice?

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

If you log off and on again, is it the same?

Revision history for this message
FC de Kock (fcdekock1946) said (last edit ):
#2

Rebooting does nothing. Apart from the annoying "black theme", everything seems to works fine. (Switching to light theme does nothing if you wondered.) If there is a way to attach a screen dump (I could not find one yet), I can paste it if my description it not clear to you.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#3

Host it on a site like imageshack or similar to make a URL which you can post as an update

Revision history for this message
FC de Kock (fcdekock1946) said :
#4

This problem is experience by a number of users. I find that I can remove the rectangle, which is actually a window. When I entered the command xwininfo I get the following info:
fck@UB2004:~$ xwininfo

xwininfo: Please select the window about which you would like information by clicking the mouse in that window.

xwininfo: Window id: 0x1c00003 (has no name)

  Absolute upper-left X: -10
  Absolute upper-left Y: -10
  Relative upper-left X: -10
  Relative upper-left Y: -10
  Width: 1926
  Height: 1086
  Depth: 32
  Visual: 0x73e
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x1c00002 (not installed)
  Bit Gravity State: NorthWestGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners: +-10+-10 -4+-10 -4-4 +-10-4
  -geometry 1926x1086-4-4

I can kill the process by Alt-2, type xkill and move the cross to the black window and press enter. It disappeared, but reappear on reboot (or on re-login). Why does it activate the window and any advice for a permanent fix?

Revision history for this message
Launchpad Janitor (janitor) said :
#5

This question was expired because it remained in the 'Open' state without activity for the last 15 days.