Plugging in a keyboard loses the non-default keyboard layouts when using more than one layout

Asked by Larry Reid on 2009-05-04

I have USA and Spanish (Spain) keyboard layouts defined on my laptop, with USA being the default. When I plug in my external keyboard I can no longer choose the Spanish layout either from the keyboard layout indicator in the panel or via the keyboard shortcut I've defined. If I bring up the keyboard preferences, the Spanish keyboard is still in the list. To work around, I either delete it and re-add the Spanish layour, or restart Gnome (log out and log in).

Sometimes after this sequence, attempting to switch layouts will cause the keyboard indicator to display "??" instead of "USA" or "Esp". Sometimes it simply displays "USA". In either case, the keyboard responds as if in the USA layout.

I'm running on a Lenovo Thinkpad x300. The original Ubuntu install was 8.04 and I've upgraded (using the upgrade process, not reinstall) to 8.10 and now 9.04. I have an external PS/2 keyboard in Spanish/Spain physical layout that I plug in through a PS/2 to USB cable. The laptop has a USA physical layout.

I first noticed this with 8.10, but I can't say for sure that it wasn't a problem in 8.04 as I didn't use the external keyboard very much with 8.04. On 8.10, the problem also happened when I suspended and resumed, but that seems to be fixed in 9.04. I can suspend and resume and the Spanish layout is still available. However, if I actually unplug the external keyboard and plug it back in, I lose the Spanish layout.

Thanks for any help you can give.

Question information

Tom (tom6) said : #1

System - Preferences - Keyboard

Good luck and regards from
Tom :)

PS also try updating your system through Synaptic ;)

Larry Reid (lcreid) said : #2

Yes, System-> Preferences-> Keyboard is how I set up multiple keyboard layouts in the first place. The problem is that every time I unplug my external keyboard (a not uncommon occurrence with a laptop) the Spanish layout disappears. I don't expect to have to go through the process of re-selecting my alternate keyboard every time I unplug my external keyboard.

And yes, I have updated through Synaptic. Sorry I wasn't clear.

So I'm hoping this can be fixed. Is this a bug? As far as I'm concerned it is because it's very much not the behaviour one would expect from a common use case.

Larry Reid (lcreid) said : #3

I've submitted this as a bug since I wasn't getting any answers here: https://bugs.launchpad.net/bugs/376592

Tom (tom6) said : #4

Often a good plan. It might also be worth trying to re-post this question in here. I'm going to link another bug-report to this because ... Well you'll see what i mean.

Good luck and regards from
Tom :)

Can you help with this problem?

Provide an answer of your own, or ask Larry Reid for more information if necessary.

To post a message you must log in.