Upgrade 8.10 to 9.04, Creative Zen and gnomad2 - I think it's a BUG.

Asked by Vihar on 2009-05-04

Under 8.10 I used gnomad2 successfully with Creative Zen MP3 player. But the device itself didn't mount automatically. After I upgraded to 9.04 doesn't recognise Zen. But it mounted automatically offering me options to open it in different ways.
Let me describe my actions (a) and results (b) under 9.04 by steps:
0 step:
a) - Creative Zen is not attached to computer; launch gnomad2 via GUI.
b) - gnomad says "No jukeboxes found on USB bus".
aa) - launch gnomad2 via terminal using command "gnomad2".
bb) - gnomad loads with the same warning in GUI and with "PDE device NULL." in the terminal.
That's normal.

1 step:
a) - Attach Creative Zen to USB
b) - the Disk Mounter at the panel shows TWO equal icons for mounted Zen. On the desktop appears an icon for mounted Zen too and I can browse, delete and add files in Zen. But Zen does NOT see them. I can see and manipulate them only by the computer browsers. Banshee and Rhythmbox dont recognise too.
aa) - launch gnomad2 via GUI.
bb) - gnomad says "No jukeboxes found on USB bus".
aaa) - launch gnomad2 via terminal using command "gnomad2".
bbb) - in GUI gnomad says "No jukeboxes found on USB bus", in the terminal - the following:

usb_claim_interface(): Device or resource busy
LIBMTP PANIC: Unable to initialize device
PDE device NULL.

Using command "sudo gnomad2" doesn't make diferrence.

2 step:
a) - Click on one of the icons of Disk Mounter on the panel and choose "Unmount". That icon and the icon on the desktop disappear. BUT there still remains one icon for Zen now telling it's not mounted.
   - Launch via GUI gnomad2.
b) - Gnomad recognises Creative Zen righteous. I can read, play and write files to and from it. The device sees the the written files. Banshee recognizes Zen too, Rhythmbox - no.

3 step:
a) - click on the remaining icon in Disk Mounter and choose "mount".
b_ - an error message appears telling ""Disk Mounter" has quit unexpectedly" - Don't reload/Reload.
aa) - choose to reload Disk Mounter.
bb) - Disk Mounter reloads but is still unable to mount Zen.
aaa) - detach and immediately attach Zen to computer.
bbb) - no icon for mounted Zen; the already opened Rhythmbox begins to recognise Zen.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
taylorchase
Solved:
2009-05-09
Last query:
2009-05-09
Last reply:
2009-05-09

This question was reopened

Paul Graydon (twirrim) said : #1

Seeing the same issue with a Zen Vision:M

Device has been found:
[ 366.503481] usb 1-7: USB disconnect, address 2
[ 378.408016] usb 1-7: new high speed USB device using ehci_hcd and address 4
[ 378.568184] usb 1-7: configuration #1 chosen from 1 choice

but attempts to mount using mtpfs result in following:

~$ sudo mtpfs -d /media/mtpplayer/
unique: 1, opcode: INIT (26), nodeid: 0, insize: 56
INIT: 7.10
flags=0x0000003b
max_readahead=0x00020000
usb_claim_interface(): Device or resource busy
LIBMTP PANIC: Unable to initialize device

or with mtp-detect I get a similar response:
$ mtp-detect
libmtp version: 0.3.0

Listing raw device(s)
   Found 1 device(s):
   Creative: ZEN Vision:M (041e:413e) @ bus 0, dev 4
Attempting to connect device(s)
usb_claim_interface(): Device or resource busy
LIBMTP PANIC: Unable to initialize device
Unable to open raw device 0
OK.

This worked fine under 8.10, has only failed under 9.04.

I've seen references elsewhere suggesting "CONFIG_USB_DEVICE_CLASS" isn't enable in the kernel, though I've not dug that deep yet.

Paul Graydon (twirrim) said : #2

Okay.. I think I've spotted part of the problem.

Something is automatically mounting the Zen when it's plugged in and puts an icon on the desktop. You can access the contents in it, and supposedly can write to it, but no MTP compatible players can see it.

Files I appeared to copy across seemingly successfully were not visible on the player when I unplugged the player. Then when I re-connected it it didn't automount the device and mtp-detect, rhythmbox et. al. worked happily.

Unplugging and replugging doesn't seem to be a particularly reliable way of being able to access the device. Not sure what is mounting it and how in the first place, it certainly doesn't seem to appear in the output from the mount command.

Any suggestions on how I can track down what is mounting it originally and resulting in it appearing on the desktop? I couldn't see anything in /var/log/messages, syslog, daemon.log, kern.log or dmesg output.

taylorchase (taylorchase) said : #3

I was having this same problem and could read/write to the device but the files were not accessible to the player after being disconnected. I found a workaround that lets you use gnomad2. Fairly simple but works nonetheless, just unmount the device volume and then run gnomad2, everything should work fine after this.

Vihar (vmankov) said : #4

Taylorchase - the same is stated by me and by Garp. The problem is that this is not a normal behaviour of the system "9.04-Creative Zen". Where is the bug? For instance, under 8.10 at my computer gnomad2 read Zen successfully when mounted but Banshee and Rhythmbox didn't.

taylorchase (taylorchase) said : #5

Check this out, this solved the automount problem for me, https://answers.launchpad.net/ubuntu/+question/30501

"
Michael Spencer said on 2008-04-28:

Editing the authorization settings seems a bit extreme ;)

Instead, turn off Nautilus' auto-mounting of external media:

$ gconf-editor

apps > nautilus > preferences
Uncheck the "media_automount" option
"

Vihar (vmankov) said : #6

Taylorchase,
I solved for MY OWN this problem by discovering FOR MY OWN that I have to UNMOUNT Creative Zen for the reason Ubuntu 9.04 to recognise it. I see too many questions about Zen here pointing the same problem. But the way of unmounting is a twisted way to do it, meaning normal point of OS view. So I posted this post as a thinking BUG. Tell me, please, do You thing it is a bug?

Vihar (vmankov) said : #7

Taylorchase,
I solved for MY OWN this problem by discovering FOR MY OWN that I have to UNMOUNT Creative Zen for the reason Ubuntu 9.04 to recognise it. I see too many questions about Zen here pointing the same problem. But the way of unmounting is a twisted way to do it, meaning normal point of OS view. So I posted this post as a thinking BUG. Tell me, please, do You thing it is a bug?

Best taylorchase (taylorchase) said : #8

Good job figuring out how to make it work on your own :) From the sounds of it, I believe it could be a bug. Perhaps more research and discussion should be done about this topic.

Vihar (vmankov) said : #9

Thanks taylorchase, that solved my question.

Vihar (vmankov) said : #10

I was just wonderring does anybody except me is thinking it may be a bug. Your answer solved my problem. Thanks, taylorchase.

Casper Kowalczyk (atrctr) said : #11

Thanks for posting a way to make Gnomad working...

Will Ubuntu developers take care of it before next release, or do we have to play on our own until 9.10? Or whether anything will ever be done about this?

Paul Graydon (twirrim) said : #12

It's not really an Ubuntu bug so much as an upstream bug with the way Gnome is handling the devices, I would be surprised if we saw anyone doing a specific Ubuntu fix for this.

Vihar (vmankov) said : #13

Garp,
a qwestion then remains: why Gnomad under 8.10 worked fine with Zen and under 9.04 i have to unmount Zen?

StefanoAdami (adamix) said : #14

I have the same "problem" with a Samsung YP-k3, and I solved this problem in the same way(on jaunty).
It will be nice if nautilus doesnt automount MTP devices or to auto-choose to unmount it if I choose "open with rithmbox" when the device was connected (or into nautilus)

I was experiencing the same problem until I started unmounting the player in nautilus. However, when I run gnomad2, the device (zen x-fi) freezes when scanning data files, making it so that I'm unable to transfer files and I have to hard reset it.

wr (w-l-rawes) said : #16

Just spent quite a few evenings trying to get gnomad2 (installed with package manager) to interface with a Creative Zen Mosaic.

Downloaded hotplug stuff, devs of gtk2 (& then pango, atk, etc), libnjb & mtp, recompiled - uuurgh – a lot of hassle – & then didn’t work:

kept getting:
   'no jukeboxes found on USB bus'
and
   'PDE device NULL'

Eventually put an 65-libmtp.rules file in /etc/udev/rules.d with:
            SYSFS{idVendor}=="041e", SYSFS{idProduct}=="4161", MODE="770", GROUP="audio"
(idProduct got by doing 'lsusb' in command line)

Which kept on not working (after editing, saving, etc) UNTIL unplugging the Zen & then replugging it in – which then re-jigged(?) the usb port and then run gnomad2

Vihar (vmankov) said : #17

Zen works with 9.04's Gnomad2 only when unmounted. This I elucidated for my case, as described above.

stephg (stephg) said : #18

Same thing for me with my ZEN V Plus.
I've solved the problem by making the player invisible for Nautilus. Usually a player must have info.capabilities=portable_audio_player,access_control in HAL. To remove the portable_audio_player item, create a no-automount.fdi file in /etc/hal/fdi/policy with :

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
 <device>
      <match key="info.product" string="ZEN V Plus">
        <remove key="info.capabilities" type="strlist">portable_audio_player</remove>
      </match>
  </device>
</deviceinfo>

Change 'ZEN V Plus' for the name of your player (you can find the right name using gnome-device-manager for instance, look for the name in the info.product property of the 'USB Interface' for the player)
Then
sudo /etc/init.d/hal restart

When your player is reconnected you should not this the portable_audio_player capability in gnome-device-manager. Nautilus can not see your player anymore.

However AFAICT Gnomad2 and Rythmbox does not seem to use the property and they still see the player.