symbol lookup error: /usr/local/lib/AppProtection/ undefined symbol: _dl_sym, version GLIBC_PRIVATE

Asked by Ghanshyam

many apps (gedit, nautilus etc) and any sudo command (e.g. for apt, dpkg) fail to run with the below error:
symbol lookup error: /usr/local/lib/AppProtection/ undefined symbol: _dl_sym, version GLIBC_PRIVATE

I upgraded to ubuntu 21.10. During upgrade, there was an error related to libc6 and post that the above eror started coming. I had to reinstall ubuntu and it got fixed. There are already known issues related to libc6 for launching vscode, teams etc. However now I tried to install another app (citrix workspace) and enabled app protection which failed and I see this error again for any sudo command and other apps launch.

Is this a problem with libc6 version mismatch? Since I cannot do sudo, how do I fix it without reinstalling ubuntu? Appreciate any help.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Revision history for this message
Best Manfred Hampl (m-hampl) said :

/usr/local/lib/AppProtection/ is a file that is not part of Ubuntu, but which must have come from some foreign source.
We cannot help with that. You have to find out what that is yourself.

This seems to be the same problem as

If sudo does not work any more, there is a workaround:
When booting the system, select "advanced options - root command prompt" from the grub menu, remount the disk in read-write mode and you have root rights.

Revision history for this message
Ghanshyam (gparvind) said :

Thanks Manfred Hampl, that solved my question.