arp duplicate entry - virtual interfaces

Asked by jmpatagonia

Hello we need help to resolv this problem:

We are starting using netplan with virtual interfaces (one physical nic), and when use list arp table, for some hosts, we have two entries with same ip, same maccadress different iface (interface), for example:

# arp -n | grep 198 ether 60:02:92:b4:26:51 C eth0.237 ether 60:02:92:b4:26:51 C eth0.37

Whats this a meaning ? the first entry have wrong vlan and are duplicated !!!

Using ssh we note the access to shell console become start slowly commands or frozen for a seconds.

--> This is a standalone ubuntu 20.04 server, no other software or service is installed in, just virtual interfaces.
--> We use netplan to set interfaces, with virtual ips or virtual nics
--> Also we have installed the package vlan package --> ii vlan 2.0.4ubuntu1.20.04.1 all ifupdown integration for vlan configuration
--> But the irrational is that we have three virtual ip (one for vlan: .37 .137 .237) and when connect via ssh from one vlan (137) the problem not exist (and the entry is not listed duplicated on arp list) but the others two vlans yes.
--> Is like the server is listening by two virtual interfaces at same time
--> The port trunking on the switch side if configured


Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
jmpatagonia (jmpatagonia) said :

Finally we found 2 loops or bucles on switchs network, that are the problem, solved