Mic not working in Ubuntu 21.04 on Acer C720P chromebook

Asked by Tony Mugan

Having installed coreboot and Ubuntu 21.04, the mic is not working.

Audio playback is working and no other issues are apparent.

I've tried tweaking the pulseaudio settings but to no avail.

I'd be grateful for any advice on debugging to find a resolution.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Tony Mugan
Last query:
Last reply:
Revision history for this message
Tony Mugan (tmugan) said :
Revision history for this message
Tony Mugan (tmugan) said :

:~$ sudo dmesg | grep snd
[ 4.882284] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC283: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[ 4.882296] snd_hda_codec_realtek hdaudioC1D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 4.882301] snd_hda_codec_realtek hdaudioC1D0: hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[ 4.882306] snd_hda_codec_realtek hdaudioC1D0: mono: mono_out=0x0
[ 4.882310] snd_hda_codec_realtek hdaudioC1D0: inputs:
[ 4.882314] snd_hda_codec_realtek hdaudioC1D0: Internal Mic=0x1a
[ 4.882349] snd_hda_codec_realtek hdaudioC1D0: Mic=0x19
[ 5.925449] snd_hda_intel 0000:00:03.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])

Revision history for this message
Tony Mugan (tmugan) said :

OK, have resolved finally after trying many combinations of entries in /etc/modprobe.d/alsa-base.conf

The additiona of this line at the end to replace any existing lines for snd-hda-intel is what worked for me.
It enabled the internal mic to work again. Tested successfully in Sound Recorder as well as Google Meet.

options snd-hda-intel model=auto,alc283-int-mic index=0,1

Revision history for this message
Tony Mugan (tmugan) said :

See my comment above for solution.

Revision history for this message
cierra hill (cieraahill) said :

Thank you for your post it really help me. Btw both ways are worked . keep it up.