open ftp links with Nautilus instead of Firefox

Asked by Joseph Maillardet

Firefox no longer supports FTP protocol. Unfortunately, the desktop file /usr/share/applications/firefox.desktop still describes it as being able to do so:
MimeType=(...);x-scheme-handler/ftp;(...)

On the contrary, Nautilus (Gnome Files) is able to handle such link/protocol but its desktop file /usr/share/applications/org.gnome.Nautilus.desktop does not mention it.

In the end, when opening an FTP link, the dialog box that appears in Firefox suggests to open the link with... Firefox.

Would you know how to correct this error without the correction being erased with each update?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
Last query:
Last reply:
Revision history for this message
Best Manfred Hampl (m-hampl) said :
#1

General solution:
Create bug reports to request that the desktop files are modified.

Possible workaround until this is corrected in the applications:
Create copies of these desktop files from /usr/share/applications/ into ~/.local/share/applications/ and make the modifications there. Your local copies should take precedence over the system entries.

Revision history for this message
Joseph Maillardet (jokx) said :
#2

Thanks, it works well.

I would like to make a bug report, but I don't know which source package to target for that.

Revision history for this message
Joseph Maillardet (jokx) said :
#3

Thanks Manfred Hampl, that solved my question.