Notebook HP 625 - problem with fan speed, huge overheating, problem with the kernel 5.4?

Asked by Piotr

Dear Ubuntu Community,

My friend have HP 625. It is notebook. He have installed Ubuntu 18.0.4.5, his kernel 5.4.0-81-generic.

He have huge problem with overheating. Fan speed is not increasing when cpu usage is increasing. This fan works only in IDLE speed. When temperature is huge then it swich his work to 100% and works in this behaviour for few second then return to IDLE speed. Unfortunately his notebook sometimes turn off because overheating problem.

I found the same issue on upstream channel, some other HP 625 users describes exactly this same issue. I am shocked than from 3.13 kernel to 5.4 nothing happen and this bug is not fixed.

This is link: https://bugzilla.kernel.org/show_bug.cgi?id=71711

I have 99% sure that this is problem with the kernel. I will try another distribution in this week but I think that this will be the same problem.

I also found on Linux Mint forum that this can be problem with AMD microcode. Someone wrote that he unistalled microcode and now everything works well. How I can safe do it? I think that this is not solution because security reasons.

I also find this same bug here but this was not fixed: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1315836

Can you help me? How I can fix it or maybe someone can fix it.

Thanks!

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

Do you have the latest BIOS?

Revision history for this message
Piotr (peterq94) said :
#2

No, he don't have the latest BIOS but I found that someone also tried update to the latest BIOS and this doesn't help at all and he still had problem with the fan speed of the CPU.

I hope that someone can help.

Revision history for this message
Piotr (peterq94) said (last edit ):
#3

I also noticed that this can be problem with sensors (kernel can't detect but on windows works fine). On my second machine I have 6 thermal zones. On this notebook where issue is exist I have only two:

$ cat /sys/class/thermal/thermal_zone*/temp
56700
20000

Can you help with this problem?

Provide an answer of your own, or ask Piotr for more information if necessary.

To post a message you must log in.