have a HD was working good, now says No Bootable Device

Asked by michael

I was trying to install Ubuntu 21.04 on new 1TB HD, and had problems. One is in question 698563. The original HD has Ubuntu 20.04 and 16.04. 21.04 would not install, so I go back to 20.04, No Bootable Device found. I took out 1TB HD. Still No Bootable Device. Have Googled, tried some, none worked. Can some one tell me, how to make it bootable? Have tried GParted disk. would not boot.


Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
michael (yellupcm-gmail) said :


Revision history for this message
Manfred Hampl (m-hampl) said :

The normal way to make a disk bootable is installing an operating system on a partition of it and installing a boot loader (e.g. grub) in its boot sector.

The question is: Why is it not bootable (any more)?
I suggest that you create a boot repair cd or bootable USB stick with boot-repair and run boot-info for checking.