Firefox browser Not responding

Asked by Rich.b

Ubuntu 20.04 LTS Up to date software.

Model: ATA KINGSTON SHSS37A (scsi)
Disk /dev/sda: 480GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt


Problem: Firefox does not respond, the only thing that works is "Reload current Page"
Can't Add tabs or close the browser.

The only thing I can do is restart or closed the PC and reboot.

This is intermittent, worked the first time this morning but not at the first attempt this afternoon.

Any advice, please.

Thank you


Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Rich.b (aybi30) said :

Before closing I once tried to start chromium this seems to work ok. This was about 2 weeks ago.

Revision history for this message
Manfred Hampl (m-hampl) said :

Do you have any add-ons activated in Firefox?

for diagnostic purposes, what is the output of the commands

uname -a
lsb_release -crid
which firefox
apt-cache policy firefox
snap list --all

Revision history for this message
Rich.b (aybi30) said :

richard@richard-H81M-S2H:~$ uname -a
Linux richard-H81M-S2H 5.4.0-81-generic #91-Ubuntu SMP Thu Jul 15 19:09:17 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
richard@richard-H81M-S2H:~$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 20.04.3 LTS
Release: 20.04
Codename: focal
richard@richard-H81M-S2H:~$ which firefox
richard@richard-H81M-S2H:~$ apt-cache policy firefox
  Installed: 91.0.2+build1-0ubuntu0.20.04.1
  Candidate: 91.0.2+build1-0ubuntu0.20.04.1
  Version table:
 *** 91.0.2+build1-0ubuntu0.20.04.1 500
        500 focal-updates/main amd64 Packages
        500 focal-security/main amd64 Packages
        100 /var/lib/dpkg/status
     75.0+build3-0ubuntu1 500
        500 focal/main amd64 Packages
richard@richard-H81M-S2H:~$ snap list --all
Name Version Rev Tracking Publisher Notes
audacity 3.0.2 910 latest/stable diddledan disabled
audacity 3.0.2 857 latest/stable diddledan -
brave 1.28.106 126 latest/stable brave disabled
brave 1.29.76 127 latest/stable brave -
canonical-livepatch 9.7.3 105 latest/stable canonical✓ -
canonical-livepatch 9.7.2 104 latest/stable canonical✓ disabled
chromium 92.0.4515.159 1708 latest/stable canonical✓ disabled
chromium 93.0.4577.63 1732 latest/stable canonical✓ -
core 16-2.51.3 11420 latest/stable canonical✓ core,disabled
core 16-2.51.4 11606 latest/stable canonical✓ core
core18 20210611 2074 latest/stable canonical✓ base,disabled
core18 20210722 2128 latest/stable canonical✓ base
core20 20210702 1081 latest/stable canonical✓ base
core20 20210429 1026 latest/stable canonical✓ base,disabled
get-iplayer 3.27 315 latest/stable snapcrafters -
get-iplayer 3.26 250 latest/stable snapcrafters disabled
gnome-3-28-1804 3.28.0-19-g98f9e67.98f9e67 161 latest/stable canonical✓ -
gnome-3-28-1804 3.28.0-19-g98f9e67.98f9e67 145 latest/stable canonical✓ disabled
gnome-3-34-1804 0+git.3556cb3 72 latest/stable/… canonical✓ -
gnome-3-34-1804 0+git.3556cb3 66 latest/stable/… canonical✓ disabled
gnome-3-38-2004 0+git.6ba6040 70 latest/stable canonical✓ -
gtk-common-themes 0.1-52-gb92ac40 1515 latest/stable/… canonical✓ -
gtk-common-themes 0.1-50-gf7627e4 1514 latest/stable/… canonical✓ disabled
gtk2-common-themes 0.1 13 latest/stable canonical✓ -
kde-frameworks-5-qt-5-15-core20 5.79.0 14 latest/stable kde✓ -
libreoffice 225 latest/stable canonical✓ disabled
libreoffice 227 latest/stable canonical✓ -
snap-store 3.38.0-64-g23c4c77 547 latest/stable/… canonical✓ -
snap-store 3.38.0-63-g766b86f 542 latest/stable/… canonical✓ disabled
snapd 2.51.4 12883 latest/stable canonical✓ snapd
snapd 2.51.3 12704 latest/stable canonical✓ snapd,disabled

Revision history for this message
Manfred Hampl (m-hampl) said :

What is blocked when Firefox is not responding any more? Just Firefox or everything else?

What you could do as workaround in such situation, is executing the command
killall firefox
or eventually
killall -s SIGKILL firefox

A complete different approach could be switching from the *.deb version of Firefox to the snap version.

Revision history for this message
Rich.b (aybi30) said :

So how do I do what you suggest? Then install .deb version of Firefox

Revision history for this message
Rich.b (aybi30) said :

Just to let you know.

I did install from Firefox an add on that gave the option of different tabs for work, banking etc,

Revision history for this message
Manfred Hampl (m-hampl) said :

How often does this problem appear, several times a day, or once every few weeks?
Do you need Firefox, or is switching to the chrome browser also an option?
There are different possibilities for coping with that problem. Which way do you want to go?

Revision history for this message
Rich.b (aybi30) said (last edit ):

The problem does not happen all the time perhaps once a day. I am more familiar the firefox but I use chromium for some things that are difficult on firefox.

I am not aware of any other problems other than with Firefox sometimes not starting. I think that the problem has become more difficult since adding the "tab" option that Firefox suggested, this seems not to work at this time!. I can start up other programs like Chromium. I have not tried any other programs. I have been restarting my PC to get out of the problem with Firefox.

Can I change to the .deb version of Firefox and if so how?

Revision history for this message
Manfred Hampl (m-hampl) said :

As far as I can see from your output, you are using the *.deb version of Firefox.
What you can try is changing to the snap version.

Revision history for this message
Rich.b (aybi30) said :

Thank you Manfred for your indulgence.

So how do I go about changing to the snap version, please?

Revision history for this message
Manfred Hampl (m-hampl) said :

remove the deb version
sudo apt purge firefox
sudo apt --purge autoremove
install the snap version
sudo snap install firefox

Revision history for this message
Rich.b (aybi30) said :

All done - Thanks.

everything seem to be ok.