Lutris Dumped Core Cinnamon 5.0.5 Mint 20.2 Uma

Asked by Jason Garlow

Lutris upon opening closes immediately. I have attempted to uninstall everything related and reinstalled with no fix found. I have posted on Lutris forums but they are very inactive. When I first installed it, it worked fine. Until I restarted the machine then the problem began. I was able to download a game FFXIV and play it. I am in the process of switching all of my windows needs over to Linux. I am a new IT student and I'm trying to learn Linux so my apologies if this is simple and I'm missing it. If you need any other information please don't hesitate to ask. Edit: I am dual booted with windows 10. Acer Helios 300 Predator
My system:

System: Kernel: 5.4.0-81-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 5.0.5
           wm: muffin dm: LightDM Distro: Linux Mint 20.2 Uma base: Ubuntu 20.04 focal
Machine: Type: Laptop System: Acer product: Predator PH317-51 v: V1.21 serial: <filter>
           Mobo: KBL model: Sienna_KLS v: V1.21 serial: <filter> UEFI: Insyde v: 1.21
           date: 11/02/2018
Battery: ID-1: BAT1 charge: 44.6 Wh condition: 44.6/48.9 Wh (91%) volts: 17.0/15.2
           model: LG 004B384234314341 serial: <filter> status: Full
CPU: Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake
           rev: 9 L2 cache: 6144 KiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44798
           Speed: 3559 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 3481 2: 3611 3: 3568
           4: 3438 5: 3562 6: 3772 7: 3530 8: 3568
Graphics: Device-1: Intel HD Graphics 630 vendor: Acer Incorporated ALI driver: i915 v: kernel
           bus ID: 00:02.0 chip ID: 8086:591b
           Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] vendor: Acer Incorporated ALI
           driver: nvidia v: 470.57.02 bus ID: 01:00.0 chip ID: 10de:1c20
           Display: x11 server: X.Org 1.20.11 driver: modesetting,nvidia
           unloaded: fbdev,nouveau,vesa resolution: 1920x1080~75Hz, 1920x1080~60Hz
           OpenGL: renderer: NVIDIA GeForce GTX 1060/PCIe/SSE2 v: 4.6.0 NVIDIA 470.57.02
           direct render: Yes
Audio: Device-1: Intel CM238 HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel
           v: kernel bus ID: 00:1f.3 chip ID: 8086:a171
           Device-2: NVIDIA GP106 High Definition Audio vendor: Acer Incorporated ALI
           driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f1
           Sound Server: ALSA v: k5.4.0-81-generic
Network: Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Lite-On
           driver: ath10k_pci v: kernel port: 4000 bus ID: 02:00.0 chip ID: 168c:003e
           IF: wlp2s0 state: up mac: <filter>
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
           vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000 bus ID: 03:00.1
           chip ID: 10ec:8168
           IF: enp3s0f1 state: down mac: <filter>
Drives: Local Storage: total: 1.14 TiB used: 81.04 GiB (6.9%)
           ID-1: /dev/sda vendor: SK Hynix model: HFS256G39TND-N210A size: 238.47 GiB
           speed: 6.0 Gb/s serial: <filter>
           ID-2: /dev/sdb vendor: Western Digital model: WD10SPZX-21Z10T0 size: 931.51 GiB
           speed: 6.0 Gb/s serial: <filter>
Partition: ID-1: / size: 273.71 GiB used: 81.03 GiB (29.6%) fs: ext4 dev: /dev/sdb5
USB: Hub: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 chip ID: 1d6b:0002
           Device-1: 1-2:2 info: Google Stadia Controller rev. A type: <vendor specific>
           driver: hid-generic,usbhid rev: 2.0 chip ID: 18d1:9400
           Device-2: 1-5:3 info: Logitech G502 HERO Gaming Mouse type: Mouse,HID
           driver: hid-generic,usbhid rev: 2.0 chip ID: 046d:c08b
           Device-3: 1-7:4 info: Lite-On type: Bluetooth driver: btusb rev: 2.0 chip ID: 04ca:3016
           Device-4: 1-9:5 info: Quanta HD Webcam type: Video driver: uvcvideo rev: 2.0
           chip ID: 0408:a060
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.0 chip ID: 1d6b:0003
Sensors: System Temperatures: cpu: 87.0 C mobo: 29.8 C gpu: nvidia temp: 53 C
           Fan Speeds (RPM): N/A
Repos: No active apt repos in: /etc/apt/sources.list
           Active apt repos in: /etc/apt/sources.list.d/additional-repositories.list
           1: deb https: // hirsute main
           Active apt repos in: /etc/apt/sources.list.d/flexiondotorg-mangohud-focal.list
           1: deb http: // focal main
           Active apt repos in: /etc/apt/sources.list.d/gerardpuig-ppa-focal.list
           1: deb http: // focal main
           Active apt repos in: /etc/apt/sources.list.d/lutris-team-lutris-focal.list
           1: deb http: // focal main
           Active apt repos in: /etc/apt/sources.list.d/microsoft-edge-beta.list
           1: deb [arch=amd64] http: // stable main
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
           1: deb http: // uma main upstream import backport
           2: deb http: // focal main restricted universe multiverse
           3: deb http: // focal-updates main restricted universe multiverse
           4: deb http: // focal-backports main restricted universe multiverse
           5: deb http: // focal-security main restricted universe multiverse
           6: deb http: // focal partner
           Active apt repos in: /etc/apt/sources.list.d/yannubuntu-boot-repair-focal.list
           1: deb http: // focal main
Info: Processes: 304 Uptime: 13m Memory: 15.52 GiB used: 2.69 GiB (17.3%) Init: systemd
           v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Client: Unknown python3.8 client
           inxi: 3.0.38
lutris -d
2021-08-31 17:31:57,677: No cores found
2021-08-31 17:31:57,874: Initializing lutris
2021-08-31 17:31:58,420: Downloading DXVK releases to /home/jj78/.local/share/lutris/runtime/dxvk/dxvk_versions.json
2021-08-31 17:31:58,658: Failed to read response's content length
2021-08-31 17:31:58,694: Writing to /home/jj78/.local/share/lutris/runtime/dxvk/dxvk_versions.json
2021-08-31 17:31:58,696: Runtime updated. Initialization complete.
INFO 2021-08-31 17:31:58,699 [application.do_command_line:315]:Lutris
INFO 2021-08-31 17:31:58,700 [startup.check_driver:49]:Using NVIDIA drivers 470.57.02 for x86_64
INFO 2021-08-31 17:31:58,700 [startup.check_driver:53]:GPU: NVIDIA GeForce GTX 1060
INFO 2021-08-31 17:31:58,701 [startup.check_driver:69]:GPU: 10DE:1C20 1025:1207 (nvidia drivers)
INFO 2021-08-31 17:31:58,701 [startup.check_driver:69]:GPU: 8086:591B 1025:1208 (i915 drivers)
MESA-INTEL: warning: Performance support disabled, consider sysctl dev.i915.perf_stream_paranoid=0

skipping config: /usr/bin/MangoHud.conf [ not found ]
skipping config: /home/jj78/.config/MangoHud/python3.8.conf [ not found ]
parsing config: /home/jj78/.config/MangoHud/MangoHud.conf [ ok ]
Segmentation fault (core dumped)

Log Message

"22:33:25 systemd-coredum: Process 5069 (lutris) of user 1000 dumped core.

Stack trace of thread 5105:
#0 0x00007f9c5fd6c66a n/a (n/a + 0x0)

22:27:08 systemd: Timed out waiting for device /dev/disk/by-uuid/19665839-a553-4646-aad6-5f6217649731.
22:26:44 kernel: Error opening PCM device front:0: No such file or directory
22:26:42 lightdm: gkr-pam: unable to locate daemon control file
22:25:37 kernel: integrity: Problem loading X.509 certificate -65"

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best actionparsnip (andrew-woodhead666) said :

Linux Mint is not supported by the Ubuntu community or Canonical in any way. It's support channels and forums are separate from Ubuntu's.
I suggest you post on the Mint forum here

None of the "Ubuntu based" distributions are supported here

Revision history for this message
Jason Garlow (jwg78) said :

Thanks actionparsnip, that solved my question.

Revision history for this message
Jason Garlow (jwg78) said :

I found the proper forum after posting this. The solution was to log in under a different user and test Lutris. It worked which meant I had some settings incorrect. It was not uninstalling completely. I had to use terminal sudo apt remove lutris then sudo apt autoremove. Afterwards I reinstalled and the problem was corrected. Thank you anyways.