symlink loop detected in path 'usr/sbin/service'

Asked by tutelacooldouce

I don't see what could have caused this? I am not sure that I am facing a bug.

$ ls -l /usr/sbin/service
lrwxrwxrwx 1 root root 17 Aug 17 10:05 /usr/sbin/service -> /usr/sbin/service

$ debsums init-system-helpers
/usr/bin/deb-systemd-helper OK
/usr/bin/deb-systemd-invoke OK
/usr/sbin/invoke-rc.d OK
debsums: Error: symlink loop detected in path 'usr/sbin/service'. Please file a bug against init-system-helpers.

$ dpkg -l |grep init-system-helpers
ii init-system-helpers 1.57 all helper tools for all init systems

$ lsb_release -rd
Description: Ubuntu 20.04.2 LTS
Release: 20.04

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Revision history for this message
Best Manfred Hampl (m-hampl) said :

I have no idea how this can have happened.
In any case I suggest to proceed as follows to correct it:

sudo rm /usr/sbin/service
sudo apt install --reinstall init-system-helpers

Does this help?

Revision history for this message
tutelacooldouce (tutelacooldouce) said :

hello, yeah I confirm. it solved my issue.

the root cause was the puppet was doing something which was not expected. We corrected it as well.

Thank you very much!