Failed to enable Livepatch: cannot enable machine:

Asked by DiabloGamer

Hi,

My laptop was working perfectly fine until few days ago when I noticed a major drop in the Internet bandwidth. The download went down by 50% approx! So I started to investigate and this is when I noticed the Live Patch was NOT enabled anymore. I installed when I installed Ubuntu and it worked without a problem. So I tried to re-enable it and it asked for my password. I entered it and got an error message:

"Failed to enable Livepatch: cannot enable machine: this machine ID is already enabled with a different key or is non-unique. Either "sudo canonical-livepatch disable" on the other machine, or regenerate a unique /etc/machine-id on this machine with "sudo rm /etc/machine-id /var/lib/dbus/machine-id && sudo systemd-machine-id-setup" server response: machine id already registered: machine id already registered"

- I didn't change a thing on my laptop since while.
- I have only ONE computer, my laptop
- Therefore I didn't use my credentials on any other machine.
- I did not install or remove any software.

How could this have happened? Live Patch is asking for the password when you try to enable or disable it. So how come it's now OFF and never asked for a password? Is it possible that a hacker cloned my laptop and that would explain this problem?

I.d like to understand how this happened and how to fix it.

Thanks in advance for your much needed help!

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
DiabloGamer (diablogamer) said :
#1

I forgot to mention:

me@Computer:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.04.2 LTS
Release: 20.04
Codename: focal

me@Computer:~$ ua status
SERVICE AVAILABLE DESCRIPTION
cis yes Center for Internet Security Audit Tools
esm-infra yes UA Infra: Extended Security Maintenance (ESM)
fips no NIST-certified core packages
fips-updates no NIST-certified core packages with priority security updates
livepatch yes Canonical Livepatch service

This machine is not attached to a UA subscription.
See https://ubuntu.com/advantage
me@Computer:~$ sudo canonical-livepatch refresh
[sudo] password for me:
2021/07/21 03:32:34 error executing refresh: Machine is not enabled. Please run 'sudo canonical-livepatch enable' with the
token obtained from https://ubuntu.com/livepatch.
me@Computer:~$ sudo ua attach
Attach requires a token: sudo ua attach <TOKEN>
To obtain a token please visit: https://ubuntu.com/advantage.

Revision history for this message
Manfred Hampl (m-hampl) said :
#2

Did you modify the contents of the files /etc/machine-id or /var/lib/dbus/machine-id ?

Revision history for this message
Launchpad Janitor (janitor) said :
#3

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.