20.04/21.04 freezing/crashing with X11 but not Wayland

Asked by barelycompetent

Hi everyone,

First time using launchpad here, please go easy on me! ;-)

I'm working in a production environment and I've ran into an issue that goes way over my head, so I'm at a loss here.
We produce systems that run video management software and for some inexplicable reason systems keep randomly freezing and becoming completely unresponsive, meaning:

---> Not able to ping machine once it's frozen, VMS server is offline and not able to SSH in.
---> Trying to drop into tty using CTRL + ALT + F1/F3 doesn't work.
---> Mouse and keyboard are completely unresponsive, even when replugging.
---> Screen is simply frozen completely, all UI elements that should update are static.
---> In two instances the desktop wasn't frozen but the internet access would seize to function despite being fine on other machines.

Initially these systems ran fine on Ubuntu Server 20.04 LTS with kernel 5.4 and the ubuntu-desktop-minimal package installed on top but we were forced to start using oem-kernel 5.10 instead due to having to upgrade to newer hardware and no other kernel versions (incl. HWE) working properly with the Intel integrated graphics unless 'nomodeset' was set in grub.
Ubuntu Desktop 21.04 seemed to have much better driver support out-of-the-box, though - and I didn't have to switch kernels to have the iGPU and NICs functioning immediately.

The current hardware configuration:

Intel® Core™ i5-10400
Intel® UHD Graphics 630
8 GB DDR4-2666
Samsung 860 EVO, 250GB (M.2)
ASRock H570M-ITX/ac (since upgraded to Z590M-ITX/ax, both have this issue)
---> On latest UEFI version (1.20)

What I've tried so far:

- Clean installation of Ubuntu Server (+ubuntu-desktop-minimal) 20.04 with upgrade to latest oem-kernel 5.10
---> Issue persists
- Clean installation of Ubuntu Desktop 21.04 with stock kernel and set to use X11
---> Issue persists
- Installed ffmpeg on both 20.04/21.04 running X11
---> Issue persists
- Tried checking log files for the machine but I can't find anything obvious that hints at the crash/issue
---> Checked: /var/log/kern.log, /var/log/dmesg, /var/log/syslog, journalctl -b
---> Also tried having journalctl -f running in the foreground but it doesn't show anything relevant once frozen
- Manually install intel graphics drivers as provided by intel
---> Issue persists

- Clean installation of Ubuntu Desktop 21.04 with stock kernel and set to use Wayland
---> Issue hasn't occurred on this machine at all
---> Currently 44 hours into a CPU stress test with VMS client open on desktop
---> Sadly it's crucial that Teamviewer works on these machines, which doesn't seem to support Wayland still

Sidenotes:
- These are all identical systems that I am testing this on, the only potential difference would be the motherboard but as mentioned before, it occurs on both models.
- I can't seem to upload text files upon posting so I'll see to it that I can add logs after the fact.

Let me know if I can provide any additional information that can help in diagnosing this issue.
Any help is very much appreciated!

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Launchpad Janitor (janitor) said :
#1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.