Wifi is connected but not network access

Asked by Arun

Wifi is connected but there is no network access even after setting defaults in netplan and I also restarted the network manager.before this issue i used vpn apt , I think , this is due to von bridge after disconnected from the vpn, the top bar shows ethernet indicator knstaed of wireless indicator. Help me out from this issue.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

Can you ping your router's internal IP (most likely your manual).

Does the wireless interfcae get an IP using DHCP? You can check this by running:

ip addr

Can you ping ok?

If you ping bbc.co.uk does it resolve the name to an IP OK?

Revision history for this message
Arun (arunsundar) said :

Problem solved after running sudo nmcli connection remove uuid_of_vpn_connection

Revision history for this message
Juan C. Simmons (costello98) said :

If the Internet works fine on other devices, the problem lies with your device and its WiFi adapter. On the other hand, if the Internet doesn't work on other devices too, then the problem is most likely with the router or the Internet connection itself. ... If your router and modem are separate, restart both.