Upgrading from Ubuntu 18.04 to 20.04 fails

Asked by Franziska Schwenke

I want to upgrade from Ubuntu 18.04 to Ubuntu 20.04 and it fails with the following message:

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade.

If none of this applies, then please report this bug using the
command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal. If
you want to investigate this yourself the log files in
'/var/log/dist-upgrade' will contain details about the upgrade.
Specifically, look at 'main.log' and 'apt.log'.

I don't really know how to read these logs, I read the threads with similar issues, but nothing applied to my case.

The content of main.log is:

2021-06-13 22:32:26,510 INFO Using config files '['./DistUpgrade.cfg.bionic', '/etc/update-manager/release-upgrades.d/ubuntu-advantage-upgrades.cfg']'
2021-06-13 22:32:26,510 INFO uname information: 'Linux asusubuntu 4.15.0-144-generic #148-Ubuntu SMP Sat May 8 02:33:43 UTC 2021 x86_64'
2021-06-13 22:32:27,044 INFO apt version: '1.6.13'
2021-06-13 22:32:27,044 INFO python version: '3.6.9 (default, Jan 26 2021, 15:33:00)
[GCC 8.4.0]'
2021-06-13 22:32:27,048 INFO release-upgrader version '20.04.33' started
2021-06-13 22:32:27,053 INFO locale: 'en_US' 'UTF-8'
2021-06-13 22:32:27,149 DEBUG Using 'DistUpgradeViewText' view
2021-06-13 22:32:27,205 DEBUG enable dpkg --force-overwrite
2021-06-13 22:32:27,242 DEBUG creating statefile: '/var/log/dist-upgrade/apt-clone_system_state.tar.gz'
2021-06-13 22:32:32,934 DEBUG lsb-release: 'bionic'
2021-06-13 22:32:32,935 DEBUG _pythonSymlinkCheck run
2021-06-13 22:32:32,936 DEBUG openCache()
2021-06-13 22:32:32,936 DEBUG quirks: running PreCacheOpen
2021-06-13 22:32:32,936 DEBUG running Quirks.PreCacheOpen
2021-06-13 22:32:34,291 DEBUG Comparing 4.15.0-143 with
2021-06-13 22:32:34,291 DEBUG Comparing 4.15.0-144 with 4.15.0-143
2021-06-13 22:32:34,292 DEBUG Comparing 4.15.0-55 with 4.15.0-144
2021-06-13 22:32:34,292 DEBUG Comparing 4.15.0-62 with 4.15.0-144
2021-06-13 22:32:34,302 DEBUG Comparing unsigned-4.15.0-55 with 4.15.0-144
2021-06-13 22:32:34,302 DEBUG Comparing unsigned-4.15.0-62 with unsigned-4.15.0-55
2021-06-13 22:32:34,621 DEBUG /openCache(), new cache size 104192
2021-06-13 22:32:34,622 DEBUG need_server_mode(): run in 'desktop' mode, (because of pkg 'ubuntu-desktop')
2021-06-13 22:32:34,622 DEBUG checkViewDepends()
2021-06-13 22:32:34,624 DEBUG running doUpdate() (showErrors=False)
2021-06-13 22:32:35,928 DEBUG openCache()
2021-06-13 22:32:37,283 DEBUG Comparing 4.15.0-143 with
2021-06-13 22:32:37,283 DEBUG Comparing 4.15.0-144 with 4.15.0-143
2021-06-13 22:32:37,284 DEBUG Comparing 4.15.0-55 with 4.15.0-144
2021-06-13 22:32:37,284 DEBUG Comparing 4.15.0-62 with 4.15.0-144
2021-06-13 22:32:37,295 DEBUG Comparing unsigned-4.15.0-55 with 4.15.0-144
2021-06-13 22:32:37,296 DEBUG Comparing unsigned-4.15.0-62 with unsigned-4.15.0-55
2021-06-13 22:32:37,628 DEBUG /openCache(), new cache size 104192
2021-06-13 22:32:37,628 DEBUG doPostInitialUpdate
2021-06-13 22:32:37,629 DEBUG quirks: running focalPostInitialUpdate
2021-06-13 22:32:37,629 DEBUG running Quirks.focalPostInitialUpdate
2021-06-13 22:32:46,573 WARNING error reading deb2snap.json file (Expected a string or a pair of strings)
2021-06-13 22:32:46,778 DEBUG Snap core18 is installed
2021-06-13 22:32:46,961 DEBUG Snap gnome-3-34-1804 is installed
2021-06-13 22:32:46,962 DEBUG Snap gnome-3-34-1804 is not tracking the release channel
2021-06-13 22:32:47,136 DEBUG Snap gtk-common-themes is installed
2021-06-13 22:32:47,136 DEBUG Snap gtk-common-themes is not tracking the release channel
2021-06-13 22:32:47,612 DEBUG Snap core is installed
2021-06-13 22:32:47,612 DEBUG Snap core is not tracking the release channel
2021-06-13 22:32:47,912 DEBUG Snap core20 is installed
2021-06-13 22:32:47,912 DEBUG Snap core20 is not tracking the release channel
2021-06-13 22:32:48,236 DEBUG Snap gnome-3-28-1804 is installed
2021-06-13 22:32:48,236 DEBUG Snap gnome-3-28-1804 is not tracking the release channel
2021-06-13 22:32:48,490 DEBUG Snap intellij-idea-community is installed
2021-06-13 22:32:48,491 DEBUG Snap intellij-idea-community is not tracking the release channel
2021-06-13 22:32:48,696 DEBUG Snap intellij-idea-ultimate is installed
2021-06-13 22:32:48,696 DEBUG Snap intellij-idea-ultimate is not tracking the release channel
2021-06-13 22:32:48,847 DEBUG Snap jupyter is installed
2021-06-13 22:32:48,848 DEBUG Snap jupyter is not tracking the release channel
2021-06-13 22:32:49,011 DEBUG Snap kde-frameworks-5-core18 is installed
2021-06-13 22:32:49,011 DEBUG Snap kde-frameworks-5-core18 is not tracking the release channel
2021-06-13 22:32:49,299 DEBUG Snap kde-frameworks-5-qt-5-14-core18 is installed
2021-06-13 22:32:49,300 DEBUG Snap kde-frameworks-5-qt-5-14-core18 is not tracking the release channel
2021-06-13 22:32:49,554 DEBUG Snap pycharm-community is installed
2021-06-13 22:32:49,554 DEBUG Snap pycharm-community is not tracking the release channel
2021-06-13 22:32:49,713 DEBUG Snap qalculate is installed
2021-06-13 22:32:49,713 DEBUG Snap qalculate is not tracking the release channel
2021-06-13 22:32:49,897 DEBUG Snap skype is installed
2021-06-13 22:32:49,897 DEBUG Snap skype is not tracking the release channel
2021-06-13 22:32:50,175 DEBUG Snap spotify is installed
2021-06-13 22:32:50,176 DEBUG Snap spotify is not tracking the release channel
2021-06-13 22:32:50,365 DEBUG Snap telegram-desktop is installed
2021-06-13 22:32:50,365 DEBUG Snap telegram-desktop is not tracking the release channel
2021-06-13 22:32:50,561 DEBUG Snap vlc is installed
2021-06-13 22:32:50,562 DEBUG Snap vlc is not tracking the release channel
2021-06-13 22:32:53,438 DEBUG MetaPkgs: ubuntu-desktop
2021-06-13 22:32:57,941 DEBUG Foreign:
2021-06-13 22:32:57,941 DEBUG Obsolete: bcc-tools discord libbcc libbcc-examples linux-image-4.15.0-55-generic-dbgsym linux-image-4.15.0-62-generic-dbgsym linux-image-unsigned-4.15.0-55-generic-dbgsym linux-image-unsigned-4.15.0-62-generic-dbgsym lutris python-bcc python-catkin-pkg-modules python-catkin-tools python-osrf-pycommon python-rosdep python-rosdep-modules python-rosdistro-modules python-rospkg-modules ros-melodic-ackermann-steering-controller ros-melodic-actionlib ros-melodic-actionlib-msgs ros-melodic-amcl ros-melodic-angles ros-melodic-base-local-planner ros-melodic-bfl ros-melodic-bond ros-melodic-bondcpp ros-melodic-camera-calibration-parsers ros-melodic-camera-info-manager ros-melodic-catkin ros-melodic-chomp-motion-planner ros-melodic-class-loader ros-melodic-clear-costmap-recovery ros-melodic-cmake-modules ros-melodic-combined-robot-hw ros-melodic-control-msgs ros-melodic-control-toolbox ros-melodic-controller-interface ros-melodic-controller-manager ros-melodic-controller-manager-msgs ros-melodic-costmap-2d ros-melodic-costmap-converter ros-melodic-cpp-common ros-melodic-cv-bridge ros-melodic-depth-image-proc ros-melodic-depthimage-to-laserscan ros-melodic-diagnostic-msgs ros-melodic-diagnostic-updater ros-melodic-diff-drive-controller ros-melodic-dynamic-reconfigure ros-melodic-effort-controllers ros-melodic-eigen-conversions ros-melodic-eigen-stl-containers ros-melodic-eigenpy ros-melodic-fake-localization ros-melodic-force-torque-sensor-controller ros-melodic-forward-command-controller ros-melodic-four-wheel-steering-msgs ros-melodic-franka-description ros-melodic-gencpp ros-melodic-geneus ros-melodic-genlisp ros-melodic-genmsg ros-melodic-gennodejs ros-melodic-genpy ros-melodic-geometric-shapes ros-melodic-geometry-msgs ros-melodic-global-planner ros-melodic-graph-msgs ros-melodic-gripper-action-controller ros-melodic-hardware-interface ros-melodic-image-geometry ros-melodic-image-proc ros-melodic-image-transport ros-melodic-imu-sensor-controller ros-melodic-interactive-markers ros-melodic-joint-limits-interface ros-melodic-joint-state-controller ros-melodic-joint-state-publisher ros-melodic-joint-state-publisher-gui ros-melodic-joint-trajectory-controller ros-melodic-joy ros-melodic-kdl-conversions ros-melodic-kdl-parser ros-melodic-laser-geometry ros-melodic-libg2o ros-melodic-libuvc ros-melodic-libuvc-camera ros-melodic-map-msgs ros-melodic-map-server ros-melodic-mbf-abstract-core ros-melodic-mbf-costmap-core ros-melodic-mbf-msgs ros-melodic-mbf-utility ros-melodic-media-export ros-melodic-message-filters ros-melodic-message-generation ros-melodic-message-runtime ros-melodic-mk ros-melodic-move-base ros-melodic-move-base-msgs ros-melodic-moveit ros-melodic-moveit-commander ros-melodic-moveit-core ros-melodic-moveit-fake-controller-manager ros-melodic-moveit-kinematics ros-melodic-moveit-msgs ros-melodic-moveit-planners ros-melodic-moveit-planners-chomp ros-melodic-moveit-planners-ompl ros-melodic-moveit-plugins ros-melodic-moveit-resources ros-melodic-moveit-resources-fanuc-description ros-melodic-moveit-resources-fanuc-moveit-config ros-melodic-moveit-resources-panda-description ros-melodic-moveit-resources-panda-moveit-config ros-melodic-moveit-resources-pr2-description ros-melodic-moveit-ros ros-melodic-moveit-ros-benchmarks ros-melodic-moveit-ros-control-interface ros-melodic-moveit-ros-manipulation ros-melodic-moveit-ros-move-group ros-melodic-moveit-ros-occupancy-map-monitor ros-melodic-moveit-ros-perception ros-melodic-moveit-ros-planning ros-melodic-moveit-ros-planning-interface ros-melodic-moveit-ros-robot-interaction ros-melodic-moveit-ros-visualization ros-melodic-moveit-ros-warehouse ros-melodic-moveit-setup-assistant ros-melodic-moveit-simple-controller-manager ros-melodic-moveit-visual-tools ros-melodic-nav-core ros-melodic-nav-msgs ros-melodic-navfn ros-melodic-nodelet ros-melodic-nodelet-topic-tools ros-melodic-object-recognition-msgs ros-melodic-octomap ros-melodic-octomap-msgs ros-melodic-ompl ros-melodic-openni2-camera ros-melodic-openni2-launch ros-melodic-orocos-kdl ros-melodic-people-msgs ros-melodic-pluginlib ros-melodic-pointcloud-to-laserscan ros-melodic-position-controllers ros-melodic-python-orocos-kdl ros-melodic-python-qt-binding ros-melodic-qt-dotgraph ros-melodic-qt-gui ros-melodic-qt-gui-cpp ros-melodic-qt-gui-py-common ros-melodic-qwt-dependency ros-melodic-random-numbers ros-melodic-realtime-tools ros-melodic-resource-retriever ros-melodic-rgbd-launch ros-melodic-robot-state-publisher ros-melodic-ros ros-melodic-ros-control ros-melodic-ros-controllers ros-melodic-ros-environment ros-melodic-ros-tutorials ros-melodic-rosbag ros-melodic-rosbag-migration-rule ros-melodic-rosbag-storage ros-melodic-rosbash ros-melodic-rosboost-cfg ros-melodic-rosbuild ros-melodic-rosclean ros-melodic-rosconsole ros-melodic-rosconsole-bridge ros-melodic-roscpp ros-melodic-roscpp-serialization ros-melodic-roscpp-traits ros-melodic-roscpp-tutorials ros-melodic-roscreate ros-melodic-rosgraph ros-melodic-rosgraph-msgs ros-melodic-roslang ros-melodic-roslaunch ros-melodic-roslib ros-melodic-roslint ros-melodic-roslz4 ros-melodic-rosmake ros-melodic-rosmaster ros-melodic-rosmsg ros-melodic-rosnode ros-melodic-rosout ros-melodic-rospack ros-melodic-rosparam ros-melodic-rospy ros-melodic-rospy-tutorials ros-melodic-rosservice ros-melodic-rostest ros-melodic-rostime ros-melodic-rostopic ros-melodic-rosunit ros-melodic-roswtf ros-melodic-rotate-recovery ros-melodic-rqt ros-melodic-rqt-action ros-melodic-rqt-bag ros-melodic-rqt-bag-plugins ros-melodic-rqt-common-plugins ros-melodic-rqt-console ros-melodic-rqt-dep ros-melodic-rqt-graph ros-melodic-rqt-gui ros-melodic-rqt-gui-cpp ros-melodic-rqt-gui-py ros-melodic-rqt-image-view ros-melodic-rqt-launch ros-melodic-rqt-logger-level ros-melodic-rqt-msg ros-melodic-rqt-plot ros-melodic-rqt-publisher ros-melodic-rqt-py-common ros-melodic-rqt-py-console ros-melodic-rqt-reconfigure ros-melodic-rqt-service-caller ros-melodic-rqt-shell ros-melodic-rqt-srv ros-melodic-rqt-top ros-melodic-rqt-topic ros-melodic-rqt-web ros-melodic-rviz ros-melodic-rviz-visual-tools ros-melodic-sensor-msgs ros-melodic-shape-msgs ros-melodic-sick-tim ros-melodic-slam-toolbox ros-melodic-slam-toolbox-msgs ros-melodic-smclib ros-melodic-sparse-bundle-adjustment ros-melodic-srdfdom ros-melodic-std-msgs ros-melodic-std-srvs ros-melodic-teb-local-planner ros-melodic-tf ros-melodic-tf-conversions ros-melodic-tf2 ros-melodic-tf2-eigen ros-melodic-tf2-geometry-msgs ros-melodic-tf2-kdl ros-melodic-tf2-msgs ros-melodic-tf2-py ros-melodic-tf2-ros ros-melodic-tf2-sensor-msgs ros-melodic-topic-tools ros-melodic-trajectory-msgs ros-melodic-transmission-interface ros-melodic-turtlesim ros-melodic-twist-mux ros-melodic-twist-mux-msgs ros-melodic-urdf ros-melodic-urdf-geometry-parser ros-melodic-urdf-test ros-melodic-urdfdom-py ros-melodic-uvc-camera ros-melodic-velocity-controllers ros-melodic-visualization-msgs ros-melodic-voxel-grid ros-melodic-warehouse-ros ros-melodic-webkit-dependency ros-melodic-xacro ros-melodic-xmlrpcpp sublime-text zoom
2021-06-13 22:32:57,942 DEBUG updateSourcesList()
2021-06-13 22:32:57,943 DEBUG rewriteSourcesList() with mirror_check
2021-06-13 22:32:57,943 DEBUG ['ubuntu-minimal', 'ubuntu-standard']
2021-06-13 22:32:57,943 DEBUG Checking pkg: ubuntu-minimal
2021-06-13 22:32:57,946 DEBUG Checking pkg: ubuntu-standard
2021-06-13 22:32:57,948 DEBUG examining: 'deb http://archive.ubuntu.com/ubuntu bionic main universe multiverse restricted'
2021-06-13 22:32:57,948 DEBUG verifySourcesListEntry: deb http://archive.ubuntu.com/ubuntu focal main universe multiverse restricted
2021-06-13 22:32:57,948 DEBUG url_downloadable: http://archive.ubuntu.com/ubuntu/dists/focal/Release
2021-06-13 22:32:57,948 DEBUG s='http' n='archive.ubuntu.com' p='/ubuntu/dists/focal/Release' q='' f=''
2021-06-13 22:32:58,032 DEBUG entry 'deb http://archive.ubuntu.com/ubuntu focal main universe multiverse restricted' updated to new dist
2021-06-13 22:32:58,032 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu/ bionic-security main multiverse universe restricted'
2021-06-13 22:32:58,032 DEBUG verifySourcesListEntry: deb http://security.ubuntu.com/ubuntu/ focal main multiverse universe restricted
2021-06-13 22:32:58,032 DEBUG url_downloadable: http://security.ubuntu.com/ubuntu//dists/focal/Release
2021-06-13 22:32:58,033 DEBUG s='http' n='security.ubuntu.com' p='/ubuntu//dists/focal/Release' q='' f=''
2021-06-13 22:32:58,278 DEBUG entry 'deb http://security.ubuntu.com/ubuntu/ focal-security main multiverse universe restricted' updated to new dist
2021-06-13 22:32:58,278 DEBUG examining: 'deb http://archive.ubuntu.com/ubuntu bionic-updates main multiverse universe restricted'
2021-06-13 22:32:58,278 DEBUG entry 'deb http://archive.ubuntu.com/ubuntu focal-updates main multiverse universe restricted' updated to new dist
2021-06-13 22:32:58,281 DEBUG running doUpdate() (showErrors=True)
2021-06-13 22:33:28,279 DEBUG openCache()
2021-06-13 22:33:29,230 DEBUG Comparing 4.15.0-143 with
2021-06-13 22:33:29,231 DEBUG Comparing 4.15.0-144 with 4.15.0-143
2021-06-13 22:33:29,231 DEBUG Comparing 4.15.0-55 with 4.15.0-144
2021-06-13 22:33:29,231 DEBUG Comparing 4.15.0-62 with 4.15.0-144
2021-06-13 22:33:29,234 DEBUG Comparing unsigned-4.15.0-55 with 4.15.0-144
2021-06-13 22:33:29,234 DEBUG Comparing unsigned-4.15.0-62 with unsigned-4.15.0-55
2021-06-13 22:33:29,467 DEBUG /openCache(), new cache size 69993
2021-06-13 22:33:29,467 DEBUG need_server_mode(): run in 'desktop' mode, (because of pkg 'ubuntu-desktop')
2021-06-13 22:33:29,468 DEBUG quirks: running PreDistUpgradeCache
2021-06-13 22:33:29,468 DEBUG running Quirks.PreDistUpgradeCache
2021-06-13 22:33:29,468 INFO checking for python-dbg (auto_inst=False)
2021-06-13 22:33:29,468 INFO checking for python-doc (auto_inst=False)
2021-06-13 22:33:29,468 INFO checking for python-minimal (auto_inst=False)
2021-06-13 22:33:29,468 INFO installing python-is-python2 because python-minimal was installed
2021-06-13 22:33:29,468 DEBUG Installing 'python-is-python2' (python-minimal was installed on the system)
2021-06-13 22:33:29,524 INFO removing python-minimal because python-is-python2 is being installed
2021-06-13 22:33:29,525 DEBUG Removing 'python-minimal' (python-is-python2 is being installed on the system)
2021-06-13 22:33:29,575 INFO failed to remove python-minimal
2021-06-13 22:33:29,576 INFO checking for python-dev (auto_inst=False)
2021-06-13 22:33:29,576 INFO installing python-dev-is-python2 because python-dev was installed
2021-06-13 22:33:29,576 DEBUG Installing 'python-dev-is-python2' (python-dev was installed on the system)
2021-06-13 22:33:29,626 INFO removing python-dev because python-dev-is-python2 is being installed
2021-06-13 22:33:29,627 DEBUG Removing 'python-dev' (python-dev-is-python2 is being installed on the system)
2021-06-13 22:33:29,678 INFO failed to remove python-dev
2021-06-13 22:33:29,678 INFO checking for libpython-dev (auto_inst=False)
2021-06-13 22:33:29,729 INFO removing libpython-dev because None is being installed
2021-06-13 22:33:29,729 DEBUG Removing 'libpython-dev' (None is being installed on the system)
2021-06-13 22:33:29,779 INFO failed to remove libpython-dev
2021-06-13 22:33:29,779 INFO checking for libpython-stdlib (auto_inst=False)
2021-06-13 22:33:29,779 INFO removing libpython-stdlib because None is being installed
2021-06-13 22:33:29,779 DEBUG Removing 'libpython-stdlib' (None is being installed on the system)
2021-06-13 22:33:29,827 INFO failed to remove libpython-stdlib
2021-06-13 22:33:29,828 INFO checking for libpython-dbg (auto_inst=False)
2021-06-13 22:33:29,828 INFO checking for python-dbg (auto_inst=True)
2021-06-13 22:33:29,828 INFO checking for python-doc (auto_inst=True)
2021-06-13 22:33:29,828 INFO checking for python-minimal (auto_inst=True)
2021-06-13 22:33:29,828 INFO installing python-is-python2 because python-minimal was installed
2021-06-13 22:33:29,828 DEBUG Installing 'python-is-python2' (python-minimal was installed on the system)
2021-06-13 22:33:29,879 INFO removing python-minimal because python-is-python2 is being installed
2021-06-13 22:33:29,879 DEBUG Removing 'python-minimal' (python-is-python2 is being installed on the system)
2021-06-13 22:33:29,879 INFO failed to remove python-minimal
2021-06-13 22:33:29,879 INFO checking for python-dev (auto_inst=True)
2021-06-13 22:33:29,879 INFO installing python-dev-is-python2 because python-dev was installed
2021-06-13 22:33:29,879 DEBUG Installing 'python-dev-is-python2' (python-dev was installed on the system)
2021-06-13 22:33:29,928 INFO removing python-dev because python-dev-is-python2 is being installed
2021-06-13 22:33:29,928 DEBUG Removing 'python-dev' (python-dev-is-python2 is being installed on the system)
2021-06-13 22:33:29,928 INFO failed to remove python-dev
2021-06-13 22:33:29,928 INFO checking for libpython-dev (auto_inst=True)
2021-06-13 22:33:29,928 INFO removing libpython-dev because None is being installed
2021-06-13 22:33:29,928 DEBUG Removing 'libpython-dev' (None is being installed on the system)
2021-06-13 22:33:29,928 INFO failed to remove libpython-dev
2021-06-13 22:33:29,928 INFO checking for libpython-stdlib (auto_inst=True)
2021-06-13 22:33:29,928 INFO removing libpython-stdlib because None is being installed
2021-06-13 22:33:29,928 DEBUG Removing 'libpython-stdlib' (None is being installed on the system)
2021-06-13 22:33:29,928 INFO failed to remove libpython-stdlib
2021-06-13 22:33:29,928 INFO checking for libpython-dbg (auto_inst=True)
2021-06-13 22:33:32,002 ERROR Dist-upgrade failed: 'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'
2021-06-13 22:33:32,004 DEBUG abort called
2021-06-13 22:33:32,006 DEBUG openCache()
2021-06-13 22:33:35,855 DEBUG Comparing 4.15.0-143 with
2021-06-13 22:33:35,856 DEBUG Comparing 4.15.0-144 with 4.15.0-143
2021-06-13 22:33:35,857 DEBUG Comparing 4.15.0-55 with 4.15.0-144
2021-06-13 22:33:35,857 DEBUG Comparing 4.15.0-62 with 4.15.0-144
2021-06-13 22:33:35,869 DEBUG Comparing unsigned-4.15.0-55 with 4.15.0-144
2021-06-13 22:33:35,869 DEBUG Comparing unsigned-4.15.0-62 with unsigned-4.15.0-55
2021-06-13 22:33:36,226 DEBUG /openCache(), new cache size 104192

and the content of apt.log:

Log time: 2021-06-13 22:32:34.615696
Log time: 2021-06-13 22:32:37.608606
Log time: 2021-06-13 22:33:29.442956
  MarkDelete python-minimal:amd64 < 2.7.15~rc1-1 @ii mK > FU=1
  MarkDelete python-dev:amd64 < 2.7.15~rc1-1 @ii mK > FU=1
  MarkDelete libpython-dev:amd64 < 2.7.15~rc1-1 @ii gK > FU=1
  MarkDelete libpython-stdlib:amd64 < 2.7.15~rc1-1 @ii mK > FU=1
  MarkInstall python-is-python2:amd64 < none -> 2.7.17-4 @un umN Ib > FU=1
  Installing python2 as Depends of python-is-python2
    MarkInstall python2:amd64 < none -> 2.7.17-2ubuntu4 @un uN Ib > FU=0
    Installing python2-minimal as PreDepends of python2
      MarkInstall python2-minimal:amd64 < none -> 2.7.17-2ubuntu4 @un uN > FU=0
    Installing libpython2-stdlib as Depends of python2
      MarkInstall libpython2-stdlib:amd64 < none -> 2.7.17-2ubuntu4 @un uN > FU=0
     Removing: python
      MarkDelete python:amd64 < 2.7.15~rc1-1 @ii mK Ib > FU=0
  MarkInstall python-dev-is-python2:amd64 < none -> 2.7.17-4 @un umN Ib > FU=1
  Installing python2-dev as Depends of python-dev-is-python2
    MarkInstall python2-dev:amd64 < none -> 2.7.17-2ubuntu4 @un uN Ib > FU=0
    Installing libpython2-dev as Depends of python2-dev
      MarkInstall libpython2-dev:amd64 < none -> 2.7.17-2ubuntu4 @un uN > FU=0
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
  Ignore MarkInstall of python:amd64 < 2.7.15~rc1-1 @ii pgR > as its mode (Delete) is protected
    MarkKeep libpython-stdlib:amd64 < 2.7.15~rc1-1 @ii gR > FU=0
    MarkKeep libpython-dev:amd64 < 2.7.15~rc1-1 @ii gR > FU=0
    MarkKeep python-dev:amd64 < 2.7.15~rc1-1 @ii gR > FU=0
    MarkKeep python-minimal:amd64 < 2.7.15~rc1-1 @ii gR > FU=0
  MarkInstall fdisk:amd64 < 2.31.1-0.4ubuntu3.7 -> 2.34-0.1ubuntu9.1 @ii umU Ib > FU=0
  Installing libncursesw6 as Depends of fdisk
    MarkInstall libncursesw6:amd64 < none -> 6.2-0ubuntu2 @un uN Ib > FU=0
    Installing libtinfo6 as Depends of libncursesw6
      MarkInstall libtinfo6:amd64 < none -> 6.2-0ubuntu2 @un uN > FU=0
  MarkInstall xfce4-pulseaudio-plugin:amd64 < 0.4.1-0ubuntu1 -> 0.4.3-0ubuntu1 @ii umU Ib > FU=0
  Installing libxfconf-0-3 as Depends of xfce4-pulseaudio-plugin
    MarkInstall libxfconf-0-3:amd64 < none -> 4.14.1-1 @un uN > FU=0
  MarkInstall libfltk1.1:amd64 < 1.1.10-23 -> 1.1.10-26ubuntu2 @ii umU Ib > FU=0
  Installing libgcc-s1 as Depends of libfltk1.1
    MarkInstall libgcc-s1:amd64 < none -> 10.2.0-5ubuntu1~20.04 @un uN Ib > FU=0
    Installing gcc-10-base as Depends of libgcc-s1
      MarkInstall gcc-10-base:amd64 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
  MarkInstall evince:amd64 < 3.28.4-0ubuntu1.2 -> 3.36.10-0ubuntu1 @ii umU Ib > FU=0
  Installing libgnome-desktop-3-19 as Depends of evince
    MarkInstall libgnome-desktop-3-19:amd64 < none -> 3.36.8-0ubuntu1 @un uN > FU=0
  MarkInstall libavresample-dev:amd64 < 7:3.4.8-0ubuntu0.2 -> 7:4.2.4-1ubuntu0.1 @ii umU Ib > FU=0
  Installing libavresample4 as Depends of libavresample-dev
    MarkInstall libavresample4:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
    Installing libavutil56 as Depends of libavresample4
      MarkInstall libavutil56:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
  MarkInstall perl-base:amd64 < 5.26.1-6ubuntu0.5 -> 5.30.0-9ubuntu0.2 @ii umU Ib > FU=0
  Installing libcrypt1 as PreDepends of perl-base
    MarkInstall libcrypt1:amd64 < none -> 1:4.4.10-10ubuntu4 @un uN > FU=0
  MarkInstall libreoffice-math:amd64 < 1:6.0.7-0ubuntu0.18.04.10 -> 1:6.4.7-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libuno-cppu3 as Depends of libreoffice-math
    MarkInstall libuno-cppu3:amd64 < none -> 1:6.4.7-0ubuntu0.20.04.1 @un uN Ib > FU=0
    Installing libuno-sal3 as Depends of libuno-cppu3
      MarkInstall libuno-sal3:amd64 < none -> 1:6.4.7-0ubuntu0.20.04.1 @un uN Ib > FU=0
       Removing: uno-libs3
        MarkDelete uno-libs3:amd64 < 6.0.7-0ubuntu0.18.04.10 @ii mK > FU=0
    Installing libuno-salhelpergcc3-3 as Depends of libuno-cppu3
      MarkInstall libuno-salhelpergcc3-3:amd64 < none -> 1:6.4.7-0ubuntu0.20.04.1 @un uN > FU=0
  Installing libuno-cppuhelpergcc3-3 as Depends of libreoffice-math
    MarkInstall libuno-cppuhelpergcc3-3:amd64 < none -> 1:6.4.7-0ubuntu0.20.04.1 @un uN Ib > FU=0
    Installing uno-libs-private as Depends of libuno-cppuhelpergcc3-3
      MarkInstall uno-libs-private:amd64 < none -> 1:6.4.7-0ubuntu0.20.04.1 @un uN > FU=0
  MarkInstall libboost-wave-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-wave1.71-dev as Depends of libboost-wave-dev
    MarkInstall libboost-wave1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
    Installing libboost1.71-dev as Depends of libboost-wave1.71-dev
      MarkInstall libboost1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
       Removing: libboost1.65-dev
        MarkDelete libboost1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
    Installing libboost-serialization1.71-dev as Depends of libboost-wave1.71-dev
      MarkInstall libboost-serialization1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
      Installing libboost-serialization1.71.0 as Depends of libboost-serialization1.71-dev
        MarkInstall libboost-serialization1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
       Removing: libboost-serialization1.65-dev
        MarkDelete libboost-serialization1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
    Installing libboost-wave1.71.0 as Depends of libboost-wave1.71-dev
      MarkInstall libboost-wave1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
      Installing libboost-thread1.71.0 as Depends of libboost-wave1.71.0
        MarkInstall libboost-thread1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
    Installing libboost-filesystem1.71-dev as Depends of libboost-wave1.71-dev
      MarkInstall libboost-filesystem1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
      Installing libboost-filesystem1.71.0 as Depends of libboost-filesystem1.71-dev
        MarkInstall libboost-filesystem1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
      Installing libboost-system1.71-dev as Depends of libboost-filesystem1.71-dev
        MarkInstall libboost-system1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
        Installing libboost-system1.71.0 as Depends of libboost-system1.71-dev
          MarkInstall libboost-system1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
         Removing: libboost-system1.65-dev
          MarkDelete libboost-system1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
       Removing: libboost-filesystem1.65-dev
        MarkDelete libboost-filesystem1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
     Removing: libboost-wave1.65-dev
      MarkDelete libboost-wave1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
  MarkInstall bluez:amd64 < 5.48-0ubuntu3.4 -> 5.53-0ubuntu3.1 @ii umU Ib > FU=0
  Installing libreadline8 as Depends of bluez
    MarkInstall libreadline8:amd64 < none -> 8.0-4 @un uN > FU=0
  MarkInstall libopencv-core-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Installing libopencv-core4.2 as Depends of libopencv-core-dev
    MarkInstall libopencv-core4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN > FU=0
  MarkInstall inxi:amd64 < 2.3.56-1 -> 3.0.38-1-0ubuntu1 @ii umU IPb > FU=0
  new important dependency: tree:amd64
  Installing tree as Recommends of inxi
    MarkInstall tree:amd64 < none -> 1.8.0-1 @un uN > FU=0
  MarkInstall gnome-power-manager:amd64 < 3.26.0-1 -> 3.32.0-2 @ii umU Ib > FU=0
  Installing gnome-settings-daemon-common as Depends of gnome-power-manager
    MarkInstall gnome-settings-daemon-common:amd64 < none -> 3.36.1-0ubuntu1 @un uN Ib > FU=0
     Removing: gnome-settings-daemon-schemas
      MarkDelete gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3 @ii mK > FU=0
  MarkInstall python3-dev:amd64 < 3.6.7-1~18.04 -> 3.8.2-0ubuntu2 @ii umU Ib > FU=0
  Installing python3.8-dev as Depends of python3-dev
    MarkInstall python3.8-dev:amd64 < none -> 3.8.5-1~20.04.3 @un uN Ib > FU=0
    Installing python3.8 as Depends of python3.8-dev
      MarkInstall python3.8:amd64 < none -> 3.8.5-1~20.04.3 @un uN Ib > FU=0
      Installing python3.8-minimal as Depends of python3.8
        MarkInstall python3.8-minimal:amd64 < none -> 3.8.5-1~20.04.3 @un uN Ib > FU=0
        Installing libpython3.8-minimal as Depends of python3.8-minimal
          MarkInstall libpython3.8-minimal:amd64 < none -> 3.8.5-1~20.04.3 @un uN IPb > FU=0
          Installing libpython3.8-stdlib as Recommends of libpython3.8-minimal
            MarkInstall libpython3.8-stdlib:amd64 < none -> 3.8.5-1~20.04.3 @un uN Ib > FU=0
            Installing libffi7 as Depends of libpython3.8-stdlib
              MarkInstall libffi7:amd64 < none -> 3.3-4 @un uN > FU=0
    Installing libpython3.8-dev as Depends of python3.8-dev
      MarkInstall libpython3.8-dev:amd64 < none -> 3.8.5-1~20.04.3 @un uN Ib > FU=0
      Installing libpython3.8 as Depends of libpython3.8-dev
        MarkInstall libpython3.8:amd64 < none -> 3.8.5-1~20.04.3 @un uN > FU=0
  MarkInstall vlc-plugin-video-output:amd64 < 3.0.8-0ubuntu18.04.1 -> 3.0.9.2-1 @ii umU Ib > FU=0
  Installing libavcodec58 as Depends of vlc-plugin-video-output
    MarkInstall libavcodec58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
    Installing libaom0 as Depends of libavcodec58
      MarkInstall libaom0:amd64 < none -> 1.0.0.errata1-3build1 @un uN > FU=0
    Installing libcodec2-0.9 as Depends of libavcodec58
      MarkInstall libcodec2-0.9:amd64 < none -> 0.9.2-2 @un uN > FU=0
    Installing libswresample3 as Depends of libavcodec58
      MarkInstall libswresample3:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
    Installing libvpx6 as Depends of libavcodec58
      MarkInstall libvpx6:amd64 < none -> 1.8.2-1build1 @un uN > FU=0
    Installing libx264-155 as Depends of libavcodec58
      MarkInstall libx264-155:amd64 < none -> 2:0.155.2917+git0a84d98-2 @un uN > FU=0
    Installing libx265-179 as Depends of libavcodec58
      MarkInstall libx265-179:amd64 < none -> 3.2.1-1build1 @un uN > FU=0
  Installing libplacebo7 as Depends of vlc-plugin-video-output
    MarkInstall libplacebo7:amd64 < none -> 1.7.0-2 @un uN > FU=0
  MarkInstall libboost-math-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-math1.71-dev as Depends of libboost-math-dev
    MarkInstall libboost-math1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
    Installing libboost-math1.71.0 as Depends of libboost-math1.71-dev
      MarkInstall libboost-math1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
     Removing: libboost-math1.65-dev
      MarkDelete libboost-math1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
  MarkInstall gnome-calendar:amd64 < 3.28.2-0ubuntu0.18.04.1 -> 3.36.2-0ubuntu1 @ii umU Ib > FU=0
  Installing libecal-2.0-1 as Depends of gnome-calendar
    MarkInstall libecal-2.0-1:amd64 < none -> 3.36.5-0ubuntu1 @un uN Ib > FU=0
    Installing libedataserver-1.2-24 as Depends of libecal-2.0-1
      MarkInstall libedataserver-1.2-24:amd64 < none -> 3.36.5-0ubuntu1 @un uN Ib > FU=0
      Installing libcamel-1.2-62 as Depends of libedataserver-1.2-24
        MarkInstall libcamel-1.2-62:amd64 < none -> 3.36.5-0ubuntu1 @un uN Ib > FU=0
        Installing libicu66 as Depends of libcamel-1.2-62
          MarkInstall libicu66:amd64 < none -> 66.1-2ubuntu2 @un uN > FU=0
  Installing libgweather-3-16 as Depends of gnome-calendar
    MarkInstall libgweather-3-16:amd64 < none -> 3.36.1-1~ubuntu20.04.1 @un uN > FU=0
  Installing libhandy-0.0-0 as Depends of gnome-calendar
    MarkInstall libhandy-0.0-0:amd64 < none -> 0.0.13-1 @un uN > FU=0
  MarkInstall winetricks:amd64 < 0.0+20180217-1 -> 0.0+20200412-1 @ii umU IPb > FU=0
  new important dependency: fuseiso:amd64
  Installing fuseiso as Recommends of winetricks
    MarkInstall fuseiso:amd64 < none -> 20070708-3.2build1 @un uN > FU=0
  MarkInstall libboost-numpy-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-numpy1.71-dev as Depends of libboost-numpy-dev
    MarkInstall libboost-numpy1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
    Installing libboost-numpy1.71.0 as Depends of libboost-numpy1.71-dev
      MarkInstall libboost-numpy1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
      Installing libboost-python1.71.0 as Depends of libboost-numpy1.71.0
        MarkInstall libboost-python1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
     Removing: libboost-numpy1.65-dev
      MarkDelete libboost-numpy1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
  MarkInstall xubuntu-icon-theme:amd64 < 18.04.5 -> 20.04.2 @ii umU Ib > FU=0
  Installing elementary-xfce-icon-theme as Depends of xubuntu-icon-theme
    MarkInstall elementary-xfce-icon-theme:amd64 < none -> 0.15-1 @un uN > FU=0
  MarkInstall libkf5texteditor5:amd64 < 5.44.0-0ubuntu2 -> 5.68.0-0ubuntu1 @ii umU Ib > FU=0
  Installing libkf5texteditor-bin as Depends of libkf5texteditor5
    MarkInstall libkf5texteditor-bin:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
    Installing libkf5authcore5 as Depends of libkf5texteditor-bin
      MarkInstall libkf5authcore5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
  Installing libgit2-28 as Depends of libkf5texteditor5
    MarkInstall libgit2-28:amd64 < none -> 0.28.4+dfsg.1-2 @un uN Ib > FU=0
    Installing libhttp-parser2.9 as Depends of libgit2-28
      MarkInstall libhttp-parser2.9:amd64 < none -> 2.9.2-2 @un uN > FU=0
    Installing libmbedcrypto3 as Depends of libgit2-28
      MarkInstall libmbedcrypto3:amd64 < none -> 2.16.4-1ubuntu2 @un uN > FU=0
    Installing libmbedtls12 as Depends of libgit2-28
      MarkInstall libmbedtls12:amd64 < none -> 2.16.4-1ubuntu2 @un uN Ib > FU=0
      Installing libmbedx509-0 as Depends of libmbedtls12
        MarkInstall libmbedx509-0:amd64 < none -> 2.16.4-1ubuntu2 @un uN > FU=0
  MarkInstall libatlas3-base:amd64 < 3.10.3-5 -> 3.10.3-8ubuntu7 @ii umU Ib > FU=0
  Installing libgfortran5 as Depends of libatlas3-base
    MarkInstall libgfortran5:amd64 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
  MarkInstall poppler-utils:amd64 < 0.62.0-2ubuntu2.12 -> 0.86.1-0ubuntu1 @ii umU Ib > FU=0
  Installing libpoppler97 as Depends of poppler-utils
    MarkInstall libpoppler97:amd64 < none -> 0.86.1-0ubuntu1 @un uN > FU=0
  MarkInstall linux-tools-generic:amd64 < 4.15.0.144.131 -> 5.4.0.74.77 @ii umU Ib > FU=0
  Installing linux-tools-5.4.0-74-generic as Depends of linux-tools-generic
    MarkInstall linux-tools-5.4.0-74-generic:amd64 < none -> 5.4.0-74.83 @un uN Ib > FU=0
    Installing linux-tools-5.4.0-74 as Depends of linux-tools-5.4.0-74-generic
      MarkInstall linux-tools-5.4.0-74:amd64 < none -> 5.4.0-74.83 @un uN > FU=0
  MarkInstall libgusb2:amd64 < 0.2.11-1 -> 0.3.4-0.1 @ii umU IPb > FU=0
  new important dependency: usb.ids:amd64
  Installing usb.ids as Recommends of libgusb2
    MarkInstall usb.ids:amd64 < none -> 2020.03.19-1 @un uN > FU=0
  MarkInstall libboost-context1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
  Installing libboost1.65-dev as Depends of libboost-context1.65-dev
      MarkKeep libboost1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall libaa1:amd64 < 1.4p5-44build2 -> 1.4p5-46 @ii umU Ib > FU=0
  Installing libncurses6 as Depends of libaa1
    MarkInstall libncurses6:amd64 < none -> 6.2-0ubuntu2 @un uN > FU=0
    MarkKeep gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3 @ii mR > FU=0
  MarkInstall libvte-2.91-0:amd64 < 0.52.2-1ubuntu1~18.04.2 -> 0.60.3-0ubuntu1~20.04 @ii umU Ib > FU=0
  Installing libpcre2-8-0 as Depends of libvte-2.91-0
    MarkInstall libpcre2-8-0:amd64 < none -> 10.34-7 @un uN > FU=0
  MarkInstall sonnet-plugins:amd64 < 5.44.0-0ubuntu1 -> 5.68.0-0ubuntu1 @ii umU Ib > FU=0
  Installing libhunspell-1.7-0 as Depends of sonnet-plugins
    MarkInstall libhunspell-1.7-0:amd64 < none -> 1.7.0-2build2 @un uN > FU=0
  MarkInstall linux-headers-generic:amd64 < 4.15.0.144.131 -> 5.4.0.74.77 @ii umU Ib > FU=0
  Installing linux-headers-5.4.0-74-generic as Depends of linux-headers-generic
    MarkInstall linux-headers-5.4.0-74-generic:amd64 < none -> 5.4.0-74.83 @un uN Ib > FU=0
    Installing linux-headers-5.4.0-74 as Depends of linux-headers-5.4.0-74-generic
      MarkInstall linux-headers-5.4.0-74:amd64 < none -> 5.4.0-74.83 @un uN > FU=0
  MarkInstall gedit:amd64 < 3.28.1-1ubuntu1.2 -> 3.36.2-0ubuntu1 @ii umU Ib > FU=0
  Installing gir1.2-gtksource-4 as Depends of gedit
    MarkInstall gir1.2-gtksource-4:amd64 < none -> 4.6.0-1 @un uN Ib > FU=0
    Installing libgtksourceview-4-0 as Depends of gir1.2-gtksource-4
      MarkInstall libgtksourceview-4-0:amd64 < none -> 4.6.0-1 @un uN Ib > FU=0
      Installing libgtksourceview-4-common as Depends of libgtksourceview-4-0
        MarkInstall libgtksourceview-4-common:amd64 < none -> 4.6.0-1 @un uN > FU=0
  Installing libamtk-5-0 as Depends of gedit
    MarkInstall libamtk-5-0:amd64 < none -> 5.0.2-1build1 @un uN Ib > FU=0
    Installing libamtk-5-common as Depends of libamtk-5-0
      MarkInstall libamtk-5-common:amd64 < none -> 5.0.2-1build1 @un uN > FU=0
  Installing libgspell-1-2 as Depends of gedit
    MarkInstall libgspell-1-2:amd64 < none -> 1.8.3-1 @un uN Ib > FU=0
    Installing libenchant-2-2 as Depends of libgspell-1-2
      MarkInstall libenchant-2-2:amd64 < none -> 2.2.8-1ubuntu0.20.04.1 @un uN IPb > FU=0
      Installing enchant-2 as Recommends of libenchant-2-2
        MarkInstall enchant-2:amd64 < none -> 2.2.8-1ubuntu0.20.04.1 @un uN > FU=0
  Installing libtepl-4-0 as Depends of gedit
    MarkInstall libtepl-4-0:amd64 < none -> 4.4.0-1 @un uN Ib > FU=0
    Installing libuchardet0 as Depends of libtepl-4-0
      MarkInstall libuchardet0:amd64 < none -> 0.0.6-3build1 @un uN > FU=0
  MarkInstall iptables:amd64 < 1.6.1-2ubuntu2 -> 1.8.4-3ubuntu2 @ii umU Ib > FU=0
  Installing libip4tc2 as Depends of iptables
    MarkInstall libip4tc2:amd64 < none -> 1.8.4-3ubuntu2 @un uN > FU=0
  Installing libip6tc2 as Depends of iptables
    MarkInstall libip6tc2:amd64 < none -> 1.8.4-3ubuntu2 @un uN > FU=0
  Installing libnftnl11 as Depends of iptables
    MarkInstall libnftnl11:amd64 < none -> 1.1.5-1 @un uN > FU=0
  MarkInstall libboost-chrono-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-chrono1.71-dev as Depends of libboost-chrono-dev
    MarkInstall libboost-chrono1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
    Installing libboost-chrono1.71.0 as Depends of libboost-chrono1.71-dev
      MarkInstall libboost-chrono1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
     Removing: libboost-chrono1.65-dev
      MarkDelete libboost-chrono1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
  MarkInstall gvfs-backends:amd64 < 1.36.1-0ubuntu1.3.3 -> 1.44.1-1ubuntu1 @ii umU Ib > FU=0
  Installing libcdio18 as Depends of gvfs-backends
    MarkInstall libcdio18:amd64 < none -> 2.0.0-2 @un uN > FU=0
  Installing libnfs13 as Depends of gvfs-backends
    MarkInstall libnfs13:amd64 < none -> 4.0.0-1 @un uN > FU=0
  MarkInstall libboost-fiber-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-fiber1.71-dev as Depends of libboost-fiber-dev
    MarkInstall libboost-fiber1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
    Installing libboost-context1.71-dev as Depends of libboost-fiber1.71-dev
      MarkInstall libboost-context1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
      Installing libboost-thread1.71-dev as Depends of libboost-context1.71-dev
        MarkInstall libboost-thread1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
        Installing libboost-atomic1.71-dev as Depends of libboost-thread1.71-dev
          MarkInstall libboost-atomic1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
          Installing libboost-atomic1.71.0 as Depends of libboost-atomic1.71-dev
            MarkInstall libboost-atomic1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
           Removing: libboost-atomic1.65-dev
            MarkDelete libboost-atomic1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
        Installing libboost-date-time1.71-dev as Depends of libboost-thread1.71-dev
          MarkInstall libboost-date-time1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
          Installing libboost-date-time1.71.0 as Depends of libboost-date-time1.71-dev
            MarkInstall libboost-date-time1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
           Removing: libboost-date-time1.65-dev
            MarkDelete libboost-date-time1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
         Removing: libboost-thread1.65-dev
          MarkDelete libboost-thread1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
      Installing libboost-context1.71.0 as Depends of libboost-context1.71-dev
        MarkInstall libboost-context1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
       Removing: libboost-context1.65-dev
        MarkDelete libboost-context1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
    Installing libboost-fiber1.71.0 as Depends of libboost-fiber1.71-dev
      MarkInstall libboost-fiber1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
     Removing: libboost-fiber1.65-dev
      MarkDelete libboost-fiber1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
  MarkInstall libtext-bibtex-perl:amd64 < 0.85-1 -> 0.88-3build1 @ii umU Ib > FU=0
  Installing libbtparse2 as Depends of libtext-bibtex-perl
    MarkInstall libbtparse2:amd64 < none -> 0.88-3build1 @un uN > FU=0
  MarkInstall kde-cli-tools:amd64 < 4:5.12.8-0ubuntu0.1 -> 4:5.18.4.1-0ubuntu1 @ii umU Ib > FU=0
  Installing libkworkspace5-5 as Depends of kde-cli-tools
    MarkInstall libkworkspace5-5:amd64 < none -> 4:5.18.5-0ubuntu0.1 @un uN > FU=0
  MarkInstall gnome-control-center:amd64 < 1:3.28.2-0ubuntu0.18.04.6 -> 1:3.36.5-0ubuntu2 @ii umU Ib > FU=0
  Installing libgsound0 as Depends of gnome-control-center
    MarkInstall libgsound0:amd64 < none -> 1.0.2-4 @un uN > FU=0
  new important dependency: rygel:amd64
  Installing rygel as Recommends of gnome-control-center
    MarkInstall rygel:amd64 < none -> 0.38.3-1ubuntu1 @un uN Ib > FU=0
    Installing libgssdp-1.2-0 as Depends of rygel
      MarkInstall libgssdp-1.2-0:amd64 < none -> 1.2.3-0ubuntu0.20.04.1 @un uN > FU=0
    Installing libgupnp-1.2-0 as Depends of rygel
      MarkInstall libgupnp-1.2-0:amd64 < none -> 1.2.3-0ubuntu0.20.04.2 @un uN > FU=0
    Installing libgupnp-av-1.0-2 as Depends of rygel
      MarkInstall libgupnp-av-1.0-2:amd64 < none -> 0.12.11-2 @un uN > FU=0
    Installing libgupnp-dlna-2.0-3 as Depends of rygel
      MarkInstall libgupnp-dlna-2.0-3:amd64 < none -> 0.10.5-4 @un uN > FU=0
    Installing librygel-core-2.6-2 as Depends of rygel
      MarkInstall librygel-core-2.6-2:amd64 < none -> 0.38.3-1ubuntu1 @un uN > FU=0
    Installing librygel-db-2.6-2 as Depends of rygel
      MarkInstall librygel-db-2.6-2:amd64 < none -> 0.38.3-1ubuntu1 @un uN > FU=0
    Installing librygel-renderer-2.6-2 as Depends of rygel
      MarkInstall librygel-renderer-2.6-2:amd64 < none -> 0.38.3-1ubuntu1 @un uN > FU=0
    Installing librygel-server-2.6-2 as Depends of rygel
      MarkInstall librygel-server-2.6-2:amd64 < none -> 0.38.3-1ubuntu1 @un uN > FU=0
  MarkInstall libboost-iostreams-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-iostreams1.71-dev as Depends of libboost-iostreams-dev
    MarkInstall libboost-iostreams1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
    Installing libboost-regex1.71-dev as Depends of libboost-iostreams1.71-dev
      MarkInstall libboost-regex1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
      Installing libboost-regex1.71.0 as Depends of libboost-regex1.71-dev
        MarkInstall libboost-regex1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
       Removing: libboost-regex1.65-dev
        MarkDelete libboost-regex1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
    Installing libboost-iostreams1.71.0 as Depends of libboost-iostreams1.71-dev
      MarkInstall libboost-iostreams1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
     Removing: libboost-iostreams1.65-dev
      MarkDelete libboost-iostreams1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
  MarkInstall libevdocument3-4:amd64 < 3.28.4-0ubuntu1.2 -> 3.36.10-0ubuntu1 @ii umU Ib > FU=0
  Installing libsynctex2 as Depends of libevdocument3-4
    MarkInstall libsynctex2:amd64 < none -> 2019.20190605.51237-3build2 @un uN > FU=0
  MarkInstall linux-cloud-tools-generic:amd64 < 4.15.0.144.131 -> 5.4.0.74.77 @ii umU Ib > FU=0
  Installing linux-cloud-tools-5.4.0-74-generic as Depends of linux-cloud-tools-generic
    MarkInstall linux-cloud-tools-5.4.0-74-generic:amd64 < none -> 5.4.0-74.83 @un uN Ib > FU=0
    Installing linux-cloud-tools-5.4.0-74 as Depends of linux-cloud-tools-5.4.0-74-generic
      MarkInstall linux-cloud-tools-5.4.0-74:amd64 < none -> 5.4.0-74.83 @un uN > FU=0
  MarkInstall libnetcdf-c++4:amd64 < 4.2-8 -> 4.2-11build2 @ii umU Ib > FU=0
  Installing libnetcdf15 as Depends of libnetcdf-c++4
    MarkInstall libnetcdf15:amd64 < none -> 1:4.7.3-1 @un uN Ib > FU=0
    Installing libhdf5-103 as Depends of libnetcdf15
      MarkInstall libhdf5-103:amd64 < none -> 1.10.4+repack-11ubuntu1 @un uN Ib > FU=0
       Removing: libhdf5-100
        MarkDelete libhdf5-100:amd64 < 1.10.0-patch1+docs-4 @ii mK > FU=0
  MarkInstall libglew-dev:amd64 < 2.0.0-5 -> 2.1.0-4 @ii umU Ib > FU=0
  Installing libglew2.1 as Depends of libglew-dev
    MarkInstall libglew2.1:amd64 < none -> 2.1.0-4 @un uN > FU=0
  MarkInstall libgdal20:amd64 < 2.2.3+dfsg-2 @ii mK Ib > FU=0
  Installing libhdf5-100 as Depends of libgdal20
      MarkKeep libhdf5-100:amd64 < 1.10.0-patch1+docs-4 @ii mR > FU=0
  MarkInstall libhwloc-plugins:amd64 < 1.11.9-1 -> 2.1.0+dfsg-4 @ii umU Ib > FU=0
  Installing libhwloc15 as Depends of libhwloc-plugins
    MarkInstall libhwloc15:amd64 < none -> 2.1.0+dfsg-4 @un uN > FU=0
  MarkInstall libpam-modules:amd64 < 1.1.8-3.6ubuntu2.18.04.3 -> 1.3.1-5ubuntu4.2 @ii umU NPb IPb > FU=0
  ignore old unsatisfied important dependency on update-motd:amd64
  MarkInstall orage:amd64 < 4.12.1-4 -> 4.12.1-7 @ii umU Ib > FU=0
  Installing orage-data as Depends of orage
    MarkInstall orage-data:amd64 < none -> 4.12.1-7 @un uN > FU=0
  MarkInstall libopencv-calib3d-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Installing libopencv-calib3d4.2 as Depends of libopencv-calib3d-dev
    MarkInstall libopencv-calib3d4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
    Installing libopencv-features2d4.2 as Depends of libopencv-calib3d4.2
      MarkInstall libopencv-features2d4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
      Installing libopencv-flann4.2 as Depends of libopencv-features2d4.2
        MarkInstall libopencv-flann4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN > FU=0
      Installing libopencv-highgui4.2 as Depends of libopencv-features2d4.2
        MarkInstall libopencv-highgui4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
        Installing libopencv-videoio4.2 as Depends of libopencv-highgui4.2
          MarkInstall libopencv-videoio4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
          Installing libopencv-imgcodecs4.2 as Depends of libopencv-videoio4.2
            MarkInstall libopencv-imgcodecs4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
            Installing libopencv-imgproc4.2 as Depends of libopencv-imgcodecs4.2
              MarkInstall libopencv-imgproc4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN > FU=0
            Installing libgdal26 as Depends of libopencv-imgcodecs4.2
              MarkInstall libgdal26:amd64 < none -> 3.0.4+dfsg-1build3 @un uN Ib > FU=0
              Installing libarmadillo9 as Depends of libgdal26
                MarkInstall libarmadillo9:amd64 < none -> 1:9.800.4+dfsg-1build1 @un uN > FU=0
              Installing libcfitsio8 as Depends of libgdal26
                MarkInstall libcfitsio8:amd64 < none -> 3.470-3 @un uN > FU=0
              Installing libcharls2 as Depends of libgdal26
                MarkInstall libcharls2:amd64 < none -> 2.0.0+dfsg-1build1 @un uN > FU=0
              Installing libgeotiff5 as Depends of libgdal26
                MarkInstall libgeotiff5:amd64 < none -> 1.5.1-2 @un uN Ib > FU=0
                Installing libproj15 as Depends of libgeotiff5
                  MarkInstall libproj15:amd64 < none -> 6.3.1-1 @un uN > FU=0
              Installing libjson-c4 as Depends of libgdal26
                MarkInstall libjson-c4:amd64 < none -> 0.13.1+dfsg-7ubuntu0.3 @un uN > FU=0
              Installing libmysqlclient21 as Depends of libgdal26
                MarkInstall libmysqlclient21:amd64 < none -> 8.0.25-0ubuntu0.20.04.1 @un uN > FU=0
              Installing libogdi4.1 as Depends of libgdal26
                MarkInstall libogdi4.1:amd64 < none -> 4.1.0+ds-1build1 @un uN Ib > FU=0
                 Removing: libogdi3.2
                  MarkDelete libogdi3.2:amd64 < 3.2.0+ds-2 @ii mK > FU=0
            Installing libgdcm3.0 as Depends of libopencv-imgcodecs4.2
              MarkInstall libgdcm3.0:amd64 < none -> 3.0.5-1.1ubuntu2 @un uN > FU=0
            Installing libopenexr24 as Depends of libopencv-imgcodecs4.2
              MarkInstall libopenexr24:amd64 < none -> 2.3.0-6ubuntu0.5 @un uN Ib > FU=0
              Installing libilmbase24 as Depends of libopenexr24
                MarkInstall libilmbase24:amd64 < none -> 2.3.0-6build1 @un uN > FU=0
          Installing libavformat58 as Depends of libopencv-videoio4.2
            MarkInstall libavformat58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
          Installing libswscale5 as Depends of libopencv-videoio4.2
            MarkInstall libswscale5:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
      Installing libopencv-ml4.2 as Depends of libopencv-features2d4.2
        MarkInstall libopencv-ml4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN > FU=0
  MarkInstall libegl1-mesa-dev:amd64 < 20.0.8-0ubuntu1~18.04.1 -> 20.2.6-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libegl-dev as Depends of libegl1-mesa-dev
    MarkInstall libegl-dev:amd64 < none -> 1.3.2-1~ubuntu0.20.04.1 @un uN Ib > FU=0
    Installing libgl-dev as Depends of libegl-dev
      MarkInstall libgl-dev:amd64 < none -> 1.3.2-1~ubuntu0.20.04.1 @un uN Ib > FU=0
      Installing libglx-dev as Depends of libgl-dev
        MarkInstall libglx-dev:amd64 < none -> 1.3.2-1~ubuntu0.20.04.1 @un uN > FU=0
  MarkInstall sane-utils:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib > FU=0
  Installing libsane as Depends of sane-utils
    MarkInstall libsane:amd64 < none -> 1.0.29-0ubuntu5.2 @un uN Ib > FU=0
    Installing libsnmp35 as Depends of libsane
      MarkInstall libsnmp35:amd64 < none -> 5.8+dfsg-2ubuntu2.3 @un uN Ib > FU=0
      Installing libperl5.30 as Depends of libsnmp35
        MarkInstall libperl5.30:amd64 < none -> 5.30.0-9ubuntu0.2 @un uN Ib > FU=0
        Installing libgdbm6 as Depends of libperl5.30
          MarkInstall libgdbm6:amd64 < none -> 1.18.1-5 @un uN > FU=0
        Installing perl-modules-5.30 as Depends of libperl5.30
          MarkInstall perl-modules-5.30:amd64 < none -> 5.30.0-9ubuntu0.2 @un uN > FU=0
      Installing libsensors5 as Depends of libsnmp35
        MarkInstall libsensors5:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib > FU=0
        Installing libsensors-config as Depends of libsensors5
          MarkInstall libsensors-config:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib > FU=0
           Removing: libsensors4
            MarkDelete libsensors4:amd64 < 1:3.4.0-4 @ii mK > FU=0
           Removing: libsensors4
            MarkDelete libsensors4:i386 < 1:3.4.0-4 @ii mK > FU=0
  MarkInstall libcppunit-dev:amd64 < 1.14.0-3 -> 1.15.1-2build1 @ii umU Ib > FU=0
  Installing libcppunit-1.15-0 as Depends of libcppunit-dev
    MarkInstall libcppunit-1.15-0:amd64 < none -> 1.15.1-2build1 @un uN > FU=0
  MarkInstall libc6-dev:amd64 < 2.27-3ubuntu1.4 -> 2.31-0ubuntu9.2 @ii umU Ib > FU=0
  Installing libcrypt-dev as Depends of libc6-dev
    MarkInstall libcrypt-dev:amd64 < none -> 1:4.4.10-10ubuntu4 @un uN > FU=0
  MarkInstall libargon2-0:amd64 < 0~20161029-1.1 -> 0~20171227-0.2 @ii umU Ib > FU=0
  Installing libargon2-1 as Depends of libargon2-0
    MarkInstall libargon2-1:amd64 < none -> 0~20171227-0.2 @un uN > FU=0
  MarkInstall joystick:amd64 < 1:1.6.0-2 -> 1:1.7.0-1 @ii umU Ib > FU=0
  Installing libsdl2-2.0-0 as Depends of joystick
    MarkInstall libsdl2-2.0-0:amd64 < none -> 2.0.10+dfsg1-3 @un uN > FU=0
  MarkInstall libopenal1:amd64 < 1:1.18.2-2 -> 1:1.19.1-1 @ii umU Ib > FU=0
  Installing libsndio7.0 as Depends of libopenal1
    MarkInstall libsndio7.0:amd64 < none -> 1.5.0-3 @un uN > FU=0
  MarkInstall libopenal1:i386 < 1:1.18.2-2 -> 1:1.19.1-1 @ii umU Ib > FU=0
  Installing libsndio7.0 as Depends of libopenal1
    MarkInstall libsndio7.0:i386 < none -> 1.5.0-3 @un uN > FU=0
  MarkInstall va-driver-all:amd64 < 2.1.0-3 -> 2.7.0-2 @ii umU Ib > FU=0
  Installing intel-media-va-driver as Depends of va-driver-all
    MarkInstall intel-media-va-driver:amd64 < none -> 20.1.1+dfsg1-1 @un uN Ib > FU=0
    Installing libigdgmm11 as Depends of intel-media-va-driver
      MarkInstall libigdgmm11:amd64 < none -> 20.1.1+ds1-1 @un uN > FU=0
  MarkInstall vino:amd64 < 3.22.0-3ubuntu1.2 -> 3.22.0-5ubuntu2.2 @ii umU Ib > FU=0
  Installing libminiupnpc17 as Depends of vino
    MarkInstall libminiupnpc17:amd64 < none -> 2.1.20190824-0ubuntu2 @un uN > FU=0
  MarkInstall libfreeimage3:amd64 < 3.17.0+ds1-5+deb9u1build0.18.04.1 -> 3.18.0+ds2-1ubuntu3 @ii umU Ib > FU=0
  Installing libraw19 as Depends of libfreeimage3
    MarkInstall libraw19:amd64 < none -> 0.19.5-1ubuntu1 @un uN > FU=0
  MarkInstall ntfs-3g:amd64 < 1:2017.3.23-2ubuntu0.18.04.2 -> 1:2017.3.23AR.3-3ubuntu1 @ii umU Ib > FU=0
  Installing libntfs-3g883 as Depends of ntfs-3g
    MarkInstall libntfs-3g883:amd64 < none -> 1:2017.3.23AR.3-3ubuntu1 @un uN > FU=0
  MarkInstall libgeos-c1v5:amd64 < 3.6.2-1build2 -> 3.8.0-1build1 @ii umU Ib > FU=0
  Installing libgeos-3.8.0 as Depends of libgeos-c1v5
    MarkInstall libgeos-3.8.0:amd64 < none -> 3.8.0-1build1 @un uN > FU=0
  MarkInstall libopencv-shape-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Installing libopencv-shape4.2 as Depends of libopencv-shape-dev
    MarkInstall libopencv-shape4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
    Installing libopencv-video4.2 as Depends of libopencv-shape4.2
      MarkInstall libopencv-video4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN > FU=0
  MarkInstall fonts-smc:amd64 < 1:7.0 -> 1:7.1 @ii umU Ib > FU=0
  Installing fonts-smc-gayathri as Depends of fonts-smc
    MarkInstall fonts-smc-gayathri:amd64 < none -> 1.100-1 @un uN > FU=0
  MarkInstall linux-image-generic:amd64 < 4.15.0.144.131 -> 5.4.0.74.77 @ii umU NPb Ib > FU=0
  Installing linux-image-5.4.0-74-generic as Depends of linux-image-generic
    MarkInstall linux-image-5.4.0-74-generic:amd64 < none -> 5.4.0-74.83 @un uN Ib > FU=0
    Installing linux-modules-5.4.0-74-generic as Depends of linux-image-5.4.0-74-generic
      MarkInstall linux-modules-5.4.0-74-generic:amd64 < none -> 5.4.0-74.83 @un uN > FU=0
  Installing linux-modules-extra-5.4.0-74-generic as Depends of linux-image-generic
    MarkInstall linux-modules-extra-5.4.0-74-generic:amd64 < none -> 5.4.0-74.83 @un uN > FU=0
  ignore old unsatisfied important dependency on thermald:amd64
  MarkInstall apt:amd64 < 1.6.13 -> 2.0.5 @ii umU Ib > FU=0
  Installing libapt-pkg6.0 as Depends of apt
    MarkInstall libapt-pkg6.0:amd64 < none -> 2.0.5 @un uN > FU=0
  MarkInstall libboost-container-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-container1.71-dev as Depends of libboost-container-dev
    MarkInstall libboost-container1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
    Installing libboost-container1.71.0 as Depends of libboost-container1.71-dev
      MarkInstall libboost-container1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
     Removing: libboost-container1.65-dev
      MarkDelete libboost-container1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
  MarkInstall libgjs0g:amd64 < 1.52.5-0ubuntu18.04.1 -> 1.64.5-0ubuntu0.20.04.01 @ii umU Ib > FU=0
  Installing libmozjs-68-0 as Depends of libgjs0g
    MarkInstall libmozjs-68-0:amd64 < none -> 68.6.0-1ubuntu1 @un uN > FU=0
  MarkInstall libreoffice-core:amd64 < 1:6.0.7-0ubuntu0.18.04.10 -> 1:6.4.7-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libboost-locale1.71.0 as Depends of libreoffice-core
    MarkInstall libboost-locale1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
  Installing liborcus-0.15-0 as Depends of libreoffice-core
    MarkInstall liborcus-0.15-0:amd64 < none -> 0.15.3-3build2 @un uN > FU=0
    MarkKeep libboost-numpy1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall cpp-7:amd64 < 7.5.0-3ubuntu1~18.04 -> 7.5.0-6ubuntu2 @ii umU Ib > FU=0
  Installing libisl22 as Depends of cpp-7
    MarkInstall libisl22:amd64 < none -> 0.22.1-1 @un uN > FU=0
  MarkInstall libtext-csv-xs-perl:amd64 < 1.34-1 -> 1.41-1 @ii umU Ib > FU=0
  Installing libencode-perl as Depends of libtext-csv-xs-perl
    MarkInstall libencode-perl:amd64 < none -> 3.02-1 @un uN > FU=0
  MarkInstall yelp:amd64 < 3.26.0-1ubuntu2 -> 3.36.2-0ubuntu1 @ii umU IPb > FU=0
  new important dependency: docbook-xml:amd64
  Installing docbook-xml as Recommends of yelp
    MarkInstall docbook-xml:amd64 < none -> 4.5-9 @un uN Ib > FU=0
    Installing sgml-data as Depends of docbook-xml
      MarkInstall sgml-data:amd64 < none -> 2.0.11 @un uN > FU=0
  MarkInstall vim-gtk:amd64 < 2:8.0.1453-1ubuntu1.4 -> 2:8.1.2269-1ubuntu5 @ii umU Ib > FU=0
  Installing vim-gtk3 as Depends of vim-gtk
    MarkInstall vim-gtk3:amd64 < none -> 2:8.1.2269-1ubuntu5 @un uN > FU=0
  MarkInstall libasound2-data:amd64 < 1.1.3-5ubuntu0.5 -> 1.2.2-2.1ubuntu2.4 @ii umU IPb > FU=0
  new important dependency: alsa-ucm-conf:amd64
  Installing alsa-ucm-conf as Recommends of libasound2-data
    MarkInstall alsa-ucm-conf:amd64 < none -> 1.2.2-1ubuntu0.7 @un uN > FU=0
  new important dependency: alsa-topology-conf:amd64
  Installing alsa-topology-conf as Recommends of libasound2-data
    MarkInstall alsa-topology-conf:amd64 < none -> 1.2.2-1 @un uN > FU=0
  MarkInstall bzr:amd64 < 2.7.0+bzr6622-10 -> 2.7.0+bzr6622+brz @ii umU Ib > FU=0
  Installing brz as Depends of bzr
    MarkInstall brz:amd64 < none -> 3.0.2-4ubuntu2 @un uN Ib > FU=0
    Installing python3-breezy as Depends of brz
      MarkInstall python3-breezy:amd64 < none -> 3.0.2-4ubuntu2 @un uN Ib > FU=0
      Installing python3-configobj as Depends of python3-breezy
        MarkInstall python3-configobj:amd64 < none -> 5.0.6-4 @un uN > FU=0
      Installing python3-dulwich as Depends of python3-breezy
        MarkInstall python3-dulwich:amd64 < none -> 0.19.15-1build1 @un uN IPb > FU=0
        Installing python3-fastimport as Recommends of python3-dulwich
          MarkInstall python3-fastimport:amd64 < none -> 0.9.8-5build1 @un uN > FU=0
      Installing python3-github as Recommends of python3-breezy
        MarkInstall python3-github:amd64 < none -> 1.43.7-1 @un uN Ib > FU=0
        Installing python3-deprecated as Depends of python3-github
          MarkInstall python3-deprecated:amd64 < none -> 1.2.7-1 @un uN Ib > FU=0
          Installing python3-wrapt as Depends of python3-deprecated
            MarkInstall python3-wrapt:amd64 < none -> 1.11.2-2build1 @un uN > FU=0
        Installing python3-jwt as Depends of python3-github
          MarkInstall python3-jwt:amd64 < none -> 1.7.1-2ubuntu2 @un uN > FU=0
      Installing python3-gitlab as Recommends of python3-breezy
        MarkInstall python3-gitlab:amd64 < none -> 1:2.0.1-1 @un uN > FU=0
      Installing python3-gpg as Recommends of python3-breezy
        MarkInstall python3-gpg:amd64 < none -> 1.13.1-7ubuntu2 @un uN > FU=0
  MarkInstall python3-protobuf:amd64 < 3.0.0-9.1ubuntu1 -> 3.6.1.3-2ubuntu5 @ii umU Ib > FU=0
  Installing libprotobuf17 as Depends of python3-protobuf
    MarkInstall libprotobuf17:amd64 < none -> 3.6.1.3-2ubuntu5 @un uN > FU=0
  MarkInstall cpp:amd64 < 4:7.4.0-1ubuntu2.3 -> 4:9.3.0-1ubuntu2 @ii umU Ib > FU=0
  Installing cpp-9 as Depends of cpp
    MarkInstall cpp-9:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN Ib > FU=0
    Installing gcc-9-base as Depends of cpp-9
      MarkInstall gcc-9-base:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN > FU=0
  MarkInstall libgpg-error0:amd64 < 1.27-6 -> 1.37-1 @ii umU IPb > FU=0
  new important dependency: libgpg-error-l10n:amd64
  Installing libgpg-error-l10n as Recommends of libgpg-error0
    MarkInstall libgpg-error-l10n:amd64 < none -> 1.37-1 @un uN > FU=0
  MarkInstall libboost-graph1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
  Installing libboost-serialization1.65-dev as Depends of libboost-graph1.65-dev
      MarkKeep libboost-serialization1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall bind9-host:amd64 < 1:9.11.3+dfsg-1ubuntu1.15 -> 1:9.16.1-0ubuntu2.8 @ii umU Ib > FU=0
  Installing bind9-libs as Depends of bind9-host
    MarkInstall bind9-libs:amd64 < none -> 1:9.16.1-0ubuntu2.8 @un uN Ib > FU=0
    Installing liblmdb0 as Depends of bind9-libs
      MarkInstall liblmdb0:amd64 < none -> 0.9.24-1 @un uN > FU=0
  MarkInstall libarchive13:amd64 < 3.2.2-3.1ubuntu0.7 -> 3.4.0-2ubuntu1 @ii umU Ib > FU=0
  Installing libnettle7 as Depends of libarchive13
    MarkInstall libnettle7:amd64 < none -> 3.5.1+really3.5.1-2ubuntu0.1 @un uN > FU=0
  MarkInstall e2fsprogs:amd64 < 1.44.1-1ubuntu1.3 -> 1.45.5-2ubuntu1 @ii umU NPb Ib > FU=0
  Installing logsave as Depends of e2fsprogs
    MarkInstall logsave:amd64 < none -> 1.45.5-2ubuntu1 @un uN > FU=0
  ignore old unsatisfied important dependency on e2fsprogs-l10n:amd64
  MarkInstall libboost-mpi-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-mpi1.71-dev as Depends of libboost-mpi-dev
    MarkInstall libboost-mpi1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
    Installing libboost-mpi1.71.0 as Depends of libboost-mpi1.71-dev
      MarkInstall libboost-mpi1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
      Installing libopenmpi3 as Depends of libboost-mpi1.71.0
        MarkInstall libopenmpi3:amd64 < none -> 4.0.3-0ubuntu1 @un uN Ib > FU=0
        Installing libevent-2.1-7 as Depends of libopenmpi3
          MarkInstall libevent-2.1-7:amd64 < none -> 2.1.11-stable-1 @un uN > FU=0
        Installing libevent-pthreads-2.1-7 as Depends of libopenmpi3
          MarkInstall libevent-pthreads-2.1-7:amd64 < none -> 2.1.11-stable-1 @un uN Ib > FU=0
          Installing libevent-core-2.1-7 as Depends of libevent-pthreads-2.1-7
            MarkInstall libevent-core-2.1-7:amd64 < none -> 2.1.11-stable-1 @un uN > FU=0
        Installing libpmix2 as Depends of libopenmpi3
          MarkInstall libpmix2:amd64 < none -> 3.1.5-1 @un uN > FU=0
        Installing libpsm2-2 as Depends of libopenmpi3
          MarkInstall libpsm2-2:amd64 < none -> 11.2.86-1 @un uN > FU=0
     Removing: libboost-mpi1.65-dev
      MarkDelete libboost-mpi1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
  MarkInstall libjq1:amd64 < 1.5+dfsg-2 -> 1.6-1ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libonig5 as Depends of libjq1
    MarkInstall libonig5:amd64 < none -> 6.9.4-1 @un uN > FU=0
  MarkInstall dnsutils:amd64 < 1:9.11.3+dfsg-1ubuntu1.15 -> 1:9.16.1-0ubuntu2.8 @ii umU Ib > FU=0
  Installing bind9-dnsutils as Depends of dnsutils
    MarkInstall bind9-dnsutils:amd64 < none -> 1:9.16.1-0ubuntu2.8 @un uN > FU=0
    MarkKeep libboost-math1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall libboost-log-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-log1.71-dev as Depends of libboost-log-dev
    MarkInstall libboost-log1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
    Installing libboost-log1.71.0 as Depends of libboost-log1.71-dev
      MarkInstall libboost-log1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
     Removing: libboost-log1.65-dev
      MarkDelete libboost-log1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
  MarkInstall g++:amd64 < 4:7.4.0-1ubuntu2.3 -> 4:9.3.0-1ubuntu2 @ii umU Ib > FU=0
  Installing g++-9 as Depends of g++
    MarkInstall g++-9:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN Ib > FU=0
    Installing gcc-9 as Depends of g++-9
      MarkInstall gcc-9:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN Ib > FU=0
      Installing libgcc-9-dev as Depends of gcc-9
        MarkInstall libgcc-9-dev:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN Ib > FU=0
        Installing libasan5 as Depends of libgcc-9-dev
          MarkInstall libasan5:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN > FU=0
        Installing libubsan1 as Depends of libgcc-9-dev
          MarkInstall libubsan1:amd64 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
    Installing libstdc++-9-dev as Depends of g++-9
      MarkInstall libstdc++-9-dev:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN > FU=0
  MarkInstall eog:amd64 < 3.28.1-1 -> 3.36.3-0ubuntu1 @ii umU Ib > FU=0
  Installing libexempi8 as Depends of eog
    MarkInstall libexempi8:amd64 < none -> 2.5.1-1build1 @un uN > FU=0
  MarkInstall gfortran:amd64 < 4:7.4.0-1ubuntu2.3 -> 4:9.3.0-1ubuntu2 @ii umU Ib > FU=0
  Installing gfortran-9 as Depends of gfortran
    MarkInstall gfortran-9:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN Ib > FU=0
    Installing libgfortran-9-dev as Depends of gfortran-9
      MarkInstall libgfortran-9-dev:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN > FU=0
  MarkInstall libspecio-perl:amd64 < 0.42-1 -> 0.45-1 @ii umU Ib > FU=0
  Installing libxstring-perl as Depends of libspecio-perl
    MarkInstall libxstring-perl:amd64 < none -> 0.002-2 @un uN > FU=0
  MarkInstall libassimp-dev:amd64 < 4.1.0~dfsg-3 -> 5.0.1~ds0-1build1 @ii umU Ib > FU=0
  Installing libassimp5 as Depends of libassimp-dev
    MarkInstall libassimp5:amd64 < none -> 5.0.1~ds0-1build1 @un uN > FU=0
  MarkInstall libopencv-imgcodecs-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Installing libgdcm-dev as Depends of libopencv-imgcodecs-dev
    MarkInstall libgdcm-dev:amd64 < none -> 3.0.5-1.1ubuntu2 @un uN Ib > FU=0
     Removing: libgdcm2-dev
      MarkDelete libgdcm2-dev:amd64 < 2.8.4-1build2 @ii mK > FU=0
  MarkInstall libboost-coroutine1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
  Installing libboost-context1.65-dev as Depends of libboost-coroutine1.65-dev
      MarkKeep libboost-context1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall dnsmasq-base:amd64 < 2.79-1ubuntu0.4 -> 2.80-1.1ubuntu1.4 @ii umU Ib > FU=0
  Installing libhogweed5 as Depends of dnsmasq-base
    MarkInstall libhogweed5:amd64 < none -> 3.5.1+really3.5.1-2ubuntu0.1 @un uN > FU=0
  MarkInstall libopenconnect5:amd64 < 7.08-3ubuntu0.18.04.2 -> 8.05-1 @ii umU Ib > FU=0
  Installing libtss2-esys0 as Depends of libopenconnect5
    MarkInstall libtss2-esys0:amd64 < none -> 2.3.2-1 @un uN Ib > FU=0
    Installing tpm-udev as Depends of libtss2-esys0
      MarkInstall tpm-udev:amd64 < none -> 0.4 @un uN > FU=0
  MarkInstall python3-brlapi:amd64 < 5.5-4ubuntu2.0.1 -> 6.0+dfsg-4ubuntu6 @ii umU Ib > FU=0
  Installing libbrlapi0.7 as Depends of python3-brlapi
    MarkInstall libbrlapi0.7:amd64 < none -> 6.0+dfsg-4ubuntu6 @un uN > FU=0
  MarkInstall python3-pil:amd64 < 5.1.0-1ubuntu0.6 -> 7.0.0-4ubuntu0.4 @ii umU Ib > FU=0
  Installing libimagequant0 as Depends of python3-pil
    MarkInstall libimagequant0:amd64 < none -> 2.12.2-1.1 @un uN > FU=0
  MarkInstall python3-keyring:amd64 < 10.6.0-1 -> 18.0.1-2ubuntu1 @ii umU Ib > FU=0
  Installing python3-entrypoints as Depends of python3-keyring
    MarkInstall python3-entrypoints:amd64 < none -> 0.3-2ubuntu1 @un uN > FU=0
  MarkInstall libc6:i386 < 2.27-3ubuntu1.4 -> 2.31-0ubuntu9.2 @ii umU Ib > FU=0
  Installing libgcc-s1 as Depends of libc6
    MarkInstall libgcc-s1:i386 < none -> 10.2.0-5ubuntu1~20.04 @un uN Ib > FU=0
    Installing gcc-10-base as Depends of libgcc-s1
      MarkInstall gcc-10-base:i386 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
  Installing libcrypt1 as Depends of libc6
    MarkInstall libcrypt1:i386 < none -> 1:4.4.10-10ubuntu4 @un uN > FU=0
  MarkInstall ubuntu-session:amd64 < 3.28.1-0ubuntu3 -> 3.36.0-2ubuntu1 @ii umU Ib > FU=0
  Installing yaru-theme-gnome-shell as Depends of ubuntu-session
    MarkInstall yaru-theme-gnome-shell:amd64 < none -> 20.04.10.1 @un uN > FU=0
  MarkInstall xfce4-settings:amd64 < 4.12.4-0ubuntu0.18.04.1 -> 4.14.3-0ubuntu1 @ii umU IPb > FU=0
  new important dependency: xiccd:amd64
  Installing xiccd as Recommends of xfce4-settings
    MarkInstall xiccd:amd64 < none -> 0.3.0-1 @un uN > FU=0
  MarkInstall libnet-dns-perl:amd64 < 1.10-2 -> 1.22-1 @ii umU IPb > FU=0
  new important dependency: libdigest-bubblebabble-perl:amd64
  Installing libdigest-bubblebabble-perl as Recommends of libnet-dns-perl
    MarkInstall libdigest-bubblebabble-perl:amd64 < none -> 0.02-2 @un uN > FU=0
  new important dependency: libnet-dns-sec-perl:amd64
  Installing libnet-dns-sec-perl as Recommends of libnet-dns-perl
    MarkInstall libnet-dns-sec-perl:amd64 < none -> 1.15-1 @un uN > FU=0
  new important dependency: libperl4-corelibs-perl:amd64
  Installing libperl4-corelibs-perl as Recommends of libnet-dns-perl
    MarkInstall libperl4-corelibs-perl:amd64 < none -> 0.004-2 @un uN > FU=0
  MarkInstall ubuntu-desktop:amd64 < 1.417.5 -> 1.450.2 @ii umU Ib > FU=0
  Installing gnome-shell-extension-desktop-icons as Depends of ubuntu-desktop
    MarkInstall gnome-shell-extension-desktop-icons:amd64 < none -> 20.04.0-3~ubuntu20.04.1 @un uN > FU=0
  Installing ubuntu-desktop-minimal as Depends of ubuntu-desktop
    MarkInstall ubuntu-desktop-minimal:amd64 < none -> 1.450.2 @un uN IPb > FU=0
    Installing apt-config-icons-hidpi as Recommends of ubuntu-desktop-minimal
      MarkInstall apt-config-icons-hidpi:amd64 < none -> 0.12.10-2 @un uN > FU=0
    Installing gamemode as Recommends of ubuntu-desktop-minimal
      MarkInstall gamemode:amd64 < none -> 1.5.1-0ubuntu3.1 @un uN Ib > FU=0
      Installing libgamemode0 as Depends of gamemode
        MarkInstall libgamemode0:amd64 < none -> 1.5.1-0ubuntu3.1 @un uN > FU=0
      Installing libgamemodeauto0 as Depends of gamemode
        MarkInstall libgamemodeauto0:amd64 < none -> 1.5.1-0ubuntu3.1 @un uN > FU=0
    Installing gnome-calculator as Recommends of ubuntu-desktop-minimal
      MarkInstall gnome-calculator:amd64 < none -> 1:3.36.0-1ubuntu1 @un uN > FU=0
    Installing gnome-characters as Recommends of ubuntu-desktop-minimal
      MarkInstall gnome-characters:amd64 < none -> 3.34.0-1 @un uN > FU=0
    Installing gnome-logs as Recommends of ubuntu-desktop-minimal
      MarkInstall gnome-logs:amd64 < none -> 3.34.0-1ubuntu1 @un uN > FU=0
    Installing gnome-system-monitor as Recommends of ubuntu-desktop-minimal
      MarkInstall gnome-system-monitor:amd64 < none -> 3.36.1-0ubuntu0.20.04.1 @un uN > FU=0
    Installing network-manager-openvpn-gnome as Recommends of ubuntu-desktop-minimal
      MarkInstall network-manager-openvpn-gnome:amd64 < none -> 1.8.12-1 @un uN Ib > FU=0
      Installing network-manager-openvpn as Depends of network-manager-openvpn-gnome
        MarkInstall network-manager-openvpn:amd64 < none -> 1.8.12-1 @un uN Ib > FU=0
        Installing openvpn as Depends of network-manager-openvpn
          MarkInstall openvpn:amd64 < none -> 2.4.7-1ubuntu2.20.04.2 @un uN Ib > FU=0
          Installing libpkcs11-helper1 as Depends of openvpn
            MarkInstall libpkcs11-helper1:amd64 < none -> 1.26-1 @un uN > FU=0
    Installing plymouth-theme-spinner as Recommends of ubuntu-desktop-minimal
      MarkInstall plymouth-theme-spinner:amd64 < none -> 0.9.4git20200323-0ubuntu6.2 @un uN Ib > FU=0
      Installing libplymouth5 as Depends of plymouth-theme-spinner
        MarkInstall libplymouth5:amd64 < none -> 0.9.4git20200323-0ubuntu6.2 @un uN > FU=0
    Installing yaru-theme-gtk as Recommends of ubuntu-desktop-minimal
      MarkInstall yaru-theme-gtk:amd64 < none -> 20.04.10.1 @un uN > FU=0
    Installing yaru-theme-icon as Recommends of ubuntu-desktop-minimal
      MarkInstall yaru-theme-icon:amd64 < none -> 20.04.10.1 @un uN > FU=0
    Installing yaru-theme-sound as Recommends of ubuntu-desktop-minimal
      MarkInstall yaru-theme-sound:amd64 < none -> 20.04.10.1 @un uN > FU=0
  MarkInstall dmeventd:amd64 < 2:1.02.145-4.1ubuntu3.18.04.3 -> 2:1.02.167-1ubuntu1 @ii umU Ib > FU=0
  Installing liblvm2cmd2.03 as Depends of dmeventd
    MarkInstall liblvm2cmd2.03:amd64 < none -> 2.03.07-1ubuntu1 @un uN Ib > FU=0
    Installing libaio1 as Depends of liblvm2cmd2.03
      MarkInstall libaio1:amd64 < none -> 0.3.112-5 @un uN > FU=0
  MarkInstall libxatracker2:amd64 < 20.0.8-0ubuntu1~18.04.1 -> 20.2.6-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libllvm11 as Depends of libxatracker2
    MarkInstall libllvm11:amd64 < none -> 1:11.0.0-2~ubuntu20.04.1 @un uN > FU=0
  MarkInstall python3-louis:amd64 < 3.5.0-1ubuntu0.3 -> 3.12.0-3 @ii umU Ib > FU=0
  Installing liblouis20 as Depends of python3-louis
    MarkInstall liblouis20:amd64 < none -> 3.12.0-3 @un uN > FU=0
  MarkInstall opam:amd64 < 1.2.2-6 -> 2.0.5-1ubuntu1 @ii umU Ib > FU=0
  Installing libglpk40 as Depends of opam
    MarkInstall libglpk40:amd64 < none -> 4.65-2 @un uN > FU=0
  Installing opam-installer as Depends of opam
    MarkInstall opam-installer:amd64 < none -> 2.0.5-1ubuntu1 @un uN Ib > FU=0
     Removing: opam-docs
      MarkDelete opam-docs:amd64 < 1.2.2-6 @ii mK > FU=0
  Installing opam-doc as Depends of opam
    MarkInstall opam-doc:amd64 < none -> 2.0.5-1ubuntu1 @un uN > FU=0
  MarkInstall lvm2:amd64 < 2.02.176-4.1ubuntu3.18.04.3 -> 2.03.07-1ubuntu1 @ii umU IPb > FU=0
  new important dependency: thin-provisioning-tools:amd64
  Installing thin-provisioning-tools as Recommends of lvm2
    MarkInstall thin-provisioning-tools:amd64 < none -> 0.8.5-4build1 @un uN > FU=0
  MarkInstall sysdig:amd64 < 0.24.1-1ubuntu4~18.04.1 -> 0.26.4-1ubuntu0.3 @ii umU Ib > FU=0
  Installing libgrpc++1 as Depends of sysdig
    MarkInstall libgrpc++1:amd64 < none -> 1.16.1-1ubuntu5 @un uN Ib > FU=0
    Installing libgrpc6 as Depends of libgrpc++1
      MarkInstall libgrpc6:amd64 < none -> 1.16.1-1ubuntu5 @un uN > FU=0
  MarkInstall libboost-random-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-random1.71-dev as Depends of libboost-random-dev
    MarkInstall libboost-random1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
    Installing libboost-random1.71.0 as Depends of libboost-random1.71-dev
      MarkInstall libboost-random1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
     Removing: libboost-random1.65-dev
      MarkDelete libboost-random1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
  MarkInstall kile:amd64 < 4:2.9.91-4 -> 4:2.9.93-1build1 @ii umU NPb Ib > FU=0
  Installing okular as Depends of kile
    MarkInstall okular:amd64 < none -> 4:19.12.3-2ubuntu1 @rc uN Ib > FU=0
    Installing libkf5kexiv2-15.0.0 as Depends of okular
      MarkInstall libkf5kexiv2-15.0.0:amd64 < none -> 19.12.3-0ubuntu1 @un uN Ib > FU=0
      Installing libexiv2-27 as Depends of libkf5kexiv2-15.0.0
        MarkInstall libexiv2-27:amd64 < none -> 0.27.2-8ubuntu2.4 @un uN > FU=0
    Installing libkf5purpose-bin as Depends of okular
      MarkInstall libkf5purpose-bin:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
      Installing libkaccounts1 as Depends of libkf5purpose-bin
        MarkInstall libkaccounts1:amd64 < none -> 4:19.12.3-0ubuntu1 @un uN Ib > FU=0
        Installing libaccounts-qt5-1 as Depends of libkaccounts1
          MarkInstall libaccounts-qt5-1:amd64 < none -> 1.15+17.04.20161104.1-0ubuntu3 @un uN Ib > FU=0
          Installing libaccounts-glib0 as Depends of libaccounts-qt5-1
            MarkInstall libaccounts-glib0:amd64 < none -> 1.23+17.04.20161104-0ubuntu3 @un uN > FU=0
        Installing libsignon-qt5-1 as Depends of libkaccounts1
          MarkInstall libsignon-qt5-1:amd64 < none -> 8.59+17.10.20170606-0ubuntu2.20.04.1 @un uN > FU=0
        Installing kaccounts-providers as Recommends of libkaccounts1
          MarkInstall kaccounts-providers:amd64 < none -> 4:19.12.3-0ubuntu1 @rc uN Ib > FU=0
          Installing plasma-framework as Depends of kaccounts-providers
            MarkInstall plasma-framework:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
            Installing qml-module-org-kde-kconfig as Depends of plasma-framework
              MarkInstall qml-module-org-kde-kconfig:amd64 < none -> 5.68.0-0ubuntu2 @un uN > FU=0
            Installing qml-module-org-kde-kirigami2 as Depends of plasma-framework
              MarkInstall qml-module-org-kde-kirigami2:amd64 < none -> 5.68.0-0ubuntu2 @un uN Ib > FU=0
              Installing libkf5kirigami2-5 as Depends of qml-module-org-kde-kirigami2
                MarkInstall libkf5kirigami2-5:amd64 < none -> 5.68.0-0ubuntu2 @un uN Ib > FU=0
                Installing libqt5quickcontrols2-5 as Depends of libkf5kirigami2-5
                  MarkInstall libqt5quickcontrols2-5:amd64 < none -> 5.12.8+dfsg-0ubuntu1 @un uN Ib > FU=0
                  Installing libqt5quicktemplates2-5 as Depends of libqt5quickcontrols2-5
                    MarkInstall libqt5quicktemplates2-5:amd64 < none -> 5.12.8+dfsg-0ubuntu1 @un uN > FU=0
              Installing qml-module-org-kde-kquickcontrolsaddons as Depends of qml-module-org-kde-kirigami2
                MarkInstall qml-module-org-kde-kquickcontrolsaddons:amd64 < none -> 5.68.0-0ubuntu2 @un uN > FU=0
              Installing qml-module-qtgraphicaleffects as Depends of qml-module-org-kde-kirigami2
                MarkInstall qml-module-qtgraphicaleffects:amd64 < none -> 5.12.8-0ubuntu1 @un uN Ib > FU=0
                Installing qml-module-qtquick-window2 as Depends of qml-module-qtgraphicaleffects
                  MarkInstall qml-module-qtquick-window2:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
                Installing qml-module-qtquick2 as Depends of qml-module-qtgraphicaleffects
                  MarkInstall qml-module-qtquick2:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
              Installing qml-module-qtqml-models2 as Depends of qml-module-org-kde-kirigami2
                MarkInstall qml-module-qtqml-models2:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
              Installing qml-module-qtquick-controls2 as Depends of qml-module-org-kde-kirigami2
                MarkInstall qml-module-qtquick-controls2:amd64 < none -> 5.12.8+dfsg-0ubuntu1 @un uN Ib > FU=0
                Installing qml-module-qtquick-templates2 as Depends of qml-module-qtquick-controls2
                  MarkInstall qml-module-qtquick-templates2:amd64 < none -> 5.12.8+dfsg-0ubuntu1 @un uN > FU=0
            Installing qml-module-org-kde-kquickcontrols as Depends of plasma-framework
              MarkInstall qml-module-org-kde-kquickcontrols:amd64 < none -> 5.68.0-0ubuntu2 @un uN Ib > FU=0
              Installing qml-module-qtquick-controls as Depends of qml-module-org-kde-kquickcontrols
                MarkInstall qml-module-qtquick-controls:amd64 < none -> 5.12.8-0ubuntu2 @un uN Ib > FU=0
                Installing qml-module-qtquick-layouts as Depends of qml-module-qtquick-controls
                  MarkInstall qml-module-qtquick-layouts:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
              Installing qml-module-qtquick-dialogs as Depends of qml-module-org-kde-kquickcontrols
                MarkInstall qml-module-qtquick-dialogs:amd64 < none -> 5.12.8-0ubuntu2 @un uN Ib > FU=0
                Installing qml-module-qtquick-privatewidgets as Depends of qml-module-qtquick-dialogs
                  MarkInstall qml-module-qtquick-privatewidgets:amd64 < none -> 5.12.8-0ubuntu2 @un uN > FU=0
            Installing libkf5calendarevents5 as Depends of plasma-framework
              MarkInstall libkf5calendarevents5:amd64 < none -> 5.68.0-0ubuntu2 @un uN > FU=0
            Installing libkf5plasma5 as Depends of plasma-framework
              MarkInstall libkf5plasma5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
            Installing libkf5plasmaquick5 as Depends of plasma-framework
              MarkInstall libkf5plasmaquick5:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
              Installing libkf5waylandclient5 as Depends of libkf5plasmaquick5
                MarkInstall libkf5waylandclient5:amd64 < none -> 4:5.68.0-0ubuntu1 @un uN Ib > FU=0
                Installing kwayland-data as Depends of libkf5waylandclient5
                  MarkInstall kwayland-data:amd64 < none -> 4:5.68.0-0ubuntu1 @rc uN > FU=0
            Installing libxcb-composite0 as Depends of plasma-framework
              MarkInstall libxcb-composite0:amd64 < none -> 1.14-2 @un uN > FU=0
            Installing libxcb-damage0 as Depends of plasma-framework
              MarkInstall libxcb-damage0:amd64 < none -> 1.14-2 @un uN > FU=0
          Installing signon-plugin-oauth2 as Depends of kaccounts-providers
            MarkInstall signon-plugin-oauth2:amd64 < none -> 0.24+16.10.20160818-0ubuntu2 @un uN Ib > FU=0
            Installing libsignon-plugins-common1 as Depends of signon-plugin-oauth2
              MarkInstall libsignon-plugins-common1:amd64 < none -> 8.59+17.10.20170606-0ubuntu2.20.04.1 @un uN > FU=0
      Installing qml-module-org-kde-bluezqt as Depends of libkf5purpose-bin
        MarkInstall qml-module-org-kde-bluezqt:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
        Installing libkf5bluezqt6 as Depends of qml-module-org-kde-bluezqt
          MarkInstall libkf5bluezqt6:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
          Installing libkf5bluezqt-data as Depends of libkf5bluezqt6
            MarkInstall libkf5bluezqt-data:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
      Installing qml-module-ubuntu-onlineaccounts as Depends of libkf5purpose-bin
        MarkInstall qml-module-ubuntu-onlineaccounts:amd64 < none -> 0.6+17.04.20170405-0ubuntu4 @un uN > FU=0
      Installing libkf5purpose5 as Depends of libkf5purpose-bin
        MarkInstall libkf5purpose5:amd64 < none -> 5.68.0-0ubuntu1 @rc uN IPb > FU=0
        Installing qml-module-org-kde-purpose as Recommends of libkf5purpose5
          MarkInstall qml-module-org-kde-purpose:amd64 < none -> 5.68.0-0ubuntu1 @un uN IPb > FU=0
          Installing kdeconnect as Recommends of qml-module-org-kde-purpose
            MarkInstall kdeconnect:amd64 < none -> 1.4-0ubuntu5 @rc uN Ib > FU=0
            Installing libqca-qt5-2-plugins as Depends of kdeconnect
              MarkInstall libqca-qt5-2-plugins:amd64 < none -> 2.2.1-2build1 @un uN Ib > FU=0
              Installing libqca-qt5-2 as Depends of libqca-qt5-2-plugins
                MarkInstall libqca-qt5-2:amd64 < none -> 2.2.1-2build1 @un uN > FU=0
            Installing qml-module-org-kde-people as Depends of kdeconnect
              MarkInstall qml-module-org-kde-people:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
              Installing libkf5people5 as Depends of qml-module-org-kde-people
                MarkInstall libkf5people5:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
                Installing libkf5people-data as Depends of libkf5people5
                  MarkInstall libkf5people-data:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
                Installing libkf5peoplebackend5 as Depends of libkf5people5
                  MarkInstall libkf5peoplebackend5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
              Installing libkf5peoplewidgets5 as Depends of qml-module-org-kde-people
                MarkInstall libkf5peoplewidgets5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
            Installing sshfs as Depends of kdeconnect
              MarkInstall sshfs:amd64 < none -> 3.6.0+repack+really2.10-0ubuntu1 @un uN > FU=0
            Installing libfakekey0 as Depends of kdeconnect
              MarkInstall libfakekey0:amd64 < none -> 0.1-10 @un uN > FU=0
            Installing libkf5pulseaudioqt2 as Depends of kdeconnect
              MarkInstall libkf5pulseaudioqt2:amd64 < none -> 1.2-2build1 @un uN > FU=0
            Installing kpeople-vcard as Recommends of kdeconnect
              MarkInstall kpeople-vcard:amd64 < none -> 0.1-0ubuntu1 @un uN Ib > FU=0
              Installing libkf5contacts5 as Depends of kpeople-vcard
                MarkInstall libkf5contacts5:amd64 < none -> 5:5.68.0-0ubuntu1 @un uN Ib > FU=0
                Installing libkf5contacts-data as Depends of libkf5contacts5
                  MarkInstall libkf5contacts-data:amd64 < none -> 5:5.68.0-0ubuntu1 @un uN > FU=0
    Installing libokular5core9 as Depends of okular
      MarkInstall libokular5core9:amd64 < none -> 4:19.12.3-2ubuntu1 @un uN Ib > FU=0
      Installing libkf5jsapi5 as Depends of libokular5core9
        MarkInstall libkf5jsapi5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
      Installing libkf5threadweaver5 as Depends of libokular5core9
        MarkInstall libkf5threadweaver5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
    Installing libqmobipocket2 as Depends of okular
      MarkInstall libqmobipocket2:amd64 < none -> 4:19.12.3-0ubuntu1 @un uN > FU=0
    Installing okular-extra-backends as Recommends of okular
      MarkInstall okular-extra-backends:amd64 < none -> 4:19.12.3-2ubuntu1 @un uN Ib > FU=0
      Installing libchm1 as Depends of okular-extra-backends
        MarkInstall libchm1:amd64 < none -> 2:0.40a-5 @un uN > FU=0
      Installing libepub0 as Depends of okular-extra-backends
        MarkInstall libepub0:amd64 < none -> 0.2.2-4ubuntu2 @un uN Ib > FU=0
        Installing libzip5 as Depends of libepub0
          MarkInstall libzip5:amd64 < none -> 1.5.1-0ubuntu1 @un uN > FU=0
      Installing libmarkdown2 as Depends of okular-extra-backends
        MarkInstall libmarkdown2:amd64 < none -> 2.2.6-1 @un uN > FU=0
    Installing qtspeech5-flite-plugin as Recommends of okular
      MarkInstall qtspeech5-flite-plugin:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
  MarkInstall libboost-mpi-python1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
  Installing libboost-mpi1.65-dev as Depends of libboost-mpi-python1.65-dev
      MarkKeep libboost-mpi1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall python3-lazr.restfulclient:amd64 < 0.13.5-1 -> 0.14.2-2build1 @ii umU Ib > FU=0
  Installing python3-oauthlib as Depends of python3-lazr.restfulclient
    MarkInstall python3-oauthlib:amd64 < none -> 3.1.0-1ubuntu2 @un uN Ib > FU=0
    Installing python3-blinker as Depends of python3-oauthlib
      MarkInstall python3-blinker:amd64 < none -> 1.4+dfsg1-0.3ubuntu1 @un uN > FU=0
  MarkInstall evolution-data-server:amd64 < 3.28.5-0ubuntu0.18.04.3 -> 3.36.5-0ubuntu1 @ii umU Ib > FU=0
  Installing libebook-1.2-20 as Depends of evolution-data-server
    MarkInstall libebook-1.2-20:amd64 < none -> 3.36.5-0ubuntu1 @un uN Ib > FU=0
    Installing libebook-contacts-1.2-3 as Depends of libebook-1.2-20
      MarkInstall libebook-contacts-1.2-3:amd64 < none -> 3.36.5-0ubuntu1 @un uN > FU=0
    Installing libedata-book-1.2-26 as Depends of libebook-1.2-20
      MarkInstall libedata-book-1.2-26:amd64 < none -> 3.36.5-0ubuntu1 @un uN > FU=0
  Installing libedata-cal-2.0-1 as Depends of evolution-data-server
    MarkInstall libedata-cal-2.0-1:amd64 < none -> 3.36.5-0ubuntu1 @un uN > FU=0
  MarkInstall procps:amd64 < 2:3.3.12-3ubuntu1.2 -> 2:3.3.16-1ubuntu2.1 @ii umU Ib > FU=0
  Installing libprocps8 as Depends of procps
    MarkInstall libprocps8:amd64 < none -> 2:3.3.16-1ubuntu2.1 @un uN > FU=0
  MarkInstall xfce4-panel:amd64 < 4.12.2-1ubuntu1 -> 4.14.3-1 @ii umU Ib > FU=0
  Installing libgarcon-gtk3-1-0 as Depends of xfce4-panel
    MarkInstall libgarcon-gtk3-1-0:amd64 < none -> 0.6.4-1 @un uN > FU=0
  MarkInstall alsa-utils:amd64 < 1.1.3-1ubuntu1 -> 1.2.2-1ubuntu2.1 @ii umU Ib > FU=0
  Installing libatopology2 as Depends of alsa-utils
    MarkInstall libatopology2:amd64 < none -> 1.2.2-2.1ubuntu2.4 @un uN > FU=0
  MarkInstall libpoco-dev:amd64 < 1.8.0.1-1ubuntu4 -> 1.9.2-3ubuntu3 @ii umU Ib > FU=0
  Installing libpococrypto62 as Depends of libpoco-dev
    MarkInstall libpococrypto62:amd64 < none -> 1.9.2-3ubuntu3 @un uN Ib > FU=0
    Installing libpocofoundation62 as Depends of libpococrypto62
      MarkInstall libpocofoundation62:amd64 < none -> 1.9.2-3ubuntu3 @un uN > FU=0
  Installing libpocodata62 as Depends of libpoco-dev
    MarkInstall libpocodata62:amd64 < none -> 1.9.2-3ubuntu3 @un uN > FU=0
  Installing libpocoencodings62 as Depends of libpoco-dev
    MarkInstall libpocoencodings62:amd64 < none -> 1.9.2-3ubuntu3 @un uN > FU=0
  Installing libpocojson62 as Depends of libpoco-dev
    MarkInstall libpocojson62:amd64 < none -> 1.9.2-3ubuntu3 @un uN > FU=0
  Installing libpocodatamysql62 as Depends of libpoco-dev
    MarkInstall libpocodatamysql62:amd64 < none -> 1.9.2-3ubuntu3 @un uN > FU=0
  Installing libpocomongodb62 as Depends of libpoco-dev
    MarkInstall libpocomongodb62:amd64 < none -> 1.9.2-3ubuntu3 @un uN Ib > FU=0
    Installing libpoconet62 as Depends of libpocomongodb62
      MarkInstall libpoconet62:amd64 < none -> 1.9.2-3ubuntu3 @un uN > FU=0
  Installing libpoconetssl62 as Depends of libpoco-dev
    MarkInstall libpoconetssl62:amd64 < none -> 1.9.2-3ubuntu3 @un uN Ib > FU=0
    Installing libpocoutil62 as Depends of libpoconetssl62
      MarkInstall libpocoutil62:amd64 < none -> 1.9.2-3ubuntu3 @un uN Ib > FU=0
      Installing libpocoxml62 as Depends of libpocoutil62
        MarkInstall libpocoxml62:amd64 < none -> 1.9.2-3ubuntu3 @un uN > FU=0
  Installing libpocodataodbc62 as Depends of libpoco-dev
    MarkInstall libpocodataodbc62:amd64 < none -> 1.9.2-3ubuntu3 @un uN > FU=0
  Installing libpocodatasqlite62 as Depends of libpoco-dev
    MarkInstall libpocodatasqlite62:amd64 < none -> 1.9.2-3ubuntu3 @un uN > FU=0
  Installing libpocoredis62 as Depends of libpoco-dev
    MarkInstall libpocoredis62:amd64 < none -> 1.9.2-3ubuntu3 @un uN > FU=0
  Installing libpocozip62 as Depends of libpoco-dev
    MarkInstall libpocozip62:amd64 < none -> 1.9.2-3ubuntu3 @un uN > FU=0
  MarkInstall libc++1:amd64 < 6.0-2 -> 1:10.0-50~exp1 @ii umU Ib > FU=0
  Installing libc++1-10 as Depends of libc++1
    MarkInstall libc++1-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN Ib > FU=0
    Installing libc++abi1-10 as Depends of libc++1-10
      MarkInstall libc++abi1-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN > FU=0
  MarkInstall orca:amd64 < 3.28.0-3ubuntu1 -> 3.36.2-1ubuntu1~20.04.1 @ii umU IPb > FU=0
  MarkInstall libomp5:amd64 < 5.0.1-1 -> 1:10.0-50~exp1 @ii umU Ib > FU=0
  Installing libomp5-10 as Depends of libomp5
    MarkInstall libomp5-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN > FU=0
  MarkInstall libvoikko1:amd64 < 4.1.1-1.1 -> 4.3-1build1 @ii umU Ib > FU=0
  Installing libhfstospell10 as Depends of libvoikko1
    MarkInstall libhfstospell10:amd64 < none -> 0.5.0-2build2 @un uN Ib > FU=0
     Removing: libhfstospell9
      MarkDelete libhfstospell9:amd64 < 0.4.5~r343-2.1build2 @ii mK Ib > FU=0
  MarkInstall gdm3:amd64 < 3.28.3-0ubuntu18.04.6 -> 3.36.3-0ubuntu0.20.04.3 @ii umU IPb > FU=0
  new important dependency: libpam-fprintd:amd64
  Installing libpam-fprintd as Recommends of gdm3
    MarkInstall libpam-fprintd:amd64 < none -> 1.90.1-1ubuntu1 @un uN Ib > FU=0
    Installing fprintd as Depends of libpam-fprintd
      MarkInstall fprintd:amd64 < none -> 1.90.1-1ubuntu1 @un uN Ib > FU=0
      Installing libfprint-2-2 as Depends of fprintd
        MarkInstall libfprint-2-2:amd64 < none -> 1:1.90.2+tod1-0ubuntu1~20.04.4 @un uN > FU=0
  MarkInstall libwmf0.2-7:amd64 < 0.2.8.4-12 -> 0.2.8.4-17ubuntu1 @ii umU IPb > FU=0
  new important dependency: fonts-urw-base35:amd64
  Installing fonts-urw-base35 as Recommends of libwmf0.2-7
    MarkInstall fonts-urw-base35:amd64 < none -> 20170801.1-3 @un uN > FU=0
  MarkInstall libbullet-dev:amd64 < 2.87+dfsg-2 -> 2.88+dfsg-2build2 @ii umU Ib > FU=0
  Installing libbullet2.88 as Depends of libbullet-dev
    MarkInstall libbullet2.88:amd64 < none -> 2.88+dfsg-2build2 @un uN > FU=0
  MarkInstall libboost-graph-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-graph1.71-dev as Depends of libboost-graph-dev
    MarkInstall libboost-graph1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
    Installing libboost-graph1.71.0 as Depends of libboost-graph1.71-dev
      MarkInstall libboost-graph1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
    Installing libboost-test1.71-dev as Depends of libboost-graph1.71-dev
      MarkInstall libboost-test1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
      Installing libboost-test1.71.0 as Depends of libboost-test1.71-dev
        MarkInstall libboost-test1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
       Removing: libboost-test1.65-dev
        MarkDelete libboost-test1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
     Removing: libboost-graph1.65-dev
      MarkDelete libboost-graph1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
  Ignore MarkInstall of python:amd64 < 2.7.15~rc1-1 @ii pgR > as its mode (Delete) is protected
  MarkInstall dkms:amd64 < 2.3-3ubuntu9.7 -> 2.8.1-5ubuntu2 @ii umU Ib > FU=0
  Installing dctrl-tools as Depends of dkms
    MarkInstall dctrl-tools:amd64 < none -> 2.24-3 @un uN > FU=0
  MarkInstall liblist-someutils-perl:amd64 < 0.56-1 -> 0.58-1 @ii umU IPb > FU=0
  new important dependency: liblist-someutils-xs-perl:amd64
  Installing liblist-someutils-xs-perl as Recommends of liblist-someutils-perl
    MarkInstall liblist-someutils-xs-perl:amd64 < none -> 0.58-2 @un uN > FU=0
  MarkInstall libkf5bookmarks5:amd64 < 5.44.0-0ubuntu1 -> 5.68.0-0ubuntu1 @ii umU IPb > FU=0
  new important dependency: keditbookmarks:amd64
  Installing keditbookmarks as Recommends of libkf5bookmarks5
    MarkInstall keditbookmarks:amd64 < none -> 19.12.3-0ubuntu1 @un uN Ib > FU=0
    Installing libkf5kiogui5 as Depends of keditbookmarks
      MarkInstall libkf5kiogui5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
  MarkInstall libboost-timer-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-timer1.71-dev as Depends of libboost-timer-dev
    MarkInstall libboost-timer1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
    Installing libboost-timer1.71.0 as Depends of libboost-timer1.71-dev
      MarkInstall libboost-timer1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
     Removing: libboost-timer1.65-dev
      MarkDelete libboost-timer1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
  MarkInstall xfwm4:amd64 < 4.12.5-1ubuntu0.18.04.1 -> 4.14.1-0ubuntu1 @ii umU Ib > FU=0
  Installing libxpresent1 as Depends of xfwm4
    MarkInstall libxpresent1:amd64 < none -> 1.0.0-2build1 @un uN > FU=0
  MarkInstall fwupdate:amd64 < 12-7~ubuntu18.04.3 -> 12-7 @ii umU Ib > FU=0
   Removing: fwupdate-signed
    MarkDelete fwupdate-signed:amd64 < 12-7~ubuntu18.04.3 @ii mK > FU=0
   Removing: libfwup1
    MarkDelete libfwup1:amd64 < 12-3bionic2 @ii mK > FU=0
  MarkInstall ocaml-nox:amd64 < 4.05.0-10ubuntu1 -> 4.08.1-8 @ii umU IPb > FU=0
  new important dependency: ocaml-man:amd64
  Installing ocaml-man as Recommends of ocaml-nox
    MarkInstall ocaml-man:amd64 < none -> 4.08.1-8 @un uN > FU=0
  MarkInstall libsvn1:amd64 < 1.9.7-4ubuntu1 -> 1.13.0-3 @ii umU Ib > FU=0
  Installing libutf8proc2 as Depends of libsvn1
    MarkInstall libutf8proc2:amd64 < none -> 2.5.0-1 @un uN > FU=0
  MarkInstall dh-strip-nondeterminism:amd64 < 0.040-1.1~build1 -> 1.7.0-1 @ii umU Ib > FU=0
  Installing libdebhelper-perl as Depends of dh-strip-nondeterminism
    MarkInstall libdebhelper-perl:amd64 < none -> 12.10ubuntu1 @un uN > FU=0
  MarkInstall libdvdnav4:amd64 < 6.0.0-1 -> 6.0.1-1build1 @ii umU Ib > FU=0
  Installing libdvdread7 as Depends of libdvdnav4
    MarkInstall libdvdread7:amd64 < none -> 6.1.0+really6.0.2-1 @un uN > FU=0
    MarkKeep libboost-system1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall libopencv-stitching-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Installing libopencv-stitching4.2 as Depends of libopencv-stitching-dev
    MarkInstall libopencv-stitching4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
    Installing libopencv-objdetect4.2 as Depends of libopencv-stitching4.2
      MarkInstall libopencv-objdetect4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN > FU=0
    MarkKeep libboost-random1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
    MarkKeep libboost-chrono1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall libopencv-superres-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Installing libopencv-superres4.2 as Depends of libopencv-superres-dev
    MarkInstall libopencv-superres4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
    Installing libopencv-contrib4.2 as Depends of libopencv-superres4.2
      MarkInstall libopencv-contrib4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
      Installing libopencv-dnn4.2 as Depends of libopencv-contrib4.2
        MarkInstall libopencv-dnn4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN > FU=0
      Installing libopencv-photo4.2 as Depends of libopencv-contrib4.2
        MarkInstall libopencv-photo4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN > FU=0
      Installing libopencv-videostab4.2 as Depends of libopencv-contrib4.2
        MarkInstall libopencv-videostab4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN > FU=0
      Installing libopencv-viz4.2 as Depends of libopencv-contrib4.2
        MarkInstall libopencv-viz4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN > FU=0
  MarkInstall libfile-stripnondeterminism-perl:amd64 < 0.040-1.1~build1 -> 1.7.0-1 @ii umU Ib > FU=0
  Installing libsub-override-perl as Depends of libfile-stripnondeterminism-perl
    MarkInstall libsub-override-perl:amd64 < none -> 0.09-2 @un uN > FU=0
  MarkInstall libgcc1:amd64 < 1:8.4.0-1ubuntu1~18.04 -> 1:10.2.0-5ubuntu1~20.04 @ii umU Ib > FU=0
   Removing: libgcc1
    MarkDelete libgcc1:i386 < 1:8.4.0-1ubuntu1~18.04 -> 1:10.2.0-5ubuntu1~20.04 @ii umU Ib > FU=0
  MarkInstall libgcc1:i386 < 1:8.4.0-1ubuntu1~18.04 -> 1:10.2.0-5ubuntu1~20.04 @ii umU Ib > FU=0
   Removing: libgcc1
    MarkDelete libgcc1:amd64 < 1:8.4.0-1ubuntu1~18.04 -> 1:10.2.0-5ubuntu1~20.04 @ii umU Ib > FU=0
  MarkInstall libreoffice-style-galaxy:amd64 < 1:6.0.7-0ubuntu0.18.04.10 -> 1:6.4.7-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libreoffice-style-colibre as Depends of libreoffice-style-galaxy
    MarkInstall libreoffice-style-colibre:amd64 < none -> 1:6.4.7-0ubuntu0.20.04.1 @un uN > FU=0
  MarkInstall libvtk6.3:amd64 < 6.3.0+dfsg1-11build1 -> 6.3.0+dfsg2-5build2 @ii umU Ib > FU=0
  Installing libhdf5-openmpi-103 as Depends of libvtk6.3
    MarkInstall libhdf5-openmpi-103:amd64 < none -> 1.10.4+repack-11ubuntu1 @un uN Ib > FU=0
     Removing: libhdf5-openmpi-100
      MarkDelete libhdf5-openmpi-100:amd64 < 1.10.0-patch1+docs-4 @ii mK > FU=0
    MarkKeep libboost-container1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall libwayland-client0:i386 < 1.16.0-1ubuntu1.1~18.04.3 -> 1.18.0-1 @ii umU Ib > FU=0
  Installing libffi7 as Depends of libwayland-client0
    MarkInstall libffi7:i386 < none -> 3.3-4 @un uN > FU=0
  MarkInstall libcairo-perl:amd64 < 1.106-2build2 -> 1.107-1 @ii umU Ib > FU=0
  Installing libextutils-depends-perl as Depends of libcairo-perl
    MarkInstall libextutils-depends-perl:amd64 < none -> 0.8000-1 @un uN > FU=0
  Installing libextutils-pkgconfig-perl as Depends of libcairo-perl
    MarkInstall libextutils-pkgconfig-perl:amd64 < none -> 1.16-1 @un uN > FU=0
  MarkInstall aisleriot:amd64 < 1:3.22.5-1 -> 1:3.22.9-1 @ii umU Ib > FU=0
  Installing guile-2.2-libs as Depends of aisleriot
    MarkInstall guile-2.2-libs:amd64 < none -> 2.2.7+1-4 @un uN > FU=0
  MarkInstall samba-libs:amd64 < 2:4.7.6+dfsg~ubuntu-0ubuntu2.23 -> 2:4.11.6+dfsg-0ubuntu1.8 @ii umU Ib > FU=0
  Installing libldb2 as Depends of samba-libs
    MarkInstall libldb2:amd64 < none -> 2:2.0.10-0ubuntu0.20.04.3 @un uN Ib > FU=0
     Removing: libldb1
      MarkDelete libldb1:amd64 < 2:1.2.3-1ubuntu0.2 @ii mK > FU=0
  Installing python3-talloc as Depends of samba-libs
    MarkInstall python3-talloc:amd64 < none -> 2.3.0-3ubuntu1 @un uN > FU=0
  MarkInstall binutils-x86-64-linux-gnu:amd64 < 2.30-21ubuntu1~18.04.5 -> 2.34-6ubuntu1.1 @ii umU Ib > FU=0
  Installing libctf-nobfd0 as Depends of binutils-x86-64-linux-gnu
    MarkInstall libctf-nobfd0:amd64 < none -> 2.34-6ubuntu1.1 @un uN > FU=0
  Installing libctf0 as Depends of binutils-x86-64-linux-gnu
    MarkInstall libctf0:amd64 < none -> 2.34-6ubuntu1.1 @un uN > FU=0
  MarkInstall biber:amd64 < 2.9-1 -> 2.14-1 @ii umU Ib > FU=0
  Installing libparse-recdescent-perl as Depends of biber
    MarkInstall libparse-recdescent-perl:amd64 < none -> 1.967015+dfsg-2 @un uN > FU=0
  MarkInstall libyaml-cpp-dev:amd64 < 0.5.2-4ubuntu1 -> 0.6.2-4ubuntu1 @ii umU Ib > FU=0
  Installing libyaml-cpp0.6 as Depends of libyaml-cpp-dev
    MarkInstall libyaml-cpp0.6:amd64 < none -> 0.6.2-4ubuntu1 @un uN > FU=0
  MarkInstall gimp:amd64 < 2.8.22-1 -> 2.10.18-1 @ii umU Ib > FU=0
  Installing libgegl-0.4-0 as Depends of gimp
    MarkInstall libgegl-0.4-0:amd64 < none -> 0.4.22-3 @un uN Ib > FU=0
    Installing libgegl-common as Depends of libgegl-0.4-0
      MarkInstall libgegl-common:amd64 < none -> 0.4.22-3 @un uN > FU=0
  Installing libheif1 as Depends of gimp
    MarkInstall libheif1:amd64 < none -> 1.6.1-1build1 @un uN Ib > FU=0
    Installing libde265-0 as Depends of libheif1
      MarkInstall libde265-0:amd64 < none -> 1.0.4-1build1 @un uN > FU=0
  Installing libmypaint-1.5-1 as Depends of gimp
    MarkInstall libmypaint-1.5-1:amd64 < none -> 1.5.1-1 @un uN Ib > FU=0
    Installing libmypaint-common as Depends of libmypaint-1.5-1
      MarkInstall libmypaint-common:amd64 < none -> 1.5.1-1 @un uN > FU=0
  MarkInstall libllvm10:i386 < 1:10.0.0-4ubuntu1~18.04.2 -> 1:10.0.0-4ubuntu1 @ii umU Ib > FU=0
  Installing libtinfo6 as Depends of libllvm10
    MarkInstall libtinfo6:i386 < none -> 6.2-0ubuntu2 @un uN > FU=0
    MarkKeep libboost-test1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall dpkg:amd64 < 1.19.0.5ubuntu2.3 -> 1.19.7ubuntu3 @ii umU Ib > FU=0
   Removing: libapt-pkg5.0
    MarkDelete libapt-pkg5.0:amd64 < 1.6.13 @ii mK > FU=0
  MarkInstall cups-filters:amd64 < 1.20.2-0ubuntu3.1 -> 1.27.4-1 @ii umU Ib > FU=0
  Installing libqpdf26 as Depends of cups-filters
    MarkInstall libqpdf26:amd64 < none -> 9.1.1-1build1 @un uN > FU=0
  MarkInstall libsane1:i386 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib > FU=0
  Installing libsane as Depends of libsane1
    MarkInstall libsane:i386 < none -> 1.0.29-0ubuntu5.2 @un uN Ib > FU=0
    Installing libcurl3-gnutls as Depends of libsane
      MarkInstall libcurl3-gnutls:i386 < none -> 7.68.0-1ubuntu2.5 @un uN Ib > FU=0
      Installing libbrotli1 as Depends of libcurl3-gnutls
        MarkInstall libbrotli1:i386 < none -> 1.0.7-6ubuntu0.1 @un uN > FU=0
      Installing libnettle7 as Depends of libcurl3-gnutls
        MarkInstall libnettle7:i386 < none -> 3.5.1+really3.5.1-2ubuntu0.1 @un uN > FU=0
      Installing libnghttp2-14 as Depends of libcurl3-gnutls
        MarkInstall libnghttp2-14:i386 < none -> 1.40.0-1build1 @un uN > FU=0
      Installing libpsl5 as Depends of libcurl3-gnutls
        MarkInstall libpsl5:i386 < none -> 0.21.0-1ubuntu1 @un uN > FU=0
      Installing librtmp1 as Depends of libcurl3-gnutls
        MarkInstall librtmp1:i386 < none -> 2.4+20151223.gitfa8646d.1-2build1 @un uN Ib > FU=0
        Installing libhogweed5 as Depends of librtmp1
          MarkInstall libhogweed5:i386 < none -> 3.5.1+really3.5.1-2ubuntu0.1 @un uN > FU=0
      Installing libssh-4 as Depends of libcurl3-gnutls
        MarkInstall libssh-4:i386 < none -> 0.9.3-2ubuntu2.1 @un uN > FU=0
    Installing libsnmp35 as Depends of libsane
      MarkInstall libsnmp35:i386 < none -> 5.8+dfsg-2ubuntu2.3 @un uN Ib > FU=0
      Installing libmysqlclient21 as Depends of libsnmp35
        MarkInstall libmysqlclient21:i386 < none -> 8.0.25-0ubuntu0.20.04.1 @un uN > FU=0
      Installing libpci3 as Depends of libsnmp35
        MarkInstall libpci3:i386 < none -> 1:3.6.4-1ubuntu0.20.04.1 @un uN Ib > FU=0
        Installing pci.ids as Depends of libpci3
          MarkInstall pci.ids:amd64 < none -> 0.0~2020.03.20-1 @un uN > FU=0
      Installing libperl5.30 as Depends of libsnmp35
        MarkInstall libperl5.30:i386 < none -> 5.30.0-9ubuntu0.2 @un uN Ib > FU=0
        Installing libbz2-1.0 as Depends of libperl5.30
          MarkInstall libbz2-1.0:i386 < none -> 1.0.8-2 @un uN > FU=0
        Installing libgdbm-compat4 as Depends of libperl5.30
          MarkInstall libgdbm-compat4:i386 < none -> 1.18.1-5 @un uN Ib > FU=0
          Installing libgdbm6 as Depends of libgdbm-compat4
            MarkInstall libgdbm6:i386 < none -> 1.18.1-5 @un uN > FU=0
      Installing libsensors5 as Depends of libsnmp35
        MarkInstall libsensors5:i386 < none -> 1:3.6.0-2ubuntu1 @un uN > FU=0
  MarkInstall imagemagick-6.q16:amd64 < 8:6.9.7.4+dfsg-16ubuntu6.9 -> 8:6.9.10.23+dfsg-2.1ubuntu11.2 @ii umU Ib > FU=0
  Installing libmagickcore-6.q16-6 as Depends of imagemagick-6.q16
    MarkInstall libmagickcore-6.q16-6:amd64 < none -> 8:6.9.10.23+dfsg-2.1ubuntu11.2 @un uN > FU=0
  Installing libmagickwand-6.q16-6 as Depends of imagemagick-6.q16
    MarkInstall libmagickwand-6.q16-6:amd64 < none -> 8:6.9.10.23+dfsg-2.1ubuntu11.2 @un uN > FU=0
  new important dependency: libmagickcore-6.q16-6-extra:amd64
  Installing libmagickcore-6.q16-6-extra as Recommends of imagemagick-6.q16
    MarkInstall libmagickcore-6.q16-6-extra:amd64 < none -> 8:6.9.10.23+dfsg-2.1ubuntu11.2 @un uN > FU=0
  MarkInstall libqt5gui5:amd64 < 5.9.5+dfsg-0ubuntu2.5 -> 5.12.8+dfsg-0ubuntu1 @ii umU Ib > FU=0
  Installing libxcb-xinput0 as Depends of libqt5gui5
    MarkInstall libxcb-xinput0:amd64 < none -> 1.14-2 @un uN > FU=0
  MarkInstall libqt5multimedia5-plugins:amd64 < 5.9.5-0ubuntu1 -> 5.12.8-0ubuntu1 @ii umU Ib > FU=0
  Installing libqt5multimediagsttools5 as Depends of libqt5multimedia5-plugins
    MarkInstall libqt5multimediagsttools5:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
  MarkInstall libsnmp30:amd64 < 5.7.3+dfsg-1.8ubuntu3.6 @ii mK Ib > FU=0
  Installing libsensors4 as Depends of libsnmp30
      MarkKeep libsensors4:amd64 < 1:3.4.0-4 @ii mR > FU=0
  MarkInstall wireshark-common:amd64 < 2.6.10-1~ubuntu18.04.0 -> 3.2.3-1 @ii umU Ib > FU=0
  Installing libwireshark13 as Depends of wireshark-common
    MarkInstall libwireshark13:amd64 < none -> 3.2.3-1 @un uN Ib > FU=0
    Installing libwiretap10 as Depends of libwireshark13
      MarkInstall libwiretap10:amd64 < none -> 3.2.3-1 @un uN Ib > FU=0
      Installing libwsutil11 as Depends of libwiretap10
        MarkInstall libwsutil11:amd64 < none -> 3.2.3-1 @un uN > FU=0
  MarkInstall libfile-mimeinfo-perl:amd64 < 0.28-1 -> 0.29-1 @ii umU IPb > FU=0
  new important dependency: libio-stringy-perl:amd64
  Installing libio-stringy-perl as Recommends of libfile-mimeinfo-perl
    MarkInstall libio-stringy-perl:amd64 < none -> 2.111-3 @un uN > FU=0
    MarkKeep libboost-log1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall nautilus:amd64 < 1:3.26.4-0~ubuntu18.04.5 -> 1:3.36.3-0ubuntu1 @ii umU Ib > FU=0
  Installing tracker as Depends of nautilus
    MarkInstall tracker:amd64 < none -> 2.3.6-0ubuntu1 @un uN Ib > FU=0
    Installing libtracker-control-2.0-0 as Depends of tracker
      MarkInstall libtracker-control-2.0-0:amd64 < none -> 2.3.6-0ubuntu1 @un uN > FU=0
    Installing tracker-miner-fs as Recommends of tracker
      MarkInstall tracker-miner-fs:amd64 < none -> 2.3.3-2 @un uN Ib > FU=0
      Installing libtracker-miner-2.0-0 as Depends of tracker-miner-fs
        MarkInstall libtracker-miner-2.0-0:amd64 < none -> 2.3.6-0ubuntu1 @un uN > FU=0
      Installing tracker-extract as Depends of tracker-miner-fs
        MarkInstall tracker-extract:amd64 < none -> 2.3.3-2 @un uN Ib > FU=0
        Installing libcue2 as Depends of tracker-extract
          MarkInstall libcue2:amd64 < none -> 2.2.1-2 @un uN > FU=0
        Installing libgsf-1-114 as Depends of tracker-extract
          MarkInstall libgsf-1-114:amd64 < none -> 1.14.46-1 @un uN Ib > FU=0
          Installing libgsf-1-common as Depends of libgsf-1-114
            MarkInstall libgsf-1-common:amd64 < none -> 1.14.46-1 @un uN > FU=0
  MarkInstall libomp-dev:amd64 < 5.0.1-1 -> 1:10.0-50~exp1 @ii umU Ib > FU=0
  Installing libomp-10-dev as Depends of libomp-dev
    MarkInstall libomp-10-dev:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN > FU=0
  MarkInstall libboost-program-options-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-program-options1.71-dev as Depends of libboost-program-options-dev
    MarkInstall libboost-program-options1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
    Installing libboost-program-options1.71.0 as Depends of libboost-program-options1.71-dev
      MarkInstall libboost-program-options1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
     Removing: libboost-program-options1.65-dev
      MarkDelete libboost-program-options1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
  MarkInstall libreoffice-help-de:amd64 < 1:6.0.7-0ubuntu0.18.04.10 -> 1:6.4.7-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libreoffice-help-common as Depends of libreoffice-help-de
    MarkInstall libreoffice-help-common:amd64 < none -> 1:6.4.7-0ubuntu0.20.04.1 @un uN > FU=0
  MarkInstall libxenstore3.0:amd64 < 4.9.2-0ubuntu1 -> 4.11.3+24-g14b62ab3e5-1ubuntu2 @ii umU Ib > FU=0
  Installing libxentoolcore1 as Depends of libxenstore3.0
    MarkInstall libxentoolcore1:amd64 < none -> 4.11.3+24-g14b62ab3e5-1ubuntu2 @un uN > FU=0
  MarkInstall libcupsmime1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
  MarkInstall libboost-mpi-python-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-mpi-python1.71-dev as Depends of libboost-mpi-python-dev
    MarkInstall libboost-mpi-python1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
    Installing libboost-mpi-python1.71.0 as Depends of libboost-mpi-python1.71-dev
      MarkInstall libboost-mpi-python1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
       Removing: libboost-mpi-python1.65.1
        MarkDelete libboost-mpi-python1.65.1:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
     Removing: libboost-mpi-python1.65-dev
      MarkDelete libboost-mpi-python1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
  MarkInstall libboost-graph-parallel-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-graph-parallel1.71-dev as Depends of libboost-graph-parallel-dev
    MarkInstall libboost-graph-parallel1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
    Installing libboost-graph-parallel1.71.0 as Depends of libboost-graph-parallel1.71-dev
      MarkInstall libboost-graph-parallel1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
     Removing: libboost-graph-parallel1.65-dev
      MarkDelete libboost-graph-parallel1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
  MarkInstall libimobiledevice6:amd64 < 1.2.1~git20171128.5a854327+dfsg-0.1 -> 1.2.1~git20191129.9f79242-1build1 @ii umU Ib > FU=0
  Installing libusbmuxd6 as Depends of libimobiledevice6
    MarkInstall libusbmuxd6:amd64 < none -> 2.0.1-2 @un uN > FU=0
    MarkKeep libgdcm2-dev:amd64 < 2.8.4-1build2 @ii mR > FU=0
  MarkInstall ruby:amd64 < 1:2.5.1 -> 1:2.7+1 @ii umU Ib > FU=0
  Installing ruby2.7 as Depends of ruby
    MarkInstall ruby2.7:amd64 < none -> 2.7.0-5ubuntu1.4 @un uN Ib > FU=0
    Installing libruby2.7 as Depends of ruby2.7
      MarkInstall libruby2.7:amd64 < none -> 2.7.0-5ubuntu1.4 @un uN Ib > FU=0
      Installing ruby-xmlrpc as Depends of libruby2.7
        MarkInstall ruby-xmlrpc:amd64 < none -> 0.3.0-2 @un uN > FU=0
    MarkKeep libboost-thread1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall libglvnd-dev:amd64 < 1.0.0-2ubuntu2.3 -> 1.3.2-1~ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libgles-dev as Depends of libglvnd-dev
    MarkInstall libgles-dev:amd64 < none -> 1.3.2-1~ubuntu0.20.04.1 @un uN > FU=0
  Installing libopengl-dev as Depends of libglvnd-dev
    MarkInstall libopengl-dev:amd64 < none -> 1.3.2-1~ubuntu0.20.04.1 @un uN > FU=0
  MarkInstall libsuitesparse-dev:amd64 < 1:5.1.2-2 -> 1:5.7.1+dfsg-2 @ii umU Ib > FU=0
  Installing libgraphblas3 as Depends of libsuitesparse-dev
    MarkInstall libgraphblas3:amd64 < none -> 1:5.7.1+dfsg-2 @un uN > FU=0
  Installing libmongoose2 as Depends of libsuitesparse-dev
    MarkInstall libmongoose2:amd64 < none -> 1:5.7.1+dfsg-2 @un uN > FU=0
    MarkKeep libboost-mpi-python1.65.1:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall acpi-support:amd64 < 0.142 -> 0.143 @ii umU NPb IPb > FU=0
    MarkKeep libboost-graph-parallel1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
    MarkKeep libhfstospell9:amd64 < 0.4.5~r343-2.1build2 @ii mR > FU=0
  MarkInstall fonts-gujr:amd64 < 2:1.2 -> 2:1.3 @ii umU Ib > FU=0
  Installing fonts-yrsa-rasa as Depends of fonts-gujr
    MarkInstall fonts-yrsa-rasa:amd64 < none -> 1.002-2 @un uN > FU=0
  MarkInstall printer-driver-gutenprint:amd64 < 5.2.13-2 -> 5.3.3-4 @ii umU Ib > FU=0
  Installing libgutenprint9 as Depends of printer-driver-gutenprint
    MarkInstall libgutenprint9:amd64 < none -> 5.3.3-4 @un uN Ib > FU=0
    Installing libgutenprint-common as Depends of libgutenprint9
      MarkInstall libgutenprint-common:amd64 < none -> 5.3.3-4 @un uN > FU=0
  MarkInstall pyqt5-dev:amd64 < 5.10.1+dfsg-1ubuntu2 -> 5.14.1+dfsg-3build1 @ii umU Ib > FU=0
  Installing python3-sip-dev as Depends of pyqt5-dev
    MarkInstall python3-sip-dev:amd64 < none -> 4.19.21+dfsg-1build1 @un uN Ib > FU=0
    Installing python3-sip as Depends of python3-sip-dev
      MarkInstall python3-sip:amd64 < none -> 4.19.21+dfsg-1build1 @un uN > FU=0
  MarkInstall lintian:amd64 < 2.5.81ubuntu1 -> 2.62.0 @ii umU Ib > FU=0
  Installing libcapture-tiny-perl as Depends of lintian
    MarkInstall libcapture-tiny-perl:amd64 < none -> 0.48-1 @un uN > FU=0
  Installing libclass-xsaccessor-perl as Depends of lintian
    MarkInstall libclass-xsaccessor-perl:amd64 < none -> 1.19-3build3 @un uN > FU=0
  Installing libcpanel-json-xs-perl as Depends of lintian
    MarkInstall libcpanel-json-xs-perl:amd64 < none -> 4.19-1build1 @un uN > FU=0
  Installing libdevel-size-perl as Depends of lintian
    MarkInstall libdevel-size-perl:amd64 < none -> 0.83-1build1 @un uN > FU=0
  Installing libfont-ttf-perl as Depends of lintian
    MarkInstall libfont-ttf-perl:amd64 < none -> 1.06-1 @un uN > FU=0
  Installing libio-async-perl as Depends of lintian
    MarkInstall libio-async-perl:amd64 < none -> 0.75-1 @un uN Ib > FU=0
    Installing libfuture-perl as Depends of libio-async-perl
      MarkInstall libfuture-perl:amd64 < none -> 0.43-1 @un uN > FU=0
    Installing libstruct-dumb-perl as Depends of libio-async-perl
      MarkInstall libstruct-dumb-perl:amd64 < none -> 0.09-1 @un uN > FU=0
    Installing libasync-mergepoint-perl as Recommends of libio-async-perl
      MarkInstall libasync-mergepoint-perl:amd64 < none -> 0.04-2 @un uN > FU=0
    Installing libsereal-perl as Recommends of libio-async-perl
      MarkInstall libsereal-perl:amd64 < none -> 4.011-1 @un uN Ib > FU=0
      Installing libsereal-decoder-perl as Depends of libsereal-perl
        MarkInstall libsereal-decoder-perl:amd64 < none -> 4.011+ds-1build1 @un uN > FU=0
      Installing libsereal-encoder-perl as Depends of libsereal-perl
        MarkInstall libsereal-encoder-perl:amd64 < none -> 4.011+ds-1build1 @un uN > FU=0
    Installing libtest-fatal-perl as Recommends of libio-async-perl
      MarkInstall libtest-fatal-perl:amd64 < none -> 0.014-1 @un uN > FU=0
    Installing libtest-refcount-perl as Recommends of libio-async-perl
      MarkInstall libtest-refcount-perl:amd64 < none -> 0.10-1 @un uN > FU=0
  Installing libio-async-loop-epoll-perl as Depends of lintian
    MarkInstall libio-async-loop-epoll-perl:amd64 < none -> 0.20-1 @un uN Ib > FU=0
    Installing liblinux-epoll-perl as Depends of libio-async-loop-epoll-perl
      MarkInstall liblinux-epoll-perl:amd64 < none -> 0.017-1 @un uN > FU=0
  Installing libjson-maybexs-perl as Depends of lintian
    MarkInstall libjson-maybexs-perl:amd64 < none -> 1.004000-1 @un uN > FU=0
  Installing liblist-compare-perl as Depends of lintian
    MarkInstall liblist-compare-perl:amd64 < none -> 0.53-1 @un uN > FU=0
  Installing libmoo-perl as Depends of lintian
    MarkInstall libmoo-perl:amd64 < none -> 2.003006-1 @un uN Ib > FU=0
    Installing libimport-into-perl as Depends of libmoo-perl
      MarkInstall libimport-into-perl:amd64 < none -> 1.002005-1 @un uN > FU=0
    Installing libstrictures-perl as Depends of libmoo-perl
      MarkInstall libstrictures-perl:amd64 < none -> 2.000006-1 @un uN > FU=0
  Installing libmoox-aliases-perl as Depends of lintian
    MarkInstall libmoox-aliases-perl:amd64 < none -> 0.001006-1 @un uN > FU=0
  Installing libpath-tiny-perl as Depends of lintian
    MarkInstall libpath-tiny-perl:amd64 < none -> 0.108-1 @un uN IPb > FU=0
    Installing libunicode-utf8-perl as Recommends of libpath-tiny-perl
      MarkInstall libunicode-utf8-perl:amd64 < none -> 0.62-1build1 @un uN > FU=0
  Installing libtype-tiny-perl as Depends of lintian
    MarkInstall libtype-tiny-perl:amd64 < none -> 1.008001-2 @un uN IPb > FU=0
    Installing libtype-tiny-xs-perl as Recommends of libtype-tiny-perl
      MarkInstall libtype-tiny-xs-perl:amd64 < none -> 0.016-1 @un uN > FU=0
  MarkInstall ure:amd64 < 6.0.7-0ubuntu0.18.04.10 -> 1:6.4.7-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libuno-purpenvhelpergcc3-3 as Depends of ure
    MarkInstall libuno-purpenvhelpergcc3-3:amd64 < none -> 1:6.4.7-0ubuntu0.20.04.1 @un uN > FU=0
  new important dependency: libjuh-java:amd64
  Installing libjuh-java as Recommends of ure
    MarkInstall libjuh-java:amd64 < none -> 1:6.4.7-0ubuntu0.20.04.1 @un uN > FU=0
  new important dependency: libjurt-java:amd64
  Installing libjurt-java as Recommends of ure
    MarkInstall libjurt-java:amd64 < none -> 1:6.4.7-0ubuntu0.20.04.1 @un uN > FU=0
  new important dependency: libridl-java:amd64
  Installing libridl-java as Recommends of ure
    MarkInstall libridl-java:amd64 < none -> 1:6.4.7-0ubuntu0.20.04.1 @un uN > FU=0
  new important dependency: libunoloader-java:amd64
  Installing libunoloader-java as Recommends of ure
    MarkInstall libunoloader-java:amd64 < none -> 1:6.4.7-0ubuntu0.20.04.1 @un uN > FU=0
  MarkInstall brltty:amd64 < 5.5-4ubuntu2.0.1 -> 6.0+dfsg-4ubuntu6 @ii umU Ib > FU=0
  Installing libpcre2-32-0 as Depends of brltty
    MarkInstall libpcre2-32-0:amd64 < none -> 10.34-7 @un uN > FU=0
    MarkKeep libboost-timer1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall libselinux1:i386 < 2.7-2build2 -> 3.0-1build2 @ii umU Ib > FU=0
  Installing libpcre2-8-0 as Depends of libselinux1
    MarkInstall libpcre2-8-0:i386 < none -> 10.34-7 @un uN > FU=0
    MarkKeep libboost-wave1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall libncurses5-dev:amd64 < 6.1-1ubuntu1.18.04 -> 6.2-0ubuntu2 @ii umU Ib > FU=0
  Installing libncurses-dev as Depends of libncurses5-dev
    MarkInstall libncurses-dev:amd64 < none -> 6.2-0ubuntu2 @un uN > FU=0
  MarkInstall phonon-backend-gstreamer:amd64 < 4:4.9.0-1 @ii mK Ib > FU=0
  MarkInstall libglib2.0-dev:amd64 < 2.56.4-0ubuntu0.18.04.8 -> 2.64.6-1~ubuntu20.04.3 @ii umU Ib > FU=0
  Installing libffi-dev as Depends of libglib2.0-dev
    MarkInstall libffi-dev:amd64 < none -> 3.3-4 @un uN > FU=0
  Installing libmount-dev as Depends of libglib2.0-dev
    MarkInstall libmount-dev:amd64 < none -> 2.34-0.1ubuntu9.1 @un uN Ib > FU=0
    Installing libblkid-dev as Depends of libmount-dev
      MarkInstall libblkid-dev:amd64 < none -> 2.34-0.1ubuntu9.1 @un uN > FU=0
  Installing libselinux1-dev as Depends of libglib2.0-dev
    MarkInstall libselinux1-dev:amd64 < none -> 3.0-1build2 @un uN Ib > FU=0
    Installing libsepol1-dev as Depends of libselinux1-dev
      MarkInstall libsepol1-dev:amd64 < none -> 3.0-1 @un uN > FU=0
    Installing libpcre2-dev as Depends of libselinux1-dev
      MarkInstall libpcre2-dev:amd64 < none -> 10.34-7 @un uN Ib > FU=0
      Installing libpcre2-16-0 as Depends of libpcre2-dev
        MarkInstall libpcre2-16-0:amd64 < none -> 10.34-7 @un uN > FU=0
      Installing libpcre2-posix2 as Depends of libpcre2-dev
        MarkInstall libpcre2-posix2:amd64 < none -> 10.34-7 @un uN > FU=0
  MarkInstall python-bs4:amd64 < 4.6.0-1 -> 4.8.2-1 @ii umU Ib > FU=0
  Installing python-soupsieve as Depends of python-bs4
    MarkInstall python-soupsieve:amd64 < none -> 1.9.5+dfsg-1 @un uN > FU=0
  MarkInstall collectd:amd64 < 5.7.2-2ubuntu1.2 -> 5.9.2.g-1ubuntu5 @ii umU IPb > FU=0
  new important dependency: intel-cmt-cat:amd64
  Installing intel-cmt-cat as Recommends of collectd
    MarkInstall intel-cmt-cat:amd64 < none -> 3.2-1 @un uN > FU=0
  new important dependency: libbson-1.0-0:amd64
  Installing libbson-1.0-0 as Recommends of collectd
    MarkInstall libbson-1.0-0:amd64 < none -> 1.16.1-1build2 @un uN > FU=0
  new important dependency: libgps26:amd64
  Installing libgps26 as Recommends of collectd
    MarkInstall libgps26:amd64 < none -> 3.20-8ubuntu0.2 @un uN > FU=0
  new important dependency: libhiredis0.14:amd64
  Installing libhiredis0.14 as Recommends of collectd
    MarkInstall libhiredis0.14:amd64 < none -> 0.14.0-6 @un uN > FU=0
  new important dependency: libmongoc-1.0-0:amd64
  Installing libmongoc-1.0-0 as Recommends of collectd
    MarkInstall libmongoc-1.0-0:amd64 < none -> 1.16.1-1build2 @un uN > FU=0
  new important dependency: libowcapi-3.2-3:amd64
  Installing libowcapi-3.2-3 as Recommends of collectd
    MarkInstall libowcapi-3.2-3:amd64 < none -> 3.2p3+dfsg1-5build1 @un uN Ib > FU=0
    Installing libow-3.2-3 as Depends of libowcapi-3.2-3
      MarkInstall libow-3.2-3:amd64 < none -> 3.2p3+dfsg1-5build1 @un uN Ib > FU=0
      Installing libftdi1-2 as Depends of libow-3.2-3
        MarkInstall libftdi1-2:amd64 < none -> 1.4-2build2 @un uN > FU=0
  new important dependency: libqpid-proton11:amd64
  Installing libqpid-proton11 as Recommends of collectd
    MarkInstall libqpid-proton11:amd64 < none -> 0.22.0-3.3build1 @un uN > FU=0
  new important dependency: librte-eal20.0:amd64
  Installing librte-eal20.0 as Recommends of collectd
    MarkInstall librte-eal20.0:amd64 < none -> 19.11.7-0ubuntu0.20.04.1 @un uN Ib > FU=0
    Installing libfdt1 as Depends of librte-eal20.0
      MarkInstall libfdt1:amd64 < none -> 1.5.1-1 @un uN > FU=0
    Installing librte-kvargs20.0 as Depends of librte-eal20.0
      MarkInstall librte-kvargs20.0:amd64 < none -> 19.11.7-0ubuntu0.20.04.1 @un uN > FU=0
  new important dependency: librte-ethdev20.0:amd64
  Installing librte-ethdev20.0 as Recommends of collectd
    MarkInstall librte-ethdev20.0:amd64 < none -> 19.11.7-0ubuntu0.20.04.1 @un uN Ib > FU=0
    Installing librte-mbuf20.0 as Depends of librte-ethdev20.0
      MarkInstall librte-mbuf20.0:amd64 < none -> 19.11.7-0ubuntu0.20.04.1 @un uN Ib > FU=0
      Installing librte-mempool20.0 as Depends of librte-mbuf20.0
        MarkInstall librte-mempool20.0:amd64 < none -> 19.11.7-0ubuntu0.20.04.1 @un uN Ib > FU=0
        Installing librte-ring20.0 as Depends of librte-mempool20.0
          MarkInstall librte-ring20.0:amd64 < none -> 19.11.7-0ubuntu0.20.04.1 @un uN > FU=0
    Installing librte-meter20.0 as Depends of librte-ethdev20.0
      MarkInstall librte-meter20.0:amd64 < none -> 19.11.7-0ubuntu0.20.04.1 @un uN > FU=0
    Installing librte-net20.0 as Depends of librte-ethdev20.0
      MarkInstall librte-net20.0:amd64 < none -> 19.11.7-0ubuntu0.20.04.1 @un uN > FU=0
  new important dependency: libvarnishapi2:amd64
  Installing libvarnishapi2 as Recommends of collectd
    MarkInstall libvarnishapi2:amd64 < none -> 6.2.1-2 @un uN > FU=0
  new important dependency: libxenmisc4.11:amd64
  Installing libxenmisc4.11 as Recommends of collectd
    MarkInstall libxenmisc4.11:amd64 < none -> 4.11.3+24-g14b62ab3e5-1ubuntu2 @un uN Ib > FU=0
    Installing libxencall1 as Depends of libxenmisc4.11
      MarkInstall libxencall1:amd64 < none -> 4.11.3+24-g14b62ab3e5-1ubuntu2 @un uN Ib > FU=0
      Installing libxentoollog1 as Depends of libxencall1
        MarkInstall libxentoollog1:amd64 < none -> 4.11.3+24-g14b62ab3e5-1ubuntu2 @un uN > FU=0
    Installing libxendevicemodel1 as Depends of libxenmisc4.11
      MarkInstall libxendevicemodel1:amd64 < none -> 4.11.3+24-g14b62ab3e5-1ubuntu2 @un uN > FU=0
    Installing libxenevtchn1 as Depends of libxenmisc4.11
      MarkInstall libxenevtchn1:amd64 < none -> 4.11.3+24-g14b62ab3e5-1ubuntu2 @un uN > FU=0
    Installing libxenforeignmemory1 as Depends of libxenmisc4.11
      MarkInstall libxenforeignmemory1:amd64 < none -> 4.11.3+24-g14b62ab3e5-1ubuntu2 @un uN > FU=0
    Installing libxengnttab1 as Depends of libxenmisc4.11
      MarkInstall libxengnttab1:amd64 < none -> 4.11.3+24-g14b62ab3e5-1ubuntu2 @un uN > FU=0
  MarkInstall libopencv-contrib-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Installing libopencv-dnn-dev as Depends of libopencv-contrib-dev
    MarkInstall libopencv-dnn-dev:amd64 < none -> 4.2.0+dfsg-5 @un uN > FU=0
  MarkInstall systemd:amd64 < 237-3ubuntu10.47 -> 245.4-4ubuntu3.6 @ii umU Ib > FU=0
  Installing systemd-timesyncd as Depends of systemd
    MarkInstall systemd-timesyncd:amd64 < none -> 245.4-4ubuntu3.6 @un uN > FU=0
  MarkInstall libwebkit2gtk-4.0-37:amd64 < 2.32.0-0ubuntu0.18.04.1 -> 2.32.0-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing xdg-dbus-proxy as Depends of libwebkit2gtk-4.0-37
    MarkInstall xdg-dbus-proxy:amd64 < none -> 0.1.2-1 @un uN > FU=0
  MarkInstall libqt5core5a:amd64 < 5.9.5+dfsg-0ubuntu2.5 -> 5.12.8+dfsg-0ubuntu1 @ii umU Ib > FU=0
  Installing libdouble-conversion3 as Depends of libqt5core5a
    MarkInstall libdouble-conversion3:amd64 < none -> 3.1.5-4ubuntu1 @un uN > FU=0
   Removing: libqtcore4
    MarkDelete libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK > FU=0
  MarkInstall thunar:amd64 < 1.6.15-0ubuntu1.18.04.1 -> 1.8.14-0ubuntu1 @ii umU Ib > FU=0
  Installing libthunarx-3-0 as Depends of thunar
    MarkInstall libthunarx-3-0:amd64 < none -> 1.8.14-0ubuntu1 @un uN > FU=0
  MarkInstall libboost-exception-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-exception1.71-dev as Depends of libboost-exception-dev
    MarkInstall libboost-exception1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
     Removing: libboost-exception1.65-dev
      MarkDelete libboost-exception1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
  MarkInstall libboost-locale-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-locale1.71-dev as Depends of libboost-locale-dev
    MarkInstall libboost-locale1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
     Removing: libboost-locale1.65-dev
      MarkDelete libboost-locale1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
  MarkInstall python-dev:amd64 < 2.7.15~rc1-1 @ii gK Ib > FU=0
  Installing python as Depends of python-dev
    Ignore MarkInstall of python:amd64 < 2.7.15~rc1-1 @ii pgR > as its mode (Delete) is protected
  MarkInstall libpolkit-backend-1-0:amd64 < 0.105-20ubuntu0.18.04.5 @ii mK Ib > FU=0
  MarkInstall debhelper:amd64 < 11.1.6ubuntu2 -> 12.10ubuntu1 @ii umU Ib > FU=0
  Installing dwz as Depends of debhelper
    MarkInstall dwz:amd64 < none -> 0.13-5 @un uN > FU=0
  MarkInstall emacsen-common:amd64 < 2.0.8 -> 3.0.4 @ii umU Ib > FU=0
   Removing: emacs25-common
    MarkDelete emacs25-common:amd64 < 25.2+1-6 @ii mK > FU=0
  MarkInstall libkf5windowsystem5:amd64 < 5.44.0-0ubuntu1 -> 5.68.0-0ubuntu1 @ii umU NPb IPb > FU=0
  ignore old unsatisfied important dependency on kwayland-integration:amd64
  ignore old unsatisfied important dependency on qtwayland5:amd64
  MarkInstall libgl1-mesa-dri:i386 < 20.0.8-0ubuntu1~18.04.1 -> 20.2.6-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libllvm11 as Depends of libgl1-mesa-dri
    MarkInstall libllvm11:i386 < none -> 1:11.0.0-2~ubuntu20.04.1 @un uN > FU=0
  MarkInstall terminator:amd64 < 1.91-1 -> 1.91-4ubuntu1 @ii umU Ib > FU=0
  Installing python3-psutil as Depends of terminator
    MarkInstall python3-psutil:amd64 < none -> 5.5.1-1ubuntu4 @un uN > FU=0
  MarkInstall python-keyring:amd64 < 10.6.0-1 -> 18.0.1-2ubuntu1 @ii umU Ib > FU=0
  Installing python-entrypoints as Depends of python-keyring
    MarkInstall python-entrypoints:amd64 < none -> 0.3-2ubuntu1 @un uN Ib > FU=0
    Installing python-configparser as Depends of python-entrypoints
      MarkInstall python-configparser:amd64 < none -> 3.5.0b2-3build1 @un uN > FU=0
   Removing: python-keyrings.alt
    MarkDelete python-keyrings.alt:amd64 < 3.0-1 @ii mK > FU=0
  MarkInstall libwine-development:amd64 < 3.6-1 -> 5.5-3ubuntu1 @ii umU Ib > FU=0
  Installing libfaudio0 as Depends of libwine-development
    MarkInstall libfaudio0:amd64 < none -> 20.04-2 @un uN Ib > FU=0
    Installing libstb0 as Depends of libfaudio0
      MarkInstall libstb0:amd64 < none -> 0.0~git20190817.1.052dce1-1 @un uN > FU=0
  Installing libvkd3d1 as Depends of libwine-development
    MarkInstall libvkd3d1:amd64 < none -> 1.1-4 @un uN > FU=0
  MarkInstall libwine-development:i386 < 3.6-1 -> 5.5-3ubuntu1 @ii umU Ib > FU=0
  Installing libncurses6 as Depends of libwine-development
    MarkInstall libncurses6:i386 < none -> 6.2-0ubuntu2 @un uN > FU=0
  Installing libfaudio0 as Depends of libwine-development
    MarkInstall libfaudio0:i386 < none -> 20.04-2 @un uN Ib > FU=0
    Installing libavcodec58 as Depends of libfaudio0
      MarkInstall libavcodec58:i386 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
      Installing libaom0 as Depends of libavcodec58
        MarkInstall libaom0:i386 < none -> 1.0.0.errata1-3build1 @un uN > FU=0
      Installing libavutil56 as Depends of libavcodec58
        MarkInstall libavutil56:i386 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
        Installing libva-drm2 as Depends of libavutil56
          MarkInstall libva-drm2:i386 < none -> 2.7.0-2 @un uN Ib > FU=0
          Installing libva2 as Depends of libva-drm2
            MarkInstall libva2:i386 < none -> 2.7.0-2 @un uN IPb > FU=0
            Installing va-driver-all as Recommends of libva2
              MarkInstall va-driver-all:i386 < none -> 2.7.0-2 @un uN Ib > FU=0
              Installing i965-va-driver as Depends of va-driver-all
                MarkInstall i965-va-driver:i386 < none -> 2.4.0-0ubuntu1 @un uN > FU=0
              Installing intel-media-va-driver as Depends of va-driver-all
                MarkInstall intel-media-va-driver:i386 < none -> 20.1.1+dfsg1-1 @un uN Ib > FU=0
                Installing libigdgmm11 as Depends of intel-media-va-driver
                  MarkInstall libigdgmm11:i386 < none -> 20.1.1+ds1-1 @un uN > FU=0
              Installing mesa-va-drivers as Depends of va-driver-all
                MarkInstall mesa-va-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN > FU=0
        Installing libva-x11-2 as Depends of libavutil56
          MarkInstall libva-x11-2:i386 < none -> 2.7.0-2 @un uN > FU=0
        Installing libvdpau1 as Depends of libavutil56
          MarkInstall libvdpau1:i386 < none -> 1.3-1ubuntu2 @un uN IPb > FU=0
          Installing vdpau-driver-all as Recommends of libvdpau1
            MarkInstall vdpau-driver-all:i386 < none -> 1.3-1ubuntu2 @un uN Ib > FU=0
            Installing mesa-vdpau-drivers as Depends of vdpau-driver-all
              MarkInstall mesa-vdpau-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN > FU=0
      Installing libcodec2-0.9 as Depends of libavcodec58
        MarkInstall libcodec2-0.9:i386 < none -> 0.9.2-2 @un uN > FU=0
      Installing libmp3lame0 as Depends of libavcodec58
        MarkInstall libmp3lame0:i386 < none -> 3.100-3 @un uN > FU=0
      Installing libopenjp2-7 as Depends of libavcodec58
        MarkInstall libopenjp2-7:i386 < none -> 2.3.1-1ubuntu4.20.04.1 @un uN > FU=0
      Installing librsvg2-2 as Depends of libavcodec58
        MarkInstall librsvg2-2:i386 < none -> 2.48.9-1ubuntu0.20.04.1 @un uN Ib > FU=0
        Installing libcairo-gobject2 as Depends of librsvg2-2
          MarkInstall libcairo-gobject2:i386 < none -> 1.16.0-4ubuntu1 @un uN > FU=0
        Installing libgdk-pixbuf2.0-0 as Depends of librsvg2-2
          MarkInstall libgdk-pixbuf2.0-0:i386 < none -> 2.40.0+dfsg-3ubuntu0.2 @un uN > FU=0
        Installing libpango-1.0-0 as Depends of librsvg2-2
          MarkInstall libpango-1.0-0:i386 < none -> 1.44.7-2ubuntu4 @un uN Ib > FU=0
          Installing libfribidi0 as Depends of libpango-1.0-0
            MarkInstall libfribidi0:i386 < none -> 1.0.8-2 @un uN > FU=0
          Installing libharfbuzz0b as Depends of libpango-1.0-0
            MarkInstall libharfbuzz0b:i386 < none -> 2.6.4-1ubuntu4 @un uN Ib > FU=0
            Installing libgraphite2-3 as Depends of libharfbuzz0b
              MarkInstall libgraphite2-3:i386 < none -> 1.3.13-11build1 @un uN > FU=0
          Installing libthai0 as Depends of libpango-1.0-0
            MarkInstall libthai0:i386 < none -> 0.1.28-3 @un uN Ib > FU=0
            Installing libdatrie1 as Depends of libthai0
              MarkInstall libdatrie1:i386 < none -> 0.2.12-3 @un uN > FU=0
        Installing libpangocairo-1.0-0 as Depends of librsvg2-2
          MarkInstall libpangocairo-1.0-0:i386 < none -> 1.44.7-2ubuntu4 @un uN Ib > FU=0
          Installing libpangoft2-1.0-0 as Depends of libpangocairo-1.0-0
            MarkInstall libpangoft2-1.0-0:i386 < none -> 1.44.7-2ubuntu4 @un uN > FU=0
        Installing librsvg2-common as Recommends of librsvg2-2
          MarkInstall librsvg2-common:i386 < none -> 2.48.9-1ubuntu0.20.04.1 @un uN > FU=0
      Installing libshine3 as Depends of libavcodec58
        MarkInstall libshine3:i386 < none -> 3.1.1-2 @un uN > FU=0
      Installing libsnappy1v5 as Depends of libavcodec58
        MarkInstall libsnappy1v5:i386 < none -> 1.1.8-1build1 @un uN > FU=0
      Installing libspeex1 as Depends of libavcodec58
        MarkInstall libspeex1:i386 < none -> 1.2~rc1.2-1.1ubuntu1 @un uN > FU=0
      Installing libswresample3 as Depends of libavcodec58
        MarkInstall libswresample3:i386 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
        Installing libsoxr0 as Depends of libswresample3
          MarkInstall libsoxr0:i386 < none -> 0.1.3-2build1 @un uN Ib > FU=0
          Installing libgomp1 as Depends of libsoxr0
            MarkInstall libgomp1:i386 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
      Installing libtwolame0 as Depends of libavcodec58
        MarkInstall libtwolame0:i386 < none -> 0.4.0-2 @un uN > FU=0
      Installing libvpx6 as Depends of libavcodec58
        MarkInstall libvpx6:i386 < none -> 1.8.2-1build1 @un uN > FU=0
      Installing libwavpack1 as Depends of libavcodec58
        MarkInstall libwavpack1:i386 < none -> 5.2.0-1ubuntu0.1 @un uN > FU=0
      Installing libwebpmux3 as Depends of libavcodec58
        MarkInstall libwebpmux3:i386 < none -> 0.6.1-2ubuntu0.20.04.1 @un uN > FU=0
      Installing libx264-155 as Depends of libavcodec58
        MarkInstall libx264-155:i386 < none -> 2:0.155.2917+git0a84d98-2 @un uN > FU=0
      Installing libx265-179 as Depends of libavcodec58
        MarkInstall libx265-179:i386 < none -> 3.2.1-1build1 @un uN Ib > FU=0
        Installing libnuma1 as Depends of libx265-179
          MarkInstall libnuma1:i386 < none -> 2.0.12-1 @un uN > FU=0
      Installing libxvidcore4 as Depends of libavcodec58
        MarkInstall libxvidcore4:i386 < none -> 2:1.3.7-1 @un uN > FU=0
      Installing libzvbi0 as Depends of libavcodec58
        MarkInstall libzvbi0:i386 < none -> 0.2.35-17 @un uN > FU=0
    Installing libstb0 as Depends of libfaudio0
      MarkInstall libstb0:i386 < none -> 0.0~git20190817.1.052dce1-1 @un uN > FU=0
  Installing libvkd3d1 as Depends of libwine-development
    MarkInstall libvkd3d1:i386 < none -> 1.1-4 @un uN > FU=0
  new important dependency: gstreamer1.0-plugins-good:i386
  Installing gstreamer1.0-plugins-good as Recommends of libwine-development
    MarkInstall gstreamer1.0-plugins-good:i386 < none -> 1.16.2-1ubuntu2.1 @un uN Ib > FU=0
    Installing libaa1 as Depends of gstreamer1.0-plugins-good
      MarkInstall libaa1:i386 < none -> 1.4p5-46 @un uN Ib > FU=0
      Installing libslang2 as Depends of libaa1
        MarkInstall libslang2:i386 < none -> 2.3.2-4 @un uN > FU=0
    Installing libavc1394-0 as Depends of gstreamer1.0-plugins-good
      MarkInstall libavc1394-0:i386 < none -> 0.5.4-5 @un uN Ib > FU=0
      Installing libraw1394-11 as Depends of libavc1394-0
        MarkInstall libraw1394-11:i386 < none -> 2.1.2-1 @un uN > FU=0
    Installing libcaca0 as Depends of gstreamer1.0-plugins-good
      MarkInstall libcaca0:i386 < none -> 0.99.beta19-2.1ubuntu1.20.04.1 @un uN Ib > FU=0
      Installing libncursesw6 as Depends of libcaca0
        MarkInstall libncursesw6:i386 < none -> 6.2-0ubuntu2 @un uN > FU=0
    Installing libdv4 as Depends of gstreamer1.0-plugins-good
      MarkInstall libdv4:i386 < none -> 1.0.0-12 @un uN > FU=0
    Installing libgstreamer-plugins-good1.0-0 as Depends of gstreamer1.0-plugins-good
      MarkInstall libgstreamer-plugins-good1.0-0:i386 < none -> 1.16.2-1ubuntu2.1 @un uN > FU=0
    Installing libgudev-1.0-0 as Depends of gstreamer1.0-plugins-good
      MarkInstall libgudev-1.0-0:i386 < none -> 1:233-1 @un uN > FU=0
    Installing libiec61883-0 as Depends of gstreamer1.0-plugins-good
      MarkInstall libiec61883-0:i386 < none -> 1.2.0-3 @un uN > FU=0
    Installing libshout3 as Depends of gstreamer1.0-plugins-good
      MarkInstall libshout3:i386 < none -> 2.4.3-1 @un uN > FU=0
    Installing libsoup2.4-1 as Depends of gstreamer1.0-plugins-good
      MarkInstall libsoup2.4-1:i386 < none -> 2.70.0-1 @un uN Ib > FU=0
      Installing glib-networking as Depends of libsoup2.4-1
        MarkInstall glib-networking:i386 < none -> 2.64.2-1ubuntu0.1 @un uN Ib > FU=0
        Installing libproxy1v5 as Depends of glib-networking
          MarkInstall libproxy1v5:i386 < none -> 0.4.15-10ubuntu1.2 @un uN > FU=0
    Installing libtag1v5 as Depends of gstreamer1.0-plugins-good
      MarkInstall libtag1v5:i386 < none -> 1.11.1+dfsg.1-0.3ubuntu2 @un uN Ib > FU=0
      Installing libtag1v5-vanilla as Depends of libtag1v5
        MarkInstall libtag1v5-vanilla:i386 < none -> 1.11.1+dfsg.1-0.3ubuntu2 @un uN Ib > FU=0
        Installing libicu66 as Depends of libtag1v5-vanilla
          MarkInstall libicu66:i386 < none -> 66.1-2ubuntu2 @un uN > FU=0
    Installing gstreamer1.0-x as Recommends of gstreamer1.0-plugins-good
      MarkInstall gstreamer1.0-x:i386 < none -> 1.16.2-4ubuntu0.1 @un uN Ib > FU=0
      Installing libxv1 as Depends of gstreamer1.0-x
        MarkInstall libxv1:i386 < none -> 2:1.0.11-1 @un uN > FU=0
  MarkInstall openssh-client:amd64 < 1:7.6p1-4ubuntu0.3 -> 1:8.2p1-4ubuntu0.2 @ii umU Ib > FU=0
  Installing libfido2-1 as Depends of openssh-client
    MarkInstall libfido2-1:amd64 < none -> 1.3.1-1ubuntu2 @un uN Ib > FU=0
    Installing libcbor0.6 as Depends of libfido2-1
      MarkInstall libcbor0.6:amd64 < none -> 0.6.0-0ubuntu1 @un uN > FU=0
  MarkInstall libqt4-sql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
  Installing libqtcore4 as Depends of libqt4-sql
      MarkKeep libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > FU=0
  MarkInstall liblouisutdml-bin:amd64 < 2.7.0-1 -> 2.8.0-3 @ii umU Ib > FU=0
  Installing liblouisutdml9 as Depends of liblouisutdml-bin
    MarkInstall liblouisutdml9:amd64 < none -> 2.8.0-3 @un uN > FU=0
    MarkKeep opam-docs:amd64 < 1.2.2-6 @ii mR > FU=0
  MarkInstall libphonon4qt5-4:amd64 < 4:4.10.0-2 -> 4:4.11.1-3build1 @ii umU Ib > FU=0
  Installing libphonon4qt5-data as Depends of libphonon4qt5-4
    MarkInstall libphonon4qt5-data:amd64 < none -> 4:4.11.1-3build1 @un uN > FU=0
  MarkInstall desktop-base:amd64 < 8.0.2ubuntu1 -> 10.0.3ubuntu1 @ii umU Ib > FU=0
  Installing fonts-quicksand as Depends of desktop-base
    MarkInstall fonts-quicksand:amd64 < none -> 0.2016-2 @un uN > FU=0
  MarkInstall qtbase5-dev:amd64 < 5.9.5+dfsg-0ubuntu2.5 -> 5.12.8+dfsg-0ubuntu1 @ii umU Ib > FU=0
  Installing libvulkan-dev as Depends of qtbase5-dev
    MarkInstall libvulkan-dev:amd64 < none -> 1.2.131.2-1 @un uN > FU=0
    MarkKeep libboost-locale1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall cups-filters-core-drivers:amd64 < 1.20.2-0ubuntu3.1 -> 1.27.4-1 @ii umU Ib > FU=0
  Installing libpoppler-cpp0v5 as Depends of cups-filters-core-drivers
    MarkInstall libpoppler-cpp0v5:amd64 < none -> 0.86.1-0ubuntu1 @un uN > FU=0
    MarkKeep libboost-atomic1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall liboctomap-dev:amd64 < 1.8.1+dfsg-1 -> 1.9.3+dfsg-2 @ii umU Ib > FU=0
  Installing liboctomap1.9 as Depends of liboctomap-dev
    MarkInstall liboctomap1.9:amd64 < none -> 1.9.3+dfsg-2 @un uN > FU=0
   Removing: liboctomap1.8
    MarkDelete liboctomap1.8:amd64 < 1.8.1+dfsg-1 @ii mK > FU=0
  MarkInstall ibus:amd64 < 1.5.17-3ubuntu5.3 -> 1.5.22-2ubuntu2.1 @ii umU Ib > FU=0
  Installing ibus-data as Depends of ibus
    MarkInstall ibus-data:amd64 < none -> 1.5.22-2ubuntu2.1 @un uN > FU=0
  Installing python3-ibus-1.0 as Depends of ibus
    MarkInstall python3-ibus-1.0:amd64 < none -> 1.5.22-2ubuntu2.1 @un uN > FU=0
  MarkInstall gstreamer1.0-libav:amd64 < 1.14.5-0ubuntu1~18.04.1 -> 1.16.2-2 @ii umU Ib > FU=0
  Installing libavfilter7 as Depends of gstreamer1.0-libav
    MarkInstall libavfilter7:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
    Installing liblilv-0-0 as Depends of libavfilter7
      MarkInstall liblilv-0-0:amd64 < none -> 0.24.6-1ubuntu0.1 @un uN Ib > FU=0
      Installing libserd-0-0 as Depends of liblilv-0-0
        MarkInstall libserd-0-0:amd64 < none -> 0.30.2-1 @un uN > FU=0
      Installing libsord-0-0 as Depends of liblilv-0-0
        MarkInstall libsord-0-0:amd64 < none -> 0.16.4-1 @un uN > FU=0
      Installing libsratom-0-0 as Depends of liblilv-0-0
        MarkInstall libsratom-0-0:amd64 < none -> 0.6.4-1 @un uN > FU=0
    Installing libmysofa1 as Depends of libavfilter7
      MarkInstall libmysofa1:amd64 < none -> 1.0~dfsg0-1 @un uN > FU=0
    Installing libpostproc55 as Depends of libavfilter7
      MarkInstall libpostproc55:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
    Installing libvidstab1.1 as Depends of libavfilter7
      MarkInstall libvidstab1.1:amd64 < none -> 1.1.0-2 @un uN > FU=0
  MarkInstall libtinyxml2-dev:amd64 < 6.0.0+dfsg-1 -> 7.0.0+dfsg-1build1 @ii umU Ib > FU=0
  Installing libtinyxml2-6a as Depends of libtinyxml2-dev
    MarkInstall libtinyxml2-6a:amd64 < none -> 7.0.0+dfsg-1build1 @un uN Ib > FU=0
     Removing: libtinyxml2-6
      MarkDelete libtinyxml2-6:amd64 < 6.0.0+dfsg-1 @ii mK > FU=0
  MarkInstall ubuntu-wallpapers:amd64 < 18.04.1-0ubuntu1 -> 20.04.2-0ubuntu1 @ii umU Ib > FU=0
  Installing ubuntu-wallpapers-focal as Depends of ubuntu-wallpapers
    MarkInstall ubuntu-wallpapers-focal:amd64 < none -> 20.04.2-0ubuntu1 @un uN > FU=0
  MarkInstall emacs25-el:amd64 < 25.2+1-6 @ii mK Ib > FU=0
  Installing emacs25-common as Depends of emacs25-el
      MarkKeep emacs25-common:amd64 < 25.2+1-6 @ii mR > FU=0
  MarkInstall libcupsppdc1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
  MarkInstall texlive-binaries:amd64 < 2017.20170613.44572-8ubuntu0.1 -> 2019.20190605.51237-3build2 @ii umU Ib > FU=0
  Installing libtexlua53 as Depends of texlive-binaries
    MarkInstall libtexlua53:amd64 < none -> 2019.20190605.51237-3build2 @un uN > FU=0
  Installing libteckit0 as Depends of texlive-binaries
    MarkInstall libteckit0:amd64 < none -> 2.5.8+ds2-5ubuntu2 @un uN > FU=0
  new important dependency: dvisvgm:amd64
  Installing dvisvgm as Recommends of texlive-binaries
    MarkInstall dvisvgm:amd64 < none -> 2.8.1-1build1 @un uN > FU=0
  MarkInstall fwupd:amd64 < 1.2.10-1ubuntu2~ubuntu18.04.5 -> 1.3.11-1~focal1 @ii umU Ib > FU=0
  Installing libfwupdplugin1 as Depends of fwupd
    MarkInstall libfwupdplugin1:amd64 < none -> 1.3.11-1~focal1 @un uN > FU=0
  MarkInstall libboost-python-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-python1.71-dev as Depends of libboost-python-dev
    MarkInstall libboost-python1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
     Removing: libboost-python1.65-dev
      MarkDelete libboost-python1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
  MarkInstall konsole-kpart:amd64 < 4:17.12.3-1ubuntu1 -> 4:19.12.3-0ubuntu1 @ii umU Ib > FU=0
  Installing libkf5newstuff5 as Depends of konsole-kpart
    MarkInstall libkf5newstuff5:amd64 < none -> 5.68.0-0ubuntu2 @un uN Ib > FU=0
    Installing libkf5newstuff-data as Depends of libkf5newstuff5
      MarkInstall libkf5newstuff-data:amd64 < none -> 5.68.0-0ubuntu2 @un uN > FU=0
    Installing libkf5newstuffcore5 as Depends of libkf5newstuff5
      MarkInstall libkf5newstuffcore5:amd64 < none -> 5.68.0-0ubuntu2 @un uN > FU=0
    Installing qml-module-org-kde-newstuff as Depends of libkf5newstuff5
      MarkInstall qml-module-org-kde-newstuff:amd64 < none -> 5.68.0-0ubuntu2 @un uN > FU=0
  MarkInstall libedata-book-1.2-25:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib > FU=0
    MarkKeep libboost-date-time1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall ros-melodic-transmission-interface:amd64 < 0.18.3-1bionic.20210505.021106 @ii mK Ib > FU=0
  Installing libtinyxml2-6 as Depends of ros-melodic-transmission-interface
      MarkKeep libtinyxml2-6:amd64 < 6.0.0+dfsg-1 @ii mR > FU=0
    MarkKeep uno-libs3:amd64 < 6.0.7-0ubuntu0.18.04.10 @ii mR > FU=0
  MarkInstall gnome-shell:amd64 < 3.28.4-0ubuntu18.04.7 -> 3.36.9-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing gir1.2-mutter-6 as Depends of gnome-shell
    MarkInstall gir1.2-mutter-6:amd64 < none -> 3.36.9-0ubuntu0.20.04.1 @un uN Ib > FU=0
    Installing libmutter-6-0 as Depends of gir1.2-mutter-6
      MarkInstall libmutter-6-0:amd64 < none -> 3.36.9-0ubuntu0.20.04.1 @un uN > FU=0
    Installing gir1.2-graphene-1.0 as Depends of gir1.2-mutter-6
      MarkInstall gir1.2-graphene-1.0:amd64 < none -> 1.10.0-1build2 @un uN > FU=0
  new important dependency: switcheroo-control:amd64
  Installing switcheroo-control as Recommends of gnome-shell
    MarkInstall switcheroo-control:amd64 < none -> 2.1-1 @un uN > FU=0
  MarkInstall libedata-cal-1.2-28:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib > FU=0
  MarkInstall libboost-stacktrace-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-stacktrace1.71-dev as Depends of libboost-stacktrace-dev
    MarkInstall libboost-stacktrace1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
    Installing libboost-stacktrace1.71.0 as Depends of libboost-stacktrace1.71-dev
      MarkInstall libboost-stacktrace1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
     Removing: libboost-stacktrace1.65-dev
      MarkDelete libboost-stacktrace1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
  MarkInstall python-pyqt5:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib > FU=0
    MarkKeep libhdf5-openmpi-100:amd64 < 1.10.0-patch1+docs-4 @ii mR > FU=0
  MarkInstall duplicity:amd64 < 0.7.17-0ubuntu1.1 -> 0.8.11.1612-1 @ii umU Ib > FU=0
  Installing librsync2 as Depends of duplicity
    MarkInstall librsync2:amd64 < none -> 2.0.2-1ubuntu1 @un uN > FU=0
  Installing python3-fasteners as Depends of duplicity
    MarkInstall python3-fasteners:amd64 < none -> 0.14.1-2 @un uN Ib > FU=0
    Installing python3-monotonic as Depends of python3-fasteners
      MarkInstall python3-monotonic:amd64 < none -> 1.5-0ubuntu2 @un uN > FU=0
  Installing python3-future as Depends of duplicity
    MarkInstall python3-future:amd64 < none -> 0.18.2-2 @un uN > FU=0
  Installing python3-lockfile as Depends of duplicity
    MarkInstall python3-lockfile:amd64 < none -> 1:0.12.2-2ubuntu2 @un uN > FU=0
  new important dependency: python3-paramiko:amd64
  Installing python3-paramiko as Recommends of duplicity
    MarkInstall python3-paramiko:amd64 < none -> 2.6.0-2 @un uN Ib > FU=0
    Installing python3-bcrypt as Depends of python3-paramiko
      MarkInstall python3-bcrypt:amd64 < none -> 3.1.7-2ubuntu1 @un uN > FU=0
  MarkInstall vlc-plugin-base:amd64 < 3.0.8-0ubuntu18.04.1 -> 3.0.9.2-1 @ii umU Ib > FU=0
  Installing libixml10 as Depends of vlc-plugin-base
    MarkInstall libixml10:amd64 < none -> 1:1.8.4-2ubuntu2 @un uN > FU=0
  Installing liblivemedia77 as Depends of vlc-plugin-base
    MarkInstall liblivemedia77:amd64 < none -> 2020.01.19-1build1 @un uN > FU=0
  Installing libprotobuf-lite17 as Depends of vlc-plugin-base
    MarkInstall libprotobuf-lite17:amd64 < none -> 3.6.1.3-2ubuntu5 @un uN > FU=0
  Installing libspatialaudio0 as Depends of vlc-plugin-base
    MarkInstall libspatialaudio0:amd64 < none -> 0.3.0+git20180730+dfsg1-2build1 @un uN > FU=0
  Installing libsrt1 as Depends of vlc-plugin-base
    MarkInstall libsrt1:amd64 < none -> 1.4.0-1build1 @un uN > FU=0
  Installing libupnp13 as Depends of vlc-plugin-base
    MarkInstall libupnp13:amd64 < none -> 1:1.8.4-2ubuntu2 @un uN > FU=0
  MarkInstall libreoffice-gnome:amd64 < 1:6.0.7-0ubuntu0.18.04.10 -> 1:6.4.7-0ubuntu0.20.04.1 @ii umU IPb > FU=0
  new important dependency: libreoffice-style-elementary:amd64
  Installing libreoffice-style-elementary as Recommends of libreoffice-gnome
    MarkInstall libreoffice-style-elementary:amd64 < none -> 1:6.4.7-0ubuntu0.20.04.1 @un uN > FU=0
    MarkKeep libogdi3.2:amd64 < 3.2.0+ds-2 @ii mR > FU=0
  MarkInstall libopencv-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Installing libopencv4.2-java as Depends of libopencv-dev
    MarkInstall libopencv4.2-java:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
    Installing libopencv4.2-jni as Depends of libopencv4.2-java
      MarkInstall libopencv4.2-jni:amd64 < none -> 4.2.0+dfsg-5 @un uN > FU=0
     Removing: libopencv3.2-java
      MarkDelete libopencv3.2-java:amd64 < 3.2.0+dfsg-4ubuntu0.1 @ii mK > FU=0
    MarkKeep fwupdate-signed:amd64 < 12-7~ubuntu18.04.3 @ii mR > FU=0
  MarkInstall libflann-dev:amd64 < 1.9.1+dfsg-2 -> 1.9.1+dfsg-9build1 @ii umU Ib > FU=0
  Installing libhdf5-mpi-dev as Depends of libflann-dev
    MarkInstall libhdf5-mpi-dev:amd64 < none -> 1.10.4+repack-11ubuntu1 @un uN Ib > FU=0
    Installing libhdf5-openmpi-dev as Depends of libhdf5-mpi-dev
      MarkInstall libhdf5-openmpi-dev:amd64 < none -> 1.10.4+repack-11ubuntu1 @un uN Ib > FU=0
      Installing libaec-dev as Depends of libhdf5-openmpi-dev
        MarkInstall libaec-dev:amd64 < none -> 1.0.4-1 @un uN > FU=0
    MarkKeep libboost-fiber1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall isc-dhcp-client:amd64 < 4.3.5-3ubuntu7.3 -> 4.4.1-2.1ubuntu5.20.04.2 @ii umU Ib > FU=0
  Installing libdns-export1109 as Depends of isc-dhcp-client
    MarkInstall libdns-export1109:amd64 < none -> 1:9.11.16+dfsg-3~ubuntu1 @un uN Ib > FU=0
    Installing libisc-export1105 as Depends of libdns-export1109
      MarkInstall libisc-export1105:amd64 < none -> 1:9.11.16+dfsg-3~ubuntu1 @un uN > FU=0
  MarkInstall libcupscgi1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
  MarkInstall gdal-data:amd64 < 2.2.3+dfsg-2 -> 3.0.4+dfsg-1build3 @ii umU Ib > FU=0
   Removing: libgdal20
    MarkDelete libgdal20:amd64 < 2.2.3+dfsg-2 @ii mK > FU=0
    MarkKeep libsensors4:i386 < 1:3.4.0-4 @ii mR > FU=0
  MarkInstall libibverbs-dev:amd64 < 17.1-1ubuntu0.2 -> 28.0-1ubuntu1 @ii umU Ib > FU=0
  Installing libnl-3-dev as Depends of libibverbs-dev
    MarkInstall libnl-3-dev:amd64 < none -> 3.4.0-1 @un uN > FU=0
  Installing libnl-route-3-dev as Depends of libibverbs-dev
    MarkInstall libnl-route-3-dev:amd64 < none -> 3.4.0-1 @un uN > FU=0
  MarkInstall libopenmpi-dev:amd64 < 2.1.1-8 -> 4.0.3-0ubuntu1 @ii umU Ib > FU=0
  Installing libevent-dev as Depends of libopenmpi-dev
    MarkInstall libevent-dev:amd64 < none -> 2.1.11-stable-1 @un uN Ib > FU=0
    Installing libevent-extra-2.1-7 as Depends of libevent-dev
      MarkInstall libevent-extra-2.1-7:amd64 < none -> 2.1.11-stable-1 @un uN > FU=0
    Installing libevent-openssl-2.1-7 as Depends of libevent-dev
      MarkInstall libevent-openssl-2.1-7:amd64 < none -> 2.1.11-stable-1 @un uN > FU=0
  new important dependency: libcoarrays-openmpi-dev:amd64
  Installing libcoarrays-openmpi-dev as Recommends of libopenmpi-dev
    MarkInstall libcoarrays-openmpi-dev:amd64 < none -> 2.8.0-1 @un uN Ib > FU=0
    Installing libcaf-openmpi-3 as Depends of libcoarrays-openmpi-dev
      MarkInstall libcaf-openmpi-3:amd64 < none -> 2.8.0-1 @un uN > FU=0
    Installing libcoarrays-dev as Depends of libcoarrays-openmpi-dev
      MarkInstall libcoarrays-dev:amd64 < none -> 2.8.0-1 @un uN > FU=0
  MarkInstall libboost-tools-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost1.71-tools-dev as Depends of libboost-tools-dev
    MarkInstall libboost1.71-tools-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
     Removing: libboost1.65-tools-dev
      MarkDelete libboost1.65-tools-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
  MarkInstall libboost-type-erasure-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-type-erasure1.71-dev as Depends of libboost-type-erasure-dev
    MarkInstall libboost-type-erasure1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
    Installing libboost-type-erasure1.71.0 as Depends of libboost-type-erasure1.71-dev
      MarkInstall libboost-type-erasure1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
     Removing: libboost-type-erasure1.65-dev
      MarkDelete libboost-type-erasure1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
  MarkInstall initramfs-tools-core:amd64 < 0.130ubuntu3.12 -> 0.136ubuntu6.5 @ii umU Ib > FU=0
  Installing lz4 as Depends of initramfs-tools-core
    MarkInstall lz4:amd64 < none -> 1.9.2-2ubuntu0.20.04.1 @un uN > FU=0
  MarkInstall libboost-coroutine-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-coroutine1.71-dev as Depends of libboost-coroutine-dev
    MarkInstall libboost-coroutine1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
    Installing libboost-coroutine1.71.0 as Depends of libboost-coroutine1.71-dev
      MarkInstall libboost-coroutine1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
     Removing: libboost-coroutine1.65-dev
      MarkDelete libboost-coroutine1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
    MarkKeep libboost-regex1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall python3-bs4:amd64 < 4.6.0-1 -> 4.8.2-1 @ii umU Ib > FU=0
  Installing python3-soupsieve as Depends of python3-bs4
    MarkInstall python3-soupsieve:amd64 < none -> 1.9.5+dfsg-1 @un uN > FU=0
    MarkKeep libopencv3.2-java:amd64 < 3.2.0+dfsg-4ubuntu0.1 @ii mR > FU=0
    MarkKeep libboost-filesystem1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
    MarkKeep libldb1:amd64 < 2:1.2.3-1ubuntu0.2 @ii mR > FU=0
    MarkKeep libfwup1:amd64 < 12-3bionic2 @ii mR > FU=0
    MarkKeep libboost-iostreams1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
    MarkKeep libgdal20:amd64 < 2.2.3+dfsg-2 @ii mR > FU=0
    MarkKeep libboost-graph1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
    MarkKeep libboost-coroutine1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
    MarkKeep libboost-mpi-python1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
    MarkKeep libapt-pkg5.0:amd64 < 1.6.13 @ii mR > FU=0
  Ignore MarkInstall of python:amd64 < 2.7.15~rc1-1 @ii pgR > as its mode (Delete) is protected
    MarkKeep libboost-program-options1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
    MarkKeep libboost-exception1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
    MarkKeep libboost-python1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
    MarkKeep python-keyrings.alt:amd64 < 3.0-1 @ii mR > FU=0
    MarkKeep libboost-stacktrace1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
    MarkKeep liboctomap1.8:amd64 < 1.8.1+dfsg-1 @ii mR > FU=0
    MarkKeep libboost1.65-tools-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
    MarkKeep libboost-type-erasure1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
Starting pkgProblemResolver with broken count: 76
Starting 2 pkgProblemResolver with broken count: 76
Investigating (0) dpkg:amd64 < 1.19.0.5ubuntu2.3 -> 1.19.7ubuntu3 @ii umU Ib >
Broken dpkg:amd64 Breaks on libapt-pkg5.0:amd64 < 1.6.13 @ii mK > (< 1.7~b)
  Considering libapt-pkg5.0:amd64 -2 as a solution to dpkg:amd64 5983
  Added libapt-pkg5.0:amd64 to the remove list
  Fixing dpkg:amd64 via remove of libapt-pkg5.0:amd64
  MarkDelete libapt-pkg5.0:amd64 < 1.6.13 @ii mK > FU=0
Investigating (0) libqt5core5a:amd64 < 5.9.5+dfsg-0ubuntu2.5 -> 5.12.8+dfsg-0ubuntu1 @ii umU Ib >
Broken libqt5core5a:amd64 Breaks on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK > (< 4:4.8.7+dfsg-20~)
  Considering libqtcore4:amd64 128 as a solution to libqt5core5a:amd64 1302
  Added libqtcore4:amd64 to the remove list
  Fixing libqt5core5a:amd64 via remove of libqtcore4:amd64
  MarkDelete libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK > FU=0
Investigating (0) libgcc1:amd64 < 1:8.4.0-1ubuntu1~18.04 -> 1:10.2.0-5ubuntu1~20.04 @ii umU Ib >
Broken libgcc1:amd64 Conflicts on libgcc1:i386 < 1:8.4.0-1ubuntu1~18.04 -> 1:10.2.0-5ubuntu1~20.04 @ii umU Ib >
  Considering libgcc1:i386 4 as a solution to libgcc1:amd64 1008
  Added libgcc1:i386 to the remove list
  Conflicts//Breaks against version 1:10-20200411-0ubuntu1 for libgcc1 but that is not InstVer, ignoring
  Conflicts//Breaks against version 1:8.4.0-1ubuntu1~18.04 for libgcc1 but that is not InstVer, ignoring
  Fixing libgcc1:amd64 via remove of libgcc1:i386
  MarkDelete libgcc1:i386 < 1:8.4.0-1ubuntu1~18.04 -> 1:10.2.0-5ubuntu1~20.04 @ii umU Ib > FU=0
Investigating (0) libuno-sal3:amd64 < none -> 1:6.4.7-0ubuntu0.20.04.1 @un uN Ib >
Broken libuno-sal3:amd64 Breaks on uno-libs3:amd64 < 6.0.7-0ubuntu0.18.04.10 @ii mK >
  Considering uno-libs3:amd64 -8 as a solution to libuno-sal3:amd64 108
  Added uno-libs3:amd64 to the remove list
  Fixing libuno-sal3:amd64 via remove of uno-libs3:amd64
  MarkDelete uno-libs3:amd64 < 6.0.7-0ubuntu0.18.04.10 @ii mK > FU=0
Investigating (0) libboost1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost1.71-dev:amd64 Conflicts on libboost1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK >
  Considering libboost1.65-dev:amd64 28 as a solution to libboost1.71-dev:amd64 62
  Added libboost1.65-dev:amd64 to the remove list
  Fixing libboost1.71-dev:amd64 via remove of libboost1.65-dev:amd64
  MarkDelete libboost1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
Investigating (0) libtinyxml2-6a:amd64 < none -> 7.0.0+dfsg-1build1 @un uN Ib >
Broken libtinyxml2-6a:amd64 Conflicts on libtinyxml2-6:amd64 < 6.0.0+dfsg-1 @ii mK >
  Considering libtinyxml2-6:amd64 74 as a solution to libtinyxml2-6a:amd64 57
  MarkKeep libtinyxml2-6a:amd64 < none -> 7.0.0+dfsg-1build1 @un uN Ib > FU=0
  Holding Back libtinyxml2-6a:amd64 rather than change libtinyxml2-6:amd64
Investigating (0) python2-minimal:amd64 < none -> 2.7.17-2ubuntu4 @un umN Ib >
Broken python2-minimal:amd64 Breaks on python-minimal:amd64 < 2.7.15~rc1-1 @ii gK > (< 2.7.15-2)
  Considering python-minimal:amd64 -3 as a solution to python2-minimal:amd64 46
  Added python-minimal:amd64 to the remove list
  Fixing python2-minimal:amd64 via remove of python-minimal:amd64
  MarkDelete python-minimal:amd64 < 2.7.15~rc1-1 @ii gK > FU=0
Investigating (0) libpython2-stdlib:amd64 < none -> 2.7.17-2ubuntu4 @un umN Ib >
Broken libpython2-stdlib:amd64 Breaks on libpython-stdlib:amd64 < 2.7.15~rc1-1 @ii gK > (< 2.7.15-2)
  Considering libpython-stdlib:amd64 -3 as a solution to libpython2-stdlib:amd64 46
  Added libpython-stdlib:amd64 to the remove list
  Fixing libpython2-stdlib:amd64 via remove of libpython-stdlib:amd64
  MarkDelete libpython-stdlib:amd64 < 2.7.15~rc1-1 @ii gK > FU=0
Investigating (0) libqtgui4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqtgui4:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 128 as a solution to libqtgui4:amd64 40
  Removing libqtgui4:amd64 rather than change libqtcore4:amd64
  MarkDelete libqtgui4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libpyside1.2:amd64 < 1.2.2+source1-3 @ii mK Ib >
Broken libpyside1.2:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.7.0)
  Considering libqtcore4:amd64 128 as a solution to libpyside1.2:amd64 26
  Removing libpyside1.2:amd64 rather than change libqtcore4:amd64
  MarkDelete libpyside1.2:amd64 < 1.2.2+source1-3 @ii mK Ib > FU=0
Investigating (0) libqt4-declarative:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-declarative:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 128 as a solution to libqt4-declarative:amd64 24
  Removing libqt4-declarative:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-declarative:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) emacsen-common:amd64 < 2.0.8 -> 3.0.4 @ii umU Ib >
Broken emacsen-common:amd64 Conflicts on emacs25-common:amd64 < 25.2+1-6 @ii mK >
  Considering emacs25-common:amd64 -1 as a solution to emacsen-common:amd64 22
  Added emacs25-common:amd64 to the remove list
  Fixing emacsen-common:amd64 via remove of emacs25-common:amd64
  MarkDelete emacs25-common:amd64 < 25.2+1-6 @ii mK > FU=0
Investigating (0) qt-at-spi:amd64 < 0.4.0-8 @ii mK Ib >
Broken qt-at-spi:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.8~)
  Considering libqtcore4:amd64 128 as a solution to qt-at-spi:amd64 21
  Removing qt-at-spi:amd64 rather than change libqtcore4:amd64
  MarkDelete qt-at-spi:amd64 < 0.4.0-8 @ii mK Ib > FU=0
Investigating (0) python-pyqt5:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib >
Broken python-pyqt5:amd64 Depends on qtbase-abi-5-9-5:amd64 < none @un H >
  Considering libqt5core5a:amd64 1302 as a solution to python-pyqt5:amd64 21
  Removing python-pyqt5:amd64 rather than change qtbase-abi-5-9-5:amd64
  MarkDelete python-pyqt5:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib > FU=0
Investigating (0) python-pyqt5.qtsvg:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib >
Broken python-pyqt5.qtsvg:amd64 Depends on python-pyqt5:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mR > (= 5.10.1+dfsg-1ubuntu2)
  Considering python-pyqt5:amd64 21 as a solution to python-pyqt5.qtsvg:amd64 19
  Removing python-pyqt5.qtsvg:amd64 rather than change python-pyqt5:amd64
  MarkDelete python-pyqt5.qtsvg:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib > FU=0
Investigating (0) libqtdbus4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqtdbus4:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 128 as a solution to libqtdbus4:amd64 17
  Removing libqtdbus4:amd64 rather than change libqtcore4:amd64
  MarkDelete libqtdbus4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-network:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 128 as a solution to libqt4-network:amd64 15
  Removing libqt4-network:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) python-pyside.qtcore:amd64 < 1.2.2+source1-3 @ii mK Ib >
Broken python-pyside.qtcore:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
  Considering libpyside1.2:amd64 26 as a solution to python-pyside.qtcore:amd64 13
  Removing python-pyside.qtcore:amd64 rather than change libpyside1.2:amd64
  MarkDelete python-pyside.qtcore:amd64 < 1.2.2+source1-3 @ii mK Ib > FU=0
Investigating (0) libboost-system1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-system1.71-dev:amd64 Conflicts on libboost-system1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-system1.65-dev:amd64 0 as a solution to libboost-system1.71-dev:amd64 13
  Added libboost-system1.65-dev:amd64 to the remove list
  Fixing libboost-system1.71-dev:amd64 via remove of libboost-system1.65-dev:amd64
  MarkDelete libboost-system1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libqt4-xml:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-xml:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 128 as a solution to libqt4-xml:amd64 12
  Removing libqt4-xml:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-xml:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libboost-thread1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-thread1.71-dev:amd64 Conflicts on libboost-thread1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-thread1.65-dev:amd64 -2 as a solution to libboost-thread1.71-dev:amd64 10
  Added libboost-thread1.65-dev:amd64 to the remove list
  Fixing libboost-thread1.71-dev:amd64 via remove of libboost-thread1.65-dev:amd64
  MarkDelete libboost-thread1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) gnome-settings-daemon-common:amd64 < none -> 3.36.1-0ubuntu1 @un uN Ib >
Broken gnome-settings-daemon-common:amd64 Breaks on gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3 @ii mK > (< 3.30.1.2-2~)
  Considering gnome-settings-daemon-schemas:amd64 -3 as a solution to gnome-settings-daemon-common:amd64 10
  Added gnome-settings-daemon-schemas:amd64 to the remove list
  Fixing gnome-settings-daemon-common:amd64 via remove of gnome-settings-daemon-schemas:amd64
  MarkDelete gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3 @ii mK > FU=0
Investigating (0) libboost-serialization1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-serialization1.71-dev:amd64 Conflicts on libboost-serialization1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-serialization1.65-dev:amd64 2 as a solution to libboost-serialization1.71-dev:amd64 9
  Added libboost-serialization1.65-dev:amd64 to the remove list
  Fixing libboost-serialization1.71-dev:amd64 via remove of libboost-serialization1.65-dev:amd64
  MarkDelete libboost-serialization1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) python-pyside.qtgui:amd64 < 1.2.2+source1-3 @ii mK Ib >
Broken python-pyside.qtgui:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
  Considering libpyside1.2:amd64 26 as a solution to python-pyside.qtgui:amd64 9
  Removing python-pyside.qtgui:amd64 rather than change libpyside1.2:amd64
  MarkDelete python-pyside.qtgui:amd64 < 1.2.2+source1-3 @ii mK Ib > FU=0
Investigating (0) python-dev:amd64 < 2.7.15~rc1-1 @ii gK Ib >
Broken python-dev:amd64 Depends on python:amd64 < 2.7.15~rc1-1 @ii pgR > (= 2.7.15~rc1-1)
  Considering python:amd64 2 as a solution to python-dev:amd64 8
  Added python:amd64 to the remove list
  Fixing python-dev:amd64 via keep of python:amd64
  Ignore MarkKeep of python:amd64 < 2.7.15~rc1-1 @ii pgR > as its mode (Delete) is protected
Investigating (0) libboost-date-time1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-date-time1.71-dev:amd64 Conflicts on libboost-date-time1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-date-time1.65-dev:amd64 -1 as a solution to libboost-date-time1.71-dev:amd64 8
  Added libboost-date-time1.65-dev:amd64 to the remove list
  Fixing libboost-date-time1.71-dev:amd64 via remove of libboost-date-time1.65-dev:amd64
  MarkDelete libboost-date-time1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libqt4-script:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-script:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 128 as a solution to libqt4-script:amd64 8
  Removing libqt4-script:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-script:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libboost-chrono1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-chrono1.71-dev:amd64 Conflicts on libboost-chrono1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-chrono1.65-dev:amd64 -2 as a solution to libboost-chrono1.71-dev:amd64 7
  Added libboost-chrono1.65-dev:amd64 to the remove list
  Fixing libboost-chrono1.71-dev:amd64 via remove of libboost-chrono1.65-dev:amd64
  MarkDelete libboost-chrono1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libqt4-sql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-sql:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 128 as a solution to libqt4-sql:amd64 7
  Removing libqt4-sql:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-sql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libboost-atomic1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-atomic1.71-dev:amd64 Conflicts on libboost-atomic1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-atomic1.65-dev:amd64 -2 as a solution to libboost-atomic1.71-dev:amd64 7
  Added libboost-atomic1.65-dev:amd64 to the remove list
  Fixing libboost-atomic1.71-dev:amd64 via remove of libboost-atomic1.65-dev:amd64
  MarkDelete libboost-atomic1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libhdf5-103:amd64 < none -> 1.10.4+repack-11ubuntu1 @un uN Ib >
Broken libhdf5-103:amd64 Conflicts on libhdf5-100:amd64 < 1.10.0-patch1+docs-4 @ii mK >
  Considering libhdf5-100:amd64 0 as a solution to libhdf5-103:amd64 7
  Added libhdf5-100:amd64 to the remove list
  Fixing libhdf5-103:amd64 via remove of libhdf5-100:amd64
  MarkDelete libhdf5-100:amd64 < 1.10.0-patch1+docs-4 @ii mK > FU=0
Investigating (0) python2-dev:amd64 < none -> 2.7.17-2ubuntu4 @un umN Ib >
Broken python2-dev:amd64 Breaks on python-dev:amd64 < 2.7.15~rc1-1 @ii gK Ib > (< 2.7.15-2)
  Considering python-dev:amd64 8 as a solution to python2-dev:amd64 5
  MarkKeep python2-dev:amd64 < none -> 2.7.17-2ubuntu4 @un umN Ib > FU=0
  Holding Back python2-dev:amd64 rather than change python-dev:amd64
Investigating (0) libboost-regex1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-regex1.71-dev:amd64 Conflicts on libboost-regex1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-regex1.65-dev:amd64 -2 as a solution to libboost-regex1.71-dev:amd64 5
  Added libboost-regex1.65-dev:amd64 to the remove list
  Fixing libboost-regex1.71-dev:amd64 via remove of libboost-regex1.65-dev:amd64
  MarkDelete libboost-regex1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libboost-filesystem1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-filesystem1.71-dev:amd64 Conflicts on libboost-filesystem1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-filesystem1.65-dev:amd64 -1 as a solution to libboost-filesystem1.71-dev:amd64 5
  Added libboost-filesystem1.65-dev:amd64 to the remove list
  Fixing libboost-filesystem1.71-dev:amd64 via remove of libboost-filesystem1.65-dev:amd64
  MarkDelete libboost-filesystem1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libqt4-xmlpatterns:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-xmlpatterns:amd64 Depends on libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-network:amd64 15 as a solution to libqt4-xmlpatterns:amd64 5
  Removing libqt4-xmlpatterns:amd64 rather than change libqt4-network:amd64
  MarkDelete libqt4-xmlpatterns:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libsensors-config:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib >
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii mK >
  Considering libsensors4:amd64 -2 as a solution to libsensors-config:amd64 4
  Added libsensors4:amd64 to the remove list
Broken libsensors-config:amd64 Conflicts on libsensors4:i386 < 1:3.4.0-4 @ii mK >
  Considering libsensors4:i386 -3 as a solution to libsensors-config:amd64 4
  Added libsensors4:i386 to the remove list
  Fixing libsensors-config:amd64 via remove of libsensors4:amd64
  MarkDelete libsensors4:amd64 < 1:3.4.0-4 @ii mK > FU=0
  Fixing libsensors-config:amd64 via remove of libsensors4:i386
  MarkDelete libsensors4:i386 < 1:3.4.0-4 @ii mK > FU=0
Investigating (0) libboost-test1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-test1.71-dev:amd64 Conflicts on libboost-test1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-test1.65-dev:amd64 -1 as a solution to libboost-test1.71-dev:amd64 4
  Added libboost-test1.65-dev:amd64 to the remove list
  Fixing libboost-test1.71-dev:amd64 via remove of libboost-test1.65-dev:amd64
  MarkDelete libboost-test1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib >
Broken python-dev-is-python2:amd64 Depends on python2-dev:amd64 < none | 2.7.17-2ubuntu4 @un umH >
  Considering python2-dev:amd64 5 as a solution to python-dev-is-python2:amd64 4
  Ignore MarkKeep of python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib > as its mode (Install) is protected
  Removing python-dev-is-python2:amd64 rather than change python2-dev:amd64
  Ignore MarkDelete of python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib > as its mode (Install) is protected
Investigating (0) libhdf5-openmpi-103:amd64 < none -> 1.10.4+repack-11ubuntu1 @un uN Ib >
Broken libhdf5-openmpi-103:amd64 Conflicts on libhdf5-openmpi-100:amd64 < 1.10.0-patch1+docs-4 @ii mK >
  Considering libhdf5-openmpi-100:amd64 -3 as a solution to libhdf5-openmpi-103:amd64 3
  Added libhdf5-openmpi-100:amd64 to the remove list
  Fixing libhdf5-openmpi-103:amd64 via remove of libhdf5-openmpi-100:amd64
  MarkDelete libhdf5-openmpi-100:amd64 < 1.10.0-patch1+docs-4 @ii mK > FU=0
Investigating (0) libqt4-sql-mysql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-sql-mysql:amd64 Depends on libqt4-sql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-sql:amd64 7 as a solution to libqt4-sql-mysql:amd64 3
  Removing libqt4-sql-mysql:amd64 rather than change libqt4-sql:amd64
  MarkDelete libqt4-sql-mysql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libboost-context1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-context1.71-dev:amd64 Conflicts on libboost-context1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-context1.65-dev:amd64 -1 as a solution to libboost-context1.71-dev:amd64 3
  Added libboost-context1.65-dev:amd64 to the remove list
  Fixing libboost-context1.71-dev:amd64 via remove of libboost-context1.65-dev:amd64
  MarkDelete libboost-context1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libgdcm-dev:amd64 < none -> 3.0.5-1.1ubuntu2 @un uN Ib >
Broken libgdcm-dev:amd64 Breaks on libgdcm2-dev:amd64 < 2.8.4-1build2 @ii mK >
  Considering libgdcm2-dev:amd64 -3 as a solution to libgdcm-dev:amd64 3
  Added libgdcm2-dev:amd64 to the remove list
  Fixing libgdcm-dev:amd64 via remove of libgdcm2-dev:amd64
  MarkDelete libgdcm2-dev:amd64 < 2.8.4-1build2 @ii mK > FU=0
Investigating (0) libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-dbus:amd64 Depends on libqtdbus4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtdbus4:amd64 17 as a solution to libqt4-dbus:amd64 3
  Removing libqt4-dbus:amd64 rather than change libqtdbus4:amd64
  MarkDelete libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libgdal20:amd64 < 2.2.3+dfsg-2 @ii mK Ib >
Broken libgdal20:amd64 Depends on libhdf5-100:amd64 < 1.10.0-patch1+docs-4 @ii mR >
  Considering libhdf5-100:amd64 0 as a solution to libgdal20:amd64 2
  Added libhdf5-100:amd64 to the remove list
  Fixing libgdal20:amd64 via keep of libhdf5-100:amd64
  MarkKeep libhdf5-100:amd64 < 1.10.0-patch1+docs-4 @ii mR > FU=0
Investigating (0) libqt4-opengl:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-opengl:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 128 as a solution to libqt4-opengl:amd64 2
  Removing libqt4-opengl:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-opengl:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libboost-mpi1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-mpi1.71-dev:amd64 Conflicts on libboost-mpi1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-mpi1.65-dev:amd64 -2 as a solution to libboost-mpi1.71-dev:amd64 2
  Added libboost-mpi1.65-dev:amd64 to the remove list
  Fixing libboost-mpi1.71-dev:amd64 via remove of libboost-mpi1.65-dev:amd64
  MarkDelete libboost-mpi1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) gdal-data:amd64 < 2.2.3+dfsg-2 -> 3.0.4+dfsg-1build3 @ii umU Ib >
Broken gdal-data:amd64 Breaks on libgdal20:amd64 < 2.2.3+dfsg-2 @ii mK > (< 2.5.0~)
  Considering libgdal20:amd64 2 as a solution to gdal-data:amd64 2
  MarkKeep gdal-data:amd64 < 2.2.3+dfsg-2 -> 3.0.4+dfsg-1build3 @ii umU Ib > FU=0
  Holding Back gdal-data:amd64 rather than change libgdal20:amd64
Investigating (0) libopencv4.2-java:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib >
Broken libopencv4.2-java:amd64 Breaks on libopencv3.2-java:amd64 < 3.2.0+dfsg-4ubuntu0.1 @ii mK >
  Considering libopencv3.2-java:amd64 -3 as a solution to libopencv4.2-java:amd64 2
  Added libopencv3.2-java:amd64 to the remove list
  Fixing libopencv4.2-java:amd64 via remove of libopencv3.2-java:amd64
  MarkDelete libopencv3.2-java:amd64 < 3.2.0+dfsg-4ubuntu0.1 @ii mK > FU=0
Investigating (0) qdbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken qdbus:amd64 Depends on libqt4-xml:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-xml:amd64 12 as a solution to qdbus:amd64 1
  Removing qdbus:amd64 rather than change libqt4-xml:amd64
  MarkDelete qdbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libphonon4:amd64 < 4:4.10.0-2 @ii mK Ib >
Broken libphonon4:amd64 Depends on libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.8.1)
  Considering libqt4-dbus:amd64 3 as a solution to libphonon4:amd64 1
  Removing libphonon4:amd64 rather than change libqt4-dbus:amd64
  MarkDelete libphonon4:amd64 < 4:4.10.0-2 @ii mK Ib > FU=0
Investigating (0) libboost-stacktrace1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-stacktrace1.71-dev:amd64 Conflicts on libboost-stacktrace1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-stacktrace1.65-dev:amd64 -3 as a solution to libboost-stacktrace1.71-dev:amd64 1
  Added libboost-stacktrace1.65-dev:amd64 to the remove list
  Fixing libboost-stacktrace1.71-dev:amd64 via remove of libboost-stacktrace1.65-dev:amd64
  MarkDelete libboost-stacktrace1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libboost-numpy1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-numpy1.71-dev:amd64 Conflicts on libboost-numpy1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK >
  Considering libboost-numpy1.65-dev:amd64 -3 as a solution to libboost-numpy1.71-dev:amd64 1
  Added libboost-numpy1.65-dev:amd64 to the remove list
  Fixing libboost-numpy1.71-dev:amd64 via remove of libboost-numpy1.65-dev:amd64
  MarkDelete libboost-numpy1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
Investigating (0) libboost-coroutine1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-coroutine1.71-dev:amd64 Conflicts on libboost-coroutine1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-coroutine1.65-dev:amd64 -3 as a solution to libboost-coroutine1.71-dev:amd64 1
  Added libboost-coroutine1.65-dev:amd64 to the remove list
  Fixing libboost-coroutine1.71-dev:amd64 via remove of libboost-coroutine1.65-dev:amd64
  MarkDelete libboost-coroutine1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libqt4-designer:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-designer:amd64 Depends on libqt4-script:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-script:amd64 8 as a solution to libqt4-designer:amd64 1
  Removing libqt4-designer:amd64 rather than change libqt4-script:amd64
  MarkDelete libqt4-designer:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libboost-graph-parallel1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-graph-parallel1.71-dev:amd64 Conflicts on libboost-graph-parallel1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-graph-parallel1.65-dev:amd64 -3 as a solution to libboost-graph-parallel1.71-dev:amd64 1
  Added libboost-graph-parallel1.65-dev:amd64 to the remove list
  Fixing libboost-graph-parallel1.71-dev:amd64 via remove of libboost-graph-parallel1.65-dev:amd64
  MarkDelete libboost-graph-parallel1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libhfstospell10:amd64 < none -> 0.5.0-2build2 @un uN Ib >
Broken libhfstospell10:amd64 Conflicts on libhfstospell:amd64 < none @un H >
  Considering libhfstospell9:amd64 -2 as a solution to libhfstospell10:amd64 1
  Added libhfstospell9:amd64 to the remove list
  Fixing libhfstospell10:amd64 via remove of libhfstospell9:amd64
  MarkDelete libhfstospell9:amd64 < 0.4.5~r343-2.1build2 @ii mK Ib > FU=0
Investigating (0) libboost1.71-tools-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost1.71-tools-dev:amd64 Conflicts on libboost1.65-tools-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK >
  Considering libboost1.65-tools-dev:amd64 -3 as a solution to libboost1.71-tools-dev:amd64 1
  Added libboost1.65-tools-dev:amd64 to the remove list
  Fixing libboost1.71-tools-dev:amd64 via remove of libboost1.65-tools-dev:amd64
  MarkDelete libboost1.65-tools-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
Investigating (0) libqt4-svg:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-svg:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 128 as a solution to libqt4-svg:amd64 1
  Removing libqt4-svg:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-svg:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libboost-log1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-log1.71-dev:amd64 Conflicts on libboost-log1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-log1.65-dev:amd64 -3 as a solution to libboost-log1.71-dev:amd64 1
  Added libboost-log1.65-dev:amd64 to the remove list
  Fixing libboost-log1.71-dev:amd64 via remove of libboost-log1.65-dev:amd64
  MarkDelete libboost-log1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libboost-mpi-python1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-mpi-python1.71-dev:amd64 Conflicts on libboost-mpi-python1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-mpi-python1.65-dev:amd64 -3 as a solution to libboost-mpi-python1.71-dev:amd64 1
  Added libboost-mpi-python1.65-dev:amd64 to the remove list
  Fixing libboost-mpi-python1.71-dev:amd64 via remove of libboost-mpi-python1.65-dev:amd64
  MarkDelete libboost-mpi-python1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libboost-locale1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-locale1.71-dev:amd64 Conflicts on libboost-locale1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-locale1.65-dev:amd64 -3 as a solution to libboost-locale1.71-dev:amd64 1
  Added libboost-locale1.65-dev:amd64 to the remove list
  Fixing libboost-locale1.71-dev:amd64 via remove of libboost-locale1.65-dev:amd64
  MarkDelete libboost-locale1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libqt4-scripttools:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-scripttools:amd64 Depends on libqt4-script:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-script:amd64 8 as a solution to libqt4-scripttools:amd64 1
  Removing libqt4-scripttools:amd64 rather than change libqt4-script:amd64
  MarkDelete libqt4-scripttools:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) python-pyside.qtnetwork:amd64 < 1.2.2+source1-3 @ii mK Ib >
Broken python-pyside.qtnetwork:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
  Considering libpyside1.2:amd64 26 as a solution to python-pyside.qtnetwork:amd64 1
  Removing python-pyside.qtnetwork:amd64 rather than change libpyside1.2:amd64
  MarkDelete python-pyside.qtnetwork:amd64 < 1.2.2+source1-3 @ii mK Ib > FU=0
Investigating (0) libpython2-dev:amd64 < none -> 2.7.17-2ubuntu4 @un umN Ib >
Broken libpython2-dev:amd64 Breaks on libpython-dev:amd64 < 2.7.15~rc1-1 @ii gK > (< 2.7.15-2)
  Considering libpython-dev:amd64 1 as a solution to libpython2-dev:amd64 1
  MarkKeep libpython2-dev:amd64 < none -> 2.7.17-2ubuntu4 @un umN Ib > FU=0
  Holding Back libpython2-dev:amd64 rather than change libpython-dev:amd64
Investigating (0) libboost-math1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-math1.71-dev:amd64 Conflicts on libboost-math1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-math1.65-dev:amd64 -3 as a solution to libboost-math1.71-dev:amd64 1
  Added libboost-math1.65-dev:amd64 to the remove list
  Fixing libboost-math1.71-dev:amd64 via remove of libboost-math1.65-dev:amd64
  MarkDelete libboost-math1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libldb2:amd64 < none -> 2:2.0.10-0ubuntu0.20.04.3 @un uN Ib >
Broken libldb2:amd64 Breaks on libldb1:amd64 < 2:1.2.3-1ubuntu0.2 @ii mK > (< 2:2~)
  Considering libldb1:amd64 -3 as a solution to libldb2:amd64 1
  Added libldb1:amd64 to the remove list
  Fixing libldb2:amd64 via remove of libldb1:amd64
  MarkDelete libldb1:amd64 < 2:1.2.3-1ubuntu0.2 @ii mK > FU=0
Investigating (0) libboost-timer1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-timer1.71-dev:amd64 Conflicts on libboost-timer1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-timer1.65-dev:amd64 -3 as a solution to libboost-timer1.71-dev:amd64 1
  Added libboost-timer1.65-dev:amd64 to the remove list
  Fixing libboost-timer1.71-dev:amd64 via remove of libboost-timer1.65-dev:amd64
  MarkDelete libboost-timer1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libqt4-help:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-help:amd64 Depends on libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-network:amd64 15 as a solution to libqt4-help:amd64 1
  Removing libqt4-help:amd64 rather than change libqt4-network:amd64
  MarkDelete libqt4-help:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libboost-fiber1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-fiber1.71-dev:amd64 Conflicts on libboost-fiber1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-fiber1.65-dev:amd64 -3 as a solution to libboost-fiber1.71-dev:amd64 1
  Added libboost-fiber1.65-dev:amd64 to the remove list
  Fixing libboost-fiber1.71-dev:amd64 via remove of libboost-fiber1.65-dev:amd64
  MarkDelete libboost-fiber1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libboost-iostreams1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-iostreams1.71-dev:amd64 Conflicts on libboost-iostreams1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-iostreams1.65-dev:amd64 -3 as a solution to libboost-iostreams1.71-dev:amd64 1
  Added libboost-iostreams1.65-dev:amd64 to the remove list
  Fixing libboost-iostreams1.71-dev:amd64 via remove of libboost-iostreams1.65-dev:amd64
  MarkDelete libboost-iostreams1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libqt4-test:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-test:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 128 as a solution to libqt4-test:amd64 1
  Removing libqt4-test:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-test:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) liboctomap-dev:amd64 < 1.8.1+dfsg-1 -> 1.9.3+dfsg-2 @ii umU Ib >
Broken liboctomap-dev:amd64 Conflicts on liboctomap1.8:amd64 < 1.8.1+dfsg-1 @ii mK >
  Considering liboctomap1.8:amd64 -3 as a solution to liboctomap-dev:amd64 1
  Added liboctomap1.8:amd64 to the remove list
  Fixing liboctomap-dev:amd64 via remove of liboctomap1.8:amd64
  MarkDelete liboctomap1.8:amd64 < 1.8.1+dfsg-1 @ii mK > FU=0
Investigating (0) python-keyring:amd64 < 10.6.0-1 -> 18.0.1-2ubuntu1 @ii umU Ib >
Broken python-keyring:amd64 Breaks on python-keyrings.alt:amd64 < 3.0-1 @ii mK > (< 3.1)
  Considering python-keyrings.alt:amd64 -3 as a solution to python-keyring:amd64 1
  Added python-keyrings.alt:amd64 to the remove list
  Fixing python-keyring:amd64 via remove of python-keyrings.alt:amd64
  MarkDelete python-keyrings.alt:amd64 < 3.0-1 @ii mK > FU=0
Investigating (0) libboost-program-options1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-program-options1.71-dev:amd64 Conflicts on libboost-program-options1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-program-options1.65-dev:amd64 -3 as a solution to libboost-program-options1.71-dev:amd64 1
  Added libboost-program-options1.65-dev:amd64 to the remove list
  Fixing libboost-program-options1.71-dev:amd64 via remove of libboost-program-options1.65-dev:amd64
  MarkDelete libboost-program-options1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libboost-exception1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-exception1.71-dev:amd64 Conflicts on libboost-exception1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-exception1.65-dev:amd64 -3 as a solution to libboost-exception1.71-dev:amd64 1
  Added libboost-exception1.65-dev:amd64 to the remove list
  Fixing libboost-exception1.71-dev:amd64 via remove of libboost-exception1.65-dev:amd64
  MarkDelete libboost-exception1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libboost-python1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-python1.71-dev:amd64 Conflicts on libboost-python1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-python1.65-dev:amd64 -3 as a solution to libboost-python1.71-dev:amd64 1
  Added libboost-python1.65-dev:amd64 to the remove list
  Fixing libboost-python1.71-dev:amd64 via remove of libboost-python1.65-dev:amd64
  MarkDelete libboost-python1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libboost-container1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-container1.71-dev:amd64 Conflicts on libboost-container1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-container1.65-dev:amd64 -3 as a solution to libboost-container1.71-dev:amd64 1
  Added libboost-container1.65-dev:amd64 to the remove list
  Fixing libboost-container1.71-dev:amd64 via remove of libboost-container1.65-dev:amd64
  MarkDelete libboost-container1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libboost-type-erasure1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-type-erasure1.71-dev:amd64 Conflicts on libboost-type-erasure1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-type-erasure1.65-dev:amd64 -3 as a solution to libboost-type-erasure1.71-dev:amd64 1
  Added libboost-type-erasure1.65-dev:amd64 to the remove list
  Fixing libboost-type-erasure1.71-dev:amd64 via remove of libboost-type-erasure1.65-dev:amd64
  MarkDelete libboost-type-erasure1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libboost-graph1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-graph1.71-dev:amd64 Conflicts on libboost-graph1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-graph1.65-dev:amd64 -3 as a solution to libboost-graph1.71-dev:amd64 1
  Added libboost-graph1.65-dev:amd64 to the remove list
  Fixing libboost-graph1.71-dev:amd64 via remove of libboost-graph1.65-dev:amd64
  MarkDelete libboost-graph1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libboost-random1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-random1.71-dev:amd64 Conflicts on libboost-random1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-random1.65-dev:amd64 -3 as a solution to libboost-random1.71-dev:amd64 1
  Added libboost-random1.65-dev:amd64 to the remove list
  Fixing libboost-random1.71-dev:amd64 via remove of libboost-random1.65-dev:amd64
  MarkDelete libboost-random1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libboost-wave1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-wave1.71-dev:amd64 Conflicts on libboost-wave1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-wave1.65-dev:amd64 -3 as a solution to libboost-wave1.71-dev:amd64 1
  Added libboost-wave1.65-dev:amd64 to the remove list
  Fixing libboost-wave1.71-dev:amd64 via remove of libboost-wave1.65-dev:amd64
  MarkDelete libboost-wave1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libqt4-qt3support:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-qt3support:amd64 Depends on libqt4-designer:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-designer:amd64 1 as a solution to libqt4-qt3support:amd64 0
  Removing libqt4-qt3support:amd64 rather than change libqt4-designer:amd64
  MarkDelete libqt4-qt3support:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libogdi4.1:amd64 < none -> 4.1.0+ds-1build1 @un uN Ib >
Broken libogdi4.1:amd64 Breaks on libogdi3.2:amd64 < 3.2.0+ds-2 @ii mK > (< 4.0.0)
  Considering libogdi3.2:amd64 -2 as a solution to libogdi4.1:amd64 0
  Added libogdi3.2:amd64 to the remove list
  Fixing libogdi4.1:amd64 via remove of libogdi3.2:amd64
  MarkDelete libogdi3.2:amd64 < 3.2.0+ds-2 @ii mK > FU=0
Investigating (0) opam-doc:amd64 < none -> 2.0.5-1ubuntu1 @un uN Ib >
Broken opam-doc:amd64 Breaks on opam-docs:amd64 < 1.2.2-6 @ii mK >
  Considering opam-docs:amd64 -4 as a solution to opam-doc:amd64 0
  Added opam-docs:amd64 to the remove list
  Fixing opam-doc:amd64 via remove of opam-docs:amd64
  MarkDelete opam-docs:amd64 < 1.2.2-6 @ii mK > FU=0
Investigating (0) libboost-mpi-python1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost-mpi-python1.71.0:amd64 Conflicts on libboost-mpi-python1.65.1:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
  Considering libboost-mpi-python1.65.1:amd64 -2 as a solution to libboost-mpi-python1.71.0:amd64 0
  Added libboost-mpi-python1.65.1:amd64 to the remove list
  Fixing libboost-mpi-python1.71.0:amd64 via remove of libboost-mpi-python1.65.1:amd64
  MarkDelete libboost-mpi-python1.65.1:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) python-pyside.qtxml:amd64 < 1.2.2+source1-3 @ii mK Ib >
Broken python-pyside.qtxml:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
  Considering libpyside1.2:amd64 26 as a solution to python-pyside.qtxml:amd64 0
  Removing python-pyside.qtxml:amd64 rather than change libpyside1.2:amd64
  MarkDelete python-pyside.qtxml:amd64 < 1.2.2+source1-3 @ii mK Ib > FU=0
Investigating (0) libqt4-dev:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-dev:amd64 Depends on libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-dbus:amd64 3 as a solution to libqt4-dev:amd64 0
  Removing libqt4-dev:amd64 rather than change libqt4-dbus:amd64
  MarkDelete libqt4-dev:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) fwupdate:amd64 < 12-7~ubuntu18.04.3 -> 12-7 @ii umU Ib >
Broken fwupdate:amd64 Breaks on fwupdate-signed:amd64 < 12-7~ubuntu18.04.3 @ii mK >
  Considering fwupdate-signed:amd64 -3 as a solution to fwupdate:amd64 0
  Added fwupdate-signed:amd64 to the remove list
Broken fwupdate:amd64 Breaks on libfwup1:amd64 < 12-3bionic2 @ii mK > (< 12-5)
  Considering libfwup1:amd64 -3 as a solution to fwupdate:amd64 0
  Added libfwup1:amd64 to the remove list
  Fixing fwupdate:amd64 via remove of fwupdate-signed:amd64
  MarkDelete fwupdate-signed:amd64 < 12-7~ubuntu18.04.3 @ii mK > FU=0
  Fixing fwupdate:amd64 via remove of libfwup1:amd64
  MarkDelete libfwup1:amd64 < 12-3bionic2 @ii mK > FU=0
Investigating (0) python-pyside.qttest:amd64 < 1.2.2+source1-3 @ii mK Ib >
Broken python-pyside.qttest:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
  Considering libpyside1.2:amd64 26 as a solution to python-pyside.qttest:amd64 -1
  Removing python-pyside.qttest:amd64 rather than change libpyside1.2:amd64
  MarkDelete python-pyside.qttest:amd64 < 1.2.2+source1-3 @ii mK Ib > FU=0
Investigating (0) libqt4-opengl-dev:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-opengl-dev:amd64 Depends on libqt4-dev:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-dev:amd64 0 as a solution to libqt4-opengl-dev:amd64 -1
  Removing libqt4-opengl-dev:amd64 rather than change libqt4-dev:amd64
  MarkDelete libqt4-opengl-dev:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) python-pyqt5.qtwebkit:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib >
Broken python-pyqt5.qtwebkit:amd64 Depends on python-pyqt5:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mR > (= 5.10.1+dfsg-1ubuntu2)
  Considering python-pyqt5:amd64 21 as a solution to python-pyqt5.qtwebkit:amd64 -1
  Removing python-pyqt5.qtwebkit:amd64 rather than change python-pyqt5:amd64
  MarkDelete python-pyqt5.qtwebkit:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib > FU=0
Investigating (0) qt4-linguist-tools:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken qt4-linguist-tools:amd64 Depends on libqt4-xml:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-xml:amd64 12 as a solution to qt4-linguist-tools:amd64 -1
  Removing qt4-linguist-tools:amd64 rather than change libqt4-xml:amd64
  MarkDelete qt4-linguist-tools:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) python-pyside.qtdeclarative:amd64 < 1.2.2+source1-3 @ii mK Ib >
Broken python-pyside.qtdeclarative:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
  Considering libpyside1.2:amd64 26 as a solution to python-pyside.qtdeclarative:amd64 -1
  Removing python-pyside.qtdeclarative:amd64 rather than change libpyside1.2:amd64
  MarkDelete python-pyside.qtdeclarative:amd64 < 1.2.2+source1-3 @ii mK Ib > FU=0
Investigating (0) libqtwebkit4:amd64 < 2.3.2-0ubuntu13 @ii mK Ib >
Broken libqtwebkit4:amd64 Depends on libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.7.0~beta1)
  Considering libqt4-network:amd64 15 as a solution to libqtwebkit4:amd64 -1
  Removing libqtwebkit4:amd64 rather than change libqt4-network:amd64
  MarkDelete libqtwebkit4:amd64 < 2.3.2-0ubuntu13 @ii mK Ib > FU=0
Investigating (0) phonon:amd64 < 4:4.10.0-2 @ii mK Ib >
Broken phonon:amd64 Depends on libphonon4:amd64 < 4:4.10.0-2 @ii mR > (>= 4:4.10.0-2)
  Considering libphonon4:amd64 1 as a solution to phonon:amd64 -1
  Removing phonon:amd64 rather than change libphonon4:amd64
  MarkDelete phonon:amd64 < 4:4.10.0-2 @ii mK Ib > FU=0
Investigating (0) python-pyside.qtsql:amd64 < 1.2.2+source1-3 @ii mK Ib >
Broken python-pyside.qtsql:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
  Considering libpyside1.2:amd64 26 as a solution to python-pyside.qtsql:amd64 -1
  Removing python-pyside.qtsql:amd64 rather than change libpyside1.2:amd64
  MarkDelete python-pyside.qtsql:amd64 < 1.2.2+source1-3 @ii mK Ib > FU=0
Investigating (0) libqt4-dev-bin:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-dev-bin:amd64 Depends on libqt4-qt3support:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-qt3support:amd64 0 as a solution to libqt4-dev-bin:amd64 -1
  Removing libqt4-dev-bin:amd64 rather than change libqt4-qt3support:amd64
  MarkDelete libqt4-dev-bin:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) python-pyside.qtuitools:amd64 < 1.2.2+source1-3 @ii mK Ib >
Broken python-pyside.qtuitools:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
  Considering libpyside1.2:amd64 26 as a solution to python-pyside.qtuitools:amd64 -1
  Removing python-pyside.qtuitools:amd64 rather than change libpyside1.2:amd64
  MarkDelete python-pyside.qtuitools:amd64 < 1.2.2+source1-3 @ii mK Ib > FU=0
Investigating (0) python-pyside.qthelp:amd64 < 1.2.2+source1-3 @ii mK Ib >
Broken python-pyside.qthelp:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
  Considering libpyside1.2:amd64 26 as a solution to python-pyside.qthelp:amd64 -1
  Removing python-pyside.qthelp:amd64 rather than change libpyside1.2:amd64
  MarkDelete python-pyside.qthelp:amd64 < 1.2.2+source1-3 @ii mK Ib > FU=0
Investigating (0) python-pyside.qtsvg:amd64 < 1.2.2+source1-3 @ii mK Ib >
Broken python-pyside.qtsvg:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
  Considering libpyside1.2:amd64 26 as a solution to python-pyside.qtsvg:amd64 -1
  Removing python-pyside.qtsvg:amd64 rather than change libpyside1.2:amd64
  MarkDelete python-pyside.qtsvg:amd64 < 1.2.2+source1-3 @ii mK Ib > FU=0
Investigating (0) libedata-book-1.2-25:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib >
Broken libedata-book-1.2-25:amd64 Depends on libebackend-1.2-10:amd64 < 3.28.5-0ubuntu0.18.04.3 -> 3.36.5-0ubuntu1 @ii umU > (= 3.28.5-0ubuntu0.18.04.3)
  Considering libebackend-1.2-10:amd64 7 as a solution to libedata-book-1.2-25:amd64 -1
  Removing libedata-book-1.2-25:amd64 rather than change libebackend-1.2-10:amd64
  MarkDelete libedata-book-1.2-25:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib > FU=0
Investigating (0) python-pyside.phonon:amd64 < 1.2.2+source1-3 @ii mK Ib >
Broken python-pyside.phonon:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
  Considering libpyside1.2:amd64 26 as a solution to python-pyside.phonon:amd64 -1
  Removing python-pyside.phonon:amd64 rather than change libpyside1.2:amd64
  MarkDelete python-pyside.phonon:amd64 < 1.2.2+source1-3 @ii mK Ib > FU=0
Investigating (0) python-pyside.qtwebkit:amd64 < 1.2.2+source1-3 @ii mK Ib >
Broken python-pyside.qtwebkit:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
  Considering libpyside1.2:amd64 26 as a solution to python-pyside.qtwebkit:amd64 -1
  Removing python-pyside.qtwebkit:amd64 rather than change libpyside1.2:amd64
  MarkDelete python-pyside.qtwebkit:amd64 < 1.2.2+source1-3 @ii mK Ib > FU=0
Investigating (0) libboost-signals1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib >
Broken libboost-signals1.65-dev:amd64 Depends on libboost1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > (= 1.65.1+dfsg-0ubuntu5)
  Considering libboost1.65-dev:amd64 28 as a solution to libboost-signals1.65-dev:amd64 -1
  Removing libboost-signals1.65-dev:amd64 rather than change libboost1.65-dev:amd64
  MarkDelete libboost-signals1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK Ib > FU=0
Investigating (0) libpyside-py3-1.2:amd64 < 1.2.2+source1-3 @ii mK Ib >
Broken libpyside-py3-1.2:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.7.0)
  Considering libqtcore4:amd64 128 as a solution to libpyside-py3-1.2:amd64 -1
  Removing libpyside-py3-1.2:amd64 rather than change libqtcore4:amd64
  MarkDelete libpyside-py3-1.2:amd64 < 1.2.2+source1-3 @ii mK Ib > FU=0
Investigating (0) emacs25-bin-common:amd64 < 25.2+1-6 @ii mK Ib >
Broken emacs25-bin-common:amd64 Depends on emacs25-common:amd64 < 25.2+1-6 @ii mR > (= 25.2+1-6)
  Considering emacs25-common:amd64 -1 as a solution to emacs25-bin-common:amd64 -1
  Removing emacs25-bin-common:amd64 rather than change emacs25-common:amd64
  MarkDelete emacs25-bin-common:amd64 < 25.2+1-6 @ii mK Ib > FU=0
Investigating (0) ros-melodic-webkit-dependency:amd64 < 1.1.0-0bionic.20200801.040531 @ii mK Ib >
Broken ros-melodic-webkit-dependency:amd64 Depends on python-pyqt5.qtwebkit:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mR >
  Considering python-pyqt5.qtwebkit:amd64 -1 as a solution to ros-melodic-webkit-dependency:amd64 -1
  Removing ros-melodic-webkit-dependency:amd64 rather than change python-pyqt5.qtwebkit:amd64
  MarkDelete ros-melodic-webkit-dependency:amd64 < 1.1.0-0bionic.20200801.040531 @ii mK Ib > FU=0
Investigating (0) phonon-backend-gstreamer:amd64 < 4:4.9.0-1 @ii mK Ib >
Broken phonon-backend-gstreamer:amd64 Depends on phonon-backend-gstreamer-common:amd64 < 4:4.9.0-1 -> 4:4.10.0-1build1 @ii umU > (= 4:4.9.0-1)
  Considering phonon-backend-gstreamer-common:amd64 0 as a solution to phonon-backend-gstreamer:amd64 -1
  Removing phonon-backend-gstreamer:amd64 rather than change phonon-backend-gstreamer-common:amd64
  MarkDelete phonon-backend-gstreamer:amd64 < 4:4.9.0-1 @ii mK Ib > FU=0
Investigating (0) python-pyside.qtopengl:amd64 < 1.2.2+source1-3 @ii mK Ib >
Broken python-pyside.qtopengl:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
  Considering libpyside1.2:amd64 26 as a solution to python-pyside.qtopengl:amd64 -1
  Removing python-pyside.qtopengl:amd64 rather than change libpyside1.2:amd64
  MarkDelete python-pyside.qtopengl:amd64 < 1.2.2+source1-3 @ii mK Ib > FU=0
Investigating (0) libqtassistantclient4:amd64 < 4.6.3-7build1 @ii mK Ib >
Broken libqtassistantclient4:amd64 Depends on libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.8.1)
  Considering libqt4-network:amd64 15 as a solution to libqtassistantclient4:amd64 -1
  Removing libqtassistantclient4:amd64 rather than change libqt4-network:amd64
  MarkDelete libqtassistantclient4:amd64 < 4.6.3-7build1 @ii mK Ib > FU=0
Investigating (0) emacs25-el:amd64 < 25.2+1-6 @ii mK Ib >
Broken emacs25-el:amd64 Depends on emacs25-common:amd64 < 25.2+1-6 @ii mR > (= 25.2+1-6)
  Considering emacs25-common:amd64 -1 as a solution to emacs25-el:amd64 -1
  Removing emacs25-el:amd64 rather than change emacs25-common:amd64
  MarkDelete emacs25-el:amd64 < 25.2+1-6 @ii mK Ib > FU=0
Investigating (0) python-pyside.qtscript:amd64 < 1.2.2+source1-3 @ii mK Ib >
Broken python-pyside.qtscript:amd64 Depends on libpyside1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
  Considering libpyside1.2:amd64 26 as a solution to python-pyside.qtscript:amd64 -1
  Removing python-pyside.qtscript:amd64 rather than change libpyside1.2:amd64
  MarkDelete python-pyside.qtscript:amd64 < 1.2.2+source1-3 @ii mK Ib > FU=0
Investigating (0) libcupsppdc1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib >
Broken libcupsppdc1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
  Considering libcups2:amd64 358 as a solution to libcupsppdc1:amd64 -2
  Removing libcupsppdc1:amd64 rather than change libcups2:amd64
  MarkDelete libcupsppdc1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
Investigating (0) shiboken:amd64 < 1.2.2-5 @ii mK Ib >
Broken shiboken:amd64 Depends on libqt4-xml:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.7.0)
  Considering libqt4-xml:amd64 12 as a solution to shiboken:amd64 -2
  Removing shiboken:amd64 rather than change libqt4-xml:amd64
  MarkDelete shiboken:amd64 < 1.2.2-5 @ii mK Ib > FU=0
Investigating (0) libpyside-dev:amd64 < 1.2.2+source1-3 @ii mK Ib >
Broken libpyside-dev:amd64 Depends on libpyside-py3-1.2:amd64 < 1.2.2+source1-3 @ii mR > (= 1.2.2+source1-3)
  Considering libpyside-py3-1.2:amd64 -1 as a solution to libpyside-dev:amd64 -2
  Removing libpyside-dev:amd64 rather than change libpyside-py3-1.2:amd64
  MarkDelete libpyside-dev:amd64 < 1.2.2+source1-3 @ii mK Ib > FU=0
Investigating (0) libcupscgi1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib >
Broken libcupscgi1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
  Considering libcups2:amd64 358 as a solution to libcupscgi1:amd64 -2
  Removing libcupscgi1:amd64 rather than change libcups2:amd64
  MarkDelete libcupscgi1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
Investigating (0) libcupsmime1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib >
Broken libcupsmime1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
  Considering libcups2:amd64 358 as a solution to libcupsmime1:amd64 -2
  Removing libcupsmime1:amd64 rather than change libcups2:amd64
  MarkDelete libcupsmime1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
Investigating (0) libboost-signals-dev:amd64 < 1.65.1.0ubuntu1 @ii mK Ib >
Broken libboost-signals-dev:amd64 Depends on libboost-signals1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR >
  Considering libboost-signals1.65-dev:amd64 -1 as a solution to libboost-signals-dev:amd64 -2
  Removing libboost-signals-dev:amd64 rather than change libboost-signals1.65-dev:amd64
  MarkDelete libboost-signals-dev:amd64 < 1.65.1.0ubuntu1 @ii mK Ib > FU=0
Investigating (0) libapt-inst2.0:amd64 < 1.6.13 @ii mK Ib >
Broken libapt-inst2.0:amd64 Depends on libapt-pkg5.0:amd64 < 1.6.13 @ii mR > (>= 1.1~exp9)
  Considering libapt-pkg5.0:amd64 -2 as a solution to libapt-inst2.0:amd64 -2
  Removing libapt-inst2.0:amd64 rather than change libapt-pkg5.0:amd64
  MarkDelete libapt-inst2.0:amd64 < 1.6.13 @ii mK Ib > FU=0
Investigating (0) python-qt4:amd64 < 4.12.1+dfsg-2 @ii mK Ib >
Broken python-qt4:amd64 Depends on libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.8.0-1~)
  Considering libqt4-dbus:amd64 3 as a solution to python-qt4:amd64 -2
  Removing python-qt4:amd64 rather than change libqt4-dbus:amd64
  MarkDelete python-qt4:amd64 < 4.12.1+dfsg-2 @ii mK Ib > FU=0
Investigating (0) libedata-cal-1.2-28:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib >
Broken libedata-cal-1.2-28:amd64 Depends on libebackend-1.2-10:amd64 < 3.28.5-0ubuntu0.18.04.3 -> 3.36.5-0ubuntu1 @ii umU > (= 3.28.5-0ubuntu0.18.04.3)
  Considering libebackend-1.2-10:amd64 7 as a solution to libedata-cal-1.2-28:amd64 -2
  Removing libedata-cal-1.2-28:amd64 rather than change libebackend-1.2-10:amd64
  MarkDelete libedata-cal-1.2-28:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib > FU=0
Investigating (0) python-pyside:amd64 < 1.2.2+source1-3 @ii mK Ib >
Broken python-pyside:amd64 Depends on python-pyside.phonon:amd64 < 1.2.2+source1-3 @ii mR > (>= 1.2.2+source1-3)
  Considering python-pyside.phonon:amd64 -1 as a solution to python-pyside:amd64 -2
  Removing python-pyside:amd64 rather than change python-pyside.phonon:amd64
  MarkDelete python-pyside:amd64 < 1.2.2+source1-3 @ii mK Ib > FU=0
Investigating (0) libsnmp30:amd64 < 5.7.3+dfsg-1.8ubuntu3.6 @ii mK Ib >
Broken libsnmp30:amd64 Depends on libsensors4:amd64 < 1:3.4.0-4 @ii mR > (>= 1:3.0.0)
  Considering libsensors4:amd64 -2 as a solution to libsnmp30:amd64 -2
  Removing libsnmp30:amd64 rather than change libsensors4:amd64
  MarkDelete libsnmp30:amd64 < 5.7.3+dfsg-1.8ubuntu3.6 @ii mK Ib > FU=0
Investigating (0) libpolkit-backend-1-0:amd64 < 0.105-20ubuntu0.18.04.5 @ii mK Ib >
Broken libpolkit-backend-1-0:amd64 Depends on libpolkit-gobject-1-0:amd64 < 0.105-20ubuntu0.18.04.5 -> 0.105-26ubuntu1.1 @ii umU > (= 0.105-20ubuntu0.18.04.5)
  Considering libpolkit-gobject-1-0:amd64 136 as a solution to libpolkit-backend-1-0:amd64 -2
  Removing libpolkit-backend-1-0:amd64 rather than change libpolkit-gobject-1-0:amd64
  MarkDelete libpolkit-backend-1-0:amd64 < 0.105-20ubuntu0.18.04.5 @ii mK Ib > FU=0
Investigating (0) libebook-1.2-19:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib >
Broken libebook-1.2-19:amd64 Depends on libedata-book-1.2-25:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mR > (= 3.28.5-0ubuntu0.18.04.3)
  Considering libedata-book-1.2-25:amd64 -1 as a solution to libebook-1.2-19:amd64 -2
  Removing libebook-1.2-19:amd64 rather than change libedata-book-1.2-25:amd64
  MarkDelete libebook-1.2-19:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib > FU=0
Investigating (0) emacs25:amd64 < 25.2+1-6 @ii mK Ib >
Broken emacs25:amd64 Depends on emacs25-bin-common:amd64 < 25.2+1-6 @ii mR > (= 25.2+1-6)
  Considering emacs25-bin-common:amd64 -1 as a solution to emacs25:amd64 -2
  Removing emacs25:amd64 rather than change emacs25-bin-common:amd64
  MarkDelete emacs25:amd64 < 25.2+1-6 @ii mK Ib > FU=0
Investigating (1) libtinyxml2-dev:amd64 < 6.0.0+dfsg-1 -> 7.0.0+dfsg-1build1 @ii umU Ib >
Broken libtinyxml2-dev:amd64 Depends on libtinyxml2-6a:amd64 < none | 7.0.0+dfsg-1build1 @un uH > (= 7.0.0+dfsg-1build1)
  Considering libtinyxml2-6a:amd64 57 as a solution to libtinyxml2-dev:amd64 62
  MarkKeep libtinyxml2-dev:amd64 < 6.0.0+dfsg-1 -> 7.0.0+dfsg-1build1 @ii umU Ib > FU=0
  Holding Back libtinyxml2-dev:amd64 rather than change libtinyxml2-6a:amd64
Investigating (1) ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mK Ib >
Broken ros-melodic-python-qt-binding:amd64 Depends on python-pyqt5:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mR >
  Considering python-pyqt5:amd64 21 as a solution to ros-melodic-python-qt-binding:amd64 60
  Added python-pyqt5:amd64 to the remove list
Broken ros-melodic-python-qt-binding:amd64 Depends on python-pyqt5.qtsvg:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mR >
  Considering python-pyqt5.qtsvg:amd64 19 as a solution to ros-melodic-python-qt-binding:amd64 60
  Added python-pyqt5.qtsvg:amd64 to the remove list
  Fixing ros-melodic-python-qt-binding:amd64 via keep of python-pyqt5:amd64
  MarkKeep python-pyqt5:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mR > FU=0
  Fixing ros-melodic-python-qt-binding:amd64 via keep of python-pyqt5.qtsvg:amd64
  MarkKeep python-pyqt5.qtsvg:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mR > FU=0
Investigating (1) python-sip-dev:amd64 < 4.19.7+dfsg-1ubuntu0.1 -> 4.19.21+dfsg-1build1 @ii umU Ib >
Broken python-sip-dev:amd64 Depends on python2-dev:amd64 < none | 2.7.17-2ubuntu4 @un umH >
  Considering python2-dev:amd64 5 as a solution to python-sip-dev:amd64 27
  MarkKeep python-sip-dev:amd64 < 4.19.7+dfsg-1ubuntu0.1 -> 4.19.21+dfsg-1build1 @ii umU Ib > FU=0
  Removing python-sip-dev:amd64 rather than change python2-dev:amd64
  MarkDelete python-sip-dev:amd64 < 4.19.7+dfsg-1ubuntu0.1 | 4.19.21+dfsg-1build1 @ii umH Ib > FU=0
Investigating (1) python-pyqt5:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib >
Broken python-pyqt5:amd64 Depends on qtbase-abi-5-9-5:amd64 < none @un H >
  Considering libqt5core5a:amd64 1302 as a solution to python-pyqt5:amd64 21
  Removing python-pyqt5:amd64 rather than change qtbase-abi-5-9-5:amd64
  MarkDelete python-pyqt5:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib > FU=0
Investigating (1) python-pyqt5.qtsvg:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib >
Broken python-pyqt5.qtsvg:amd64 Depends on python-pyqt5:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mR > (= 5.10.1+dfsg-1ubuntu2)
  Considering python-pyqt5:amd64 21 as a solution to python-pyqt5.qtsvg:amd64 19
  Removing python-pyqt5.qtsvg:amd64 rather than change python-pyqt5:amd64
  MarkDelete python-pyqt5.qtsvg:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib > FU=0
Investigating (1) python-dev:amd64 < 2.7.15~rc1-1 @ii gK Ib >
Broken python-dev:amd64 Depends on python:amd64 < 2.7.15~rc1-1 @ii pgR > (= 2.7.15~rc1-1)
  Considering python:amd64 2 as a solution to python-dev:amd64 8
  Added python:amd64 to the remove list
  Fixing python-dev:amd64 via keep of python:amd64
  Ignore MarkKeep of python:amd64 < 2.7.15~rc1-1 @ii pgR > as its mode (Delete) is protected
Investigating (1) ros-melodic-python-orocos-kdl:amd64 < 1.4.0-0bionic.20201017.032955 @ii mK Ib >
Broken ros-melodic-python-orocos-kdl:amd64 Depends on python-sip-dev:amd64 < 4.19.7+dfsg-1ubuntu0.1 | 4.19.21+dfsg-1build1 @ii umR >
  Considering python-sip-dev:amd64 27 as a solution to ros-melodic-python-orocos-kdl:amd64 8
  Removing ros-melodic-python-orocos-kdl:amd64 rather than change python-sip-dev:amd64
  MarkDelete ros-melodic-python-orocos-kdl:amd64 < 1.4.0-0bionic.20201017.032955 @ii mK Ib > FU=0
Investigating (1) libhdf5-103:amd64 < none -> 1.10.4+repack-11ubuntu1 @un uN Ib >
Broken libhdf5-103:amd64 Conflicts on libhdf5-100:amd64 < 1.10.0-patch1+docs-4 @ii mK >
  Considering libhdf5-100:amd64 0 as a solution to libhdf5-103:amd64 7
  Added libhdf5-100:amd64 to the remove list
  Fixing libhdf5-103:amd64 via remove of libhdf5-100:amd64
  MarkDelete libhdf5-100:amd64 < 1.10.0-patch1+docs-4 @ii mK > FU=0
Investigating (1) libgdal26:amd64 < none -> 3.0.4+dfsg-1build3 @un uN Ib >
Broken libgdal26:amd64 Depends on gdal-data:amd64 < 2.2.3+dfsg-2 | 3.0.4+dfsg-1build3 @ii umH > (>= 3.0.4+dfsg-1build3)
  Considering gdal-data:amd64 2 as a solution to libgdal26:amd64 5
  MarkKeep libgdal26:amd64 < none -> 3.0.4+dfsg-1build3 @un uN Ib > FU=0
  Holding Back libgdal26:amd64 rather than change gdal-data:amd64
Investigating (1) python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib >
Broken python-dev-is-python2:amd64 Depends on python2-dev:amd64 < none | 2.7.17-2ubuntu4 @un umH >
  Considering python2-dev:amd64 5 as a solution to python-dev-is-python2:amd64 4
  Ignore MarkKeep of python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib > as its mode (Install) is protected
  Removing python-dev-is-python2:amd64 rather than change python2-dev:amd64
  Ignore MarkDelete of python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib > as its mode (Install) is protected
Investigating (1) libgdal20:amd64 < 2.2.3+dfsg-2 @ii mK Ib >
Broken libgdal20:amd64 Depends on libhdf5-100:amd64 < 1.10.0-patch1+docs-4 @ii mR >
  Considering libhdf5-100:amd64 0 as a solution to libgdal20:amd64 2
  Added libhdf5-100:amd64 to the remove list
Broken libgdal20:amd64 Depends on libogdi3.2:amd64 < 3.2.0+ds-2 @ii mR > (>= 3.2.0)
  Considering libogdi3.2:amd64 -2 as a solution to libgdal20:amd64 2
  Added libogdi3.2:amd64 to the remove list
  Fixing libgdal20:amd64 via keep of libhdf5-100:amd64
  MarkKeep libhdf5-100:amd64 < 1.10.0-patch1+docs-4 @ii mR > FU=0
  Fixing libgdal20:amd64 via keep of libogdi3.2:amd64
  MarkKeep libogdi3.2:amd64 < 3.2.0+ds-2 @ii mR > FU=0
 Try to Re-Instate (1) gdal-data:amd64
  MarkKeep gdal-data:amd64 < 2.2.3+dfsg-2 -> 3.0.4+dfsg-1build3 @ii umU Ib > FU=0
Investigating (1) libogdi4.1:amd64 < none -> 4.1.0+ds-1build1 @un uN Ib >
Broken libogdi4.1:amd64 Breaks on libogdi3.2:amd64 < 3.2.0+ds-2 @ii mK > (< 4.0.0)
  Considering libogdi3.2:amd64 -2 as a solution to libogdi4.1:amd64 0
  Added libogdi3.2:amd64 to the remove list
  Fixing libogdi4.1:amd64 via remove of libogdi3.2:amd64
  MarkDelete libogdi3.2:amd64 < 3.2.0+ds-2 @ii mK > FU=0
Investigating (1) ros-melodic-rqt-web:amd64 < 0.4.8-0bionic.20210505.022403 @ii mK Ib >
Broken ros-melodic-rqt-web:amd64 Depends on ros-melodic-webkit-dependency:amd64 < 1.1.0-0bionic.20200801.040531 @ii mR >
  Considering ros-melodic-webkit-dependency:amd64 -1 as a solution to ros-melodic-rqt-web:amd64 -1
  Removing ros-melodic-rqt-web:amd64 rather than change ros-melodic-webkit-dependency:amd64
  MarkDelete ros-melodic-rqt-web:amd64 < 0.4.8-0bionic.20210505.022403 @ii mK Ib > FU=0
Investigating (1) ros-melodic-tf2-sensor-msgs:amd64 < 0.6.5-0bionic.20210505.031317 @ii mK Ib >
Broken ros-melodic-tf2-sensor-msgs:amd64 Depends on ros-melodic-python-orocos-kdl:amd64 < 1.4.0-0bionic.20201017.032955 @ii mR >
  Considering ros-melodic-python-orocos-kdl:amd64 8 as a solution to ros-melodic-tf2-sensor-msgs:amd64 -1
  Removing ros-melodic-tf2-sensor-msgs:amd64 rather than change ros-melodic-python-orocos-kdl:amd64
  MarkDelete ros-melodic-tf2-sensor-msgs:amd64 < 0.6.5-0bionic.20210505.031317 @ii mK Ib > FU=0
Investigating (1) ros-melodic-tf-conversions:amd64 < 1.12.1-1bionic.20210505.034735 @ii mK Ib >
Broken ros-melodic-tf-conversions:amd64 Depends on ros-melodic-python-orocos-kdl:amd64 < 1.4.0-0bionic.20201017.032955 @ii mR >
  Considering ros-melodic-python-orocos-kdl:amd64 8 as a solution to ros-melodic-tf-conversions:amd64 -1
  Removing ros-melodic-tf-conversions:amd64 rather than change ros-melodic-python-orocos-kdl:amd64
  MarkDelete ros-melodic-tf-conversions:amd64 < 1.12.1-1bionic.20210505.034735 @ii mK Ib > FU=0
Investigating (1) ros-melodic-rqt-common-plugins:amd64 < 0.4.8-0bionic.20210505.042624 @ii mK Ib >
Broken ros-melodic-rqt-common-plugins:amd64 Depends on ros-melodic-rqt-web:amd64 < 0.4.8-0bionic.20210505.022403 @ii mR >
  Considering ros-melodic-rqt-web:amd64 -1 as a solution to ros-melodic-rqt-common-plugins:amd64 -2
  Removing ros-melodic-rqt-common-plugins:amd64 rather than change ros-melodic-rqt-web:amd64
  MarkDelete ros-melodic-rqt-common-plugins:amd64 < 0.4.8-0bionic.20210505.042624 @ii mK Ib > FU=0
Investigating (1) ros-melodic-pointcloud-to-laserscan:amd64 < 1.4.1-1bionic.20210505.040213 @ii mK Ib >
Broken ros-melodic-pointcloud-to-laserscan:amd64 Depends on ros-melodic-tf2-sensor-msgs:amd64 < 0.6.5-0bionic.20210505.031317 @ii mR >
  Considering ros-melodic-tf2-sensor-msgs:amd64 -1 as a solution to ros-melodic-pointcloud-to-laserscan:amd64 -2
  Removing ros-melodic-pointcloud-to-laserscan:amd64 rather than change ros-melodic-tf2-sensor-msgs:amd64
  MarkDelete ros-melodic-pointcloud-to-laserscan:amd64 < 1.4.1-1bionic.20210505.040213 @ii mK Ib > FU=0
Investigating (1) python-qt4-dev:amd64 < 4.12.1+dfsg-2 @ii mK Ib >
Broken python-qt4-dev:amd64 Depends on python-sip-dev:amd64 < 4.19.7+dfsg-1ubuntu0.1 | 4.19.21+dfsg-1build1 @ii umR >
  Considering python-sip-dev:amd64 27 as a solution to python-qt4-dev:amd64 -2
  Removing python-qt4-dev:amd64 rather than change python-sip-dev:amd64
  MarkDelete python-qt4-dev:amd64 < 4.12.1+dfsg-2 @ii mK Ib > FU=0
 Try to Re-Instate (2) libtinyxml2-dev:amd64
  MarkKeep libtinyxml2-dev:amd64 < 6.0.0+dfsg-1 -> 7.0.0+dfsg-1build1 @ii umU Ib > FU=0
Investigating (2) ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mK Ib >
Broken ros-melodic-python-qt-binding:amd64 Depends on python-pyqt5:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mR >
  Considering python-pyqt5:amd64 21 as a solution to ros-melodic-python-qt-binding:amd64 60
  Added python-pyqt5:amd64 to the remove list
Broken ros-melodic-python-qt-binding:amd64 Depends on python-pyqt5.qtsvg:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mR >
  Considering python-pyqt5.qtsvg:amd64 19 as a solution to ros-melodic-python-qt-binding:amd64 60
  Added python-pyqt5.qtsvg:amd64 to the remove list
Broken ros-melodic-python-qt-binding:amd64 Depends on python-sip-dev:amd64 < 4.19.7+dfsg-1ubuntu0.1 | 4.19.21+dfsg-1build1 @ii umR >
  Considering python-sip-dev:amd64 27 as a solution to ros-melodic-python-qt-binding:amd64 60
  Added python-sip-dev:amd64 to the remove list
  Fixing ros-melodic-python-qt-binding:amd64 via keep of python-pyqt5:amd64
  MarkKeep python-pyqt5:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mR > FU=0
  Fixing ros-melodic-python-qt-binding:amd64 via keep of python-pyqt5.qtsvg:amd64
  MarkKeep python-pyqt5.qtsvg:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mR > FU=0
  Fixing ros-melodic-python-qt-binding:amd64 via keep of python-sip-dev:amd64
  MarkKeep python-sip-dev:amd64 < 4.19.7+dfsg-1ubuntu0.1 | 4.19.21+dfsg-1build1 @ii umR > FU=0
Investigating (2) ros-melodic-tf2-geometry-msgs:amd64 < 0.6.5-0bionic.20210505.031257 @ii mK Ib >
Broken ros-melodic-tf2-geometry-msgs:amd64 Depends on ros-melodic-python-orocos-kdl:amd64 < 1.4.0-0bionic.20201017.032955 @ii mR >
  Considering ros-melodic-python-orocos-kdl:amd64 8 as a solution to ros-melodic-tf2-geometry-msgs:amd64 38
  Added ros-melodic-python-orocos-kdl:amd64 to the remove list
  Fixing ros-melodic-tf2-geometry-msgs:amd64 via keep of ros-melodic-python-orocos-kdl:amd64
  MarkKeep ros-melodic-python-orocos-kdl:amd64 < 1.4.0-0bionic.20201017.032955 @ii mR > FU=0
 Try to Re-Instate (2) python-sip-dev:amd64
  MarkKeep python-sip-dev:amd64 < 4.19.7+dfsg-1ubuntu0.1 -> 4.19.21+dfsg-1build1 @ii umU Ib > FU=0
Investigating (2) python-sip-dev:amd64 < 4.19.7+dfsg-1ubuntu0.1 | 4.19.21+dfsg-1build1 @ii umH Ib >
Broken python-sip-dev:amd64 Depends on python-sip:amd64 < 4.19.7+dfsg-1ubuntu0.1 -> 4.19.21+dfsg-1build1 @ii umU > (= 4.19.7+dfsg-1ubuntu0.1)
  Considering python-sip:amd64 5 as a solution to python-sip-dev:amd64 60
  Added python-sip:amd64 to the remove list
Broken python-sip-dev:amd64 Depends on sip-dev:amd64 < 4.19.7+dfsg-1ubuntu0.1 -> 4.19.21+dfsg-1build1 @ii umU > (= 4.19.7+dfsg-1ubuntu0.1)
  Considering sip-dev:amd64 7 as a solution to python-sip-dev:amd64 60
  Added sip-dev:amd64 to the remove list
  Fixing python-sip-dev:amd64 via keep of python-sip:amd64
  MarkKeep python-sip:amd64 < 4.19.7+dfsg-1ubuntu0.1 -> 4.19.21+dfsg-1build1 @ii umU > FU=0
  Fixing python-sip-dev:amd64 via keep of sip-dev:amd64
  MarkKeep sip-dev:amd64 < 4.19.7+dfsg-1ubuntu0.1 -> 4.19.21+dfsg-1build1 @ii umU > FU=0
Investigating (2) libopencv-imgcodecs4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib >
Broken libopencv-imgcodecs4.2:amd64 Depends on libgdal26:amd64 < none | 3.0.4+dfsg-1build3 @un uH > (>= 2.0.1)
  Considering libgdal26:amd64 5 as a solution to libopencv-imgcodecs4.2:amd64 24
  MarkKeep libopencv-imgcodecs4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
  Holding Back libopencv-imgcodecs4.2:amd64 rather than change libgdal26:amd64
Investigating (2) libopencv-highgui4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib >
Broken libopencv-highgui4.2:amd64 Depends on libopencv-imgcodecs4.2:amd64 < none | 4.2.0+dfsg-5 @un uH > (>= 4.2.0+dfsg)
  Considering libopencv-imgcodecs4.2:amd64 24 as a solution to libopencv-highgui4.2:amd64 23
  MarkKeep libopencv-highgui4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
  Holding Back libopencv-highgui4.2:amd64 rather than change libopencv-imgcodecs4.2:amd64
Investigating (2) libopencv-videoio4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib >
Broken libopencv-videoio4.2:amd64 Depends on libopencv-imgcodecs4.2:amd64 < none | 4.2.0+dfsg-5 @un uH > (= 4.2.0+dfsg-5)
  Considering libopencv-imgcodecs4.2:amd64 24 as a solution to libopencv-videoio4.2:amd64 22
  MarkKeep libopencv-videoio4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
  Holding Back libopencv-videoio4.2:amd64 rather than change libopencv-imgcodecs4.2:amd64
Investigating (2) python-pyqt5:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib >
Broken python-pyqt5:amd64 Depends on qtbase-abi-5-9-5:amd64 < none @un H >
  Considering libqt5core5a:amd64 1302 as a solution to python-pyqt5:amd64 60
  Removing python-pyqt5:amd64 rather than change qtbase-abi-5-9-5:amd64
  MarkDelete python-pyqt5:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib > FU=0
Investigating (2) python-pyqt5.qtsvg:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib >
Broken python-pyqt5.qtsvg:amd64 Depends on python-pyqt5:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mR > (= 5.10.1+dfsg-1ubuntu2)
  Considering python-pyqt5:amd64 1302 as a solution to python-pyqt5.qtsvg:amd64 60
  Removing python-pyqt5.qtsvg:amd64 rather than change python-pyqt5:amd64
  MarkDelete python-pyqt5.qtsvg:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mK Ib > FU=0
Investigating (2) libopencv-videoio-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib >
Broken libopencv-videoio-dev:amd64 Depends on libopencv-videoio4.2:amd64 < none | 4.2.0+dfsg-5 @un uH > (= 4.2.0+dfsg-5)
  Considering libopencv-videoio4.2:amd64 22 as a solution to libopencv-videoio-dev:amd64 13
  MarkKeep libopencv-videoio-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Removing libopencv-videoio-dev:amd64 rather than change libopencv-videoio4.2:amd64
  MarkDelete libopencv-videoio-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 | 4.2.0+dfsg-5 @ii umH Ib > FU=0
Investigating (2) libopencv-highgui-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib >
Broken libopencv-highgui-dev:amd64 Depends on libopencv-highgui4.2:amd64 < none | 4.2.0+dfsg-5 @un uH > (= 4.2.0+dfsg-5)
  Considering libopencv-highgui4.2:amd64 23 as a solution to libopencv-highgui-dev:amd64 13
  MarkKeep libopencv-highgui-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Removing libopencv-highgui-dev:amd64 rather than change libopencv-highgui4.2:amd64
  MarkDelete libopencv-highgui-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 | 4.2.0+dfsg-5 @ii umH Ib > FU=0
Investigating (2) libopencv-imgcodecs-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib >
Broken libopencv-imgcodecs-dev:amd64 Depends on libopencv-imgcodecs4.2:amd64 < none | 4.2.0+dfsg-5 @un uH > (= 4.2.0+dfsg-5)
  Considering libopencv-imgcodecs4.2:amd64 24 as a solution to libopencv-imgcodecs-dev:amd64 10
  MarkKeep libopencv-imgcodecs-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Removing libopencv-imgcodecs-dev:amd64 rather than change libopencv-imgcodecs4.2:amd64
  MarkDelete libopencv-imgcodecs-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 | 4.2.0+dfsg-5 @ii umH Ib > FU=0
Investigating (2) libopencv-objdetect4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib >
Broken libopencv-objdetect4.2:amd64 Depends on libopencv-highgui4.2:amd64 < none | 4.2.0+dfsg-5 @un uH > (= 4.2.0+dfsg-5)
  Considering libopencv-highgui4.2:amd64 23 as a solution to libopencv-objdetect4.2:amd64 10
  MarkKeep libopencv-objdetect4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
  Holding Back libopencv-objdetect4.2:amd64 rather than change libopencv-highgui4.2:amd64
Investigating (2) libopencv-features2d-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib >
Broken libopencv-features2d-dev:amd64 Depends on libopencv-highgui-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 | 4.2.0+dfsg-5 @ii umR > (= 4.2.0+dfsg-5)
  Considering libopencv-highgui-dev:amd64 23 as a solution to libopencv-features2d-dev:amd64 10
  MarkKeep libopencv-features2d-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Removing libopencv-features2d-dev:amd64 rather than change libopencv-highgui-dev:amd64
  MarkDelete libopencv-features2d-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 | 4.2.0+dfsg-5 @ii umH Ib > FU=0
Investigating (2) python-dev:amd64 < 2.7.15~rc1-1 @ii gK Ib >
Broken python-dev:amd64 Depends on python:amd64 < 2.7.15~rc1-1 @ii pgR > (= 2.7.15~rc1-1)
  Considering python:amd64 2 as a solution to python-dev:amd64 8
  Added python:amd64 to the remove list
  Fixing python-dev:amd64 via keep of python:amd64
  Ignore MarkKeep of python:amd64 < 2.7.15~rc1-1 @ii pgR > as its mode (Delete) is protected
Investigating (2) libopencv-objdetect-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib >
Broken libopencv-objdetect-dev:amd64 Depends on libopencv-highgui-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 | 4.2.0+dfsg-5 @ii umR > (= 4.2.0+dfsg-5)
  Considering libopencv-highgui-dev:amd64 23 as a solution to libopencv-objdetect-dev:amd64 8
  MarkKeep libopencv-objdetect-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Removing libopencv-objdetect-dev:amd64 rather than change libopencv-highgui-dev:amd64
  MarkDelete libopencv-objdetect-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 | 4.2.0+dfsg-5 @ii umH Ib > FU=0
 Try to Re-Instate (2) sip-dev:amd64
Re-Instated sip-dev:amd64 (18 vs 18)
Investigating (2) libopencv-contrib4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib >
Broken libopencv-contrib4.2:amd64 Depends on libopencv-highgui4.2:amd64 < none | 4.2.0+dfsg-5 @un uH > (= 4.2.0+dfsg-5)
  Considering libopencv-highgui4.2:amd64 23 as a solution to libopencv-contrib4.2:amd64 7
  MarkKeep libopencv-contrib4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
  Holding Back libopencv-contrib4.2:amd64 rather than change libopencv-highgui4.2:amd64
Investigating (2) libhdf5-103:amd64 < none -> 1.10.4+repack-11ubuntu1 @un uN Ib >
Broken libhdf5-103:amd64 Conflicts on libhdf5-100:amd64 < 1.10.0-patch1+docs-4 @ii mK >
  Considering libhdf5-100:amd64 0 as a solution to libhdf5-103:amd64 7
  Added libhdf5-100:amd64 to the remove list
  Fixing libhdf5-103:amd64 via remove of libhdf5-100:amd64
  MarkDelete libhdf5-100:amd64 < 1.10.0-patch1+docs-4 @ii mK > FU=0
Investigating (2) libopencv-stitching4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib >
Broken libopencv-stitching4.2:amd64 Depends on libopencv-objdetect4.2:amd64 < none | 4.2.0+dfsg-5 @un uH > (= 4.2.0+dfsg-5)
  Considering libopencv-objdetect4.2:amd64 10 as a solution to libopencv-stitching4.2:amd64 6
  MarkKeep libopencv-stitching4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
  Holding Back libopencv-stitching4.2:amd64 rather than change libopencv-objdetect4.2:amd64
Investigating (2) libopencv-superres4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib >
Broken libopencv-superres4.2:amd64 Depends on libopencv-videoio4.2:amd64 < none | 4.2.0+dfsg-5 @un uH > (= 4.2.0+dfsg-5)
  Considering libopencv-videoio4.2:amd64 22 as a solution to libopencv-superres4.2:amd64 6
  MarkKeep libopencv-superres4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
  Holding Back libopencv-superres4.2:amd64 rather than change libopencv-videoio4.2:amd64
Investigating (2) libopencv-videostab4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib >
Broken libopencv-videostab4.2:amd64 Depends on libopencv-videoio4.2:amd64 < none | 4.2.0+dfsg-5 @un uH > (>= 4.2.0+dfsg)
  Considering libopencv-videoio4.2:amd64 22 as a solution to libopencv-videostab4.2:amd64 6
  MarkKeep libopencv-videostab4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
  Holding Back libopencv-videostab4.2:amd64 rather than change libopencv-videoio4.2:amd64
Investigating (2) libopencv-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib >
Broken libopencv-dev:amd64 Depends on libopencv-features2d-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 | 4.2.0+dfsg-5 @ii umR > (= 4.2.0+dfsg-5)
  Considering libopencv-features2d-dev:amd64 23 as a solution to libopencv-dev:amd64 6
  MarkKeep libopencv-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Removing libopencv-dev:amd64 rather than change libopencv-features2d-dev:amd64
  MarkDelete libopencv-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 | 4.2.0+dfsg-5 @ii umH Ib > FU=0
Investigating (2) libopencv-stitching-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib >
Broken libopencv-stitching-dev:amd64 Depends on libopencv-objdetect-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 | 4.2.0+dfsg-5 @ii umR > (= 4.2.0+dfsg-5)
  Considering libopencv-objdetect-dev:amd64 23 as a solution to libopencv-stitching-dev:amd64 5
  MarkKeep libopencv-stitching-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Removing libopencv-stitching-dev:amd64 rather than change libopencv-objdetect-dev:amd64
  MarkDelete libopencv-stitching-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 | 4.2.0+dfsg-5 @ii umH Ib > FU=0
 Try to Re-Instate (2) python-sip:amd64
Re-Instated python-sip:amd64 (16 vs 16)
Investigating (2) libopencv-videostab-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib >
Broken libopencv-videostab-dev:amd64 Depends on libopencv-videostab4.2:amd64 < none | 4.2.0+dfsg-5 @un uH > (= 4.2.0+dfsg-5)
  Considering libopencv-videostab4.2:amd64 6 as a solution to libopencv-videostab-dev:amd64 5
  MarkKeep libopencv-videostab-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Removing libopencv-videostab-dev:amd64 rather than change libopencv-videostab4.2:amd64
  MarkDelete libopencv-videostab-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 | 4.2.0+dfsg-5 @ii umH Ib > FU=0
Investigating (2) libopencv-superres-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib >
Broken libopencv-superres-dev:amd64 Depends on libopencv-superres4.2:amd64 < none | 4.2.0+dfsg-5 @un uH > (= 4.2.0+dfsg-5)
  Considering libopencv-superres4.2:amd64 6 as a solution to libopencv-superres-dev:amd64 5
  MarkKeep libopencv-superres-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Removing libopencv-superres-dev:amd64 rather than change libopencv-superres4.2:amd64
  MarkDelete libopencv-superres-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 | 4.2.0+dfsg-5 @ii umH Ib > FU=0
Investigating (2) python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib >
Broken python-dev-is-python2:amd64 Depends on python2-dev:amd64 < none | 2.7.17-2ubuntu4 @un umH >
  Considering python2-dev:amd64 5 as a solution to python-dev-is-python2:amd64 4
  Ignore MarkKeep of python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib > as its mode (Install) is protected
  Removing python-dev-is-python2:amd64 rather than change python2-dev:amd64
  Ignore MarkDelete of python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib > as its mode (Install) is protected
Investigating (2) ros-melodic-cv-bridge:amd64 < 1.13.0-0bionic.20210505.032238 @ii mK Ib >
Broken ros-melodic-cv-bridge:amd64 Depends on libopencv-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 | 4.2.0+dfsg-5 @ii umR >
  Considering libopencv-dev:amd64 23 as a solution to ros-melodic-cv-bridge:amd64 3
  Removing ros-melodic-cv-bridge:amd64 rather than change libopencv-dev:amd64
  MarkDelete ros-melodic-cv-bridge:amd64 < 1.13.0-0bionic.20210505.032238 @ii mK Ib > FU=0
Investigating (2) libopencv-contrib-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib >
Broken libopencv-contrib-dev:amd64 Depends on libopencv-contrib4.2:amd64 < none | 4.2.0+dfsg-5 @un uH > (= 4.2.0+dfsg-5)
  Considering libopencv-contrib4.2:amd64 7 as a solution to libopencv-contrib-dev:amd64 3
  MarkKeep libopencv-contrib-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Removing libopencv-contrib-dev:amd64 rather than change libopencv-contrib4.2:amd64
  MarkDelete libopencv-contrib-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 | 4.2.0+dfsg-5 @ii umH Ib > FU=0
Investigating (2) libgdal20:amd64 < 2.2.3+dfsg-2 @ii mK Ib >
Broken libgdal20:amd64 Depends on libhdf5-100:amd64 < 1.10.0-patch1+docs-4 @ii mR >
  Considering libhdf5-100:amd64 7 as a solution to libgdal20:amd64 2
  Removing libgdal20:amd64 rather than change libhdf5-100:amd64
  MarkDelete libgdal20:amd64 < 2.2.3+dfsg-2 @ii mK Ib > FU=0
Investigating (2) ros-melodic-image-geometry:amd64 < 1.13.0-0bionic.20210505.032728 @ii mK Ib >
Broken ros-melodic-image-geometry:amd64 Depends on libopencv-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 | 4.2.0+dfsg-5 @ii umR >
  Considering libopencv-dev:amd64 23 as a solution to ros-melodic-image-geometry:amd64 1
  Removing ros-melodic-image-geometry:amd64 rather than change libopencv-dev:amd64
  MarkDelete ros-melodic-image-geometry:amd64 < 1.13.0-0bionic.20210505.032728 @ii mK Ib > FU=0
Investigating (2) libopencv-contrib3.2:amd64 < 3.2.0+dfsg-4ubuntu0.1 @ii mK Ib >
Broken libopencv-contrib3.2:amd64 Depends on libhdf5-100:amd64 < 1.10.0-patch1+docs-4 @ii mR >
  Considering libhdf5-100:amd64 7 as a solution to libopencv-contrib3.2:amd64 0
  Removing libopencv-contrib3.2:amd64 rather than change libhdf5-100:amd64
  MarkDelete libopencv-contrib3.2:amd64 < 3.2.0+dfsg-4ubuntu0.1 @ii mK Ib > FU=0
Investigating (2) libopencv4.2-jni:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib >
Broken libopencv4.2-jni:amd64 Depends on libopencv-highgui4.2:amd64 < none | 4.2.0+dfsg-5 @un uH > (= 4.2.0+dfsg-5)
  Considering libopencv-highgui4.2:amd64 23 as a solution to libopencv4.2-jni:amd64 0
  MarkKeep libopencv4.2-jni:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
  Holding Back libopencv4.2-jni:amd64 rather than change libopencv-highgui4.2:amd64
Investigating (2) ros-melodic-image-proc:amd64 < 1.15.0-1bionic.20210505.035446 @ii mK Ib >
Broken ros-melodic-image-proc:amd64 Depends on ros-melodic-cv-bridge:amd64 < 1.13.0-0bionic.20210505.032238 @ii mR >
  Considering ros-melodic-cv-bridge:amd64 23 as a solution to ros-melodic-image-proc:amd64 0
  Removing ros-melodic-image-proc:amd64 rather than change ros-melodic-cv-bridge:amd64
  MarkDelete ros-melodic-image-proc:amd64 < 1.15.0-1bionic.20210505.035446 @ii mK Ib > FU=0
Investigating (2) ros-melodic-depth-image-proc:amd64 < 1.15.0-1bionic.20210505.044041 @ii mK Ib >
Broken ros-melodic-depth-image-proc:amd64 Depends on ros-melodic-cv-bridge:amd64 < 1.13.0-0bionic.20210505.032238 @ii mR >
  Considering ros-melodic-cv-bridge:amd64 23 as a solution to ros-melodic-depth-image-proc:amd64 0
  Removing ros-melodic-depth-image-proc:amd64 rather than change ros-melodic-cv-bridge:amd64
  MarkDelete ros-melodic-depth-image-proc:amd64 < 1.15.0-1bionic.20210505.044041 @ii mK Ib > FU=0
Investigating (2) ros-melodic-moveit-ros-perception:amd64 < 1.0.7-1bionic.20210505.050749 @ii mK Ib >
Broken ros-melodic-moveit-ros-perception:amd64 Depends on ros-melodic-cv-bridge:amd64 < 1.13.0-0bionic.20210505.032238 @ii mR >
  Considering ros-melodic-cv-bridge:amd64 23 as a solution to ros-melodic-moveit-ros-perception:amd64 0
  Removing ros-melodic-moveit-ros-perception:amd64 rather than change ros-melodic-cv-bridge:amd64
  MarkDelete ros-melodic-moveit-ros-perception:amd64 < 1.0.7-1bionic.20210505.050749 @ii mK Ib > FU=0
Investigating (2) libopencv3.2-jni:amd64 < 3.2.0+dfsg-4ubuntu0.1 @ii mK Ib >
Broken libopencv3.2-jni:amd64 Depends on libopencv-contrib3.2:amd64 < 3.2.0+dfsg-4ubuntu0.1 @ii mR >
  Considering libopencv-contrib3.2:amd64 7 as a solution to libopencv3.2-jni:amd64 -1
  Removing libopencv3.2-jni:amd64 rather than change libopencv-contrib3.2:amd64
  MarkDelete libopencv3.2-jni:amd64 < 3.2.0+dfsg-4ubuntu0.1 @ii mK Ib > FU=0
Investigating (2) ros-melodic-rgbd-launch:amd64 < 2.2.2-0bionic.20210505.045145 @ii mK Ib >
Broken ros-melodic-rgbd-launch:amd64 Depends on ros-melodic-depth-image-proc:amd64 < 1.15.0-1bionic.20210505.044041 @ii mR >
  Considering ros-melodic-depth-image-proc:amd64 23 as a solution to ros-melodic-rgbd-launch:amd64 -1
  Removing ros-melodic-rgbd-launch:amd64 rather than change ros-melodic-depth-image-proc:amd64
  MarkDelete ros-melodic-rgbd-launch:amd64 < 2.2.2-0bionic.20210505.045145 @ii mK Ib > FU=0
Investigating (2) ros-melodic-rviz-visual-tools:amd64 < 3.8.0-4bionic.20210505.045341 @ii mK Ib >
Broken ros-melodic-rviz-visual-tools:amd64 Depends on ros-melodic-tf-conversions:amd64 < 1.12.1-1bionic.20210505.034735 @ii mR >
  Considering ros-melodic-tf-conversions:amd64 -1 as a solution to ros-melodic-rviz-visual-tools:amd64 -1
  Removing ros-melodic-rviz-visual-tools:amd64 rather than change ros-melodic-tf-conversions:amd64
  MarkDelete ros-melodic-rviz-visual-tools:amd64 < 3.8.0-4bionic.20210505.045341 @ii mK Ib > FU=0
Investigating (2) ros-melodic-costmap-converter:amd64 < 0.0.12-1bionic.20210505.040946 @ii mK Ib >
Broken ros-melodic-costmap-converter:amd64 Depends on ros-melodic-cv-bridge:amd64 < 1.13.0-0bionic.20210505.032238 @ii mR >
  Considering ros-melodic-cv-bridge:amd64 23 as a solution to ros-melodic-costmap-converter:amd64 -1
  Removing ros-melodic-costmap-converter:amd64 rather than change ros-melodic-cv-bridge:amd64
  MarkDelete ros-melodic-costmap-converter:amd64 < 0.0.12-1bionic.20210505.040946 @ii mK Ib > FU=0
Investigating (2) ros-melodic-moveit-ros:amd64 < 1.0.7-1bionic.20210505.061946 @ii mK Ib >
Broken ros-melodic-moveit-ros:amd64 Depends on ros-melodic-moveit-ros-perception:amd64 < 1.0.7-1bionic.20210505.050749 @ii mR >
  Considering ros-melodic-moveit-ros-perception:amd64 23 as a solution to ros-melodic-moveit-ros:amd64 -1
  Removing ros-melodic-moveit-ros:amd64 rather than change ros-melodic-moveit-ros-perception:amd64
  MarkDelete ros-melodic-moveit-ros:amd64 < 1.0.7-1bionic.20210505.061946 @ii mK Ib > FU=0
Investigating (2) ros-melodic-rqt-image-view:amd64 < 0.4.16-1bionic.20210505.032821 @ii mK Ib >
Broken ros-melodic-rqt-image-view:amd64 Depends on ros-melodic-cv-bridge:amd64 < 1.13.0-0bionic.20210505.032238 @ii mR >
  Considering ros-melodic-cv-bridge:amd64 23 as a solution to ros-melodic-rqt-image-view:amd64 -1
  Removing ros-melodic-rqt-image-view:amd64 rather than change ros-melodic-cv-bridge:amd64
  MarkDelete ros-melodic-rqt-image-view:amd64 < 0.4.16-1bionic.20210505.032821 @ii mK Ib > FU=0
Investigating (2) libnetcdf13:amd64 < 1:4.6.0-2build1 @ii mK Ib >
Broken libnetcdf13:amd64 Depends on libhdf5-100:amd64 < 1.10.0-patch1+docs-4 @ii mR >
  Considering libhdf5-100:amd64 7 as a solution to libnetcdf13:amd64 -1
  Removing libnetcdf13:amd64 rather than change libhdf5-100:amd64
  MarkDelete libnetcdf13:amd64 < 1:4.6.0-2build1 @ii mK Ib > FU=0
Investigating (2) ros-melodic-teb-local-planner:amd64 < 0.8.4-1bionic.20210505.041952 @ii mK Ib >
Broken ros-melodic-teb-local-planner:amd64 Depends on ros-melodic-costmap-converter:amd64 < 0.0.12-1bionic.20210505.040946 @ii mR >
  Considering ros-melodic-costmap-converter:amd64 23 as a solution to ros-melodic-teb-local-planner:amd64 -2
  Removing ros-melodic-teb-local-planner:amd64 rather than change ros-melodic-costmap-converter:amd64
  MarkDelete ros-melodic-teb-local-planner:amd64 < 0.8.4-1bionic.20210505.041952 @ii mK Ib > FU=0
Investigating (2) ros-melodic-moveit-visual-tools:amd64 < 3.5.2-0bionic.20210505.052218 @ii mK Ib >
Broken ros-melodic-moveit-visual-tools:amd64 Depends on ros-melodic-rviz-visual-tools:amd64 < 3.8.0-4bionic.20210505.045341 @ii mR >
  Considering ros-melodic-rviz-visual-tools:amd64 -1 as a solution to ros-melodic-moveit-visual-tools:amd64 -2
  Removing ros-melodic-moveit-visual-tools:amd64 rather than change ros-melodic-rviz-visual-tools:amd64
  MarkDelete ros-melodic-moveit-visual-tools:amd64 < 3.5.2-0bionic.20210505.052218 @ii mK Ib > FU=0
Investigating (2) ros-melodic-openni2-launch:amd64 < 1.5.1-1bionic.20210505.050459 @ii mK Ib >
Broken ros-melodic-openni2-launch:amd64 Depends on ros-melodic-depth-image-proc:amd64 < 1.15.0-1bionic.20210505.044041 @ii mR >
  Considering ros-melodic-depth-image-proc:amd64 23 as a solution to ros-melodic-openni2-launch:amd64 -2
  Removing ros-melodic-openni2-launch:amd64 rather than change ros-melodic-depth-image-proc:amd64
  MarkDelete ros-melodic-openni2-launch:amd64 < 1.5.1-1bionic.20210505.050459 @ii mK Ib > FU=0
Investigating (2) ros-melodic-moveit:amd64 < 1.0.7-1bionic.20210505.063146 @ii mK Ib >
Broken ros-melodic-moveit:amd64 Depends on ros-melodic-moveit-ros:amd64 < 1.0.7-1bionic.20210505.061946 @ii mR >
  Considering ros-melodic-moveit-ros:amd64 23 as a solution to ros-melodic-moveit:amd64 -2
  Removing ros-melodic-moveit:amd64 rather than change ros-melodic-moveit-ros:amd64
  MarkDelete ros-melodic-moveit:amd64 < 1.0.7-1bionic.20210505.063146 @ii mK Ib > FU=0
Investigating (2) ros-melodic-depthimage-to-laserscan:amd64 < 1.0.8-0bionic.20210505.035508 @ii mK Ib >
Broken ros-melodic-depthimage-to-laserscan:amd64 Depends on ros-melodic-image-geometry:amd64 < 1.13.0-0bionic.20210505.032728 @ii mR >
  Considering ros-melodic-image-geometry:amd64 23 as a solution to ros-melodic-depthimage-to-laserscan:amd64 -2
  Removing ros-melodic-depthimage-to-laserscan:amd64 rather than change ros-melodic-image-geometry:amd64
  MarkDelete ros-melodic-depthimage-to-laserscan:amd64 < 1.0.8-0bionic.20210505.035508 @ii mK Ib > FU=0
Investigating (3) ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mK Ib >
Broken ros-melodic-python-qt-binding:amd64 Depends on python-pyqt5:amd64 < 5.10.1+dfsg-1ubuntu2 @ii mR >
  Considering python-pyqt5:amd64 1302 as a solution to ros-melodic-python-qt-binding:amd64 60
  Removing ros-melodic-python-qt-binding:amd64 rather than change python-pyqt5:amd64
  MarkDelete ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mK Ib > FU=0
Investigating (3) ros-melodic-qt-gui:amd64 < 0.4.2-1bionic.20210505.012901 @ii mK Ib >
Broken ros-melodic-qt-gui:amd64 Depends on ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mR > (>= 0.3.0)
  Considering ros-melodic-python-qt-binding:amd64 1302 as a solution to ros-melodic-qt-gui:amd64 49
  Removing ros-melodic-qt-gui:amd64 rather than change ros-melodic-python-qt-binding:amd64
  MarkDelete ros-melodic-qt-gui:amd64 < 0.4.2-1bionic.20210505.012901 @ii mK Ib > FU=0
Investigating (3) ros-melodic-rqt-gui:amd64 < 0.5.2-1bionic.20210505.021441 @ii mK Ib >
Broken ros-melodic-rqt-gui:amd64 Depends on ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mR >
  Considering ros-melodic-python-qt-binding:amd64 1302 as a solution to ros-melodic-rqt-gui:amd64 38
  Removing ros-melodic-rqt-gui:amd64 rather than change ros-melodic-python-qt-binding:amd64
  MarkDelete ros-melodic-rqt-gui:amd64 < 0.5.2-1bionic.20210505.021441 @ii mK Ib > FU=0
Investigating (3) python-sip-dev:amd64 < 4.19.7+dfsg-1ubuntu0.1 | 4.19.21+dfsg-1build1 @ii umH Ib >
Broken python-sip-dev:amd64 Depends on python-sip:amd64 < 4.19.7+dfsg-1ubuntu0.1 -> 4.19.21+dfsg-1build1 @ii umU > (= 4.19.7+dfsg-1ubuntu0.1)
  Considering python-sip:amd64 60 as a solution to python-sip-dev:amd64 60
  Removing python-sip-dev:amd64 rather than change python-sip:amd64
  MarkDelete python-sip-dev:amd64 < 4.19.7+dfsg-1ubuntu0.1 | 4.19.21+dfsg-1build1 @ii umH Ib > FU=0
Investigating (3) libopencv-features2d4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib >
Broken libopencv-features2d4.2:amd64 Depends on libopencv-highgui4.2:amd64 < none | 4.2.0+dfsg-5 @un uH > (= 4.2.0+dfsg-5)
  Considering libopencv-highgui4.2:amd64 23 as a solution to libopencv-features2d4.2:amd64 24
  MarkKeep libopencv-features2d4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
  Holding Back libopencv-features2d4.2:amd64 rather than change libopencv-highgui4.2:amd64
Investigating (3) ros-melodic-rqt-gui-py:amd64 < 0.5.2-1bionic.20210505.022023 @ii mK Ib >
Broken ros-melodic-rqt-gui-py:amd64 Depends on ros-melodic-qt-gui:amd64 < 0.4.2-1bionic.20210505.012901 @ii mR > (>= 0.3.0)
  Considering ros-melodic-qt-gui:amd64 1302 as a solution to ros-melodic-rqt-gui-py:amd64 20
  Removing ros-melodic-rqt-gui-py:amd64 rather than change ros-melodic-qt-gui:amd64
  MarkDelete ros-melodic-rqt-gui-py:amd64 < 0.5.2-1bionic.20210505.022023 @ii mK Ib > FU=0
Investigating (3) libopencv-imgcodecs3.2:amd64 < 3.2.0+dfsg-4ubuntu0.1 @ii mK Ib >
Broken libopencv-imgcodecs3.2:amd64 Depends on gdal-abi-2-2-3:amd64 < none @un H >
  Considering libgdal20:amd64 7 as a solution to libopencv-imgcodecs3.2:amd64 15
  Added libgdal20:amd64 to the remove list
Broken libopencv-imgcodecs3.2:amd64 Depends on libgdal20:amd64 < 2.2.3+dfsg-2 @ii mR > (>= 2.0.1)
  Considering libgdal20:amd64 7 as a solution to libopencv-imgcodecs3.2:amd64 15
  Added libgdal20:amd64 to the remove list
  Fixing libopencv-imgcodecs3.2:amd64 via keep of libgdal20:amd64
  MarkKeep libgdal20:amd64 < 2.2.3+dfsg-2 @ii mR > FU=0
  Fixing libopencv-imgcodecs3.2:amd64 via keep of libgdal20:amd64
Investigating (3) libopencv-calib3d-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib >
Broken libopencv-calib3d-dev:amd64 Depends on libopencv-features2d-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 | 4.2.0+dfsg-5 @ii umR > (= 4.2.0+dfsg-5)
  Considering libopencv-features2d-dev:amd64 23 as a solution to libopencv-calib3d-dev:amd64 11
  MarkKeep libopencv-calib3d-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Removing libopencv-calib3d-dev:amd64 rather than change libopencv-features2d-dev:amd64
  MarkDelete libopencv-calib3d-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 | 4.2.0+dfsg-5 @ii umH Ib > FU=0
Investigating (3) ros-melodic-rqt-py-common:amd64 < 0.5.2-1bionic.20210505.031051 @ii mK Ib >
Broken ros-melodic-rqt-py-common:amd64 Depends on ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mR > (>= 0.2.19)
  Considering ros-melodic-python-qt-binding:amd64 1302 as a solution to ros-melodic-rqt-py-common:amd64 10
  Removing ros-melodic-rqt-py-common:amd64 rather than change ros-melodic-python-qt-binding:amd64
  MarkDelete ros-melodic-rqt-py-common:amd64 < 0.5.2-1bionic.20210505.031051 @ii mK Ib > FU=0
Investigating (3) python-dev:amd64 < 2.7.15~rc1-1 @ii gK Ib >
Broken python-dev:amd64 Depends on python:amd64 < 2.7.15~rc1-1 @ii pgR > (= 2.7.15~rc1-1)
  Considering python:amd64 8 as a solution to python-dev:amd64 8
  Removing python-dev:amd64 rather than change python:amd64
  MarkDelete python-dev:amd64 < 2.7.15~rc1-1 @ii gK Ib > FU=0
Investigating (3) ros-melodic-python-orocos-kdl:amd64 < 1.4.0-0bionic.20201017.032955 @ii mK Ib >
Broken ros-melodic-python-orocos-kdl:amd64 Depends on python-sip-dev:amd64 < 4.19.7+dfsg-1ubuntu0.1 | 4.19.21+dfsg-1build1 @ii umR >
  Considering python-sip-dev:amd64 60 as a solution to ros-melodic-python-orocos-kdl:amd64 38
  Removing ros-melodic-python-orocos-kdl:amd64 rather than change python-sip-dev:amd64
  MarkDelete ros-melodic-python-orocos-kdl:amd64 < 1.4.0-0bionic.20201017.032955 @ii mK Ib > FU=0
Investigating (3) python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib >
Broken python-dev-is-python2:amd64 Depends on python2-dev:amd64 < none | 2.7.17-2ubuntu4 @un umH >
  Considering python2-dev:amd64 5 as a solution to python-dev-is-python2:amd64 5
  Ignore MarkKeep of python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib > as its mode (Install) is protected
  Removing python-dev-is-python2:amd64 rather than change python2-dev:amd64
  Ignore MarkDelete of python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib > as its mode (Install) is protected
Investigating (3) ros-melodic-qt-gui-py-common:amd64 < 0.4.2-1bionic.20210505.012905 @ii mK Ib >
Broken ros-melodic-qt-gui-py-common:amd64 Depends on ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mR > (>= 0.3.0)
  Considering ros-melodic-python-qt-binding:amd64 1302 as a solution to ros-melodic-qt-gui-py-common:amd64 3
  Removing ros-melodic-qt-gui-py-common:amd64 rather than change ros-melodic-python-qt-binding:amd64
  MarkDelete ros-melodic-qt-gui-py-common:amd64 < 0.4.2-1bionic.20210505.012905 @ii mK Ib > FU=0
Investigating (3) ros-melodic-rqt-console:amd64 < 0.4.9-1bionic.20210505.031441 @ii mK Ib >
Broken ros-melodic-rqt-console:amd64 Depends on ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mR > (>= 0.2.19)
  Considering ros-melodic-python-qt-binding:amd64 1302 as a solution to ros-melodic-rqt-console:amd64 3
  Removing ros-melodic-rqt-console:amd64 rather than change ros-melodic-python-qt-binding:amd64
  MarkDelete ros-melodic-rqt-console:amd64 < 0.4.9-1bionic.20210505.031441 @ii mK Ib > FU=0
Investigating (3) libgdal20:amd64 < 2.2.3+dfsg-2 @ii mK Ib >
Broken libgdal20:amd64 Depends on libhdf5-100:amd64 < 1.10.0-patch1+docs-4 @ii mR >
  Considering libhdf5-100:amd64 7 as a solution to libgdal20:amd64 15
  Added libhdf5-100:amd64 to the remove list
Broken libgdal20:amd64 Depends on libnetcdf13:amd64 < 1:4.6.0-2build1 @ii mR > (>= 4.0.1)
  Considering libnetcdf13:amd64 7 as a solution to libgdal20:amd64 15
  Added libnetcdf13:amd64 to the remove list
Broken libgdal20:amd64 Depends on libogdi3.2:amd64 < 3.2.0+ds-2 @ii mR > (>= 3.2.0)
  Considering libogdi3.2:amd64 -2 as a solution to libgdal20:amd64 15
  Added libogdi3.2:amd64 to the remove list
  Fixing libgdal20:amd64 via keep of libhdf5-100:amd64
  MarkKeep libhdf5-100:amd64 < 1.10.0-patch1+docs-4 @ii mR > FU=0
  Fixing libgdal20:amd64 via keep of libnetcdf13:amd64
  MarkKeep libnetcdf13:amd64 < 1:4.6.0-2build1 @ii mR > FU=0
  Fixing libgdal20:amd64 via keep of libogdi3.2:amd64
  MarkKeep libogdi3.2:amd64 < 3.2.0+ds-2 @ii mR > FU=0
Investigating (3) python-opencv:amd64 < 3.2.0+dfsg-4ubuntu0.1 @ii mK Ib >
Broken python-opencv:amd64 Depends on libopencv-contrib3.2:amd64 < 3.2.0+dfsg-4ubuntu0.1 @ii mR >
  Considering libopencv-contrib3.2:amd64 7 as a solution to python-opencv:amd64 2
  Removing python-opencv:amd64 rather than change libopencv-contrib3.2:amd64
  MarkDelete python-opencv:amd64 < 3.2.0+dfsg-4ubuntu0.1 @ii mK Ib > FU=0
Investigating (3) ros-melodic-rqt-logger-level:amd64 < 0.4.8-0bionic.20210505.030208 @ii mK Ib >
Broken ros-melodic-rqt-logger-level:amd64 Depends on ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mR > (>= 0.2.19)
  Considering ros-melodic-python-qt-binding:amd64 1302 as a solution to ros-melodic-rqt-logger-level:amd64 2
  Removing ros-melodic-rqt-logger-level:amd64 rather than change ros-melodic-python-qt-binding:amd64
  MarkDelete ros-melodic-rqt-logger-level:amd64 < 0.4.8-0bionic.20210505.030208 @ii mK Ib > FU=0
Investigating (3) libopencv4.2-java:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib >
Broken libopencv4.2-java:amd64 Depends on libopencv4.2-jni:amd64 < none | 4.2.0+dfsg-5 @un uH > (>= 4.2.0+dfsg-5)
  Considering libopencv4.2-jni:amd64 0 as a solution to libopencv4.2-java:amd64 2
  MarkKeep libopencv4.2-java:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
  Holding Back libopencv4.2-java:amd64 rather than change libopencv4.2-jni:amd64
Investigating (3) ros-melodic-rviz:amd64 < 1.13.17-1bionic.20210505.041235 @ii mK Ib >
Broken ros-melodic-rviz:amd64 Depends on ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mR >
  Considering ros-melodic-python-qt-binding:amd64 1302 as a solution to ros-melodic-rviz:amd64 2
  Removing ros-melodic-rviz:amd64 rather than change ros-melodic-python-qt-binding:amd64
  MarkDelete ros-melodic-rviz:amd64 < 1.13.17-1bionic.20210505.041235 @ii mK Ib > FU=0
Investigating (3) ros-melodic-rqt-msg:amd64 < 0.4.8-0bionic.20210505.031540 @ii mK Ib >
Broken ros-melodic-rqt-msg:amd64 Depends on ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mR > (>= 0.2.19)
  Considering ros-melodic-python-qt-binding:amd64 1302 as a solution to ros-melodic-rqt-msg:amd64 1
  Removing ros-melodic-rqt-msg:amd64 rather than change ros-melodic-python-qt-binding:amd64
  MarkDelete ros-melodic-rqt-msg:amd64 < 0.4.8-0bionic.20210505.031540 @ii mK Ib > FU=0
Investigating (3) ros-melodic-qt-dotgraph:amd64 < 0.4.2-1bionic.20210505.012849 @ii mK Ib >
Broken ros-melodic-qt-dotgraph:amd64 Depends on ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mR > (>= 0.3.0)
  Considering ros-melodic-python-qt-binding:amd64 1302 as a solution to ros-melodic-qt-dotgraph:amd64 0
  Removing ros-melodic-qt-dotgraph:amd64 rather than change ros-melodic-python-qt-binding:amd64
  MarkDelete ros-melodic-qt-dotgraph:amd64 < 0.4.2-1bionic.20210505.012849 @ii mK Ib > FU=0
Investigating (3) ros-melodic-moveit-ros-visualization:amd64 < 1.0.7-1bionic.20210505.055610 @ii mK Ib >
Broken ros-melodic-moveit-ros-visualization:amd64 Depends on ros-melodic-moveit-ros-perception:amd64 < 1.0.7-1bionic.20210505.050749 @ii mR >
  Considering ros-melodic-moveit-ros-perception:amd64 23 as a solution to ros-melodic-moveit-ros-visualization:amd64 0
  Removing ros-melodic-moveit-ros-visualization:amd64 rather than change ros-melodic-moveit-ros-perception:amd64
  MarkDelete ros-melodic-moveit-ros-visualization:amd64 < 1.0.7-1bionic.20210505.055610 @ii mK Ib > FU=0
Investigating (3) libogdi4.1:amd64 < none -> 4.1.0+ds-1build1 @un uN Ib >
Broken libogdi4.1:amd64 Breaks on libogdi3.2:amd64 < 3.2.0+ds-2 @ii mK > (< 4.0.0)
  Considering libogdi3.2:amd64 15 as a solution to libogdi4.1:amd64 0
  MarkKeep libogdi4.1:amd64 < none -> 4.1.0+ds-1build1 @un uN Ib > FU=0
  Holding Back libogdi4.1:amd64 rather than change libogdi3.2:amd64
Investigating (3) ros-melodic-rqt-graph:amd64 < 0.4.11-1bionic.20210505.030154 @ii mK Ib >
Broken ros-melodic-rqt-graph:amd64 Depends on ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mR > (>= 0.2.19)
  Considering ros-melodic-python-qt-binding:amd64 1302 as a solution to ros-melodic-rqt-graph:amd64 0
  Removing ros-melodic-rqt-graph:amd64 rather than change ros-melodic-python-qt-binding:amd64
  MarkDelete ros-melodic-rqt-graph:amd64 < 0.4.11-1bionic.20210505.030154 @ii mK Ib > FU=0
Investigating (3) ros-melodic-rqt-gui-cpp:amd64 < 0.5.2-1bionic.20210505.022126 @ii mK Ib >
Broken ros-melodic-rqt-gui-cpp:amd64 Depends on ros-melodic-qt-gui:amd64 < 0.4.2-1bionic.20210505.012901 @ii mR > (>= 0.3.0)
  Considering ros-melodic-qt-gui:amd64 1302 as a solution to ros-melodic-rqt-gui-cpp:amd64 0
  Removing ros-melodic-rqt-gui-cpp:amd64 rather than change ros-melodic-qt-gui:amd64
  MarkDelete ros-melodic-rqt-gui-cpp:amd64 < 0.5.2-1bionic.20210505.022126 @ii mK Ib > FU=0
Investigating (3) ros-melodic-rqt-bag:amd64 < 0.5.1-1bionic.20210505.030223 @ii mK Ib >
Broken ros-melodic-rqt-bag:amd64 Depends on ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mR > (>= 0.2.19)
  Considering ros-melodic-python-qt-binding:amd64 1302 as a solution to ros-melodic-rqt-bag:amd64 0
  Removing ros-melodic-rqt-bag:amd64 rather than change ros-melodic-python-qt-binding:amd64
  MarkDelete ros-melodic-rqt-bag:amd64 < 0.5.1-1bionic.20210505.030223 @ii mK Ib > FU=0
Investigating (3) ros-melodic-rqt-plot:amd64 < 0.4.13-1bionic.20210505.031325 @ii mK Ib >
Broken ros-melodic-rqt-plot:amd64 Depends on ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mR > (>= 0.2.19)
  Considering ros-melodic-python-qt-binding:amd64 1302 as a solution to ros-melodic-rqt-plot:amd64 0
  Removing ros-melodic-rqt-plot:amd64 rather than change ros-melodic-python-qt-binding:amd64
  MarkDelete ros-melodic-rqt-plot:amd64 < 0.4.13-1bionic.20210505.031325 @ii mK Ib > FU=0
Investigating (3) ros-melodic-rqt-top:amd64 < 0.4.8-0bionic.20210505.022358 @ii mK Ib >
Broken ros-melodic-rqt-top:amd64 Depends on ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mR > (>= 0.2.19)
  Considering ros-melodic-python-qt-binding:amd64 1302 as a solution to ros-melodic-rqt-top:amd64 -1
  Removing ros-melodic-rqt-top:amd64 rather than change ros-melodic-python-qt-binding:amd64
  MarkDelete ros-melodic-rqt-top:amd64 < 0.4.8-0bionic.20210505.022358 @ii mK Ib > FU=0
Investigating (3) ros-melodic-qt-gui-cpp:amd64 < 0.4.2-1bionic.20210505.013751 @ii mK Ib >
Broken ros-melodic-qt-gui-cpp:amd64 Depends on ros-melodic-qt-gui:amd64 < 0.4.2-1bionic.20210505.012901 @ii mR > (>= 0.3.0)
  Considering ros-melodic-qt-gui:amd64 1302 as a solution to ros-melodic-qt-gui-cpp:amd64 -1
  Removing ros-melodic-qt-gui-cpp:amd64 rather than change ros-melodic-qt-gui:amd64
  MarkDelete ros-melodic-qt-gui-cpp:amd64 < 0.4.2-1bionic.20210505.013751 @ii mK Ib > FU=0
Investigating (3) ros-melodic-joint-state-publisher-gui:amd64 < 1.12.15-1bionic.20210505.032058 @ii mK Ib >
Broken ros-melodic-joint-state-publisher-gui:amd64 Depends on ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mR >
  Considering ros-melodic-python-qt-binding:amd64 1302 as a solution to ros-melodic-joint-state-publisher-gui:amd64 -1
  Removing ros-melodic-joint-state-publisher-gui:amd64 rather than change ros-melodic-python-qt-binding:amd64
  MarkDelete ros-melodic-joint-state-publisher-gui:amd64 < 1.12.15-1bionic.20210505.032058 @ii mK Ib > FU=0
Investigating (3) ros-melodic-rqt-bag-plugins:amd64 < 0.5.1-1bionic.20210505.031403 @ii mK Ib >
Broken ros-melodic-rqt-bag-plugins:amd64 Depends on ros-melodic-rqt-bag:amd64 < 0.5.1-1bionic.20210505.030223 @ii mR >
  Considering ros-melodic-rqt-bag:amd64 1302 as a solution to ros-melodic-rqt-bag-plugins:amd64 -1
  Removing ros-melodic-rqt-bag-plugins:amd64 rather than change ros-melodic-rqt-bag:amd64
  MarkDelete ros-melodic-rqt-bag-plugins:amd64 < 0.5.1-1bionic.20210505.031403 @ii mK Ib > FU=0
Investigating (3) ros-melodic-moveit-setup-assistant:amd64 < 1.0.7-1bionic.20210505.061703 @ii mK Ib >
Broken ros-melodic-moveit-setup-assistant:amd64 Depends on ros-melodic-moveit-ros-visualization:amd64 < 1.0.7-1bionic.20210505.055610 @ii mR >
  Considering ros-melodic-moveit-ros-visualization:amd64 23 as a solution to ros-melodic-moveit-setup-assistant:amd64 -1
  Removing ros-melodic-moveit-setup-assistant:amd64 rather than change ros-melodic-moveit-ros-visualization:amd64
  MarkDelete ros-melodic-moveit-setup-assistant:amd64 < 1.0.7-1bionic.20210505.061703 @ii mK Ib > FU=0
Investigating (3) ros-melodic-rqt-dep:amd64 < 0.4.9-0bionic.20210505.032320 @ii mK Ib >
Broken ros-melodic-rqt-dep:amd64 Depends on ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mR > (>= 0.2.19)
  Considering ros-melodic-python-qt-binding:amd64 1302 as a solution to ros-melodic-rqt-dep:amd64 -1
  Removing ros-melodic-rqt-dep:amd64 rather than change ros-melodic-python-qt-binding:amd64
  MarkDelete ros-melodic-rqt-dep:amd64 < 0.4.9-0bionic.20210505.032320 @ii mK Ib > FU=0
Investigating (3) ros-melodic-rqt-service-caller:amd64 < 0.4.8-0bionic.20210505.032305 @ii mK Ib >
Broken ros-melodic-rqt-service-caller:amd64 Depends on ros-melodic-rqt-gui:amd64 < 0.5.2-1bionic.20210505.021441 @ii mR >
  Considering ros-melodic-rqt-gui:amd64 1302 as a solution to ros-melodic-rqt-service-caller:amd64 -1
  Removing ros-melodic-rqt-service-caller:amd64 rather than change ros-melodic-rqt-gui:amd64
  MarkDelete ros-melodic-rqt-service-caller:amd64 < 0.4.8-0bionic.20210505.032305 @ii mK Ib > FU=0
Investigating (3) ros-melodic-rqt-launch:amd64 < 0.4.8-0bionic.20210505.031532 @ii mK Ib >
Broken ros-melodic-rqt-launch:amd64 Depends on ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mR > (>= 0.2.19)
  Considering ros-melodic-python-qt-binding:amd64 1302 as a solution to ros-melodic-rqt-launch:amd64 -1
  Removing ros-melodic-rqt-launch:amd64 rather than change ros-melodic-python-qt-binding:amd64
  MarkDelete ros-melodic-rqt-launch:amd64 < 0.4.8-0bionic.20210505.031532 @ii mK Ib > FU=0
Investigating (3) ros-melodic-rqt-reconfigure:amd64 < 0.5.4-1bionic.20210505.031528 @ii mK Ib >
Broken ros-melodic-rqt-reconfigure:amd64 Depends on ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mR > (>= 0.2.19)
  Considering ros-melodic-python-qt-binding:amd64 1302 as a solution to ros-melodic-rqt-reconfigure:amd64 -1
  Removing ros-melodic-rqt-reconfigure:amd64 rather than change ros-melodic-python-qt-binding:amd64
  MarkDelete ros-melodic-rqt-reconfigure:amd64 < 0.5.4-1bionic.20210505.031528 @ii mK Ib > FU=0
Investigating (3) ros-melodic-rqt-publisher:amd64 < 0.4.8-0bionic.20210505.031447 @ii mK Ib >
Broken ros-melodic-rqt-publisher:amd64 Depends on ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mR > (>= 0.2.19)
  Considering ros-melodic-python-qt-binding:amd64 1302 as a solution to ros-melodic-rqt-publisher:amd64 -1
  Removing ros-melodic-rqt-publisher:amd64 rather than change ros-melodic-python-qt-binding:amd64
  MarkDelete ros-melodic-rqt-publisher:amd64 < 0.4.8-0bionic.20210505.031447 @ii mK Ib > FU=0
Investigating (3) ros-melodic-rqt-shell:amd64 < 0.4.9-0bionic.20210505.023722 @ii mK Ib >
Broken ros-melodic-rqt-shell:amd64 Depends on ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mR > (>= 0.2.19)
  Considering ros-melodic-python-qt-binding:amd64 1302 as a solution to ros-melodic-rqt-shell:amd64 -1
  Removing ros-melodic-rqt-shell:amd64 rather than change ros-melodic-python-qt-binding:amd64
  MarkDelete ros-melodic-rqt-shell:amd64 < 0.4.9-0bionic.20210505.023722 @ii mK Ib > FU=0
Investigating (3) ros-melodic-rqt-py-console:amd64 < 0.4.8-0bionic.20210505.022348 @ii mK Ib >
Broken ros-melodic-rqt-py-console:amd64 Depends on ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mR > (>= 0.2.19)
  Considering ros-melodic-python-qt-binding:amd64 1302 as a solution to ros-melodic-rqt-py-console:amd64 -1
  Removing ros-melodic-rqt-py-console:amd64 rather than change ros-melodic-python-qt-binding:amd64
  MarkDelete ros-melodic-rqt-py-console:amd64 < 0.4.8-0bionic.20210505.022348 @ii mK Ib > FU=0
Investigating (3) ros-melodic-rqt-action:amd64 < 0.4.9-0bionic.20210505.032001 @ii mK Ib >
Broken ros-melodic-rqt-action:amd64 Depends on ros-melodic-rqt-msg:amd64 < 0.4.8-0bionic.20210505.031540 @ii mR >
  Considering ros-melodic-rqt-msg:amd64 1302 as a solution to ros-melodic-rqt-action:amd64 -1
  Removing ros-melodic-rqt-action:amd64 rather than change ros-melodic-rqt-msg:amd64
  MarkDelete ros-melodic-rqt-action:amd64 < 0.4.9-0bionic.20210505.032001 @ii mK Ib > FU=0
Investigating (3) ros-melodic-moveit-resources-panda-moveit-config:amd64 < 0.7.3-1bionic.20210505.042654 @ii mK Ib >
Broken ros-melodic-moveit-resources-panda-moveit-config:amd64 Depends on ros-melodic-joint-state-publisher-gui:amd64 < 1.12.15-1bionic.20210505.032058 @ii mR >
  Considering ros-melodic-joint-state-publisher-gui:amd64 1302 as a solution to ros-melodic-moveit-resources-panda-moveit-config:amd64 -1
  Removing ros-melodic-moveit-resources-panda-moveit-config:amd64 rather than change ros-melodic-joint-state-publisher-gui:amd64
  MarkDelete ros-melodic-moveit-resources-panda-moveit-config:amd64 < 0.7.3-1bionic.20210505.042654 @ii mK Ib > FU=0
Investigating (3) ros-melodic-rqt-topic:amd64 < 0.4.11-1bionic.20210505.024955 @ii mK Ib >
Broken ros-melodic-rqt-topic:amd64 Depends on ros-melodic-python-qt-binding:amd64 < 0.4.3-1bionic.20210505.012216 @ii mR > (>= 0.2.19)
  Considering ros-melodic-python-qt-binding:amd64 1302 as a solution to ros-melodic-rqt-topic:amd64 -1
  Removing ros-melodic-rqt-topic:amd64 rather than change ros-melodic-python-qt-binding:amd64
  MarkDelete ros-melodic-rqt-topic:amd64 < 0.4.11-1bionic.20210505.024955 @ii mK Ib > FU=0
Investigating (3) ros-melodic-rqt-srv:amd64 < 0.4.8-0bionic.20210505.032044 @ii mK Ib >
Broken ros-melodic-rqt-srv:amd64 Depends on ros-melodic-rqt-gui:amd64 < 0.5.2-1bionic.20210505.021441 @ii mR >
  Considering ros-melodic-rqt-gui:amd64 1302 as a solution to ros-melodic-rqt-srv:amd64 -1
  Removing ros-melodic-rqt-srv:amd64 rather than change ros-melodic-rqt-gui:amd64
  MarkDelete ros-melodic-rqt-srv:amd64 < 0.4.8-0bionic.20210505.032044 @ii mK Ib > FU=0
Investigating (3) ros-melodic-slam-toolbox:amd64 < 1.1.6-1bionic.20210505.045310 @ii mK Ib >
Broken ros-melodic-slam-toolbox:amd64 Depends on ros-melodic-rviz:amd64 < 1.13.17-1bionic.20210505.041235 @ii mR >
  Considering ros-melodic-rviz:amd64 1302 as a solution to ros-melodic-slam-toolbox:amd64 -2
  Removing ros-melodic-slam-toolbox:amd64 rather than change ros-melodic-rviz:amd64
  MarkDelete ros-melodic-slam-toolbox:amd64 < 1.1.6-1bionic.20210505.045310 @ii mK Ib > FU=0
Investigating (3) ros-melodic-rqt:amd64 < 0.5.2-1bionic.20210505.023708 @ii mK Ib >
Broken ros-melodic-rqt:amd64 Depends on ros-melodic-rqt-gui:amd64 < 0.5.2-1bionic.20210505.021441 @ii mR > (>= 0.3.0)
  Considering ros-melodic-rqt-gui:amd64 1302 as a solution to ros-melodic-rqt:amd64 -2
  Removing ros-melodic-rqt:amd64 rather than change ros-melodic-rqt-gui:amd64
  MarkDelete ros-melodic-rqt:amd64 < 0.5.2-1bionic.20210505.023708 @ii mK Ib > FU=0
Investigating (3) ros-melodic-moveit-resources:amd64 < 0.7.3-1bionic.20210505.053030 @ii mK Ib >
Broken ros-melodic-moveit-resources:amd64 Depends on ros-melodic-moveit-resources-panda-moveit-config:amd64 < 0.7.3-1bionic.20210505.042654 @ii mR >
  Considering ros-melodic-moveit-resources-panda-moveit-config:amd64 1302 as a solution to ros-melodic-moveit-resources:amd64 -2
  Removing ros-melodic-moveit-resources:amd64 rather than change ros-melodic-moveit-resources-panda-moveit-config:amd64
  MarkDelete ros-melodic-moveit-resources:amd64 < 0.7.3-1bionic.20210505.053030 @ii mK Ib > FU=0
Investigating (4) ros-melodic-tf2-geometry-msgs:amd64 < 0.6.5-0bionic.20210505.031257 @ii mK Ib >
Broken ros-melodic-tf2-geometry-msgs:amd64 Depends on ros-melodic-python-orocos-kdl:amd64 < 1.4.0-0bionic.20201017.032955 @ii mR >
  Considering ros-melodic-python-orocos-kdl:amd64 60 as a solution to ros-melodic-tf2-geometry-msgs:amd64 38
  Removing ros-melodic-tf2-geometry-msgs:amd64 rather than change ros-melodic-python-orocos-kdl:amd64
  MarkDelete ros-melodic-tf2-geometry-msgs:amd64 < 0.6.5-0bionic.20210505.031257 @ii mK Ib > FU=0
Investigating (4) ros-melodic-moveit-core:amd64 < 1.0.7-1bionic.20210505.044151 @ii mK Ib >
Broken ros-melodic-moveit-core:amd64 Depends on ros-melodic-tf2-geometry-msgs:amd64 < 0.6.5-0bionic.20210505.031257 @ii mR >
  Considering ros-melodic-tf2-geometry-msgs:amd64 60 as a solution to ros-melodic-moveit-core:amd64 33
  Removing ros-melodic-moveit-core:amd64 rather than change ros-melodic-tf2-geometry-msgs:amd64
  MarkDelete ros-melodic-moveit-core:amd64 < 1.0.7-1bionic.20210505.044151 @ii mK Ib > FU=0
Investigating (4) libopencv-calib3d4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib >
Broken libopencv-calib3d4.2:amd64 Depends on libopencv-features2d4.2:amd64 < none | 4.2.0+dfsg-5 @un uH > (= 4.2.0+dfsg-5)
  Considering libopencv-features2d4.2:amd64 24 as a solution to libopencv-calib3d4.2:amd64 28
  MarkKeep libopencv-calib3d4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
  Holding Back libopencv-calib3d4.2:amd64 rather than change libopencv-features2d4.2:amd64
Investigating (4) libopencv-video4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib >
Broken libopencv-video4.2:amd64 Depends on libopencv-calib3d4.2:amd64 < none | 4.2.0+dfsg-5 @un uH > (>= 4.2.0+dfsg)
  Considering libopencv-calib3d4.2:amd64 28 as a solution to libopencv-video4.2:amd64 16
  MarkKeep libopencv-video4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
  Holding Back libopencv-video4.2:amd64 rather than change libopencv-calib3d4.2:amd64
Investigating (4) ros-melodic-moveit-ros-planning:amd64 < 1.0.7-1bionic.20210505.050752 @ii mK Ib >
Broken ros-melodic-moveit-ros-planning:amd64 Depends on ros-melodic-moveit-core:amd64 < 1.0.7-1bionic.20210505.044151 @ii mR >
  Considering ros-melodic-moveit-core:amd64 60 as a solution to ros-melodic-moveit-ros-planning:amd64 15
  Removing ros-melodic-moveit-ros-planning:amd64 rather than change ros-melodic-moveit-core:amd64
  MarkDelete ros-melodic-moveit-ros-planning:amd64 < 1.0.7-1bionic.20210505.050752 @ii mK Ib > FU=0
Investigating (4) libopencv-video-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib >
Broken libopencv-video-dev:amd64 Depends on libopencv-video4.2:amd64 < none | 4.2.0+dfsg-5 @un uH > (= 4.2.0+dfsg-5)
  Considering libopencv-video4.2:amd64 16 as a solution to libopencv-video-dev:amd64 14
  MarkKeep libopencv-video-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Removing libopencv-video-dev:amd64 rather than change libopencv-video4.2:amd64
  MarkDelete libopencv-video-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 | 4.2.0+dfsg-5 @ii umH Ib > FU=0
Investigating (4) ros-melodic-moveit-ros-occupancy-map-monitor:amd64 < 1.0.7-1bionic.20210505.050244 @ii mK Ib >
Broken ros-melodic-moveit-ros-occupancy-map-monitor:amd64 Depends on ros-melodic-moveit-core:amd64 < 1.0.7-1bionic.20210505.044151 @ii mR >
  Considering ros-melodic-moveit-core:amd64 60 as a solution to ros-melodic-moveit-ros-occupancy-map-monitor:amd64 11
  Removing ros-melodic-moveit-ros-occupancy-map-monitor:amd64 rather than change ros-melodic-moveit-core:amd64
  MarkDelete ros-melodic-moveit-ros-occupancy-map-monitor:amd64 < 1.0.7-1bionic.20210505.050244 @ii mK Ib > FU=0
Investigating (4) libhdf5-103:amd64 < none -> 1.10.4+repack-11ubuntu1 @un uN Ib >
Broken libhdf5-103:amd64 Conflicts on libhdf5-100:amd64 < 1.10.0-patch1+docs-4 @ii mK >
  Considering libhdf5-100:amd64 15 as a solution to libhdf5-103:amd64 7
  MarkKeep libhdf5-103:amd64 < none -> 1.10.4+repack-11ubuntu1 @un uN Ib > FU=0
  Holding Back libhdf5-103:amd64 rather than change libhdf5-100:amd64
Investigating (4) libopencv-shape4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib >
Broken libopencv-shape4.2:amd64 Depends on libopencv-video4.2:amd64 < none | 4.2.0+dfsg-5 @un uH > (= 4.2.0+dfsg-5)
  Considering libopencv-video4.2:amd64 16 as a solution to libopencv-shape4.2:amd64 6
  MarkKeep libopencv-shape4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
  Holding Back libopencv-shape4.2:amd64 rather than change libopencv-video4.2:amd64
Investigating (4) libnetcdf15:amd64 < none -> 1:4.7.3-1 @un uN Ib >
Broken libnetcdf15:amd64 Depends on libhdf5-103:amd64 < none | 1.10.4+repack-11ubuntu1 @un uH >
  Considering libhdf5-103:amd64 7 as a solution to libnetcdf15:amd64 5
  MarkKeep libnetcdf15:amd64 < none -> 1:4.7.3-1 @un uN Ib > FU=0
  Holding Back libnetcdf15:amd64 rather than change libhdf5-103:amd64
Investigating (4) libopencv-shape-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib >
Broken libopencv-shape-dev:amd64 Depends on libopencv-shape4.2:amd64 < none | 4.2.0+dfsg-5 @un uH > (= 4.2.0+dfsg-5)
  Considering libopencv-shape4.2:amd64 6 as a solution to libopencv-shape-dev:amd64 5
  MarkKeep libopencv-shape-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Removing libopencv-shape-dev:amd64 rather than change libopencv-shape4.2:amd64
  MarkDelete libopencv-shape-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 | 4.2.0+dfsg-5 @ii umH Ib > FU=0
Investigating (4) python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib >
Broken python-dev-is-python2:amd64 Depends on python2-dev:amd64 < none | 2.7.17-2ubuntu4 @un umH >
  Considering python2-dev:amd64 5 as a solution to python-dev-is-python2:amd64 5
  Ignore MarkKeep of python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib > as its mode (Install) is protected
  Removing python-dev-is-python2:amd64 rather than change python2-dev:amd64
  Ignore MarkDelete of python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib > as its mode (Install) is protected
Investigating (4) libvtk6.3:amd64 < 6.3.0+dfsg1-11build1 -> 6.3.0+dfsg2-5build2 @ii umU Ib >
Broken libvtk6.3:amd64 Depends on libnetcdf15:amd64 < none | 1:4.7.3-1 @un uH > (>= 4.0.1)
  Considering libnetcdf15:amd64 5 as a solution to libvtk6.3:amd64 3
  MarkKeep libvtk6.3:amd64 < 6.3.0+dfsg1-11build1 -> 6.3.0+dfsg2-5build2 @ii umU Ib > FU=0
  Removing libvtk6.3:amd64 rather than change libnetcdf15:amd64
  MarkDelete libvtk6.3:amd64 < 6.3.0+dfsg1-11build1 | 6.3.0+dfsg2-5build2 @ii umH Ib > FU=0
Investigating (4) ros-melodic-moveit-ros-warehouse:amd64 < 1.0.7-1bionic.20210505.052331 @ii mK Ib >
Broken ros-melodic-moveit-ros-warehouse:amd64 Depends on ros-melodic-moveit-core:amd64 < 1.0.7-1bionic.20210505.044151 @ii mR >
  Considering ros-melodic-moveit-core:amd64 60 as a solution to ros-melodic-moveit-ros-warehouse:amd64 3
  Removing ros-melodic-moveit-ros-warehouse:amd64 rather than change ros-melodic-moveit-core:amd64
  MarkDelete ros-melodic-moveit-ros-warehouse:amd64 < 1.0.7-1bionic.20210505.052331 @ii mK Ib > FU=0
Investigating (4) libnetcdf-c++4:amd64 < 4.2-8 -> 4.2-11build2 @ii umU Ib >
Broken libnetcdf-c++4:amd64 Depends on libnetcdf15:amd64 < none | 1:4.7.3-1 @un uH > (>= 1:4.4.0)
  Considering libnetcdf15:amd64 5 as a solution to libnetcdf-c++4:amd64 3
  MarkKeep libnetcdf-c++4:amd64 < 4.2-8 -> 4.2-11build2 @ii umU Ib > FU=0
  Holding Back libnetcdf-c++4:amd64 rather than change libnetcdf15:amd64
Investigating (4) ros-melodic-moveit-ros-move-group:amd64 < 1.0.7-1bionic.20210505.052928 @ii mK Ib >
Broken ros-melodic-moveit-ros-move-group:amd64 Depends on ros-melodic-moveit-core:amd64 < 1.0.7-1bionic.20210505.044151 @ii mR >
  Considering ros-melodic-moveit-core:amd64 60 as a solution to ros-melodic-moveit-ros-move-group:amd64 2
  Removing ros-melodic-moveit-ros-move-group:amd64 rather than change ros-melodic-moveit-core:amd64
  MarkDelete ros-melodic-moveit-ros-move-group:amd64 < 1.0.7-1bionic.20210505.052928 @ii mK Ib > FU=0
Investigating (4) ros-melodic-moveit-ros-manipulation:amd64 < 1.0.7-1bionic.20210505.053639 @ii mK Ib >
Broken ros-melodic-moveit-ros-manipulation:amd64 Depends on ros-melodic-moveit-core:amd64 < 1.0.7-1bionic.20210505.044151 @ii mR >
  Considering ros-melodic-moveit-core:amd64 60 as a solution to ros-melodic-moveit-ros-manipulation:amd64 1
  Removing ros-melodic-moveit-ros-manipulation:amd64 rather than change ros-melodic-moveit-core:amd64
  MarkDelete ros-melodic-moveit-ros-manipulation:amd64 < 1.0.7-1bionic.20210505.053639 @ii mK Ib > FU=0
Investigating (4) ros-melodic-moveit-ros-planning-interface:amd64 < 1.0.7-1bionic.20210505.054643 @ii mK Ib >
Broken ros-melodic-moveit-ros-planning-interface:amd64 Depends on ros-melodic-moveit-core:amd64 < 1.0.7-1bionic.20210505.044151 @ii mR >
  Considering ros-melodic-moveit-core:amd64 60 as a solution to ros-melodic-moveit-ros-planning-interface:amd64 1
  Removing ros-melodic-moveit-ros-planning-interface:amd64 rather than change ros-melodic-moveit-core:amd64
  MarkDelete ros-melodic-moveit-ros-planning-interface:amd64 < 1.0.7-1bionic.20210505.054643 @ii mK Ib > FU=0
Investigating (4) ros-melodic-moveit-simple-controller-manager:amd64 < 1.0.7-1bionic.20210505.045452 @ii mK Ib >
Broken ros-melodic-moveit-simple-controller-manager:amd64 Depends on ros-melodic-moveit-core:amd64 < 1.0.7-1bionic.20210505.044151 @ii mR >
  Considering ros-melodic-moveit-core:amd64 60 as a solution to ros-melodic-moveit-simple-controller-manager:amd64 0
  Removing ros-melodic-moveit-simple-controller-manager:amd64 rather than change ros-melodic-moveit-core:amd64
  MarkDelete ros-melodic-moveit-simple-controller-manager:amd64 < 1.0.7-1bionic.20210505.045452 @ii mK Ib > FU=0
Investigating (4) ros-melodic-moveit-ros-robot-interaction:amd64 < 1.0.7-1bionic.20210505.052407 @ii mK Ib >
Broken ros-melodic-moveit-ros-robot-interaction:amd64 Depends on ros-melodic-moveit-core:amd64 < 1.0.7-1bionic.20210505.044151 @ii mR >
  Considering ros-melodic-moveit-core:amd64 60 as a solution to ros-melodic-moveit-ros-robot-interaction:amd64 0
  Removing ros-melodic-moveit-ros-robot-interaction:amd64 rather than change ros-melodic-moveit-core:amd64
  MarkDelete ros-melodic-moveit-ros-robot-interaction:amd64 < 1.0.7-1bionic.20210505.052407 @ii mK Ib > FU=0
Investigating (4) libopencv-viz3.2:amd64 < 3.2.0+dfsg-4ubuntu0.1 @ii mK Ib >
Broken libopencv-viz3.2:amd64 Depends on libvtk6.3:amd64 < 6.3.0+dfsg1-11build1 | 6.3.0+dfsg2-5build2 @ii umR >
  Considering libvtk6.3:amd64 5 as a solution to libopencv-viz3.2:amd64 0
  Removing libopencv-viz3.2:amd64 rather than change libvtk6.3:amd64
  MarkDelete libopencv-viz3.2:amd64 < 3.2.0+dfsg-4ubuntu0.1 @ii mK Ib > FU=0
Investigating (4) ros-melodic-moveit-kinematics:amd64 < 1.0.7-1bionic.20210505.052403 @ii mK Ib >
Broken ros-melodic-moveit-kinematics:amd64 Depends on ros-melodic-moveit-core:amd64 < 1.0.7-1bionic.20210505.044151 @ii mR >
  Considering ros-melodic-moveit-core:amd64 60 as a solution to ros-melodic-moveit-kinematics:amd64 0
  Removing ros-melodic-moveit-kinematics:amd64 rather than change ros-melodic-moveit-core:amd64
  MarkDelete ros-melodic-moveit-kinematics:amd64 < 1.0.7-1bionic.20210505.052403 @ii mK Ib > FU=0
Investigating (4) ros-melodic-chomp-motion-planner:amd64 < 1.0.7-1bionic.20210505.050303 @ii mK Ib >
Broken ros-melodic-chomp-motion-planner:amd64 Depends on ros-melodic-moveit-core:amd64 < 1.0.7-1bionic.20210505.044151 @ii mR >
  Considering ros-melodic-moveit-core:amd64 60 as a solution to ros-melodic-chomp-motion-planner:amd64 0
  Removing ros-melodic-chomp-motion-planner:amd64 rather than change ros-melodic-moveit-core:amd64
  MarkDelete ros-melodic-chomp-motion-planner:amd64 < 1.0.7-1bionic.20210505.050303 @ii mK Ib > FU=0
Investigating (4) ros-melodic-moveit-planners-ompl:amd64 < 1.0.7-1bionic.20210505.052300 @ii mK Ib >
Broken ros-melodic-moveit-planners-ompl:amd64 Depends on ros-melodic-moveit-core:amd64 < 1.0.7-1bionic.20210505.044151 @ii mR >
  Considering ros-melodic-moveit-core:amd64 60 as a solution to ros-melodic-moveit-planners-ompl:amd64 -1
  Removing ros-melodic-moveit-planners-ompl:amd64 rather than change ros-melodic-moveit-core:amd64
  MarkDelete ros-melodic-moveit-planners-ompl:amd64 < 1.0.7-1bionic.20210505.052300 @ii mK Ib > FU=0
Investigating (4) ros-melodic-moveit-ros-control-interface:amd64 < 1.0.7-1bionic.20210505.045814 @ii mK Ib >
Broken ros-melodic-moveit-ros-control-interface:amd64 Depends on ros-melodic-moveit-simple-controller-manager:amd64 < 1.0.7-1bionic.20210505.045452 @ii mR >
  Considering ros-melodic-moveit-simple-controller-manager:amd64 60 as a solution to ros-melodic-moveit-ros-control-interface:amd64 -1
  Removing ros-melodic-moveit-ros-control-interface:amd64 rather than change ros-melodic-moveit-simple-controller-manager:amd64
  MarkDelete ros-melodic-moveit-ros-control-interface:amd64 < 1.0.7-1bionic.20210505.045814 @ii mK Ib > FU=0
Investigating (4) ros-melodic-rotate-recovery:amd64 < 1.16.7-1bionic.20210505.042037 @ii mK Ib >
Broken ros-melodic-rotate-recovery:amd64 Depends on ros-melodic-tf2-geometry-msgs:amd64 < 0.6.5-0bionic.20210505.031257 @ii mR >
  Considering ros-melodic-tf2-geometry-msgs:amd64 60 as a solution to ros-melodic-rotate-recovery:amd64 -1
  Removing ros-melodic-rotate-recovery:amd64 rather than change ros-melodic-tf2-geometry-msgs:amd64
  MarkDelete ros-melodic-rotate-recovery:amd64 < 1.16.7-1bionic.20210505.042037 @ii mK Ib > FU=0
Investigating (4) ros-melodic-moveit-fake-controller-manager:amd64 < 1.0.7-1bionic.20210505.052415 @ii mK Ib >
Broken ros-melodic-moveit-fake-controller-manager:amd64 Depends on ros-melodic-moveit-core:amd64 < 1.0.7-1bionic.20210505.044151 @ii mR >
  Considering ros-melodic-moveit-core:amd64 60 as a solution to ros-melodic-moveit-fake-controller-manager:amd64 -1
  Removing ros-melodic-moveit-fake-controller-manager:amd64 rather than change ros-melodic-moveit-core:amd64
  MarkDelete ros-melodic-moveit-fake-controller-manager:amd64 < 1.0.7-1bionic.20210505.052415 @ii mK Ib > FU=0
Investigating (4) ros-melodic-mbf-utility:amd64 < 0.3.4-1bionic.20210505.034558 @ii mK Ib >
Broken ros-melodic-mbf-utility:amd64 Depends on ros-melodic-tf2-geometry-msgs:amd64 < 0.6.5-0bionic.20210505.031257 @ii mR >
  Considering ros-melodic-tf2-geometry-msgs:amd64 60 as a solution to ros-melodic-mbf-utility:amd64 -1
  Removing ros-melodic-mbf-utility:amd64 rather than change ros-melodic-tf2-geometry-msgs:amd64
  MarkDelete ros-melodic-mbf-utility:amd64 < 0.3.4-1bionic.20210505.034558 @ii mK Ib > FU=0
Investigating (4) ros-melodic-moveit-planners:amd64 < 1.0.7-1bionic.20210505.060148 @ii mK Ib >
Broken ros-melodic-moveit-planners:amd64 Depends on ros-melodic-chomp-motion-planner:amd64 < 1.0.7-1bionic.20210505.050303 @ii mR >
  Considering ros-melodic-chomp-motion-planner:amd64 60 as a solution to ros-melodic-moveit-planners:amd64 -1
  Removing ros-melodic-moveit-planners:amd64 rather than change ros-melodic-chomp-motion-planner:amd64
  MarkDelete ros-melodic-moveit-planners:amd64 < 1.0.7-1bionic.20210505.060148 @ii mK Ib > FU=0
Investigating (4) ros-melodic-moveit-planners-chomp:amd64 < 1.0.7-1bionic.20210505.055649 @ii mK Ib >
Broken ros-melodic-moveit-planners-chomp:amd64 Depends on ros-melodic-chomp-motion-planner:amd64 < 1.0.7-1bionic.20210505.050303 @ii mR >
  Considering ros-melodic-chomp-motion-planner:amd64 60 as a solution to ros-melodic-moveit-planners-chomp:amd64 -1
  Removing ros-melodic-moveit-planners-chomp:amd64 rather than change ros-melodic-chomp-motion-planner:amd64
  MarkDelete ros-melodic-moveit-planners-chomp:amd64 < 1.0.7-1bionic.20210505.055649 @ii mK Ib > FU=0
Investigating (4) ros-melodic-moveit-plugins:amd64 < 1.0.7-1bionic.20210505.054854 @ii mK Ib >
Broken ros-melodic-moveit-plugins:amd64 Depends on ros-melodic-moveit-fake-controller-manager:amd64 < 1.0.7-1bionic.20210505.052415 @ii mR >
  Considering ros-melodic-moveit-fake-controller-manager:amd64 60 as a solution to ros-melodic-moveit-plugins:amd64 -1
  Removing ros-melodic-moveit-plugins:amd64 rather than change ros-melodic-moveit-fake-controller-manager:amd64
  MarkDelete ros-melodic-moveit-plugins:amd64 < 1.0.7-1bionic.20210505.054854 @ii mK Ib > FU=0
Investigating (4) ros-melodic-moveit-ros-benchmarks:amd64 < 1.0.7-1bionic.20210505.053147 @ii mK Ib >
Broken ros-melodic-moveit-ros-benchmarks:amd64 Depends on ros-melodic-moveit-core:amd64 < 1.0.7-1bionic.20210505.044151 @ii mR >
  Considering ros-melodic-moveit-core:amd64 60 as a solution to ros-melodic-moveit-ros-benchmarks:amd64 -1
  Removing ros-melodic-moveit-ros-benchmarks:amd64 rather than change ros-melodic-moveit-core:amd64
  MarkDelete ros-melodic-moveit-ros-benchmarks:amd64 < 1.0.7-1bionic.20210505.053147 @ii mK Ib > FU=0
Investigating (4) ros-melodic-mbf-costmap-core:amd64 < 0.3.4-1bionic.20210505.041445 @ii mK Ib >
Broken ros-melodic-mbf-costmap-core:amd64 Depends on ros-melodic-mbf-utility:amd64 < 0.3.4-1bionic.20210505.034558 @ii mR >
  Considering ros-melodic-mbf-utility:amd64 60 as a solution to ros-melodic-mbf-costmap-core:amd64 -1
  Removing ros-melodic-mbf-costmap-core:amd64 rather than change ros-melodic-mbf-utility:amd64
  MarkDelete ros-melodic-mbf-costmap-core:amd64 < 0.3.4-1bionic.20210505.041445 @ii mK Ib > FU=0
Investigating (4) ros-melodic-moveit-commander:amd64 < 1.0.7-1bionic.20210505.055610 @ii mK Ib >
Broken ros-melodic-moveit-commander:amd64 Depends on ros-melodic-moveit-ros-planning-interface:amd64 < 1.0.7-1bionic.20210505.054643 @ii mR >
  Considering ros-melodic-moveit-ros-planning-interface:amd64 60 as a solution to ros-melodic-moveit-commander:amd64 -1
  Removing ros-melodic-moveit-commander:amd64 rather than change ros-melodic-moveit-ros-planning-interface:amd64
  MarkDelete ros-melodic-moveit-commander:amd64 < 1.0.7-1bionic.20210505.055610 @ii mK Ib > FU=0
Investigating (4) ros-melodic-move-base:amd64 < 1.16.7-1bionic.20210505.042506 @ii mK Ib >
Broken ros-melodic-move-base:amd64 Depends on ros-melodic-rotate-recovery:amd64 < 1.16.7-1bionic.20210505.042037 @ii mR >
  Considering ros-melodic-rotate-recovery:amd64 60 as a solution to ros-melodic-move-base:amd64 -2
  Removing ros-melodic-move-base:amd64 rather than change ros-melodic-rotate-recovery:amd64
  MarkDelete ros-melodic-move-base:amd64 < 1.16.7-1bionic.20210505.042506 @ii mK Ib > FU=0
Investigating (5) libopencv-viz4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib >
Broken libopencv-viz4.2:amd64 Depends on libvtk6.3:amd64 < 6.3.0+dfsg1-11build1 | 6.3.0+dfsg2-5build2 @ii umR > (>= 6.3.0+dfsg2)
  Considering libvtk6.3:amd64 5 as a solution to libopencv-viz4.2:amd64 6
  MarkKeep libopencv-viz4.2:amd64 < none -> 4.2.0+dfsg-5 @un uN Ib > FU=0
  Holding Back libopencv-viz4.2:amd64 rather than change libvtk6.3:amd64
Investigating (5) libopencv-viz-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib >
Broken libopencv-viz-dev:amd64 Depends on libopencv-viz4.2:amd64 < none | 4.2.0+dfsg-5 @un uH > (= 4.2.0+dfsg-5)
  Considering libopencv-viz4.2:amd64 6 as a solution to libopencv-viz-dev:amd64 5
  MarkKeep libopencv-viz-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 -> 4.2.0+dfsg-5 @ii umU Ib > FU=0
  Removing libopencv-viz-dev:amd64 rather than change libopencv-viz4.2:amd64
  MarkDelete libopencv-viz-dev:amd64 < 3.2.0+dfsg-4ubuntu0.1 | 4.2.0+dfsg-5 @ii umH Ib > FU=0
Investigating (5) python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib >
Broken python-dev-is-python2:amd64 Depends on python2-dev:amd64 < none | 2.7.17-2ubuntu4 @un umH >
  Considering python2-dev:amd64 5 as a solution to python-dev-is-python2:amd64 5
  Ignore MarkKeep of python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib > as its mode (Install) is protected
  Removing python-dev-is-python2:amd64 rather than change python2-dev:amd64
  Ignore MarkDelete of python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib > as its mode (Install) is protected
 Try to Re-Instate (5) libnetcdf-c++4:amd64
  MarkKeep libnetcdf-c++4:amd64 < 4.2-8 -> 4.2-11build2 @ii umU Ib > FU=0
Investigating (6) python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib >
Broken python-dev-is-python2:amd64 Depends on python2-dev:amd64 < none | 2.7.17-2ubuntu4 @un umH >
  Considering python2-dev:amd64 5 as a solution to python-dev-is-python2:amd64 5
  Ignore MarkKeep of python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib > as its mode (Install) is protected
  Removing python-dev-is-python2:amd64 rather than change python2-dev:amd64
  Ignore MarkDelete of python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib > as its mode (Install) is protected
Investigating (7) python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib >
Broken python-dev-is-python2:amd64 Depends on python2-dev:amd64 < none | 2.7.17-2ubuntu4 @un umH >
  Considering python2-dev:amd64 5 as a solution to python-dev-is-python2:amd64 5
  Ignore MarkKeep of python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib > as its mode (Install) is protected
  Removing python-dev-is-python2:amd64 rather than change python2-dev:amd64
  Ignore MarkDelete of python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib > as its mode (Install) is protected
Investigating (8) python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib >
Broken python-dev-is-python2:amd64 Depends on python2-dev:amd64 < none | 2.7.17-2ubuntu4 @un umH >
  Considering python2-dev:amd64 5 as a solution to python-dev-is-python2:amd64 5
  Ignore MarkKeep of python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib > as its mode (Install) is protected
  Removing python-dev-is-python2:amd64 rather than change python2-dev:amd64
  Ignore MarkDelete of python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib > as its mode (Install) is protected
Investigating (9) python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib >
Broken python-dev-is-python2:amd64 Depends on python2-dev:amd64 < none | 2.7.17-2ubuntu4 @un umH >
  Considering python2-dev:amd64 5 as a solution to python-dev-is-python2:amd64 5
  Ignore MarkKeep of python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib > as its mode (Install) is protected
  Removing python-dev-is-python2:amd64 rather than change python2-dev:amd64
  Ignore MarkDelete of python-dev-is-python2:amd64 < none -> 2.7.17-4 @un pumN Ib > as its mode (Install) is protected
Done
Log time: 2021-06-13 22:33:36.207909

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Franziska Schwenke
Solved:
Last query:
Last reply:
Revision history for this message
Franziska Schwenke (frnzs) said :
#1

I solved the problem by purging all the ros-* packages and doing an autoremove afterwards.