18.04LTS will not upgrade due to 386 issue, but running amd64 bit CPU.

Asked by J Cimino on 2021-06-10

OS will not allow upgrade to 20.04 due to 386 CPU issue but am running Rysen amd64 chip. Can you help fix this issue?
Thank you!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

What is the output of:

uname -a; lsb_release -a

Thanks

Revision history for this message
Manfred Hampl (m-hampl) said :
#2

Please also add the output of the command

lscpu

Revision history for this message
J Cimino (intersource) said :
#3

Hello,

I am not versed in shell or command scripts.  I have a book by Mark
Sobell, Practical guide to Linux, published in 2010. This is all the
reference I have other than Ubuntu online.  Whenever I have tried to
upgrade from 18.04LTS I get this error of 386 system and cannot upgrade,
I am running amd64 Rysen but tried to remove the 386 with command but
have not succeeded as yet. the commands you have sent uname gets --help'
for more information? Says invalid option.

Thankk you for trying to help,

JC

Revision history for this message
Manfred Hampl (m-hampl) said :
#4

There is no need to be an expert is shell scripting to execute a few diagnostic commands.

Take this document and mark the following line of text with your mouse and then copy it:

uname -a; lsb_release -a; lscpu

Open a terminal window (e.g. by simultaneously pressing ctrl-alt-t)

In the terminal window press the right mouse button and select "paste" from the pop-up.

Press the enter key to execute the commands

Use the mouse button to mark all output in the terminal window, press the right mouse button and select "copy" from the pop-up

Paste everything into this question document that we can see.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#5

You don't need to be versed in scrip. It's copying and pasting....

Revision history for this message
J Cimino (intersource) said :
#6

Linux ubuntuhome 4.15.0-144-generic #148-Ubuntu SMP Sat May 8 02:32:19
UTC 2021 i686 athlon i686 GNU/Linux
No LSB modules are available.
Distributor ID:    Ubuntu
Description:    Ubuntu 18.04.5 LTS
Release:    18.04
Codename:    bionic
Architecture:        i686
CPU op-mode(s):      32-bit, 64-bit
Byte Order:          Little Endian
CPU(s):              4
On-line CPU(s) list: 0-3
Thread(s) per core:  2
Core(s) per socket:  2
Socket(s):           1
Vendor ID:           AuthenticAMD
CPU family:          21
Model:               2
Model name:          AMD FX(tm)-4300 Quad-Core Processor
Stepping:            0
CPU MHz:             1669.862
CPU max MHz:         3800.0000
CPU min MHz:         1400.0000
BogoMIPS:            7650.61
Virtualization:      AMD-V
L1d cache:           16K
L1i cache:           64K
L2 cache:            2048K
L3 cache:            4096K
Flags:               fpu vme de pse tsc msr pae mce cx8 apic sep mtrr
pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext
fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nonstop_tsc cpuid
extd_apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 sse4_1
sse4_2 popcnt aes xsave avx f16c lahf_lm cmp_legacy svm extapic
cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt
fma4 tce nodeid_msr tbm topoext perfctr_core perfctr_nb cpb hw_pstate
ssbd ibpb vmmcall bmi1 arat npt lbrv svm_lock nrip_save tsc_scale
vmcb_clean flushbyasid decodeassists pausefilter pfthreshold

Revision history for this message
J Cimino (intersource) said :
#7

Sorry but not sure what to look at in this window.  I think I should go
back to windows. I am not qualified to use Ubuntu.  It was easy at first
but then it changed and Ubuntu grew past me. Download center disappeared
and it got more cryptic.

Thank you for at least responding and trying to help.

JC

Revision history for this message
Manfred Hampl (m-hampl) said :
#8

You have the following problem:

Your system has an AMD processor that is capable of running 32bit and 64bit operating systems. That's good.
You are running the 32bit version of Ubuntu 18.04. That's bad.

Past Ubuntu releases came in 32bit and 64bit variants, but from Ubuntu 20.04 onwards there is no 32bit variant any more.
There is no way to do a release upgrade from 32bit Ubuntu 18.04 to a newer release.
If you want Ubuntu 20.04, then you have to do a new installation of the 64bit variant.

Revision history for this message
Best actionparsnip (andrew-woodhead666) said :
#9

I'd wipe the install off and do a clean install of Focal (Ubuntu 20.04) in 64bit. You can restore your user data from your backups

Revision history for this message
J Cimino (intersource) said :
#10

Thanks actionparsnip, that solved my question.