Package dependencies cannot be resolved

Asked by Stefank on 2021-06-05

Could I have help with updating my OS please?

Today I used Software Updater and for the first time got the message:

"Package dependencies cannot be resolved
This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.
Transaction failed: Package dependencies cannot be resolved
 The following packages have unmet dependencies:

grub-efi-amd64-signed: Depends: grub2-common (>= 2.02~beta2-36ubuntu3.31) but 2.04-1ubuntu26.12 is to be installed"

I am using Ubuntu 20.04 Focal Fossa and downloading from the UK server.
The packages waiting to be installed are:
Help
Ubuntu base

I have retried several times and rebooted, but get the same message each time.
Thanks in advance to you wonderful experts out there. I'm sure you will crack this.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Bashing-om
Solved:
Last query:
Last reply:
Revision history for this message
Best Bashing-om (bashing-om) said :
#1

Hello Stefank

Let us make sure we have a firm foundation to work from.
run terminal commands:
sudo apt update
sudo apt upgrade
sudo apt -f install

If there are errors please post the output(s).

Maybe these resolve the issue - or points us in a direction to know where to go to.

-my bit to try and help-

Revision history for this message
Stefank (stefankarpik) said :
#2

Hello Bashing-om

It worked!
Thanks so much.

Revision history for this message
Stefank (stefankarpik) said :
#3

Thanks Bashing-om, that solved my question.

Revision history for this message
Bashing-om (bashing-om) said :
#4

Stefank :D

Welcome - glad it worked out

enjoy