Ubuntu cloud image not getting IP through DHCP

Asked by Eduardo Santos on 2021-06-05

I'm trying to create a virtual machine using KVM, my host machine is a Ubuntu Server 21.04 with virtualization support. I am using the latest Ubuntu 18.04 and 20.04 cloud images. I tried creating a cloud-init image with and without network configuration (tried explicitly setting dhcp4 to true, tried setting it to false and manually assigning a static IP address, and tried not configuring any networking at all through cloud-init).

No matter what I do and try differently, the Ubuntu cloud images just won't be assigned an IP address. This is strange, I followed a handful of different guides and tutorials on installing Ubuntu cloud images using virt-install, but for me it just won't work.

I can get IP addresses when installing CentOS 7 and CentOS 8 virtual machines, the problem only occurs with the Ubuntu cloud images.

Is this a bug? Have other people complained about this?

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Launchpad Janitor (janitor) said :
#1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.