ubuntu 20.04 failing to install GRUB - fatal error

Asked by fowell whitfield on 2021-06-04

I have Windows 10 and ubuntu in dual boot on my PC. I recently upgraded the motherboard from a BIOS to a UEFI system. After that, dual boot still continued to work. I could still select Windows 10 or Ubuntu 18.04 LTS from GRUB.I recently upgraded to Ubuntu 20.04 and I noticed major issues:

1. The graphics driver. The monitor was flickering
2. I could no longer access my Ubuntu 18.04 server using samba share

I tried to fix the driver issue by installing the latest recommended driver but the problem persisted. - My GPU is an Nvidia GEFORCE GT 710
I also tried to install samba but I received an error message about broken packages which I couldn't fix - even with Synaptic #

So I decided to reinstall Ubuntu 20.04 from a live CD.
The error "ubuntu 20.04 does not install grub on /dev/sda - fatal error" has appeared 4 times already.
I also notice that the Installer does not detect Windows 10 - I guess because it was installed in the old BIOS system and I am trying to install in UEFI (so that I can create a ESP ?)
When trying to install without an ESP I got a warning that the system would not be bootable.

Do I need to reinstall Windows 10 in UEFI and then install Ubuntu 20.04 ?

Thanks in advance

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Launchpad Janitor (janitor) said :
#2

This question was expired because it remained in the 'Open' state without activity for the last 15 days.