focal upgrade from bionic fails leaving OS unusable

Asked by ipkpjersi on 2021-05-29

A few weeks ago, when upgrading from Ubuntu 18.04 (bionic) to Ubuntu 20.04 (focal), the upgrade failed with libc6 updating successfully, and libc-bin failing to upgrade. This renders the OS unusable, as commands like sudo etc no longer work and fail with errors like "sudo: 3 incorrect password attempts" without even prompting for a password. I tried for 3 hours with chroot to repair the OS install, but I did not have any luck. I ended up doing a clean focal install. Last week, I tried upgrading from Ubuntu 18.04 to 20.04 on a different computer and again I had the exact same issue. The weird thing was, a month ago I was able to successfully upgrade my laptop from Ubuntu 18.04 to 20.04 which made me think it would be safe to do so on my desktop, which of course ended up not being the case and left me with a broken OS.

I'm not really sure what my questions is - other than, is this a bug, one that hasn't been reported before? It feels like a bug to me. I was able to upgrade this same system from Ubuntu 15.04 -> 15.10 -> 16.04 -> 18.04 without issues.

I managed to take some pictures with my phone of the errors.

Here is the error of libc-bin failing to upgrade: https://i.imgur.com/sLDf2Rx.png

Here is another error, it may or may not have been related: https://i.imgur.com/mp4qyYa.png

I noticed some other perl errors like this which again may or may not be related: https://i.imgur.com/KzBDaRq.png

Thanks.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Launchpad Janitor (janitor) said :
#1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
ipkpjersi (ipkpjersi) said :
#2

Am I really the only person who experienced this issue? I wanted to reported this as a bug but decided to just have it as a question for now.

Can you help with this problem?

Provide an answer of your own, or ask ipkpjersi for more information if necessary.

To post a message you must log in.