Help mounting separate harddrive/permissions...

Asked by anti00 on 2009-05-03

I've looked though enough forums to kill somebody, but figured out how to at least mount the drive. using "sudo mount /dev/sda1/ /mnt"... I've also tried creating a new directory for it using "sudo mkdir"... when I do the second option I can at least SEE the drive. And it is mounted. But I can only SEE it. I can't write to it. I can't even unmount it unless I go into Gparter. Moreover, I can't delete the directory I made just to see if I could mount it. It says I don't have the permission (on a side note; nothing pisses off more than things I OWN telling me I don't have permission :P). I'm new to linux, yes, but this is getting really frustrating.

Can someone tell me how to properly mount the drive to the right location and change the read/write permissions??? And how to delete the test directory I made? PLEASE?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Siyan Panayotov
Solved:
2009-05-03
Last query:
2009-05-03
Last reply:
2009-05-03
Siyan Panayotov (xsisqox) said : #1

Is the partition NTFS? If so, you can use ntfs-config - a graphical app, very easy ... i use it too ... manualy configuration isn't for me :) but if it's not NTFS ... look at /etc/fstab ... but find some more info about configuring it :)

Siyan Panayotov (xsisqox) said : #2

You delete the test dir with the "rm" command .. if you don't own it, the use sudo - "sudo rm /path/to/my/dir" ... if you have mounted a partition, and it's not unmounted yet, use "sudo umount /path/to/my/dir" and the remove it.

anti00 (anti00) said : #3

The "rm" command doesn't work: "cannot remove '/whatever" "it is a directory..." Or similarly. And before you say "oh, I mean 'rmdir'"... I tried that one, too: "failed to remove '/whatever" "it is not empty..."

I can't empty it either... because of the permissions. I tried the root user thing... and still permission denied.

I'm sure the drive is NTFS as it had windows2k on it previously. But, for some other f-ing reason, Ubuntu won't let me enable the NTFS-Configuration Tool without a connection to the internet (another issue I'm trying to resolve).

Thanks for trying... any other suggestions? I'm about to throw in the towel and take my friend up on his recovered win2k disk.

Siyan Panayotov (xsisqox) said : #4

"rm" removes directories, too! When it's not empty, add the --recursive atribute .. like "sudo rm --recursive /my/path"!
And the internet .. if the computer has floppy/usb, you can typ eon another machine "apt-get download ntfs-config", then copy the package on floppy/usb (etc ..) and install it on the Ubuntu's machine

Siyan Panayotov (xsisqox) said : #5

But before running "rm --recursive" make sure, you don't have eny importnant information in that directory! For ezample, if you run the command in a mounted location ...

anti00 (anti00) said : #6

Ok... the "--recursive" deal worked. Thanks for that! I think I've figured out why I don't have the permissions I need to read/write on to the drive I'm trying to mount... it says I'm not the owner... so... how do I mess with those permissions.... or how do I make myself the owner. Anything in gparted for that... or the terminal?

And about the NTFS-config... it's not a matter of it not being installed... I've installed it twice. I just can't enable it in the add/remove section. For some reason it says it requires a connection to the internet.

anti00 (anti00) said : #7

I just don't understand why it thinks I'm not the owner... I think Homer said it once; "Stupid computer!"

Siyan Panayotov (xsisqox) said : #8

Haha
The configuration file, that handles drives is fstab. there, you can find info - which device, in which location, mounts where and with these-and-these permissions ...
If a particular file/directory is the problem, you can change the permissionsusing chmod ... type "man chmod" for more info.

Best Siyan Panayotov (xsisqox) said : #9

A good tutorial, which made me understand it, was http://www.comptechdoc.org/os/linux/usersguide/linux_ugfilesp.html
and then googling for "fstab umask" or "fstab configuration" (see http://www.cae.wisc.edu/linfstab)

anti00 (anti00) said : #10

Well I managed to get the drive to mount... there was a file inside that was called "lost+found" not really sure where it came from. Or, is it a linux default thing... like and Windows temp file? Anyway, I can't rename it... I'm not sure how, but thanks to you, Siyan, I was able to use the chmod to change the file's owner. And now the spare drive can actually mount AND has read/write privileges!

Two more tasks to go... internet. And printer... it's an HP and I haven't even attempted testing yet. The internets are now my priority! if you have any suggestions, as you've been EXTREMELY helpful, sir. Please check it out... https://answers.launchpad.net/ubuntu/+question/69584

anti00 (anti00) said : #11

Oops, thanks again.

anti00 (anti00) said : #12

Thanks Siyan Panayotov, that solved my question.

Tom (tom6) said : #13

Brilliant!! Nicely done, congrats :))))