Upgrade from 16.04.7 to 18.04.5 fails on P700 thinkstation

Asked by Peter Maguire on 2021-05-08

Link to report

https://bugs.launchpad.net/ubuntu/+source/shim-signed/+filebug/f2θ7d88a-afba-11eb-b34a-θθ2481e7f48a?field.title=package+shim-signed+1.33.1z7E16.04.6%2B15%2.B11552672000.a4a1fbe-0ubunta2+failed+to+install%2Fupgrade%3A+subprocess+installed•post-installation+script+returned+error+exit+status+1

Since I could not get a clean install of 20.04.1 to work, installer fails, I tried 16.04.7 to 18.04.5, it also fails

hardware

Lenovo P700, default hardware

Regards
Peter

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Manfred Hampl (m-hampl) said :
#1

What is the current status of your system?
Do you have Ubuntu installed, and if yes, which version?
If installing Ubuntu does not work, what exactly happens when you try?

Just writing "it fails" is insufficient, please provide more details what you see when it is going wrong (e.g. full error message).

Revision history for this message
Peter Maguire (peter-magu) said :
#2

Hi

blow by blow account, I wish to reuse a old pc for linux, formally windows so

1: attempted to install v20 LTS from DVD, installer failed, not a bootable system, sent error report, no error number noticed
2: tried V18 LTS from DVD, installer failed, not a bootable system, not surprising same installer, sent error report, no error number notice
3: installed V16 LTS, old installer works, now tried to upgrade to 20 LTS
     a: patched V16
     b: do a release upgrade, failed, still bootable but I do not wish to stay on V16, see https://www.cyber.gov.au/acsc/view-all-content/publications/essential-eight-explained, sent error report see link in my first message, I have a picture of the screen if you want (tty).

so I got the huff and changed to debian V10, I do not have the time to wait for solution, it is to replace an even older system which is starting to fail. Nothing found on the web with people having the same problem with my hardware, sorting of suggesting no one else has attempted to install V20 LTS on a lenovo thinkstation P700 so hardware?????.

Revision history for this message
Manfred Hampl (m-hampl) said :
#3

1. Ubuntu release numbers have four digits with a dot in the middle (YY.MM), see https://ubuntu.com/about/release-cycle
I assume that you meant Ubuntu releases 20.04, 18.04 and 16.04

2. Again you do not provide enough information that we can help.
"installer failed, not a bootable system"
In what sense did the installer fail?
Did the installer refuse to start at all, or were you able to go through the installation process, but it has not created a bootable system?

3. Whatever you tried with the link at the beginning of your question, it did not work.
This is not a link to a bug report and there are no traces of a bug report created by you in recent past.
There is only one bug report with your participation which is https://bugs.launchpad.net/calibre/+bug/1141078 from eight years ago.

Revision history for this message
Peter Maguire (peter-magu) said :
#4

On the matter of the link, I knew it did not work, this why I came here, I have had another look at the OCR result and finally found why it was not working

θ = 0, plus a few other problems Z instead of % etc that I had missed with my first review.

corrected link is

https://bugs.launchpad.net/ubuntu/+source/shim-signed/+filebug/f207d88a-afba-11eb-b34a-002481e7f48a?field.title=package+shim-signed+1.33.1%7E16.04.6%2B15%2B1552672080.a4a1fbe-0ubuntu2+failed+to+install%2Fupgrade%3A+subprocess+installed+post-installation+script+returned+error+exit+status+1

on the matters of version I thought that would be clear enough, there is after all there is only one v16, one v18, one v20 available for obvious download.
I use one word where other use hundreds.

Installer failed:
1: run do-release-update to update v16 LTS to v18 LTS , CRT no GUI, the very minal options selected.
2: at some stage it fails to install a component, I did not recognize any info of the form "install failed on component X for reason Y"

thus you have all the info I have/recognized.

You might notice something I missed in the photo of the screen, do you wish a copy of the photo?

Revision history for this message
Manfred Hampl (m-hampl) said :
#5

I am sorry, but I'm still not able to understand your problem.

I do not see any answer to my information request in comment #3

Are you having a problem with the initial Ubuntu installer, or with the release upgrader?

Revision history for this message
Launchpad Janitor (janitor) said :
#6

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.