Thunderbird takes too long to load messages

Asked by William Pabon on 2021-05-01

Hi!

I don't know if there is a different sub-forum for this subject within this platform. If there is, sorry, and advice for a redirect. The advice I received from mozilla (from: https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems) didn't help much to solve it. After the latest update of Thunderbird (version 78.7.1), loading emails from gmail and hotmail take much, much longer than previously. I followed, to the best of my knowledge, the suggestions from mozilla on the website above, but it didn't solve the situation. Hope that I can receive here some fresh ideas to resolve this issue. This is what I get when running Thunderbird in cli mode:

williepabon@williepabon-Macmini:~$ thunderbird
[calBackendLoader] Using Thunderbird's libical backend
console.debug: "Successfully loaded OpenPGP library librnp.so from /usr/lib/thunderbird/librnp.so"
console.warn: "[l10nregistry] Attempting to synchronously load file\n resource:///chrome/en-US/locale/en-US/calendar/messenger/openpgp/msgReadStatus.ftl while it's being loaded asynchronously."
JavaScript error: resource://gre/modules/ActorManagerChild.jsm, line 297: TypeError: singletons is null
JavaScript error: resource://gre/modules/ActorManagerChild.jsm, line 297: TypeError: singletons is null
JavaScript error: resource://gre/modules/ActorManagerChild.jsm, line 297: TypeError: singletons is null
Extension error: Error while loading 'jar:file:///usr/lib/thunderbird/omni.ja!/chrome/messenger/search-extensions/twitter/manifest.json' (NS_ERROR_FILE_NOT_FOUND) resource://gre/modules/Extension.jsm:570 :: readJSON/</<@resource://gre/modules/Extension.jsm:570:20
onStopRequest@resource://gre/modules/NetUtil.jsm:128:18

console.log: (new Error("Cannot load required OTR library", "resource:///modules/OTRLib.jsm", 75))
console.debug: "public keys: 0, secret keys: 0"
console.debug: "Successfully loaded optional OpenPGP library libgpgme.so.11 from system's standard library locations"
console.debug: "gpgme version: 1.13.1-unknown"
JavaScript error: chrome://chat/content/conversation-browser.js, line 853: NotSupportedError: CustomElementRegistry.define: 'conversation-browser' has already been defined as a custom element

Information about my machine:

williepabon@williepabon-Macmini:~$ uname -a
Linux williepabon-Macmini 5.4.0-72-generic #80-Ubuntu SMP Mon Apr 12 17:35:00 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
williepabon@williepabon-Macmini:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.04.2 LTS
Release: 20.04
Codename: focal

Thank you for any help.

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.