Thinkpad fan & cpu turbo not working after upgrade to 21.04

Asked by Eugen on 2021-05-01

Hi,

Hardware:
Lenovo Thinkpad E480

In 20.10 CPU turbo and fan worked "out of the box" (I actually didn't know which package controls them, just worked)
After upgrading to 21.04, the fan didn't work at all

I got the fan working with fancontrol and also with thinkfan, but both produce a rather "irrational" fan behaviour with late spinups or random spinups etc. - i now only use thinkfan with the config below:

Even with fan set manually to fullspeed via thinfan, cpu turbo modes are not used anymore
CPU is a i3-8130U with a 3,4Ghz turbo for one-core - so previously "stress -c 1" lead to a clock of 3,4Ghz (checked with lscpu) - now it sticks to 2,2 - 2,6Ghz, not more.

I'ts not the new 5.11.xx kernel, I tried booting with the old 5.8.xx from 20.10, and it didn't help

config used currently (works, but badly, see description above):
sensors:
  - hwmon: /sys/devices/platform/coretemp.0/hwmon/hwmon4/temp3_input
  - hwmon: /sys/devices/platform/coretemp.0/hwmon/hwmon4/temp1_input
  - hwmon: /sys/devices/platform/coretemp.0/hwmon/hwmon4/temp2_input

fans:
  - tpacpi: /proc/acpi/ibm/fan

levels:
  - [0, 0, 50]
  - ["level auto", 45, 75]
  - ["level disengaged", 70, 255]

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Eugen
Solved:
Last query:
Last reply:
Eugen (thinkpadder) said : #1

Hi,

okay I fixed the "irrational" fan behaivour by letting everything handles by the auto mode, so my conf is reduced to:
  - ["level auto", 0, 100]

sorry for that, my config was just shit :/

Also the Turbo Problem is actually not related to the fan problem, it is related to the new energy settings mode in the preferences: it defaultet to "balanced" - but balanced seems not to use turbo or cap clock

when set to "full system power" i get the full 3,4Ghz turbo.

Eugen (thinkpadder) said : #2

Hi,

okay I fixed the "irrational" fan behaivour by letting everything handles by the auto mode, so my conf is reduced to:
  - ["level auto", 0, 100]

sorry for that, my config was just shit :/

Also the Turbo Problem is actually not related to the fan problem, it is related to the new energy settings mode in the preferences: it defaultet to "balanced" - but balanced seems not to use turbo or cap clock

when set to "full system power" i get the full 3,4Ghz turbo.

Eugen (thinkpadder) said : #3

actually the new modes are worse than the old "no modes at all" thing:
previuosly my cpu would clock down to 800mhz in idle and go to 3,4ghz turbo when needed

now:
i can have performance mode with turbo up to 3,4ghz but the cpu clocks down in idle just to 2,2ghz --> drains battery
or i can have "balanced" with idle trottle to 800mhz but only a max. clock of 2,6ghz --> bad single threaded performance, generall "slower" reaction times of OS etc.