How to install Linksys wusb6100m

Asked by William Pabon on 2021-04-28

Hi:
The wifi card inside my pc apparently stopped working. I bought the Linksys wusb6100m dongle to replace it, but I'm not familiar with the steps to install it, since there are no drivers that I know of for ubuntu. The system recognizes it, as shown below:

williepabon@williepabon-Macmini:~$ lsusb
Bus 002 Device 005: ID 05ac:8242 Apple, Inc. Built-in IR Receiver
Bus 002 Device 008: ID 05ac:828a Apple, Inc.
Bus 002 Device 004: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 002 Device 003: ID 0424:2512 Microchip Technology, Inc. (formerly SMSC) USB 2.0 Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 003 Device 003: ID 046d:0825 Logitech, Inc. Webcam C270
Bus 003 Device 002: ID 0458:201d KYE Systems Corp. (Mouse Systems) ColorPage-Vivid 1200 X
Bus 003 Device 005: ID 13b1:0042 Linksys WUSB6100M 802.11a/b/g/n/ac Wireless Adapter
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Shown below is the information about my pc:

williepabon@williepabon-Macmini:~$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 20.04.2 LTS
Release: 20.04
Codename: focal
williepabon@williepabon-Macmini:~$ uname -a
Linux williepabon-Macmini 5.4.0-72-generic #80-Ubuntu SMP Mon Apr 12 17:35:00 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
williepabon@williepabon-Macmini:~$

Please, help. Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
Last query:
Last reply:
Manfred Hampl (m-hampl) said : #1

For diagnostic purposes proceed as follows:

unplug the WLAN adapter, wait a minute
issue the command
dmesg
and note down the time code of the last entry shown.
plug in the WLAN adapter again, wait a minute
issue the command
dmesg
again and copy all lines that have been added to the first execution and paste them into this question document.

William Pabon (williepabon) said : #2

Manfred:

Thanks for answering. I'm not totally sure if I'm doing this correctly, but this is the information I obtained following your instructions. For the first dmseg, the last line is:

[ 351.873338] usb 3-1: USB disconnect, device number 2

For the second dmesg, the following lines appeared after the one above:

[ 857.494024] usb 3-1: new high-speed USB device number 6 using xhci_hcd
[ 857.642977] usb 3-1: New USB device found, idVendor=13b1, idProduct=0042, bcdDevice=90.10
[ 857.642982] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 857.642984] usb 3-1: Product: USBWLAN
[ 857.642987] usb 3-1: Manufacturer: Qualcomm Atheros
[ 857.642989] usb 3-1: SerialNumber: 12345678
[ 857.644838] usb 3-1: Warning: ath10k USB support is incomplete, don't expect anything to work!
[ 857.645095] usb 3-1: Unsupported hardware version: 0x5020001
[ 857.645103] usb 3-1: could not get hw params (-22)
[ 857.645109] usb 3-1: could not probe fw (-22)

Hope this helps. Thanks

Best Manfred Hampl (m-hampl) said : #3

Well done, but probably not helpful.

The output shows that the system believes that your device needs the ath10k driver, but it fails.

Other people had the same problem and could not solve it, see e.g. https://askubuntu.com/q/799104

Did you check whether the device is supposed to work with Linux before buying it?

William Pabon (williepabon) said : #4

Manfred:

Thanks for the info. Regrettably, I did not check if the dongle was Linux compatible because I bought it before my current problem, for a Windows machine. Well then, I will have to start a search for a wifi dongle that works with Linux. Any ideas where to start? Thanks again.

William Pabon (williepabon) said : #5

Thanks Manfred Hampl, that solved my question.