Update is not succeeding when using Ubuntu Software Updater

Asked by Edwin M Culver on 2021-04-27

I am getting this error when using the Ubuntu software updater:

"This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.
Transaction failed: Package dependencies cannot be resolved
 The following packages have unmet dependencies:

grub-efi-amd64-signed: Depends: grub2-common (>= 2.02~beta2-36ubuntu3.31) but 2.04-1ubuntu35.6 is to be installed"

Ubuntu 20.10
64 bit
Gnome 3.38.3

Processor: Intel® Core™ i5-8365U CPU @ 1.60GHz × 8
Graphics: Mesa Intel® UHD Graphics 620 (WHL GT2)
Windowing system: Wayland

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Bernard Stafford (bernard010) said : #1

Log out -> Click on the Gear Icon to the right of the login -> Change to X11
Log In -> Open Ubuntu Software -> Click on search top left [magnifying glass icon] ->
Type: Synaptic Package Manager -> Install
Open Synaptic Package Manager -> Password Required
 [Optional right click icon on Dock select add to Favorites]
On Left lower Tab- Click on Custom Filters ->
On Left upper Click on Broken -> This will list all Broken Packages
You are able to Uninstall or Reinstall packages.
Documentation for Synaptic:
https://help.ubuntu.com/community/SynapticHowto
https://help.ubuntu.com/stable/ubuntu-help/addremove-install-synaptic.html.en
This is the Ubuntu preferred method of installing packages other than Snaps in the Snap Store.

Can you help with this problem?

Provide an answer of your own, or ask Edwin M Culver for more information if necessary.

To post a message you must log in.