xterm Only 4 Characers wide

Asked by tomdean on 2021-04-16

Today, I found the system hung, non-responsive. Could not ping it from another computer. About 4 hours earlier it was normal.

I cycled power. Boot seemed normal.

I started an xterm. Seemed OK. ls produced a file listing, but only the first 4 char of each file name. If ls produced 2 columns, only the first 4 char of each file name was displayed.

I cleared all the checked items in xterm, no change.

Graphical things like firefox are OK.
What else?

> env
SHELL=/bin/bash
WINDOWID=14680077
XTERM_VERSION=XTerm(353)
XTERM_SHELL=/bin/bash
EDITOR=emacs
XDG_SEAT=seat0
PWD=/home/tomdean
LOGNAME=tomdean
XDG_SESSION_TYPE=tty
XAUTHORITY=/home/tomdean/.Xauthority
WINDOWPATH=1
MOTD_SHOWN=pam
HOME=/home/tomdean
LANG=en_US.UTF-8
LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=00:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arc=01;31:*.arj=01;31:*.taz=01;31:*.lha=01;31:*.lz4=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.tzo=01;31:*.t7z=01;31:*.zip=01;31:*.z=01;31:*.dz=01;31:*.gz=01;31:*.lrz=01;31:*.lz=01;31:*.lzo=01;31:*.xz=01;31:*.zst=01;31:*.tzst=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.alz=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.cab=01;31:*.wim=01;31:*.swm=01;31:*.dwm=01;31:*.esd=01;31:*.jpg=01;35:*.jpeg=01;35:*.mjpg=01;35:*.mjpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.m4a=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.oga=00;36:*.opus=00;36:*.spx=00;36:*.xspf=00;36:
EXINIT=set autoindent
INVOCATION_ID=7742155add744642b02cba06fb284302
XTERM_LOCALE=C
INFOPATH=/usr/share/info:/usr/share/info/emacs:/usr/local/share/info
LESSCLOSE=/usr/bin/lesspipe %s %s
XDG_SESSION_CLASS=user
TERM=xterm
LESSOPEN=| /usr/bin/lesspipe %s
USER=tomdean
DISPLAY=:0
SHLVL=2
PAGER=more
XDG_VTNR=1
XDG_SESSION_ID=1
XDG_RUNTIME_DIR=/run/user/1000
LC_ALL=C
JOURNAL_STREAM=9:29840
HUSHLOGIN=FALSE
PATH=:/home/tomdean/bin:/bin:/usr/bin:/usr/games:/usr/local/bin:/usr/local/pgsql/bin
MAIL=/var/mail/tomdean
_=/usr/bin/env

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
tomdean
Solved:
Last query:
Last reply:
tomdean (tomdean) said : #1

The xerm opens, , the border and background seem normal width.

tomdean (tomdean) said : #2

This is a known problem with oibaf-ubuntu-graphics-drivers.

sudo apt install ppa-purge
sudo ppa-purge ppa:oibaf/graphics-drivers

fixes the problem.

So... Using the official Ubuntu repository rather than a PPA you found online. Makes absolute sense to me

tomdean (tomdean) said : #4

Yes.

Installing the oibaf was an attempt to solve a different problem with the AMD Radeon HD 6870. This PPA was on launchapd...

after ppa-purge,
# deb http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu focal main
# deb-src http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu focal main

But, I used this for a long time before the problem happened.

Fixed now.

Thanks,
Tom Dean