General question and wireless specific question

Asked by Chuck

I am a retired 'newbie' on Ubuntu and trying to learn basics, but, speciffically, I am trying to get the wireless card working. When I read about most Linux topics the level of the dialog is much beyond my understanding. For example, I do not know how to "compile". There are "terminal" commands to get things done, but no explanation is offered on how to do it. How do I implement, " sudo lsmod | grep ipw 2200" or whatever about the driver??? Let me add that my lunch is eaten regularly with wireless set-up on windows-based machines. It seems like a giant puzzle to get it working.

At this point I have installed what appears to be a working copy of U 7.0.4 on a second drive in the cd tray of a t23 ibm laptop. I was thrilled. It was easy. I used wubi. I found it by googling the question of how to install on a secondary drive using the cd slot. I didn't know what I was doing, but it sailed through fine. No wonder Gates is getting nervous. I am really impressed so far, but I pose ( my lack of knowledge) a serious challenge to some of the steps to fix things I've read so far.

My immediate goals:
1) get the wirless working;
2) use Ubuntu and see if it can meet a 'newbies' needs;
3)learn how to tinker with the program ( and how to avoid having to tinker)

Questions:
1) Can you direct me to a bottom-line introduction to the commands, procedures and requirements for solving the above questions??
2) Can you help to get the wireless working?
3)network manager is a part of 7.0.4 or has to be found and installed?
4) ndiswrapper-- is it what I need and how do I use it with my linksys wpc54gr card?

Thank you

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:

This question was reopened

Revision history for this message
SageMassa (jedd.bissegger) said :
#1

Generaly terminal commands can be cut and pasted directly into your terminal. (you can access this by clicking on applications then accesories then terminal.

As for the wireless aspect try the walk through located at www.ubuntuguide.org
Also go to system then administration then network and see if you can configure this card here...it may be detected. Dont forget to turn the wireless on with your fn + appropriate wireless key or the hardware button for this.

Revision history for this message
Chuck (chux-industryinet) said :
#2

"Dont forget to turn the wireless on with your fn + appropriate wireless key or the hardware button for this. " ???

I assume there is a procedure to do something by simultaneously pressing the Fn and ?? key. How am I supposed to know this and how a,d what is does?? Thanks

Revision history for this message
Alan Pope 🍺🐧🐱 πŸ¦„ (popey) said :
#3

Most laptops have a physical switch which turns the wifi on and off. Alternatively it may be implemented in software - i.e. not a physical switch but a "logical" on which is toggled by you pressing a certain combination of keys. The Fn key is often found in the bottom left of the keyboard on a laptop. The function keys often have little legends on them - one to suspend, one to show battery status, one to switch between internal and external displays and so on. One may have a little antenna icon on it, which if pressed with the Fn key switches wifi circuitry on and off with each depress.

Revision history for this message
SageMassa (jedd.bissegger) said :
#4

Your Laptop has the following wireless card
 WiFi Features

    * Chipset: Harris Semiconductor Prism 2.5
    * IEEE Standards: 802.11b
    * PCI ID: 1260:3873

 Linux WiFi driver

This adapter works with the 'orinoco_pci' driver as part of any recent 2.4 or 2.6 kernel.
In addition the 'hostap' driver can also be used.

I am having a hard time finding a keymap for your laptop however if i remember correctly from when i had a t series Fn + F5 is the wireless on/off keystroke

You may want to install a wireless manager such as wifi-radar
(from a terminal type- sudo apt-get install wifi-radar)
open this program (located in applications then internet) see if it can detect any wireless networks (obiously do this where you know a network is up)
Then play with the fn keys to see if your wireless comes on. There should also be a indicator light that tells if wifi is active somewhere on the laptop usualy near the hdd activity light etc.

Thanks

Revision history for this message
Chuck (chux-industryinet) said :
#5

Thanks so much for your help. First, I really like Ubuntu. I see a it becoming very popular as people, like me, with little experience with "code" can get a working system that really shines.
It seems wireless is my only unsolved problem. Everything else is working so far, but wireless is a pain on windows and I'm not doing any better here. The difference is I like Ubuntu's attitude.

My IBM T23 does not have internal wireless. I have tried 2 linksys pcmic(whatever) cards, a wpc54gr & a wpc11.V.#4. I ran something that seem to say that the wpc54 gr has a RaLinl Rt 2600 8002.11 mimo; the wpc11 has a Realtek RTL8180L. A note suggested I use the windows xp for the realtek.

Questions:
1) Should I buy a card specifically for the Ubuntu system that has a very high probability of working? Please specify make and model.
2) Will either of the 2 cards I have mentioned work? I have diswrapper 1.3xx installed, will it do?
3)I installed and ran the program several times without any problems but now it does not open. s

Revision history for this message
Chuck (chux-industryinet) said :
#6

The wifi radar program no longer opens. Any suggestions?

Revision history for this message
SageMassa (jedd.bissegger) said :
#7

wpc11 cards have linux drivers.

Linksys WPC11 V2.5 Driver Download
Instant Wireless Network PC Card (PCMCIA)
Driver Release Version 1.3 for Linux
Release Date: 12/27/2001

You can get the driver here
http://www.wardrive.net/drivers/linksys

as for wifi-radar
Open a terminal and type
sudo wifi-radar
then enter your password
if it fails to load it should give you some indications as to why in the terminal.

Let us know how it goes...I am happy ,btw, that you like Ubuntu it can be a touch more work but the payoff is well worth it.

Revision history for this message
Chuck (chux-industryinet) said :
#8

Re: wifi-radar, I get this message after I typed sudo wifi-radar and password:
Password:
dhclient3 --version 2>&1
Traceback (most recent call last):
  File "/usr/sbin/wifi-radar", line 1414, in <module>
    auto_profile_order = auto_profile_order.split( ',' )
AttributeError: 'list' object has no attribute 'split'

Any suggestions??

I will now try to install the wpc11 driver.

Revision history for this message
Chuck (chux-industryinet) said :
#9

here are the iwconfig results with the wpc54gr card. I'm not sure the wpc11 is working.
~$ /bin/iwconfig
bash: /bin/iwconfig: No such file or directory
chuck@Chux:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

irda0 no wireless extensions.

ra0 RT61 Wireless ESSID:"Chux" Nickname:""
          Mode:Managed Frequency:2.437 GHz Access Point: 00:16:B6:26:13:B4
          Bit Rate=54 Mb/s
          RTS thr:off Fragment thr:off
          Link Quality=82/100 Signal level:-53 dBm Noise level:-63 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Revision history for this message
SageMassa (jedd.bissegger) said :
#10

Can you issue the command
sudo apt-get remove --purge wifi-radar
then
sudo apt-get install wifi-radar

This should correct the problem with wifi-radar.

The wpc54gr card seems to be working. If wifi radar comes back up you can manage networks with that...

Let me know how it goes.

Revision history for this message
Chuck (chux-industryinet) said :
#11

Thanx, I re-installed wifi-radar and it is working. I opened wifi-radar using "sudo wifi-radar". With wifi-radar open, I see a message at the bottom that says ":connected to Chux (IP 192.168.1.103). The icon under ssid has a question mark and on the right is a pad lock, full staircase and b. I cannot connect to the internet.

A larger screen is scrollingb info on, lo, eth0,irad0 that repeats no wireless connections & interface doesn't support scanning. I have some questions about what is needed in the setup and could not find any directions. In wifi-radar:
1) under wifi options, What "mode" is needed? Infrastructure is used in winxp
2) Key --- is that my wap security number? --- or what goes here?
3) security --- open or restricted??
4) My router is set up with 64 bit. The "use WPA" has a box for Driver. Is a driver needed or my security code??

Can you offer steps to connect or where else to look for answers or even better, step by step directions for connecting with wireless? I am using the wpc54gr (RaLink RT2600 802 mimo, a linksys wrt54gs router and a D-Link modem. My wpc11 is a version 4 card and has a Realtek RT8180l.

Last, is this something I can do???

Revision history for this message
Chuck (chux-industryinet) said :
#12

I am trying to fix this on my own but it is impossible for me to do it without something to follow. Plz tell me how to do this:
I have downloaded ndiswrapper-1.44. the instructions say:
Download the latest version of the ndiswrapper sources from here and
extract it with the command

  tar zxvf ndiswrapper-version.tar.gz

Thisis what I get:

$ tar zxvf ndiswrapper-version.tar.gz
tar: ndiswrapper-version.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors

Plz help explain what I am doing wrong, Thanx

Revision history for this message
jinxed (s0nic-llama) said :
#13

excuse me, could someone tell me how to get my wireless working. i cant seem to get it to work. it only works when connected with a wire.

it would be greatly appreciated if you could tell me how to turn it on or something.

im usign a macbook g5 i think with. it is an intell mac.

please help me.

Can you help with this problem?

Provide an answer of your own, or ask Chuck for more information if necessary.

To post a message you must log in.